脚本语言支持组件

脚本语言支持组件 帮助手册20080811版 返回支持库手册 返回首页

本支持库实现了用户为任意的脚本引擎编写和运行脚本。

操作系统支持： Windows

窗口组件数据类型：

脚本组件

常量表...

例程名称 | 下载 | 说明
脚本组件例程 | 脚本组件例程.e | 演示了脚本组件支持库的使用方法
脚本文件 | CHART.JS CHART.VBS EXCEL.VBS flash.html flash.js Hello.js math.js NETWORK.VBS REGISTRY.VBS SHORTCUT.VBS SHOWVAR.VBS timeout.js | 相关的一些脚本文件

适用版本，脚本语言支持组件 （1.3#0版）


脚本组件

脚本组件 功能型窗口组件 操作系统支持：Windows 跳至：脚本语言支持组件

支持运行各种脚本语言。

属性：

左边 | 顶边 | 宽度 | 高度
标记 | 可视 | 禁止 | 鼠标指针
语言 | 错误信息 | 超时 |

方法：


左边 基本属性

数据类型：整数型；

语法： 对象.左边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的左边为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


顶边 基本属性

数据类型：整数型；

语法： 对象.顶边 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的顶边为100；如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


宽度 基本属性

数据类型：整数型；

语法： 对象.宽度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的宽度为200，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


高度 基本属性

数据类型：整数型；

语法： 对象.高度 = 整数型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置窗口的高度为100，如果要同时设置这几个属性，可以用“组件.移动”命令来实现。

参见：例程1


标记 基本属性

数据类型：文本型；

语法： 对象.标记 = 文本型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据库、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

这个例程中，我们首先在程序设置状态的时候把测试的4个按钮的标记分别写入文本型的“1”“2”“3”“4”，然后我们用循环通过“取标记组件”命令来寻找这个组件，然后我们把找到的组件的事件转移到一个新的按钮上。这样可以利用标记来减少重复代码。这是标记的作用之一。

参见：例程1


可视 基本属性

数据类型：逻辑型；

语法： 对象.可视 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的可视属性。

参见：例程1


禁止 基本属性

数据类型：逻辑型；

语法： 对象.禁止 = 逻辑型

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、菜单、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的禁止属性。

参见：例程1


鼠标指针 基本属性

数据类型：字节集；

语法： 对象.鼠标指针 = 字节集

应用对象：

窗口、编辑框、图片框、外形框、画板、分组框、标签、按钮、选择框、单选框、组合框、列表框、选择列表框、横向滚动条、纵向滚动条、进度条、滑块条、选择夹、影像框、日期框、月历、驱动器框、目录框、文件框、颜色选择器、超级链接框、调节器、通用对话框、时钟、打印机、数据报、客户、服务器、端口、表格、数据源、通用提供者、数据库提供者、图形按钮、外部数据提供者、超文本浏览框、树型框、状态条、工具条、超级列表框、透明标签、超级按钮、高级影像框、分隔条、超级编辑框、数据库连接、记录集、柱状图控件、饼形图控件、曲线图控件、Word程序、Word文档集、Word图形、Excel程序、Excel工作簿、Excel图表、脚本组件

例程：

说明：

设置控件的鼠标指针。

参见：例程1


语言 (脚本组件)

语言 属性 所属对象：脚本组件 操作系统支持：Windows

数据类型：文本型；设置或返回正在使用的 脚本 语言名称。

可供选择的属性值：
0、JScript
1、VBScript

例程

说明：

将脚本组件的语言设为语言组合框中的内容。

参见：例程


错误信息 (脚本组件)

错误信息 属性 所属对象：脚本组件 操作系统支持：Windows

数据类型：文本型；只读；如果脚本执行出错返回出错说明。

例程

说明：

将脚本组件所执行错误的原因显示在结果编辑框中。

参见：例程


超时 (脚本组件)

超时 属性 所属对象：脚本组件 操作系统支持：Windows

数据类型：整数型；设置或返回时间（毫秒），此时间后用户可选择中止脚本代码的执行或允许代码继续执行。

例程

说明：

将脚本组件的超时属性设为使用到数值命令转换为数值的超时编辑框中的内容。

参见：例程


执行 (脚本组件)

执行 方法 操作系统支持：Windows 所属对象：脚本组件

执行指定的代码文本。返回真为执行正常，返回假为出错，错误信息可以从“错误码信息”属性中取得。

语法： 逻辑型 脚本组件．执行 （脚本代码）

参数名 | 描 述
脚本代码 | 必需的；文本型。包含要执行的脚本代码，如为空则默认为执行上次的脚本代码。如果脚本代码中包括函数或过程，执行此方法后可以用“运行”方法来单独执行。

例程

说明：

通过脚本对话框，打开脚本文件；读入脚本数据转换成文本型放到文本数据中，然后执行文本数据内的脚本。

参见：例程


计算表达式 (脚本组件)

计算表达式 方法 操作系统支持：Windows 所属对象：脚本组件

计算表达式并返回结果。

语法： 文本型 脚本组件．计算表达式 （表达式）

参数名 | 描 述
表达式 | 必需的；文本型。要计算的表达式。

例程

说明：

执行文本变量中的计算表达式，将结果显示在结果编辑框中。

注：计算表达式中可以四则混合运算，比如1+(2*3)/6+10-10。

附Java表达式与运算符表(其中x和y为任意数值)：

括号

(x) [x]

中括号只用于指明数组的下标

求反、

自加、

自减

-x

返回 x 的相反数

!x

返回与 x (逻辑值)相反的逻辑值(真为非0，假为0)

x++

x 值加 1，但仍返回原来的 x 值

x--

x 值减 1，但仍返回原来的 x 值

++x

x 值加 1，返回后来的 x 值

--x

x 值减 1，返回后来的 x 值

乘、除

x*y

返回 x 乘以 y 的值

x/y

返回 x 除以 y 的值

x%y

返回 x 与 y 的模（x 除以y 的余数）

加、减

x+y

返回 x 加 y 的值

x-y

返回 x 减 y 的值

关系运算

x<y x<=y
x>=y x>y

当符合条件时返回 true 值，否则返回 false 值

等于、
不等于

x==y

当 x 等于 y 时返回 true 值，否则返回 false 值

x!=y

当 x 不等于 y 时返回 true 值，否则返回 false 值

位与

x&y

当两个数位同时为 1 时，返回的数据的当前数位为 1，其他情况都为 0

位异或

x^y

两个数位中有且只有一个为 0 时，返回 0，否则返回 1

位或

x|y

两个数位中只要有一个为 1，则返回 1；当两个数位都为零时才返回零

位运算符通常会被当作逻辑运算符来使用。它的实际运算情况是：把两个操作数（即 x 和 y）化成二进制数，对每个数位执行以上所列工作，然后返回得到的新二进制数。由于“真”值在电脑内部（通常）是全部数位都是 1 的二进制数，而“假”值则是全部是 0 的二进制数，所以位运算符也可以充当逻辑运算符。

逻辑与

x&&y

当 x 和 y 同时为 true 时返回 true，否则返回 false

逻辑或

x||y

当 x 和 y 任意一个为 true 时返回 true，当两者同时为 false 时返回 false

逻辑与/或有时候被称为“快速与/或”。这是因为当第一操作数（x）已经可以决定结果，它们将不去理会 y 的值。例如，false && y，因为x == false，不管 y 的值是什么，结果始终是 false，于是本表达式立即返回 false，而不论 y 是多少，甚至 y 可以导致出错，程序也可以照样运行下去。

条件

c?x:y

当条件 c 为 true 时返回 x 的值（执行 x 语句），否则返回 y 的值（执行 y 语句）

赋值、
复合运算

x=y

把 y 的值赋给 x，返回所赋的值

x+=y x-=y x*=y
x/=y x%=y

x 与 y 相加/减/乘/除/求余，所得结果赋给 x，并返回 x 赋值后的值

参见：例程


清除 (脚本组件)

清除 方法 操作系统支持：Windows 所属对象：脚本组件

清除上次执行代码,包括过程。

语法： 无返回值 脚本组件．清除 （）

例程

说明：

清除上次执行代码,包括过程。

参见：例程


运行 (脚本组件)

运行 方法 操作系统支持：Windows 所属对象：脚本组件

运行指定的过程，如有返回值返回相关数据，否则返回空文本。

语法： 文本型 脚本组件．运行 （过程或函数名，［参数块］，… ）

参数名 | 描 述
过程或函数名 | 必需的；文本型。所要运行的过程或函数名。
参数块 | 可选的；可扩充的；通用型。要执行过程或函数的参数。

例程

说明：

运行刚执行过的脚本中的函数名为函数名编辑框中的内容，第一个参数为参数编辑框中的内容，第二个参数为参数块编辑框中的内容。

运行方法中的参数块是可扩充的，如果所要执行的函数没有参数，那么参数块请留空。

注：运行函数之前如果没有执行过脚本，那么调用运行将没有结果。

参见：例程


常量 | 常量值 | 描 述
#无超时 | -1 | 用于设置脚本组件的超时属性，使脚本引擎的执行无超时。