操作系统界面功能支持库

操作系统界面功能支持库 帮助手册20080808版 返回支持库手册 返回首页

本支持库封装了Windows操作系统用户界面中的常用功能。

操作系统支持： Windows

命令类别：

快捷方式操作

文件操作

杂类

常量表

例程列表：

例程名称 | 下载 | 说明
界面支持库测试程序 | 功能全面演示.e | 本程序用作测试操作系统界面支持库。
关闭系统测试 | 关闭系统测试.e | 本程序用作测试"关闭系统"命令

适用版本，操作系统界面功能支持库 （1.0#50版）


快捷方式操作

快捷方式操作 类别 跳至：操作系统界面功能支持库


创建快捷方式 命令 所属类别：快捷方式操作

创建快捷方式 命令 操作系统支持：Windows 所属类别：快捷方式操作

本命令建立指定的快捷方式文件，成功返回真，失败返回假。

语法： 逻辑型 创建快捷方式 （快捷方式文件名，指向文件路径，［备注信息］，［命令行文本］，［工作目录］）

参数名 | 描 述
快捷方式文件名 | 必需的；文本型。如果文件名不包含后缀，将自动加上“.lnk”后缀名。
指向文件路径 | 必需的；文本型。本参数提供快捷方式所指向文件的全路径名。
备注信息 | 可选的；文本型。本参数提供对应此快捷方式的描述文本信息，如果被省略，默认为空文本。
命令行文本 | 可选的；文本型。本参数提供启动快捷方式指向文件时附加的命令行文本，如果被省略，默认为空文本。
工作目录 | 可选的；文本型。本参数提供启动快捷方式指向文件时所需预置的工作目录，如果被省略，默认为空文本。

例程：

说明：

创建指定文件的快捷方式，如果不命名快捷方式的后缀，自动添加”.lnk”后缀

参见：例程1


查询快捷方式 命令 所属类别：快捷方式操作

查询快捷方式 命令 操作系统支持：Windows 所属类别：快捷方式操作

本命令从指定快捷方式文件中获取该快捷方式所指向的文件路径名，如果该文件不是快捷方式文件或执行失败则返回空文本。

语法： 文本型 查询快捷方式 （快捷方式文件名）

参数名 | 描 述
快捷方式文件名 | 必需的；文本型。如果文件名不包含后缀，将自动加上“.lnk”后缀名。

例程：

说明：

查找指定的快捷方式所指向的真正文件路径，可以用这个命令来判断某个快捷方式是否有效


文件操作

文件操作 类别 跳至：操作系统界面功能支持库


浏览文件夹 命令 操作系统支持：Windows 所属类别：文件操作

打开一个对话框，浏览系统中存在的所有文件夹，返回被选定文件夹的路径名，如果未选中任何文件夹，则返回空文本。

语法： 文本型 浏览文件夹 （标题，［是否包含文件］）

参数名 | 描 述
标题 | 必需的；文本型。本参数提供显示在对话框上部的标题文本。
是否包含文件 | 可选的；逻辑型。本参数指定是否在浏览框中同时列出文件名。如果被省略，默认值为假。

例程：

说明：

通过＂浏览文件夹＂命令选择一个文件或文件夹，如果用户放弃操作，将返回空文本，注意如果选择的是根目录，路径最后将为“\”。


删除到回收站 命令 操作系统支持：Windows 所属类别：文件操作

本命令可以将一个或一批文件删除到Windows系统回收站中，成功返回真，失败或被用户中止删除操作返回假。

语法： 逻辑型 删除到回收站 （［删除选项］，欲删除文件）

参数名 | 描 述
删除选项 | 可选的；整数型。本参数提供删除操作选项，可以为以下常量值之一或之和： 1: #不询问删除; 2: #不提示错误; 4: #不显示进度。如果被省略，默认值为 0 。
欲删除文件 | 必需的；可扩充的；文本型，参数数据可以同时提供数组或非数组数据。可以以数组方式同时提供多个文件或文件夹名，注意必须是全路径，支持通配符“*”和“?”。

例程：

说明：

将选择的文件删除到回收站中。删除选项中的常量可以任意组合相加。


进度复制文件 命令 操作系统支持：Windows 所属类别：文件操作

本命令可以将一个或一批文件复制到另一个目录中，并同时显示一个复制进度对话框，成功返回真，失败或被用户中止复制操作返回假。

语法： 逻辑型 进度复制文件 （目的目录，源文件）

参数名 | 描 述
目的目录 | 必需的；文本型。本参数提供目的目录路径，如果该目录不存在，系统将自动询问是否创建。
源文件 | 必需的；可扩充的；文本型，参数数据可以同时提供数组或非数组数据。可以以数组方式同时提供多个文件或文件夹名，注意必须是全路径，支持通配符“*”和“?”。

例程：

说明：

将指定的文件复制到桌面上，源文件不被改变或移动。


进度移动文件 命令 操作系统支持：Windows 所属类别：文件操作

本命令可以将一个或一批文件移动到另一个目录中，并同时显示一个移动进度对话框，成功返回真，失败或被用户中止移动操作返回假。

语法： 逻辑型 进度移动文件 （目的目录，源文件）

参数名 | 描 述
目的目录 | 必需的；文本型。本参数提供目的目录路径，如果该目录不存在，系统将自动询问是否创建。
源文件 | 必需的；可扩充的；文本型，参数数据可以同时提供数组或非数组数据。可以以数组方式同时提供多个文件或文件夹名，注意必须是全路径，支持通配符“*”和“?”。

例程：

说明：

将指定的文件移动到桌面上。


杂类

杂类 类别 跳至：操作系统界面功能支持库


执行 命令 操作系统支持：Windows 所属类别：杂类

使用Windows的用户界面系统执行指定命令。

语法： 无返回值 执行 （［命令类型］，欲操作文件名，［命令行］，［默认当前目录］）

参数名 | 描 述
命令类型 | 可选的；整数型。本参数提供欲执行命令的类型，可以为以下常量值之一： 1: #编辑文档; 启动编辑软件打开“欲操作文件名”参数所指定的文档文件进行编辑。 2: #浏览文件夹; 打开“欲操作文件名”参数所指定的文件夹进行浏览。 3: #寻找文件; 打开“欲操作文件名”参数所指定的文件夹进行文件寻找操作。 4: #打开文件; 打开“欲操作文件名”参数所指定的文件，该文件可以是可执行文件、文档文件或文件夹。 5: #打印文档; 打印“欲操作文件名”参数所指定的文档文件，注意该文档的编辑软件可能不支持本命令，故使用前需要先测试是否可用。 如果本参数被省略或者为0，系统将首先搜寻注册表以获取对应于欲操作文件的一个合适命令类型，如果未找到，将使用“#打开文件”命令。
欲操作文件名 | 必需的；文本型。本参数提供欲操作文件或文件夹的名称。
命令行 | 可选的；文本型。如果欲进行操作的类型为“打开文件”且被打开文件为可执行文件，本参数提供启动该可执行文件时欲附加的命令行文本，其它情况下本参数将被忽略。如果本参数被省略，默认为空文本。
默认当前目录 | 可选的；文本型。本参数提供命令执行时的默认当前目录，如果被省略，默认为空文本。

例程：

说明：

在类型选择框中选中不同项，执行不同命令


取特定目录 命令 操作系统支持：Windows 所属类别：杂类

本命令返回指定的Windows系统特定目录，所返回目录名以“\”符号结束，如失败返回空文本。

语法： 文本型 取特定目录 （欲获取目录类型）

参数名 | 描 述
欲获取目录类型 | 必需的；整数型。本参数指定欲获取目录的类型，可以为以下常量值之一： 1: #我的文档; 2: #我的收藏夹; 3: #系统桌面; 4: #系统字体; 5: #开始菜单组; 6: #程序菜单组; 7: #启动菜单组; 8: #程序数据目录; 9: #Windows安装目录; 10: #Windows系统目录; 11: #临时文件目录。

例程：

说明：

在组合框中选择不同项目，取出不同的目录路径。


关闭系统 命令 操作系统支持：Windows 所属类别：杂类

本命令可以执行关机、重启、注销等Windows系统操作。成功返回真，失败返回假。

语法： 逻辑型 关闭系统 （关闭方式，［是否强制执行］）

参数名 | 描 述
关闭方式 | 必需的；整数型。本参数可以为以下常量值之一： 1: #关机; 2: #重启; 3: #注销; 4: #休眠 5: #冬眠。 注意在Windows95/98/ME下冬眠等同于休眠。
是否强制执行 | 可选的；逻辑型。本参数指定是否不等待当前正在运行的所有软件正常结束而立即执行指定的操作。如果本参数被省略，默认值为假。

例程：

说明：

选择不同的组合框项目，执行相应的关闭系统命令


常量 | 常量值 | 描 述
#编辑文档 | 1 |
#浏览文件夹 | 2 |
#寻找文件 | 3 |
#打开文件 | 4 |
#打印文档 | 5 |
#我的文档 | 1 |
#我的收藏夹 | 2 |
#系统桌面 | 3 |
#系统字体 | 4 |
#开始菜单组 | 5 |
#程序菜单组 | 6 |
#启动菜单组 | 7 |
#程序数据目录 | 8 |
#Windows安装目录 | 9 |
#Windows系统目录 | 10 |
#临时文件目录 | 11 |
#不询问删除 | 1 |
#不提示错误 | 2 |
#不显示进度 | 4 |
#关机 | 1 |
#重启 | 2 |
#注销 | 3 |
#休眠 | 4 |
#冬眠 | 5 |