软件介绍

一、软件功能介绍

根据卫生部《关于进一步规范预防性健康检查管理工作的通知》规定，健康证明是格式固定，表明从业人员经过预防性健康体检合格，可以从事相关卫生行业的工作的证明性文件。

在健康证明的发放过程中，不少单位采用WPS或WORD固定排版，填充式打印来实现，其明显的弊端是：

1、操作繁琐，效率低下。一般每个地区从业人员均在数千至数万人之间，如此大量的健康证明，没有一个良好的交互界面，不但容易出错，而且录入速度难以提高。

2、无法保存健康证明数据，为统计、查询带来不便。

为此，我们根据实际工作需求，编写了这款《健康证明发放管理程序》，在软件的开发过程中，我们深入观察、分析了各地健康证明发放相关内容，尽可能做到适应更多不同地区的需要，经过一年多时间的试用，取得了良好的效果。

《健康证明发放管理系统》具有如下优点：

1、最大限度地满足用户不同需要，由用户自由定制数据库，自由设置区域、工种，自由按排健康证明布局。

2、为用户提供良好的交互界面，录入方便、简捷、安全。

3、提供简单易用的查询功能、统计功能，满足日常工作需要。

4、多用户操作，后台记录健康证明发放者姓名。管理员可以方便地查看健康证明发放者情况。

5、提供套打及直接打印两种打印方式，提供单张健康证明打印及批量打印两种功能，均由用户自由选择。

6、多方面多层次的安全保护，任何非程序运行中导致的数据改变，都会被系统发现，并自动恢复。从而最大限度地保证数据的安全。

二、同类软件比较

目前还未发现一款比较完整的健康证明管理程序（或从业人员管理程序），已有的程序一般都非常简单，只适合软件作者当地情况，并且打印设置功能不强。而《健康证明管理系统》的开发，弥补了这一空白，并且全开放式的用户操作，灵活的系统配置，可以适合任何地区使用。

如果需要进一步定制，欢迎与作者联系。

二○○五年四月二十二日


安装与注册

《健康证明发放管理系统》为绿色软件，拷贝即可使用，对系统配置要求低，可以适用于WINDOWS98、ME、2000、XP、2003等多种操作系统。

2005特别版开放全部功能，不需要注册即可使用。


用户管理

1、登录系统

系统默认管理员为“超级管理员”，默认密码为：8888。由于管理员拥有一些与系统数据安全有关的权限，所以请在登录后立即修改管理员密码。另外，管理员可以随意添加普通用户，以方便不同的工作人员进行健康证明发放管理。

在系统运行过程中，你还可以随时重新登录，以更换当前用户。

在登录系统时，如果你选择了保存密码，那么下次以同一用户登录时，就不再需要输入密码。考虑到系统数据的安全，超级管理员不允许保存密码。

2、添加用户

只有“超级管理员”才有添加用户的权限。你可以添加任意数量的用户，输入用户名，用户密码及复核密码，确定后即可添加一个新用户。除了超级管理员以外，其它所有的用户拥有的权限完全一样。

3、删除用户

只有“超级管理员”才有添加用户的权限。除了超级管理员自身外，其他任何用户都可以被删除，而不会影响系统数据。

4、修改密码

每个用户均可以随时为自己修改密码，正确输入原有密码，再输入新密码，并进行复核，即可修改。

注意：即使超级管理员，也无权修改其他用户的密码！


使用说明

数据操作

1、健康证明数据操作：

包括健康证明的添加、修改、删除（只在超级管理员才拥有删除健康证明的权限）。操作方法简单明了，方便快捷。在健康证明数据录入过程中，可以用TAB键转移输入焦点，另外，只要按下回车键，即自动将输入焦点转移到保存按钮。再次按下回车键，即可保存。快捷的录入过程中，基本不需要鼠标操作。从而最大程序地方便用户。

2、健康证明数据查询：

系统提供两种查询方法，即可以按从业人员姓名及按健康证明编号来查询。如果数据库中包含多个符合条件的健康证明数据，可以按查找下一个（F3键）继续查找。操作简单，快捷键符合常用软件通用规定。

3、健康证明打印：

系统提供了单张健康证明打印及批量打印健康证明的功能。前者用于少量健康证明发放时，完成一张录入，即打印健康证明。后者，用于同一区域批量健康证明发放，用户可以一次性录入多份健康证明数据，然后用批量打印功能全部打印。

健康证明打印需要注意以下几点：

（1）在打印前必须进行打印设置。打印设置不需要使用复杂的报表编辑器，采用的是傻瓜式丈量的方式，用户勾选需要打印的项目，并用直尺量取相应项目在健康证明卡片上的距左边及顶边的位置，录入保存（录入单位为：毫米），即可完成打印设置。

（2）设置时请注意是否需要套打。套打指将相关项目数据打印在已经印制好的固定格式的健康证明卡片上。否则，则将相关项目连同其项目标题，一直打印在空白纸装上。如果套打，则在丈量时，应该量取相关项目内容填充位置。否则，应该量取相关项目标题所在位置。

（3）应正确设置健康证明大小。根据卫生部文件规定，健康证明大小应该是9.5cm×6.5cm，但各地设置的卡片大小可能不尽相同，所以请正确设置。另外，有些单位的健康证明采取连续纸方式，比如，作者所在单位，健康证明为每4张一联形式，所以请同时设置健康证明连续张数。

系统同时提供即时方便的打印预览功能，可以预览打印效果，同时方便用户对其设定的打印设置进行修改。

4、数据备份与恢复：

在健康证明录入过程中，系统会自动将数据备份到程序目录下的autobak目录下，同时，为进一步确保数据安全，系统还提供了数据备份及数据恢复菜单功能。并且，每次程序退出时，会自动提醒用户备份。

用户备份数据前，需要先设置数据备份目录，建议数据备份目录应该设置在程序目录不同的分区中。

在程序启动时，会自动检查数据的完整性，并通过多方面尝试自动恢复。如果恢复不成功，则需要用户通过数据恢复菜单功能，利用备份的数据来恢复。

5、数据年结：

由于健康证明数量比较大，所以一般不赞成用户将多年数据保存在同一数据为中。因此，在每年的12月31日或次年的1月4日前，系统均会提醒用户进行数据年结。即把一年的数据冻结并保存至系统默认的年结目录。并清空现有数据，从新开始新的一年的健康证明发放管理。

注意：只有超级管理员才有权限执行此项操作，并且在操作前需要输入权限密码：jkzm-restoredata。

由于数据年结会将现有的所有健康证明数据全部冻结，因此，此项操作最好在系统规定的时间内执行。否则将有可能造成某年数据在查询和统计方面的麻烦。

数据年结后，你可以选择重新初始化系统，或继续使用当前的系统设置。作者建议用户一般应对系统设置保持一定的连贯性，不要频繁改变系统配置。

对已经年结并冻结的健康证明数据，你可以通过查看往年数据菜单进行查看，但冻结的数据不允许修改和打印。

在查看冻结数据时，如果需要录入新健康证明，请点击“返回”按钮或者通过菜单选择退出查看状态，返回健康证明录入管理状态。

6、数据统计：

系统提供全自动的统计方法，会根据用户在系统配置中设置的区域分类、工种分类等，进行全面分类统计，统计结果可以保存为文本文件以进一步编辑排版并打印。


系统配置

在系统使用过程中，你可以随时对多项系统配置进行调整。

一、数据字典

《健康证明管理系统》将以下基本确定不变的项目归纳为数据字典，具体如下：

1、单位名称：

可以随时修改发证单位或健康检查单位名称，该名称将显示在健康证明界面下部。并可打印至健康证明卡片中设定的位置。

在进行单位名称设置时，请保存名称首部的“发证单位：”或“健康检查单位：”字样。

如：发证单位：启东市卫生监督所。

或：健康检查单位：启东市疾病预防控制中心。

2、备份目录：

为了确保数据安全，你需要设置一个数据备份目录，并确保该目录不会被删除。建议将备份目录设置在与《健康证明管理系统》安装所在分区不同的磁盘分区中。

如果你没有设置备份目录，在你执行数据备份操作时，系统会提醒你进行此项设置。

3、工种设置：

对从业人员所属行业工种进行分类设置。系统默认提供。如果你觉得默认的工种分类不适合当地实际情况，你可以通过此项操作进行修改。

考虑到健康证明卡片打印空间，建议每个工种名称保持在4个汉字以内，最长不要超过5个汉字。

4、区域设置：

如果你还需要对当地所有从业人员健康证明进行分区管理，可以在这里设置具体的区域。区域字段的设置请参考“重设字段”。

注意：如果你同时选择了一级区域及二级区域，那么，必须为每个一级区域下设置相应的二级区域。

二、规则设置

1、编号规则：

某些省份地区对健康证明编号作了具体规定，比如江苏省卫生厅规定，江苏省各地的健康证明号码规则为：

固定的地区11位编码（由省卫生厅设定并统一下达）＋健康证明流水号。

为确保《健康证明管理系统》适合不同地区的不同要求，系统提供了编号规则设置功能。根据用户在重设字段中设定的字段的不同，可以设置不同的编号规则。

编号中的具体内容如下：

固定编码：如果你在编号规则中设置了需要固定编码，请正确输入固定编码。

区域代码：如果你在编号规则中设置了区域代码。请正确设置一级区域或二级区域代码，注意：一级区域及二级区域，其固定代码均以数字表示，且不超过2位数。

流水号：从1开始的流水号。请根据用户当地可能的从业人员数合理设置流水号长度。比如，如果当地从业人员数大约为6000人，那么请设置流水号长度为4。

注意，编号规则的改变，将会导致原有健康证明数据中，健康证明号码与改变后的编号规则不兼容，在你对这些健康证明数据进行修改时，系统将提示号码错误，不允许保存。同时，你将无法使用批量打印功能对原有健康证明数据进行批量打印。所以，请在录入健康证明数据前，妥善设置好编号规则，在运行过程中，不有随意修改此项规则。

为确保数据安全，只有超级管理员才有权限进行编号规则设置。

2、证件设置：

设置健康证明卡片的大小（宽度及高度）以及连纸张数。请用直尺直接丈量，单位：毫米。

连续张数指某些地区，以数张健康证明连续为一页的情况下，每页中的健康证明卡片张数。此项设置在批量打印时生效。

如果批量打印时，打印的健康证明份数小于连续张数，系统会自动匹配换页。

3、卡片布局：

根据用户设置的数据库字段，合理按排健康证明管理系统主界面的布局显示。请根据你个人的喜好进行设置。

（1）移动组件：点击需要改变位置的组件，该组件即处于选中状态。然后按下鼠标并拖动至相应位置，如果对移动的位置不满意，你还可以通过点击工具条上的相应按钮，进行微调。

（2）改变组件大小：在实际操作时可以由用户输入内容的组件，均可以改变宽度（照片框会根据用户改变的宽度，自动调节高度）。鼠标按住组件右边框处，并左右拖动，即可改变组件大小。

（3）切换组件：双击组件，可以将组件在健康证明卡片区域与组件寄存区中来回切换，以方便用户调整。

除了分隔线外，其余所有组件最后均必须排布在健康证明卡片显示区域。

4、打印设置：

具体设置健康证明各项目的打印位置。系统采用了傻瓜式的直接丈量方式，省略了繁琐的报表设置过程。请用直尺精确丈量。单位：毫米。

健康证明打印支持套打及全部打印两种模式。详细请参见：数据操作->健康证明打印。

勾选所有需要打印的字段，并正确设置打印位置。设置完毕，你可以通过菜单[打印->打印预览]来察看效果。

注意，系统并不会自动对你设置的健康证明卡片大小与相关字段打印位置进行判断。在设置时请不要超出打印范围。

5、照片来源：

设置健康证明卡片中照片来源。具体包括：

仅显示：仅在系统界面中显示照片框，而不导入实际照片。

来自文件：从图像文件中导入从业人员照片，可以实际保存到数据库并打印。

来自数码设备：从系统安装的数码设备中获取从业人员照片。可以实际保存到数据库并打印。


系统配置

附加功能

为方便用户使用，《健康证明管理系统》还提供了贴心的附加功能。

一、计算器：

调用系统自带的计算器。

2、记事本：

调用系统自带的记事本。

3、背景音乐设置：

设置系统运行时的背景音乐，支持mp3、wma、mid、wav等各种常见的音乐文件格式，支持加入多个音乐文件。支持随机或顺序播放。

你甚至可以将本系统当成一个简单的音乐播放器来处理。


初始化系统

第一次运行本系统时，《健康证明管理系统》将调用默认系统配置及数据库设置，如果用户觉得默认配置不适合当地实际需要，可以通过菜单：“数据库->初始化”进行初始化设置。

在系统进行过程中，用户也可以随时进行初始化设置。

注意：为保证数据完整，一旦初始化完成并正式启用系统后，请不要随意进行系统初始化。虽然，系统会尽可能地保留现有健康证明数据，但由于给予了用户比较大的自由度，初始化前后不匹配的数据字段将会被抛弃。

为确保系统数据安全，只有超级管理员才有权限在使用过程中进行系统初始化，并且必须输入权限密码：jkzm-restoredata。

初始化设置包括以下几步：

1、选择字段：

除编号，姓名，性别，工种，年龄，发证日期等必需项目外，你还可以根据需要，选择区域、体检结果、培训结果、照片等项目。

（1）区域设置：

系统已经设置了从业人员按工种分类。如果你需要对辖区内从业人员按区域规划进一步分类，你可以选择区域设置中的一级区域及二级区域。系统同时支持用户设置二级区域分类，为健康证明的分类管理提供良好基础。

比如：上海市卫生监督所，可以对其发放的从业人员按区进行划分，即一级区域：徐汇区、卢湾区、静安区等。然后对每个区又可以按街道或者其他项目进行进一步分类，即二级区域。

注意：如果你未选择一级区域，则二级区域也不可选。如果你选择了一级区域，则二级区域可以选也可以不选。一切均根据用户实际需要而定。

你所选择并设置的区域仅在添加或统计健康证明数据时作分类用。并不会实际打印到健康证明卡片上。

（2）证件相关：

证件相关中的项目均可以实际显示到健康证明卡片界面并打印。用户可以根据需要选择。

其中：体检结果与培训结果即使未选择，即数据库中不存在该字段，在打印健康证明卡片时，也可以设置打印。

2、编号规则：

详见系统配置相关内容。

3、区域设置：

如果你在设计字段时选择了区域。则需要进行区域设置。

详见系统配置相关内容。

4、卡片布局：

根据用户设置的数据库字段项目，重新进行卡片布局设置。

详见系统配置相关内容。


联系方法

本系统使用全中文全可视易语言编写，易语言4.0以上程序安装包中，已经包含《健康证明管理系统》2005特别版全部源程序，欢迎下载。

软件支持请访问大连大有吴涛易语言有限公司官方网站：http://www.dywt.com.cn。


卫生部关于进一步规范预防性健康检查管理工作的通知

卫法监发[2002]300号

卫生部关于进一步规范预防性健康检查管理工作的通知

各省、自治区、直辖市卫生厅局，卫生部卫生监督中心：

根据国务院《关于取消第一批行政审批项目的决定》（国发[2002]24号）的有关要求，为认真做好取消食品生产经营人员健康证发放审批和化妆品生产人员健康证发放审批后的后续监管和衔接，保证预防性健康检查的质量，防止出现预防性健康管理脱节，现将有关事宜通知如下：

一、各级卫生行政部门对食品生产经营人员和化妆品生产人

员健康证的发放不再进行审批。食品生产经营人员、化妆品生产人员应当按照《食品卫生法》、《化妆品卫生监督条例》的有关规定进行健康检查，取得健康证明后方可参加工作。未取得健康证明的人员，不得从事食品生产经营和化妆品生产。

二、食品生产经营单位、化妆品生产单位应当按规定组织从业人员的预防性健康检查，并负责建立个人健康档案，同时要将个人的健康证明存档备查。

三、承担预防性健康检查工作的医疗卫生机构（以下简称健康检查单位）应当按照我部1995年发布实施的《预防性健康检查管理办法》的有关规定，使用中华人民共和国预防性健康检查用表，在指定的范围内开展预防性健康检查工作，不得随意增减健康检查项目和频次。健康检查单位每年应当定期向卫生行政部门报告预防性健康检查工作情况。

健康检查单位对预防性健康检查合格的食品生产经营人员、化妆品生产人员发给健康证明，并加盖健康检查单位的公章。

四、健康证明由省级卫生行政部门所属卫生监督机构统一印制、编号，具体样式见附件。

各级卫生行政部门应当按照《食品卫生法》和《预防性健康检查管理办法》等规定，加强对食品生产经营企业、化妆品生产企业卫生知识培训工作和预防性健康检查工作实施情况的监督检查。

执行中发现的问题，请及时告我部卫生法制与监督司。

附件：健康证明（样式）

二○○二年十二月五日

附件：

健 康 证 明（样式）

照 片

编号：

姓名： 性别：

工种： 年龄：

体检： 合 格

发证日期：

健康检查单位： （章）