IT售后管理系统v3.0版

本软件使用易语言编写，大连大有吴涛易语言软件开发有限公司官方网址:http://www.dywt.com.cn


序言：

现在大部分IT零售、批发（电脑城装机商）公司在客户售后系统上采用EXECL等简单的资料管理，尤其在客户维修记录上，无法做到统一管理，数据统计等必要的功能，造成客户流失，投诉等问题。开发者以在电脑零售公司多年的工作经验，结合智能化管理的先进思想开发出此IT售后管理系统，解决了上述绝大部分问题，使之管理智能化，规范化。

适用范围：

主要面向所有中小型IT业零售、批发公司（电脑城装机商）使用。也可适用于电器零售行业，小型机械销售，零配件销售行业等对客户售后有一定需求，货品有一定报修期限，货品划分类别简洁化的所有行业。

结构概述：

本系统暂分为五个主要功能模块：客户资料管理模块，会员资料管理模块，货品配置管理模块，客户维修管理模块，其他辅助功能模块。（后续版本功能将继续增强）

系统配置要求：

运行本系统最低硬件配置：PII233、32M内存、300M可用硬盘空间；

运行本系统所需软件环境：中文Windows98SE/Me/2000/XP/2003，Windows95或Windows98第一版需另行安装数据库驱动程序；

推荐系统：Windows XP

屏幕分辨率不低于800*600。最适合分辨率为 800*600


系统主界面：

大部分功能将在主界面中完成。如果选择了登陆帐套将直接打开信息导航窗口，可选择相应功能来完成工作。主界面底部的状态栏显示了当前登陆的用户、帐套和系统日期。

主要功能显示在信息导航条左边，点击相应按钮可切换到具体功能选项夹。信息导航的下面是辅助功能区，可方便调用、查看常用信息：如货品资料、基础资料、客户信息等。


系统主界面

资料录入：

录入客户、会员资料，浏览、查询资料。将客户的基础信息和配置信息录入至系统，可条件查询、浏览录入的资料，修改、删除资料。

录入资料：用于录入客户、会员基础资料和配置资料。可简单浏览资料，修改、删除资料。

浏览资料：浏览所有已录入的客户、会员资料，可过滤特点资料，修改、删除资料。

查询资料：多条件、可嵌套查询客户、会员的各种资料信息。


资料录入：

录入客户、会员的基础资料和详细配置资料。实现录入、浏览、修改、删除等功能。

客户、会员资料将以唯一编号（唯一编号可由系统自动生成，推荐由系统生成，以免编号重复）储存。

基础资料将记录姓名、电话（可分移动电话和固定电话）、地址等。

销售资料将记录销售部门、销售代表、技术负责、销售单号、金额和购买日期等信息。

配置资料将记录客户、会员的配置情况。可在表格中调用货品资料窗口来快速录入配置情况。客户配置将按类别分类，可记录类别、品牌、型号、单位、数量、质保方式和备注信息。


资料浏览：

按日期浏览所有记录的资料。可查询详细资料和配置资料。点击“↓”可收缩浏览界面,方便浏览大量信息。也可点击“高级查询”来显示特点资料。

浏览资料时初始日期将自动指向当月一号。浏览资料时可将修改、删除选定的资料。可用高级查询来过滤特点信息。可打印显示的资料。


查询资料：

多条件方式查询，记录中所有的字段都可作为查询的关键字，保证遍历所有记录。支持精确查询和模糊查询方式。支持多种条件嵌套查询。

根据各种查询关键字的类型不同，系统自动调整查询方式，如查询购买日期时系统自动将条件值转换到日期型，方便查询时的条件输入。可多条件相结合查询，查询条件将显示在条件框中，一目了然、操作简单易懂、条件分明。


维修系统：

用于记录客户的维修情况。可定时提示为该维修的客户，可将维修任务分配到每个技术人员，可以审核最终的维修情况，不合格将不予审核。

维修登记：记录客户报修时的资料。

维修审核：用于分配维修任务和最终维修情况的审核。

维修记录：浏览所有已登记的记录。

维修查询：用于查询特点资料。


维修登记：

维修登记将记录客户报修时的资料。可以导入客户资料，免除手动输入的麻烦。可以显示维修次数。可以设置维修信息。

利用“导入”按钮可方便导入已登记的客户、会员基础资料，提高登记速度，免除逐条录入和询问客户具体信息的麻烦。

可显示当天已登记的单数，方便登记员统筹安排下面客户的维修日期。

可显示当前维修客户的维修状况、次数。

可设置预约维修日期、时间。

可设置维修类型、服务方式、服务费用等。


维修审核：

维修审核用于分配维修任务和最终维修情况的审核。点出窗口将显示出所有未审核过的维修记录，以示提醒。将未维修的任务分配给技术人员，结果由审核人审核合格后审批，以消除此记录。可以查看由那位技术人员维修的记录。

点击“技术员”可弹出所有技术人员名单，可指派由那位技术人员承接此维修任务。维修完毕或第二天再由审核人员审核维修情况，合格后完成审核，消除此维修记录。

点击“审核人”可弹出所有具有审核权限的人名单。

单击维修记录，可以查看具体登记情况。


基础信息：

可设置基础资料：如货品资料、销售人员、销售部门、技术人员、计量单位、故障情况等。用于录入等功能时的常用设置。

基础资料: 配置常用信息。如销售部门、技术人员、计量单位、故障情况等。

货品资料：配置货品资料，用于快速录入资料时调用。

客户信息：显示所有已登记客户的基础资料。

会员信息：显示所有已登记会员的基础资料。


货品资料：

配置货品资料，用于快速录入资料时调用。可添加到打开的单据中。可编辑货品资料。可在录入资料时自动隐藏（在系统设置中可设置），便于录入资料（推荐打开此功能）。

可按类别、品牌、型号分类显示。支持模糊查询货品。

双击货品或用右键菜单中的“添加”功能，可将货品自动添加到已打开的记录资料单据中。

用“全部添加”可以将所选中的所有货品逐条添加到单据中。

可编辑货品。分类设置。

双击每个类别可进行添加、修改、删除货品。

可设置质保方式、计量单位、备注等信息。

每样货品单独一个编号。可由系统自动生成（推荐）。


客户

客户、会员信息：

显示所有已登记客户、会员的基础资料。可导出至已打开的单据中，如：维修登记。便于快速录入资料和浏览所有登记客户、会员基础资料。

日期初始化到当前日期的三个月前，可浏览近三个月的所有客户、会员资料。

简单查询可过滤出特点信息。

双击信息或右键菜单中的导出至单据，可将选定资料导出至已打开的单据中。


系统设置：

用于配置系统重要信息。可管理用户，设置权限。管理帐套，备份、恢复数据，配置系统等等。

用户管理：添加、修改、删除用户（要操作用户具有相应权限），设置用户权限、密码。

帐套管理：添加、修改、删除帐套（要操作用户具有相应权限）。

系统配置：配置系统信息。

备份数据：备份所有帐套资料数据。

恢复数据：恢复所有帐套资料数据。


登陆系统：

可选择系统中的管理用户来登陆系统并根据登陆用户的权限来设置系统使用范围。

初次登陆系统将以“初始管理员”身份登陆，请登陆系统后及时新增、修改管理用户名及密码。

注册版将显示注册单位名称在登陆界面上。


帐套管理：

本系统引入财务管理模式，将记录分帐套管理，可以由用户自行建立（按年份或部门）帐套，使之记录管理科学化，分类化、查询快捷准确。

登陆系统后将出现登陆的帐套选择界面，可选择登陆帐套。系统自带一个演示帐套，可修改或删除此演示帐套。一般一个帐套要使用很常时间，可以将常登陆的帐套的登陆方式设置成“默认”，下次登陆时将直接登陆到此帐套中。

如初次使用，可点击“新增”按钮来新增一个帐套：

注意帐套名称不可重复，只能是系统中唯一的帐套名。可设置隶属部门和备注。


用户管理：

添加、修改、删除管理用户（要操作用户具有相应权限），设置管理用户的权限、密码等。

权限可细分置每个功能，精确划分权限。

如初次使用未设立管理用户时，将提示新增一名具有所有权限的管理用户，此时添加的第一名用户系统将自动给予所有权限，以保证一名超级用户的存在。

不具备管理用户权限的用户登陆此窗口将不能操作其他用户，只能修改自己的登陆密码。只有具有管理权限的用户才可以新增、修改、删除其他用户的设置。

请一定保持至少一名用户具有所有权限。


系统配置：

配置系统的外观、背景图片、单据编号、提示信息等等。

外观设置可将系统外观根据用户喜好配置成不同风格。可以在主界面中加入一张背景图片，使办公更加轻松（加入背景图片后可能会造成系统启动和运行速度减慢，建议不设置）。

系统设置中的单据编号头可以设置不同单据的开始编号，不同编号头可以使人一眼即知是什么类型的单据，但编号头应具有统一性，不应经常更换。

维修提示是在每次登陆系统时提示为完成的维修任务。

货品自动隐藏是在货品配置窗口不在操作时自动隐藏，以方便录入资料。


注册说明

本软件使用易语言编写，大连大有吴涛易语言软件开发有限公司官方网址:http://www.dywt.com.cn