AutoCAD 2007 帮助

AutoCAD 2007 开发人员帮助

欢迎使用 AutoCAD 2007 开发人员帮助

AutoCAD 开发人员帮助提供了有关自定义和扩展 AutoCAD 的完整信息。请单击右侧的链接或使用“目录”选项卡浏览帮助主题。

一般信息

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP 教程

DXF 参考手册

ActiveX 和 VBA 开发人员手册

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

我的帮助
网上资源


自定义手册

《自定义手册》向有经验的用户介绍如何自定义 AutoCAD。要浏览《自定义手册》，请使用“帮助”窗口左侧的“目录”选项卡。

  • 自定义基础知识
  • 自定义线型
  • 自定义填充图案
  • 自定义用户界面
  • DIESEL
  • 幻灯片和命令脚本
  • 编程接口简介
  • 形和形字体
一般信息

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP 教程

DXF 参考手册

ActiveX 和 VBA 开发人员手册

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

我的帮助


AutoLISP Reference

AutoLISP 参照提供 AutoLISP® 的全面参考。AutoLISP 是一种功能全面的解释性编程语言，可用于调用 AutoCAD 命令、系统变量和对话框。AutoLISP 参考包含以下主题：

  • AutoLISP 函数：运算符、A、B、C、D、E、F、G、H、I、J、K、L、M、N、O、P、Q、R、S、T、U、V、W、X、Y、Z。
  • 外部定义命令
一般信息

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP 教程

DXF 参考手册

ActiveX 和 VBA 开发人员手册

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

我的帮助


AutoLISP Developer's Guide

《AutoLISP Developer's Guide》提供有关使用 Visual LISP® 交互式开发环境开发何测试 AutoLISP® 程序的信息。同时还描述了如何使用 Visual LISP 提供的扩展来创建 ActiveX® Automation。《AutoLISP Developer's Guide》中包括以下主题：

  • 简介
  • 使用 Visual LISP 环境
  • 使用 AutoLISP 语言
  • 使用可编程对话框
  • 附录
一般信息

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP 教程

DXF 参考手册

ActiveX 和 VBA 开发人员手册

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

我的帮助


AutoLISP 教程

AutoLISP 教程循序渐进地介绍如何使用 Visual LISP™ 开发 AutoLISP® 应用程序。AutoLISP 教程包含以下主题：

  • 简介
  • 设计和开始编程
  • 使用 Visual LISP 调试工具
  • 绘制小路边界
  • 创建工程和添加界面
  • 绘制砖
  • 使用反应器
  • 程序集成
一般信息

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP 教程

DXF 参考手册

ActiveX 和 VBA 开发人员手册

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

我的帮助


DXF 参考手册

DXF 参考提供 DXF™ 文件格式的全面参考。DXF 参考包含以下主题：

  • DXF 格式
  • HEADER 段
  • CLASSES 段
  • TABLES 段
  • BLOCKS 段
  • ENTITIES 段
  • OBJECTS 段
  • THUMBNAILIMAGE 段
  • 图形交换文件格式
  • 高级 DXF 问题
一般信息

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP 教程

DXF 参考手册

ActiveX 和 VBA 开发人员手册

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

我的帮助


ActiveX 和 VBA 开发人员手册

《ActiveX 和 VBA 开发人员手册》说明如何使用 ActiveX 和 VBA 开发应用程序来自定义 AutoCAD。本手册还包括样例代码和详细的操作步骤。《ActiveX 和 VBA 开发人员手册》包含以下主题：

  • 简介
  • VBA 使用入门
  • ActiveX Automation 基础知识
  • 控制 AutoCAD 环境
  • 创建和编辑 AutoCAD 图元
  • 标注和公差
  • 自定义工具栏和菜单
  • 使用事件
  • 在三维空间中工作
  • 定义布局并打印
  • 高级绘图与组织技术
  • 使用 VBA 开发应用程序
  • 与其他应用程序及 Windows API 交互
  • 设计花园小路 -- ActiveX/VBA 教程
  • Visual LISP 与 ActiveX/VBA 的比较
一般信息

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP 教程

DXF 参考手册

ActiveX 和 VBA 开发人员手册

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

我的帮助


ActiveX and VBA Reference

《ActiveX and VBA Reference》提供 ActiveX 对象模型及其关联接口部件的参考。《ActiveX and VBA Reference》包含以下主题：

  • 对象模型
  • 事件
  • 方法
  • 特性
  • 对象
  • 代码样例
一般信息

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP 教程

DXF 参考手册

ActiveX 和 VBA 开发人员手册

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

我的帮助


Sheet Set Objects Reference

《Sheet Set Objects Reference》提供了关于图纸集管理器对象的参考。《Sheet Set Objects Reference》包含以下主题：

  • 图纸集管理器对象概述
  • 对象
  • 方法
  • 特性
  • 枚举
一般信息

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP 教程

DXF 参考手册

ActiveX 和 VBA 开发人员手册

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

我的帮助


Connectivity Automation Reference

《Connectivity Automation Reference》提供 Connectivity Automation 对象模型及其关联接口部件的参考。《Connectivity Automation Reference》包含以下主题：

  • Connectivity Automation 对象
  • 对象模型
  • 对象
  • 方法
  • 特性
  • 事件
一般信息

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP 教程

DXF 参考手册

ActiveX 和 VBA 开发人员手册

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

我的帮助


ObjectARX

ObjectARX®，即 AutoCAD® Runtime Extension 编程环境，它包含可构造块的 C++ 库。这些构造块可用来开发 AutoCAD 应用程序、扩展 AutoCAD 类和协议，以及创建操作方式与 AutoCAD 内置命令相同的新命令。

如果此帮助项目在“目录”选项卡中显示为页面图标 ( [image])，则 ObjectARX 文档在帮助系统中将不可用。

AutoCAD ObjectARX 文档可从 Autodesk 网站的开发中心部分下载。要将 ObjectARX 文档和 AutoCAD 文档整合，请将 ObjectARX 帮助文件复制到“AutoCAD \HELP\”文件夹中。
一般信息

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP 教程

DXF 参考手册

ActiveX 和 VBA 开发人员手册

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

我的帮助


我的帮助

用户可以创建自己的帮助主题组，称为“我的帮助”。用户将“我的帮助”主题添加到 AutoCAD 帮助中之后，这些主题即可从“帮助”窗口左侧窗格的“目录”选项卡、“索引”选项卡（如果用户添加了索引条目）和“搜索”选项卡中找到。在“目录”选项卡中单击“我的帮助”主题，可以访问用户添加到 AutoCAD 帮助中的帮助主题。

有关设置“我的帮助”的信息，请参见设置“我的帮助”。
一般信息

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP 教程

DXF 参考手册

ActiveX 和 VBA 开发人员手册

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

我的帮助


帮助版本信息


意见？

请使用该表格将意见发送至负责该文档的 Autodesk 技术出版组。

姓名（可选）：
         电子邮件（可选）：
意见：

注意：该表并不作为用户接收反馈或技术支持的途径。用户提供的信息可使我们将来更好地更新该文档。谢谢!


AnswerWorks®


Query Tips

The following tips can help you get more useful results from your questions.

  • Filter your search by selecting only those documentation components that are likely to have the type of information you are looking for. Select a book or a set of books from the List of Documentation Components to Search.
  • Check your question for typographical errors. Important words may be ignored if they can't be recognized.
  • Write your query in the form of a question (How do I turn off dialog boxes?), or a phrase (turn off dialogs), or a keyword (dialogs). Each yields slightly different results.
  • Enter fewer words. Fewer words often produce better results.
    Example: maximum viewports returns a different list of topics than How do I increase the maximum displayable viewports?
  • Order your words differently. The order of words can affect your results.
    Example: maximum viewports is interpreted differently than viewports maximum.
  • Use different but similar words or terms in your question.
    Example: draw circles displays slightly different topics than create circles.
    Example: dialog boxes returns different results than dialogs.
  • Don't use punctuation characters. Use the Search tab if you need to search for terms that include any punctuation characters.
    Example: Entering file names such as acad.pat returns unreliable results.
  • Don't enter words that contain numbers.
    Example: Entering terms that include 3D returns unreliable results. You get better results if you spell out the term three dimensional.
  • Don't enter words that might be very commonly found in Help topics.
    Example: Entering drawing or line probably skews the results. Remove such words from your query or use more specific words.


版权和商标

版权所有 © 2006 Autodesk, Inc.

保留所有权利

本出版物或其任何部分，均不允许任何人因任何目的、以任何形式、采用任何方法予以复制。

Autodesk, Inc. 对这些资料不作任何明确或隐含的担保，包括但不仅限于对适销性和针对特定用途的适用性的担保。Autodesk, Inc. 仅按 照其实际状态（以“原样”方式）提供这些资料。

在任何情况下，对由购买或使用这些资料引起的或与之相关的直接、间接、偶然或必然的任何损失，Autodesk, Inc. 均不负有赔偿责任。 无论涉及何种诉讼，Autodesk, Inc. 所承担的赔偿责任以不超过此处所述资料的售价为限。

Autodesk, Inc. 保留酌情对产品进行修订和改进的权利。本出版物描述的是其出版时产品的状态，可能并不反映产品未来的情况。

Autodesk Trademarks

以下列出的是 Autodesk, Inc. 在美国和（或）其他国家和地区的注册商标：3D Studio、 3D Studio MAX、 3D Studio VIZ、 3ds max、 ActiveShapes、 Actrix、ADI、 AEC-X、 ATC、 AUG、 AutoCAD、 AutoCAD LT、Autodesk、Autodesk Envision、Autodesk Inventor、Autodesk Map, Autodesk MapGuide、Autodesk Streamline、 Autodesk WalkThrough、 Autodesk World、AutoLISP、 AutoSketch、 Backdraft、bringing information down to earth、Buzzsaw、CAD Overlay、Character Studio、Cinepak, Cinepak (徽标)、Civil 3D、Cleaner、 Combustion、Design Your World、 Design Your World (徽标)、EditDV、Education by Design、Gmax、Heidi、HOOPS、i-drop、IntroDV、Lustre、Mechanical Desktop、 ObjectARX、Powered with Autodesk Technology (徽标)、ProjectPoint、RadioRay、 Reactor、Revit、VISION*、Visual、Visual Construction、 Visual Drainage、Visual Hydro、Visual Landscape、Visual Roads、Visual Survey、 Visual Toolbox、Visual Tugboat、Visual LISP、Volo、 WHIP!和 WHIP! (徽标)。

以下是 Autodesk, Inc. 在美国和/或其他国家或地区的商标： AutoCAD Learning Assistance、AutoCAD Simulator、AutoCAD SQL Extension、 AutoCAD SQL Interface、AutoSnap、AutoTrack、Built with ObjectARX (徽标)、Burn、CAiCE、Cinestream、Cleaner Central、ClearScale、 Colour Warper、Content Explorer、Dancing Baby (图像)、DesignCenter、Design Doctor、Designer's Toolkit、DesignKids、DesignProf、 DesignServer、Design Web Format、DWF、DWFit、DWG Linking、DWG TrueConvert、DWG TrueView、DXF、Extending the Design Team、GDX Driver、Gmax (徽标)、Gmax ready (徽标)、Heads-up Design、Incinerator、jobnet、LocationLogic、ObjectDBX、Plasma、 PolarSnap、Productstream、RealDWG、Real-time Roto、Render Queue、Topobase、Toxik、Visual Bridge、Visual Syllabus和 Wiretap。

Autodesk Canada Co. 商标

以下是 Autodesk Canada Inc. 在美国和（或）加拿大，和（或）其他国家或地区的注册商标：Discreet、Fire、Flame、Flint、Flint RT、Frost、 Glass、Inferno、MountStone、 Riot、 River、Smoke、Sparks、Stone、Stream、Vapour、Wire。

以下是 Autodesk Canada Inc. 在美国和（或）加拿大，和（或）其他国家或地区的商标： Backburner、Multi-Master Editing。

第三方商标

所有其他品牌名称、产品名称或商标均属于其各自的持有人。

第三方软件程序声明

ACIS 版权所有 © 1989-2001 Spatial Corp. 。部分版权所有 © 2002 Autodesk, Inc.。

AnswerWorks 4.0 © ; 1997-2003 WexTech Systems, Inc. 本软件的部分 © Vantage-Knexys。 保留所有权利。

版权所有 © 1997 Microsoft Corporation。保留所有权利。

版权所有 © 1988 - 1997 Sam Leffle。

版权所有 © 1991 - 1997 Silicon Graphics Inc.。

AutoCAD® 2007 和 AutoCAD LT® 2007 拥有来自从 Dainippon Ink 和 Chemicals, Inc. 的 DIC Color Guide® 导出数据的许可证。

版权所有 © Dainippon Ink 和Chemicals, Inc. 保留所有权利。 DIC 和DIC Color Guide 是 Dainippon Ink 和 Chemicals, Inc.注册商标。

International CorrectSpell™ Spelling Correction System © 1995 by Lernout & Hauspie Speech Products, N.V. 。保留所有权利。

InstallShield™ 3.0. Copyright © 1997 InstallShield Software Corporation。保留所有权利。

在软件应用程序或用户文档内所显示的 PANTONE® 颜色与 PANTONE 认可的标准可能并不相符。请参阅现行的 PANTONE 颜色出版物以获得正 确的颜色。

PANTONE ® 或其他 PANTONE，Inc. 的商标为 PANTONE，Inc.所有。© Pantone, Inc., 2002

PANTONE，Inc. 是授权给 Autodesk, Inc. 的颜色数据和/或软件的版权拥有者，它们只提供与特定的Autodesk 软件产品一起使用。PANTONE 颜 色数据和/或软件不可被复制到另外的磁盘或记忆体内，除非是作为执行此 Autodesk 软件产品的一部分。

部分版权所有 © 1991-1996 Arthur D. Applegate。 保留所有权利。

本软件的某些部分基于 Independent JPEG Group 的工作成果。

RAL DESIGN © RAL, Sankt Augustin, 2002

RAL CLASSIC © RAL, Sankt Augustin, 2002

RAL 颜色的代理已经由 RAL Deutsches Institut f黵 G黷esicherung und Kennzeichnung e.V. (RAL German Institute for Quality Assurance and Certification, re. Assoc.), D-53757 Sankt Augustin 所批准。

出自 Bitstream® typeface library 的字体版权所有 1992。

出自 Payne Loving Trust 的字体版权所有 © 1996。保留所有权利。

印刷手册和帮助由 Idiom WorldServer™ 软件制作。

政府使用

美国政府使用、复制或分发本软件应遵循 FAR 12.212（商用计算机软件限制权利）和 DFAR 227.7202（技术数据和计算机权利）中阐述的限定。

Published by:

Autodesk, Inc.

111 McInnis Parkway

San Rafael, CA 94903

USA


设置“我的帮助”

要设置“我的帮助”，用户必须以 HTML 格式创建帮助主题，然后使用 Microsoft HTML Help Workshop 对其进行编译，以创建一个名为 myhelp.chm 的编译帮助文件。将此文件复制到 AutoCAD\Help 文件夹中。

在“我的帮助”的主要主题中显示带超链接的主题标题的步骤

  • 在 CHM 文件中包含一个文件，在该文件中列出这些主题标题。将该文件命名为 myhelp_toc.html。

在“目录”选项卡中显示主题标题的步骤

  • 在 CHM 文件中包含一个文件，在该文件中列出这些主题标题的 HHC（帮助目录）。

显示用户添加到帮助主题中的任意索引条目的步骤

  • 在 CHM 文件中包含一个 HHK（帮助索引）文件。

即使未包含 myhelp_toc.html 文件、HHC 文件或 HHK 文件，CHM 文件中的内容也可以从“搜索”选项卡中找到。

用户可能希望查看“我的帮助”样例文件。提取 myhelp.zip 样例文件。


zz [空白主题]

空白主题

此主题故意保留为空白。