定点设备 - 概念

定点设备
概念
操作步骤
命令

可以使用双键或三键鼠标、数字化仪游标或笔针作为定点设备。

  • 定点设备按钮
    前 10 个定点设备按钮将自动指定；用户可以重新指定除按钮 1（拾取键）以外的其他所有按钮。
  • 数字化仪
    可以将数字化仪的游标器或笔针用作定点设备，或者将图纸图形记入文件。
请将关于此页的评论发送给我们


定点设备 - 操作步骤

定点设备
概念
操作步骤
命令

练习使用鼠标的几种功能的步骤

关闭绘图区域中所有快捷菜单的步骤

逐个关闭快捷菜单的步骤


定点设备 - 命令

定点设备
概念
操作步骤
命令
命令
OPTIONS | 自定义程序设置
PAN | 在当前视口中移动视图
REINIT | 重初始化数字化仪、数字化仪的输入/输出端口和程序参数文件
TABLET | 校准、配置、打开和关闭已连接的数字化仪
ZOOM | 放大或缩小显示当前视口中对象的外观尺寸
系统变量
MBUTTONPAN | 控制定点设备上的第三按钮或滑轮的操作
SHORTCUTMENU | 控制默认模式、编辑模式和命令模式的快捷菜单在绘图区域是否可用
TABMODE | 控制数字化仪的使用
ZOOMFACTOR | 控制向前或后滑动鼠标滚轮时，比例的变化程度
实用程序
没有条目。 |
命令修饰符
没有条目。 |


定点设备按钮 - 概念

定点设备
定点设备按钮
概念
操作步骤
命令

前 10 个定点设备按钮将自动指定；用户可以重新指定除按钮 1（拾取键）以外的其他所有按钮。

在双按钮鼠标上，左按钮是拾取键，用于

  • 指定位置
  • 指定编辑对象
  • 选择菜单选项、对话框按钮和字段

鼠标右键的操作取决于上下文；它可用于

  • 结束正在进行的命令
  • 显示快捷菜单
  • 显示“对象捕捉”菜单
  • 显示“工具栏”对话框

可以在“选项”对话框中 (OPTIONS) 修改单击鼠标右键操作。 在菜单文件中定义定点设备上其他按钮的操作。

滑轮鼠标

滑轮鼠标上的两个按钮之间有一个小滑轮。 左右按钮的功能和标准鼠标一样。 滑轮可以转动或按下。 可以使用滑轮在图形中进行缩放和平移，而无需使用任何命令。

默认情况下，缩放比例设为 10%；每次转动滑轮都将按 10% 的增量改变缩放级别。 ZOOMFACTOR 系统变量控制滑轮转动（无论向前还是向后）的增量变化。 其数值越大，增量变化就越大。

下表列出了此程序支持的滑轮鼠标动作。

要... | 操作...
放大或缩小 | 转动滑轮：向前，放大；向后，缩小
缩放到图形范围 | 双击滑轮按钮
平移 | 按住滑轮按钮并拖动鼠标
平移（操纵杆） | 按住 CTRL 键以及滑轮按钮并拖动鼠标
显示“对象捕捉”菜单 | 将 MBUTTONPAN 系统变量设置为 0 并单击滑轮按钮

请参见

自定义手册中的自定义鼠标按钮


定点设备按钮 - 操作步骤

定点设备
定点设备按钮
概念
操作步骤
命令

练习使用鼠标的几种功能的步骤

关闭绘图区域中所有快捷菜单的步骤

逐个关闭快捷菜单的步骤


练习使用鼠标的几种功能的步骤 - 操作步骤

定点设备
定点设备按钮
概念
操作步骤
命令

练习使用鼠标的几种功能的步骤

  1. 移动鼠标可以发现：屏幕指针位于绘图区域中，其形状为十字光标；不在绘图区域中将变为箭头；而在文本窗口中则变为 I 型光标。
  2. 继续移动鼠标会发现状态栏上坐标显示中的数字有所变化。 这些数字表示屏幕上十字光标的精确位置或坐标。 在坐标显示中单击可以将其关闭。 请注意，只有在绘图区域中单击时，才能更新坐标。
  3. 找到状态栏上的“捕捉”按钮之后，使用鼠标的拾取键（通常为左按钮）在其上单击。 请注意：按钮变暗表示“捕捉”模式已打开。
  4. 在屏幕上移动指针会发现，指针附着或“捕捉”到屏幕上预定义的间隔相等的点。 可以改变间隔的大小。
  5. 再次单击“捕捉”按钮可以关闭“捕捉”模式。
  6. 将指针移到绘图区域顶部的“标准”工具栏上。 将指针放置在按钮上稍作停留，会显示一个称为工具栏提示的弹出式标签，用来标识按钮。
  7. 将指针移动到工具栏一端的双条线上。 然后，按住拾取键，将工具栏拖至屏幕上合适的位置。
  8. 通过将工具栏拖到绘图区域的顶部、底部或两侧的固定位置即可以将其固定。 当工具栏的轮廓出现在固定区域时，释放拾取键。


关闭绘图区域中所有快捷菜单的步骤 - 操作步骤

定点设备
定点设备按钮
概念
操作步骤
命令

关闭绘图区域中所有快捷菜单的步骤

  1. 单击“工具”菜单 »“选项”。
  2. 在“选项”对话框的“用户系统配置”选项卡上，清除“Windows 标准”下的“绘图区域中使用快捷菜单”。
  3. 单击“确定”将当前选项设置记录到系统注册表中，然后关闭“选项”对话框。

命令输入 OPTIONS


逐个关闭快捷菜单的步骤 - 操作步骤

定点设备
定点设备按钮
概念
操作步骤
命令

逐个关闭快捷菜单的步骤

  1. 依次单击“工具”菜单 »“选项”。
  2. 在“选项”对话框的“用户系统配置”选项卡中，选择“绘图区域”中的快捷菜单，然后单击“自定义右键单击”。
  3. 在“自定义右键单击”对话框中的“默认模式”、“编辑模式”或“命令模式”下，选择控制在绘图区域中单击鼠标右键时发生的操作的选项。
  4. 单击“应用并关闭”关闭对话框。
  5. 单击“确定”将当前选项设置记录到系统注册表中，然后关闭“选项”对话框。

命令输入 OPTIONS


定点设备按钮 - 命令

定点设备
定点设备
定点设备按钮
概念
操作步骤
命令

命令
OPTIONS | 自定义程序设置
PAN | 在当前视口中移动视图
ZOOM | 放大或缩小显示当前视口中对象的外观尺寸
系统变量
MBUTTONPAN | 控制定点设备上的第三按钮或滑轮的操作
SHORTCUTMENU | 控制默认模式、编辑模式和命令模式的快捷菜单在绘图区域是否可用
ZOOMFACTOR | 控制向前或后滑动鼠标滚轮时，比例的变化程度
实用程序
没有条目。 |
命令修饰符
没有条目。 |


数字化仪 - 概念

定点设备
数字化仪
概念
操作步骤
命令

可以将数字化仪的游标器或笔针用作定点设备，或者将图纸图形记入文件。

数字化仪是一个外围设备，可用于将图纸图形记入图形文件或从数字化仪覆盖中选择命令。 安装 Wintab 驱动程序后，还可以使用数字化仪指针来代替鼠标作为系统指针，选择菜单项和图形对象，或者与操作系统进行交互。 数字化仪指针可以是游标或笔针。

必须首先配置数字化仪然后再对其进行校准（可选）。

  • 配置数字化仪之后，数字化仪表面的一部分将作为菜单区域和屏幕指向区域进行分配。
  • 数字化仪经校准后，可用于将现有图纸图形或照片中的几何图形记入图形中。

可以轻松的切换使用未校准的作为系统指针的数字化仪（“数字化仪”模式关闭）或已校准的用于数字化图形的数字化仪（“数字化仪”模式打开）。 单击状态栏上的“数字化仪”按钮。 如果指定了屏幕定点区，状态栏上将显示一个“浮动”按钮，用于打开或关闭屏幕定点区。

注意 数字化仪覆盖样例“tablet.dwg”包含于“Sample”文件夹中，该文件夹位于产品安装目录中。

请参见

创建数字化仪菜单自定义手册中的


定点设备
定点设备
概念
操作步骤
命令

没有该主题的操作步骤。


数字化仪 - 命令

定点设备
定点设备
数字化仪
概念
操作步骤
命令

命令
OPTIONS | 自定义程序设置
REINIT | 重初始化数字化仪、数字化仪的输入/输出端口和程序参数文件
TABLET | 校准、配置、打开和关闭已连接的数字化仪
系统变量
TABMODE | 控制数字化仪的使用
实用程序
没有条目。 |
命令修饰符
没有条目。 |


使用绘图仪和打印机 - 概念

使用绘图仪和打印机
概念
操作步骤
命令

可以使用多种类型的绘图仪和打印机生成图形的硬拷贝输出， 还可以将图形输出到各种格式的文件。

  • 支持的绘图仪
    HDI（Heidi® 设备接口）驱动程序用于与硬拷贝设备进行通信。 这些驱动程序可分为三类：文件格式驱动程序、HDI 非系统驱动程序和 HDI 系统打印机驱动程序。
  • 设置绘图仪和打印机
    每个绘图仪配置中都包含以下信息：设备驱动程序和型号、设备所连接的输出端口以及设备特有的各种设置等。
  • 使用绘图仪配置编辑器
    使用添加绘图仪向导创建绘图仪配置 (PC3) 文件之后，可以使用绘图仪配置编辑器编辑此文件。
  • 修改基本的 PC3 文件信息
    绘图仪配置编辑器的“基本”选项卡中包含关于 PC3 文件的基本信息。 可以在“说明”区域中添加或修改信息。
  • 控制 PC3 文件设备和文档设置
    在绘图仪配置编辑器中的“设备和文档设置”选项卡上，用户可以修改绘图仪配置 (PC3) 文件中的许多设置。
  • 解决与 Windows 打印管理器的冲突
    需要对本地连接的绘图仪使用适当的驱动程序。
  • 端口设置
    绘图仪配置编辑器中的“端口”选项卡包含有关绘图仪端口配置的信息。


使用绘图仪和打印机 - 操作步骤

使用绘图仪和打印机
概念
操作步骤
命令

打开 Autodesk 绘图仪管理器的步骤

为 Windows 系统打印机创建 PC3 文件的步骤

配置本地非系统绘图仪的步骤

配置网络非系统绘图仪的步骤

启动绘图仪配置编辑器的步骤

以新文件名保存 PC3 文件的步骤

添加或修改 PC3 文件说明的步骤

调整介质设置的步骤

配置笔的步骤

指定图形设置的步骤

指定自定义特性的步骤

设置初始化字符串的步骤

校准绘图仪的步骤

将 PMP 文件附加到 PC3 文件的步骤

从 PC3 文件拆离 PMP 文件的步骤

以新文件名保存 PMP 文件的步骤

从头开始添加新的自定义图纸尺寸的步骤（仅适用于非系统 HDI 驱动程序）

从头开始添加新的自定义图纸尺寸的步骤（仅适用于系统打印机）

从现有图纸尺寸添加新的自定义图纸尺寸的步骤

编辑自定义图纸尺寸的步骤

删除自定义图纸尺寸的步骤

修改标准图纸尺寸的步骤

过滤图纸尺寸的步骤

调整端口设置的步骤

使用后台打印的步骤

指定后台打印文件位置的步骤

为本地非系统绘图仪设置超时值的步骤

为网络打印机或 Windows 系统打印机设置超时值的步骤

调整串口设置的步骤


使用绘图仪和打印机 - 命令

使用绘图仪和打印机
概念
操作步骤
命令
命令
PAGESETUP | 控制每个新建布局的页面布局、打印设备、图纸尺寸和其他设置
PCINWIZARD | 显示向导，将 PCP 和 PC2 配置文件中的打印设置输入到“模型”选项卡或当前布局中
PLOT | 将图形打印到绘图仪、打印机或文件
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


支持的绘图仪 - 概念

使用绘图仪和打印机
支持的绘图仪
概念
操作步骤
命令

HDI（Heidi® 设备接口）驱动程序用于与硬拷贝设备进行通信。 这些驱动程序可分为三类：文件格式驱动程序、HDI 非系统驱动程序和 HDI 系统打印机驱动程序。

注意 强烈建议用户定期更新驱动程序以避免出现打印问题。

光栅格式

使用光栅 HDI 驱动程序可以支持以下光栅文件格式：

  • CALS MIL-R-28002A Type 1（CCITT G4 2D 压缩）
  • CALS Type 1（CCITT G4 2D 压缩）
  • Independent JPEG Group JFIF（JPEG 压缩）
  • MS-Windows BMP（无压缩 DIB）
  • Portable Network Graphics PNG（LZH 压缩）
  • TIFF Version 6（CCITT G4 2D 压缩）
  • TIFF Version 6（无压缩）
  • TrueVision TGA Version 2（无压缩）
  • ZSoft PC Paintbrush PCX（ZSOFT PACKBITS 压缩）
PosScript 格式

使用 Adobe PostScript HDI 驱动程序可支持以下 PostScript 输出：

  • Level 1
  • Level 1Plus（支持彩色图像的 Level 1）
  • Level 2
DXB 格式

使用 AutoCAD DXB 文件驱动程序支持 AutoCAD DXB 文件格式。

HP 绘图仪

使用 HP-GL 和 HP-GL/2 HDI 驱动程序可支持 HP 笔式绘图仪。 使用 HP-GL 和 HP-GL/2 HDI 驱动程序可支持以下绘图仪

注意 尽管可以使用 HP-GL 和 HP-GL/2 HDI 驱动程序打印到 HP DesignJet 绘图仪，但这些绘图仪最好使用针对 CAD 的使用而优化的 HP Windows 系统打印机驱动程序。

  • 7475A
  • 7550A
  • 7580B
  • 7585B
  • 7586B
  • 7600 系列型号 240 D/A1
  • 7600 系列型号 240 E/A0
  • 7600 系列型号 250 E/A0
  • 7600 系列型号 255 E/A0
  • 7600 系列型号 355 E/A0
  • HP DesignJet ColorPro CAD
  • HP DesignJet 3500CP
  • HP DesignJet 3000CP
  • HP DesignJet 2500CP
  • HP DesignJet 2000CP
  • HP DesignJet 1055CM
  • HP DesignJet 1050C
  • HP DesignJet 755CM
  • HP DesignJet 750C Plus
  • HP DesignJet 750C
  • HP DesignJet 700
  • HP DesignJet 650C
  • HP DesignJet 600
  • HP DesignJet 488CA
  • HP DesignJet 455CA
  • HP DesignJet 450C
  • HP DesignJet 430
  • HP DesignJet 350C
  • HP DesignJet 330
  • HP DesignJet 250C
  • HP DesignJet 230
  • HP DesignJet 220
  • HP DesignJet 200
  • DraftMaster 1 (7595A)
  • DraftMaster 2 (7596A)
  • DraftMaster MX 7599
  • DraftMaster Mx Plus 7599B
  • DraftMaster RX 7596B
  • DraftMaster RX Plus 7596C
  • DraftMaster SX Plus Sheet Feed 7595C
  • DraftPro (7570A)
  • DraftPro Plus C3170A
  • DraftPro Plus C3171A
  • DraftPro-DXL (7575A)
  • DraftPro-EXL (7576A)
  • LaserJet 4
  • LaserJet 4M
  • LaserJet 4MV
  • LaserJet 4Si
  • LaserJet 4SiMx
  • LaserJet 4V
  • LaserJet 5
  • LaserJet 5M
  • LaserJet 5Si
  • LaserJet 5Si Mopier
  • LaserJet 5SiMX
  • LaserJet III
  • LaserJet IIID
  • LaserJet IIISi
  • Generic SHPGL
  • Generic LHPGL
Xerox 绘图仪

Xerox 提供的设备驱动程序支持以下 Xerox 绘图仪：

  • 6030 Wide Format
  • 6050 Wide Format
  • Wide Format Print System 510 系列
  • Wide Format Print System 721p
  • Wide Format Print System 8825（1 个卷筒）
  • Wide Format Print System 8825（2 个卷筒）
  • Wide Format Print System 8830
  • Wide Format Print System 8850
  • Wide Format Print System 8855
Océ 绘图仪

Océ 提供的设备驱动程序支持以下 Océ 绘图仪。

注意 虽然可以使用 HP-GL 和 HP-GL/2 HDI 驱动程序来打印到 Océ TDS/TCS 绘图仪，但是，建议将已针对 CAD 使用而优化过的 Océ Windows 系统打印机驱动程序与这些绘图仪配合使用。

  • 5120 A1 (LZ_1.x)/5120 (LZ_4.x)
  • 5120 A0 (LZ_1.x)/ 5120(LZ_4.x)
  • 5150 CC_2.x
  • 5200 (MI_1.x)
  • 5200 MI_4.x
  • 5250 CG_1.x
  • 9055-S/95xx-S (FR/FP1.x)
  • 9300 LVI_1.x
  • 9400(附带扫描仪) (LV_3.x)
  • 9400 LV_3.x/4.x
  • 9400-11 EPC-MI_1.x
  • 9600
  • 9700 (R1.0)
  • 9800 (R3 & EPC R)
  • TCS400 Colour HDI
  • TCS500 Colour HDI
  • TDS300 HDI
  • TDS320 HDI
  • TDS400 HDI
  • TDS450 HDI
  • TDS600 HDI
  • TDS800 HDI
  • TDS860 HDI
CalComp 绘图仪

使用 CalComp 提供的设备驱动程序可支持以下 CalComp 绘图仪：

  • 52224 DrawingMaster Plus
  • 52236 DrawingMaster Plus
  • 52424 DrawingMaster Plus
  • 52436 DrawingMaster Plug
  • 54424 Solus LED 绘图仪
  • 54436 Solus LED Plotter
不再支持的绘图仪

Autodesk 将不再测试或修复以下设备的问题。 它们仍然可以使用，但不受本版本的支持。

HP 绘图仪（不再支持）
  • 7600 Series model 240 D/A1
  • 7600 Series model 240 D/A0
  • 7600 Series model 250
  • 7600 系列型号 255
  • 7600 系列型号 355
CalComp 绘图仪（不再支持）
  • 1023 Artisan 笔式绘图仪
  • 1025 Artisan Pen Plotter
  • 1026 Artisan Pen Plotter
  • 2024 PaceSetter 笔式绘图仪
  • 2036 PaceSetter Pen Plotter
  • 3024 DesignMate 笔式绘图仪
  • 3036 DesignMate Pen Plotter
  • 4036 PaceSetter Pen Plotter
  • 5324 TechJet Color
  • 5324GT TechJet Color
  • 53336 DrawingMaster DM600
  • 5336 TechJet Color
  • 5336GT TechJet Color
  • 5336i TechJet Color 175i
  • 53436 Drawing Master DM800
  • 5424 TechJet 720
  • 5436 TechJet 720
  • 5524 TechJet Color
  • 5536 TechJet Color
  • 5624 TechJet Color 720c
  • 5636 TechJet Color 720c
  • 57424 Monochrome Electrostatic
  • 57436 Monochrome Electrostatic
  • 57444 Monochrome Electrostatic
  • 58424 Color Electrostatic
  • 58436 Color Electrostatic
  • 58444 Color Electrostatic
  • 67436 Monochrome Electrostatic
  • 68436 Color Electrostatic
  • 68444 Color Electrostatic


使用绘图仪和打印机
使用绘图仪和打印机
概念
操作步骤
命令

没有该主题的操作步骤。


支持的绘图仪 - 命令

使用绘图仪和打印机
使用绘图仪和打印机
支持的绘图仪
概念
操作步骤
命令

命令
PLOT | 将图形打印到绘图仪、打印机或文件
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


设置绘图仪和打印机 - 概念

使用绘图仪和打印机
设置绘图仪和打印机
概念
操作步骤
命令

每个绘图仪配置中都包含以下信息：设备驱动程序和型号、设备所连接的输出端口以及设备特有的各种设置等。

AutoCAD 在“打印”和“页面设置”对话框中列出了针对 Windows 配置的打印机或绘图仪。 除非 AutoCAD 的默认值与 Windows 的值不同，否则无需使用系统打印机驱动程序来配置这些设备。

注意 非系统设备称为绘图仪，Windows 系统设备称为打印机。

如果 AutoCAD 支持绘图仪而 Windows 不支持，则可以使用某个 HDI 非系统打印机驱动程序。 也可以使用非系统驱动程序创建 PostScript、光栅或 Web 图形格式 (DWF) 文件和可移植文档格式 (PDF) 文件

必须使用非默认设置配置本地或网络上的非系统绘图仪和 Windows 系统打印机。 如果只修改图纸尺寸，则无需配置系统打印机。

AutoCAD 将有关介质和打印设备的信息存储在配置的打印 (PC3) 文件中。 打印配置是便携式的，并且可以在办公室或项目组中共享（只要他们用于相同的驱动器、型号和驱动程序版本）。 Windows 系统打印机共享的打印配置也需要相同的 Windows 版本。 如果校准一台绘图仪，校准信息存储在打印模型参数 (PMP) 文件中，此文件可附加到任何为校准绘图仪而创建的 PC3 文件中。

可以为多个设备配置 AutoCAD，并为一个设备存储多个配置。 每个绘图仪配置中都包含以下信息：设备驱动程序和型号、设备所连接的输出端口以及设备特有的各种设置等。 可以为相同绘图仪创建多个具有不同输出选项的 PC3 文件。 创建 PC3 文件后，该文件将显示在“打印”对话框的绘图仪配置名称列表中。

要创建这些 PC3 文件，请使用 Autodesk 绘图仪管理器中的添加绘图仪向导。 绘图仪管理器是一个 Windows 资源管理器窗口。 添加绘图仪向导与 Windows 的添加打印机向导类似。 使用添加绘图仪向导，用户可以指定配置的是非系统的本地或网络绘图仪，还是系统打印机。 也可创建任意数量的绘图仪设备配置，这些配置使用 Windows 系统打印机驱动程序或 Autodesk 非系统打印机驱动程序。 配置存储在用户配置中。

有多种方法可用于修改 Windows 系统打印机的默认设置，且无需创建 PC3 文件。 例如，可以从“控制面板”中修改全系统特性， 也可以选择“打印”对话框中的“特性”选项，进行打印但不保存特性。

注意 如果要升级驱动程序，请尝试使用现有的 PC3 文件。 如果它不起作用，则需要创建新的 PC3 文件。 许多情况下，可以从旧的 PC3 文件中将一些设置复制和粘贴到用新驱动程序创建的新 PC3 文件中。

请参见

使用绘图仪配置编辑器

校准绘图仪以及使用自定义图纸尺寸


设置绘图仪和打印机 - 操作步骤

使用绘图仪和打印机
设置绘图仪和打印机
概念
操作步骤
命令

打开 Autodesk 绘图仪管理器的步骤

为 Windows 系统打印机创建 PC3 文件的步骤

配置本地非系统绘图仪的步骤

配置网络非系统绘图仪的步骤


打开 Autodesk 绘图仪管理器的步骤 - 操作步骤

使用绘图仪和打印机
设置绘图仪和打印机
概念
操作步骤
命令

打开 Autodesk 绘图仪管理器的步骤

也可以使用以下方法之一来打开 Autodesk 绘图仪管理器：

  • 从“文件”菜单中选择“绘图仪管理器”。
  • 在命令行中输入 plottermanager。
  • 从“工具”菜单中选择“选项”。 在“打印和发布”选项卡中选择“添加或配置绘图仪”。


为 Windows 系统打印机创建 PC3 文件的步骤 - 操作步骤

使用绘图仪和打印机
设置绘图仪和打印机
概念
操作步骤
命令

为 Windows 系统打印机创建 PC3 文件的步骤

  1. 打开 Autodesk 绘图仪管理器。
  2. 在“Autodesk 绘图仪管理器”中双击“添加绘图仪向导”快捷方式图标。
  3. 在添加绘图仪向导中，阅读“简介”，然后选择“下一步”，进入“添加绘图仪 - 开始”对话框。
  4. 在“添加绘图仪 - 开始”对话框中选择“系统打印机”。 选择“下一步”。
  5. 在“添加绘图仪 - 系统打印机”对话框中选择要配置的系统打印机。

    6. 列表中包括操作系统能够识别的所有打印机。 如果列表中没有要连接的打印机，必须首先使用 Windows“控制面板”中的“添加打印机向导”来添加打印机。

    （可选）“输入 PCP 或 PC2”屏幕使用户可以使用通过早期版本的 AutoCAD 创建的 PCP 或 PC2 文件中的配置信息。

  6. 在“添加绘图仪 - 绘图仪名称”对话框中输入一个名称以标识当前配置的绘图仪。 选择“下一步”。
  7. 在“添加绘图仪 - 完成”对话框中选择“完成”退出添加绘图仪向导。

    8. 新配置的绘图仪的 PC3 文件显示在“绘图仪”窗口中，并且设备列表中会显示可用的绘图仪。

    现在，用户可以通过选择“添加绘图仪 - 完成”对话框中的“编辑绘图仪配置”来修改绘图仪的默认设置。 也可以选择“添加绘图仪 - 完成”对话框中的“校准绘图仪”对新配置的绘图仪进行校准测试。


配置本地非系统绘图仪的步骤 - 操作步骤

使用绘图仪和打印机
设置绘图仪和打印机
概念
操作步骤
命令

配置本地非系统绘图仪的步骤

  1. 打开 Autodesk 绘图仪管理器。
  2. 在“Autodesk 绘图仪管理器”中双击“添加绘图仪向导”快捷方式。
  3. 在添加绘图仪向导中，阅读“简介”，然后选择“下一步”，进入“添加绘图仪 - 开始”对话框。
  4. 在“添加绘图仪 - 开始”对话框中选择“我的电脑”。 选择“下一步”。
  5. 在“添加绘图仪 - 绘图仪型号”对话框中选择制造商和型号。 选择“下一步”。

    6. 如果是配置 PostScript 设备，请从“制造商”列表中选择“Adobe”。

    如果所需的绘图仪没有列在表中，但有驱动程序盘，可选择“从磁盘安装”，定位到该驱动程序盘上的 HIF 文件，开始安装绘图仪附带的驱动程序。

    （可选）“输入 PCP 或 PC2”屏幕使用户可以使用通过早期版本的 AutoCAD 创建的 PCP 或 PC2 文件中的配置信息。

  6. 在“添加绘图仪 - 端口”对话框中选择打印时使用的端口。 选择“下一步”。 此时将显示指定设备的可用端口。
  7. 在“添加绘图仪 - 绘图仪名称”对话框中输入一个名称以标识当前配置的绘图仪。 选择“下一步”。
  8. 在“添加绘图仪 - 完成”对话框中选择“完成”退出添加绘图仪向导。

    9. 新配置的绘图仪的 PC3 文件显示在“绘图仪”窗口中，并且设备列表中会显示可用的绘图仪。

    现在，用户可以通过选择“添加绘图仪 - 完成”对话框中的“编辑绘图仪配置”来修改绘图仪的默认设置。 也可以选择“添加绘图仪 - 完成”对话框中的“校准绘图仪”对新配置的绘图仪进行校准测试。


配置网络非系统绘图仪的步骤 - 操作步骤

使用绘图仪和打印机
设置绘图仪和打印机
概念
操作步骤
命令

配置网络非系统绘图仪的步骤

  1. 打开 Autodesk 绘图仪管理器。
  2. 双击“添加绘图仪向导”快捷方式图标。
  3. 在添加绘图仪向导中，阅读“简介”，然后选择“下一步”，进入“添加绘图仪 - 开始”对话框。
  4. 在“添加绘图仪 - 开始”对话框中选择“网络绘图仪服务器”。 选择“下一步”。
  5. 在“添加绘图仪 - 网络绘图仪”对话框中输入要使用的网络绘图仪服务器的共享名。

    6. 服务器必须已在网络中存在。 详细信息请与系统管理员联系。

    必须使用通用命名约定 (UNC)。 正确的 UNC 路径格式为 \\server name\share name。 选择“浏览”可指定网络上现有的共享名。

  6. 在“添加绘图仪 - 绘图仪型号”对话框中选择制造商和型号。 选择“下一步”。

    7. 如果是配置 PostScript 设备，请从“制造商”列表中选择“Adobe”。

    如果用户的绘图仪未在可用的绘图仪列表中，但有绘图仪的驱动程序盘，则选择“从磁盘安装”并找到驱动程序盘上的 HIF 文件，然后安装绘图仪附带的驱动程序。

    （可选）“输入 PCP 或 PC2”屏幕使用户可以使用通过早期版本的 AutoCAD 创建的 PCP 或 PC2 文件中的配置信息。

  7. 在“添加绘图仪 - 绘图仪名称”对话框中输入一个名称以标识当前配置的绘图仪。 选择“下一步”。
  8. 在“添加绘图仪 - 完成”对话框中选择“完成”退出添加绘图仪向导。

    9. 新配置的绘图仪的 PC3 文件显示在“绘图仪”窗口中，并且设备列表中会显示可用的绘图仪。

    现在，用户可以通过选择“添加绘图仪 - 完成”对话框中的“编辑绘图仪配置”来修改绘图仪的默认设置。 也可以选择“添加绘图仪 - 完成”对话框中的“校准绘图仪”对新配置的绘图仪进行校准测试。


设置绘图仪和打印机 - 命令

使用绘图仪和打印机
使用绘图仪和打印机
设置绘图仪和打印机
概念
操作步骤
命令

命令
PAGESETUP | 控制每个新建布局的页面布局、打印设备、图纸尺寸和其他设置
PCINWIZARD | 显示向导，将 PCP 和 PC2 配置文件中的打印设置输入到“模型”选项卡或当前布局中
PLOT | 将图形打印到绘图仪、打印机或文件
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


使用绘图仪配置编辑器 - 概念

使用绘图仪和打印机
使用绘图仪配置编辑器
概念
操作步骤
命令

使用添加绘图仪向导创建绘图仪配置 (PC3) 文件之后，可以使用绘图仪配置编辑器编辑此文件。

绘图仪配置编辑器提供用于修改绘图仪端口连接和输出设置的选项，包括介质、图形、物理笔配置、自定义特性、初始化字符串、校准以及用户定义的图纸尺寸。 用户可以在 PC3 文件之间拖放这些选项。

注意 在拖放一个选项时，整个分枝都将随之拖放。 如果从 Windows 系统驱动程序拖放，大多数情况下，“自定义”分枝也将被复制。 对于非系统驱动程序，只有显式选定“自定义”选项时，才会复制该选项。

“绘图仪配置编辑器”包含三个选项卡。 “基本”选项卡中包含关于配置的绘图仪的基本信息。 “端口”选项卡中包含打印设备和计算机之间的通信信息。 “设备和文档设置”选项卡包含打印选项。 根据配置的打印设备的不同，在“设备和文档设置”选项卡中还有一些附加选项。 例如，当配置非系统笔式绘图仪时，可以使用相应选项修改物理笔的特性。

可以编辑非系统绘图仪和系统绘图仪的绘图仪配置文件。 还可以修改 Windows 系统打印机的默认设置，而无需创建 PC3 文件。 例如，可以在 Windows 的“控制面板”中修改全系统特性， 也可以选择“打印”对话框中的“特性”选项，进行打印但不保存特性。


使用绘图仪配置编辑器 - 操作步骤

使用绘图仪和打印机
使用绘图仪配置编辑器
概念
操作步骤
命令

启动绘图仪配置编辑器的步骤

以新文件名保存 PC3 文件的步骤


启动绘图仪配置编辑器的步骤 - 操作步骤

使用绘图仪和打印机
使用绘图仪配置编辑器
概念
操作步骤
命令

启动绘图仪配置编辑器的步骤

使用以下方法之一：

  • 在 Windows 资源管理器中双击 PC3 文件，或者在该文件上单击鼠标右键，然后选择“打开”。 （默认情况下，PC3 文件存储在用户配置文件夹中。）
  • 在“添加绘图仪”向导的“添加绘图仪 - 完成”对话框中选择“编辑绘图仪配置”。
  • 在“文件”菜单上，单击“打印”。 在“打印”对话框的“打印机/绘图仪”下选择一个设备，然后单击“特性”。
  • 在“文件”菜单中，单击“页面设置管理器”。 在“页面设置管理器”中选择一种页面设置，然后单击“修改”。 在“页面设置”对话框的“打印机/绘图仪”下选择一个设备，然后单击“特性”。


以新文件名保存 PC3 文件的步骤 - 操作步骤

使用绘图仪和打印机
使用绘图仪配置编辑器
概念
操作步骤
命令

以新文件名保存 PC3 文件的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 在“Autodesk 绘图仪管理器”中双击要使用的 PC3 文件。
  3. 在绘图仪配置编辑器中，选择“设备和文档设置”选项卡。
  4. 选择“另存为”。
  5. 在“另存为”对话框中输入 PC3 文件的新文件名。
  6. 选择“保存”。


使用绘图仪配置编辑器 - 命令

使用绘图仪和打印机
使用绘图仪和打印机
使用绘图仪配置编辑器
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


修改基本的 PC3 文件信息 - 概念

使用绘图仪和打印机
修改基本的 PC3 文件信息
概念
操作步骤
命令

绘图仪配置编辑器的“基本”选项卡中包含关于 PC3 文件的基本信息。 可以在“说明”区域中添加或修改信息。

选项卡的其他部分是只读的。 “基本”选项卡中的信息包括：

  • 配置的绘图仪文件名
  • 关于绘图仪的说明或其他信息
  • 绘图仪驱动程序类型（系统或非系统）、名称、型号和位置
  • HDI 驱动程序文件版本号（AutoCAD 专用驱动程序文件）
  • 网络服务器的 UNC 名称（如果绘图仪连接到网络服务器上）、输入/输出端口（如果绘图仪连接到本地）或系统打印机名称（如果配置的绘图仪为系统打印机）
  • PMP 文件名和位置（如果绘图仪校准文件 [PMP] 被附着到 PC3 文件中）


添加或修改 PC3 文件说明的步骤 - 操作步骤

使用绘图仪和打印机
修改基本的 PC3 文件信息
概念
操作步骤
命令

添加或修改 PC3 文件说明的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击需要修改其设置的绘图仪配置 (PC3) 文件。
  3. 选择“绘图仪配置编辑器”中的“基本”选项卡。
  4. 在“说明”区域插入光标。
  5. 为 PC3 文件添加说明或修改现有的说明。


修改基本的 PC3 文件信息 - 命令

使用绘图仪和打印机
使用绘图仪和打印机
修改基本的 PC3 文件信息
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


控制 PC3 文件设备和文档设置 - 概念

使用绘图仪和打印机
控制 PC3 文件设备和文档设置
概念
操作步骤
命令

在绘图仪配置编辑器中的“设备和文档设置”选项卡上，用户可以修改绘图仪配置 (PC3) 文件中的许多设置。

注意 只有配置设备可用的设置才会显示在树状图中。 另外，如果设备通过“自定义特性”选项处理设置，或不支持该功能，用户可能无法编辑某些设置。

  • 调整介质设置（仅限于非系统绘图仪）
    根据配置的绘图仪所支持的特性，可以修改纸张来源、类型和图纸尺寸。
  • 指定物理笔配置（仅限于笔式绘图仪）
    绘图仪配置编辑器中的“物理笔配置”设置用于控制笔式绘图仪中的笔。
  • 指定图形输出设置
    根据配置的绘图仪的功能，可以修改绘图仪的颜色深度、分辨率或抖动，并可以指定矢量图形的输出为彩色还是单色。
  • 调整自定义特性
    在绘图仪配置编辑器中“设备和文档设置”选项卡的树状视图中选择“自定义特性”，可以修改已配置的绘图仪的特性。
  • 使用初始化字符串
    可以使用 ASCII 文字初始化字符串为绘图仪进行打印准备。
  • 校准绘图仪以及使用自定义图纸尺寸
    只有在图形必须具有精确的比例，而打印机或绘图仪打印出的图形不准确时，才有必要执行绘图仪校准。


控制 PC3 文件设备和文档设置 - 操作步骤

使用绘图仪和打印机
控制 PC3 文件设备和文档设置
概念
操作步骤
命令

调整介质设置的步骤

配置笔的步骤

指定图形设置的步骤

指定自定义特性的步骤

设置初始化字符串的步骤

校准绘图仪的步骤

将 PMP 文件附加到 PC3 文件的步骤

从 PC3 文件拆离 PMP 文件的步骤

以新文件名保存 PMP 文件的步骤

从头开始添加新的自定义图纸尺寸的步骤（仅适用于非系统 HDI 驱动程序）

从头开始添加新的自定义图纸尺寸的步骤（仅适用于系统打印机）

从现有图纸尺寸添加新的自定义图纸尺寸的步骤

编辑自定义图纸尺寸的步骤

删除自定义图纸尺寸的步骤

修改标准图纸尺寸的步骤

过滤图纸尺寸的步骤


控制 PC3 文件设备和文档设置 - 命令

使用绘图仪和打印机
控制 PC3 文件设备和文档设置
概念
操作步骤
命令
命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


调整介质设置（仅限于非系统绘图仪） - 概念

使用绘图仪和打印机
调整介质设置（仅限于非系统绘图仪）
概念
操作步骤
命令

根据配置的绘图仪所支持的特性，可以修改纸张来源、类型和图纸尺寸。

可以指定是双面打印还是单面打印。 如果打印机支持剪裁、分页和装订，可在“介质目标”选项下指定所需选项。 对于 Windows 系统打印机，必须使用“自定义特性”选项配置“介质”设置。


调整介质设置的步骤 - 操作步骤

使用绘图仪和打印机
调整介质设置（仅限于非系统绘图仪）
概念
操作步骤
命令

调整介质设置的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击需要修改其介质设置的绘图仪配置 (PC3) 文件。
  3. 在绘图仪配置编辑器中，选择“设备和文档设置”选项卡。
  4. 双击“介质”来查看介质设置。
  5. 执行以下操作之一：
    • 选择源和大小。在“介质源和大小”下，从“源”列表中选择纸张来源。 如果需要，可从“宽度”列表中选择卷筒宽度或从“纸盒类型”列表中选择纸盒。 在“大小”下选择所需的图纸尺寸。 如果选择“自动”，打印机会自动选择合适的纸张来源。
    • 选择介质类型。在“介质类型”下，选择一种可用的介质类型。
    • 选择双向打印。在“双向打印”下，选择“短边”或“长边”。 有些绘图仪可能不支持此选项。
    • 选择介质目标。在“介质目标”下，指定一个可用选项，例如剪切。 有些绘图仪可能不支持此选项。
  6. 完成后，选择“确定”。

命令输入 PLOTTERMANAGER


调整介质设置（仅限于非系统绘图仪） - 命令

使用绘图仪和打印机
使用绘图仪和打印机
调整介质设置（仅限于非系统绘图仪）
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


指定物理笔配置（仅限于笔式绘图仪） - 概念

使用绘图仪和打印机
指定物理笔配置（仅限于笔式绘图仪）
概念
操作步骤
命令

绘图仪配置编辑器中的“物理笔配置”设置用于控制笔式绘图仪中的笔。

如果配置的绘图仪支持，可以在单笔绘图仪上指定换笔，调整笔宽的多边形面积，以及设置笔优化。 在“设备和文档设置”选项卡下面的窗格中显示了笔的参数表，其中包括笔的颜色、宽度和运笔速度。

注意 无法自动检测物理笔信息。 用户必须在“物理笔特性”选项下指定笔式绘图仪的相关信息。

即使用户不打算使用打印样式表，也必须指定笔设置。 如果选择不创建打印样式表，AutoCAD 将自动使用用户提供的笔色和笔宽信息指定笔。 AutoCAD 使用颜色与指定给对象的颜色最接近的笔。 如果有多个笔符合此条件，将采用具有最接近对象的指定宽度的笔。 如果最合适的笔的宽度略小于对象的宽度，AutoCAD 会多次绘制此对象直到完整绘制出对象。 如果使用打印样式表，可以为每一种打印样式指定物理笔编号。

请参见

《用户手册》中的切换打印样式表类型


配置笔的步骤 - 操作步骤

使用绘图仪和打印机
指定物理笔配置（仅限于笔式绘图仪）
概念
操作步骤
命令

配置笔的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击需要修改其笔设置的绘图仪配置 (PC3) 文件。
  3. 在绘图仪配置编辑器中，选择“设备和文档设置”选项卡。
  4. 双击“物理笔配置”查看笔配置设置。
  5. 选择“笔配置”。 在“笔配置”下执行以下操作之一：
    • 如果使用单笔绘图仪，并且打印时需要使用不同的笔，应选择“提示换笔”。
    • 如果在打印填充区域和宽多段线时需要高精度，应选择“区域填充校正”。 AutoCAD 将笔向内移动半个笔宽。
    • 在“笔优化级别”下选择一种可用方法。 列表中的每种方法包括列在它前面的优化方法（“无优化”除外）。
  6. 选择“物理笔特性”。 为绘图仪上的每种笔指定颜色、速度和宽度。 此步骤不能省略。

    7. 注意 使用“打印样式表编辑器”为对象指定特定的颜色和笔宽，使其与打印设备的打印颜色和宽度相对应。

  7. 完成后，选择“确定”。

命令输入 PLOTTERMANAGER


指定物理笔配置（仅限于笔式绘图仪） - 命令

使用绘图仪和打印机
使用绘图仪和打印机
指定物理笔配置（仅限于笔式绘图仪）
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


指定图形输出设置 - 概念

使用绘图仪和打印机
指定图形输出设置
概念
操作步骤
命令

根据配置的绘图仪的功能，可以修改绘图仪的颜色深度、分辨率或抖动，并可以指定矢量图形的输出为彩色还是单色。

当在绘图仪上用有限的内存打印光栅图像时，可以通过降低图像质量来提高性能。 如果使用的非系统绘图仪支持安装大小不同的 RAM，则可以向 AutoCAD 提供该信息以提高性能。


指定图形设置的步骤 - 操作步骤

使用绘图仪和打印机
指定图形输出设置
概念
操作步骤
命令

指定图形设置的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击需要修改其笔设置的绘图仪配置 (PC3) 文件。
  3. 在绘图仪配置编辑器中，选择“设备和文档设置”选项卡。
  4. 双击“图形”以查看图形输出设置。
  5. 执行以下操作之一：
    • 选择“安装的内存”并输入绘图仪中可用的内存大小。
    • 选择“矢量图形”并选择颜色深度、分辨率和抖动。
    • 选择“光栅图形”并平衡输出质量和性能。
    • 选择“TrueType 文字”并选择打印 TrueType 文字的方式。
    • 选择“合并”控制，并指定交叉直线是覆盖下面的直线还是与之合并。
  6. 完成后，选择“确定”。

命令输入 PLOTTERMANAGER


指定图形输出设置 - 命令

使用绘图仪和打印机
使用绘图仪和打印机
指定图形输出设置
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


调整自定义特性 - 概念

使用绘图仪和打印机
调整自定义特性
概念
操作步骤
命令

在绘图仪配置编辑器中“设备和文档设置”选项卡的树状视图中选择“自定义特性”，可以修改已配置的绘图仪的特性。

每一种绘图仪的设置各不相同。 如果绘图仪制造商提供的设备驱动程序中不包括“自定义特性”对话框，则不能使用“自定义特性”选项。 对于其他驱动程序，“自定义特性”选项是唯一一个可用的树状视图选项。 对于 Windows 系统打印机，多数设备特有的设置在此对话框中完成。

对于设备特有的信息，可在“自定义特性”对话框中选择有关配置的驱动程序的“帮助”。


指定自定义特性的步骤 - 操作步骤

使用绘图仪和打印机
调整自定义特性
概念
操作步骤
命令

指定自定义特性的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击需要修改其自定义特性的绘图仪配置 (PC3) 文件。
  3. 在绘图仪配置编辑器中，选择“设备和文档设置”选项卡。
  4. 在树状视图中选择“自定义特性”。 在“访问自定义”对话框中选择“自定义特性”按钮。
  5. 设置打印机或绘图仪的特性。 特性取决于不同的绘图仪和制造商。
  6. 选择“确定”，退出所有对话框。

命令输入 PLOTTERMANAGER


调整自定义特性 - 命令

使用绘图仪和打印机
使用绘图仪和打印机
调整自定义特性
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


使用初始化字符串 - 概念

使用绘图仪和打印机
使用初始化字符串
概念
操作步骤
命令

可以使用 ASCII 文字初始化字符串为绘图仪进行打印准备。

如果要在仿真模式下打印到不支持的非系统绘图仪，则可以使用 ASCII 文本初始化字符串准备绘图仪进行打印，设置针对特定设备的选项，以及将绘图仪恢复到原始状态。 只有高级用户才需要使用初始化字符串。


设置初始化字符串的步骤 - 操作步骤

使用绘图仪和打印机
使用初始化字符串
概念
操作步骤
命令

设置初始化字符串的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击需要修改其初始化字符串设置的绘图仪配置 (PC3) 文件。
  3. 在绘图仪配置编辑器中，选择“设备和文档设置”选项卡。
  4. 在树状视图中选择“初始化字符串”以查看初始化字符串设置。
  5. 根据需要输入“初始化之前”字符串、“初始化之后”字符串和“终止”字符串。
  6. 选择“确定”。

命令输入 PLOTTERMANAGER


使用初始化字符串 - 命令

使用绘图仪和打印机
使用绘图仪和打印机
使用初始化字符串
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


校准绘图仪以及使用自定义图纸尺寸 - 概念

使用绘图仪和打印机
校准绘图仪以及使用自定义图纸尺寸
概念
操作步骤
命令

只有在图形必须具有精确的比例，而打印机或绘图仪打印出的图形不准确时，才有必要执行绘图仪校准。

可以调整绘图仪校准设置以更正比例偏差，还可以为非系统绘图仪添加自定义图纸尺寸。

校准文件

校准绘图仪是可选的操作。 如果用户绘图仪的比例精度符合制造商的规格，则图形中一条 10 英寸的线条以 1:1 比例打印到图纸上应该正好等于 10 英寸。 如果需要更正比例偏差，可调整绘图仪校准。 如果用户的绘图仪提供校准实用程序，则使用该实用程序代替 AutoCAD 校准实用程序，以便校准适用于所有使用此绘图仪的应用程序。

要校准绘图仪，必须指定测试矩形的尺寸，打印测试矩形，测量实际尺寸，最后在“校准绘图仪”向导中输入实际测量值。 AutoCAD 会计算绘图仪的必要的校准。

完成“校准绘图仪”向导后，AutoCAD 将创建一个打印模型参数 (PMP) 文件来存储每个打印设备的校准结果。 AutoCAD 会自动将生成的 PMP 文件附着到用于执行校准测试的绘图仪配置 (PC3) 文件中。

通过对绘图仪进行校准，可创建一个包含校准信息的绘图仪型号参数 (PMP) 文件。 如果 PMP 文件尚未附着到正在编辑的绘图仪配置文件 (PC3)中，必须先创建关联然后才能使用 PMP 文件。 如果从添加绘图仪向导内对绘图仪进行校准，则已附着 PMP 文件。 可以使用“校准”中的“用户定义的图纸尺寸”选项在 PC3 文件中添加或拆离 PMP 文件。 如果一个设备不止配置了一个 PC3 文件，可使用“绘图仪配置编辑器”将它们附着到同一个 PMP 文件中。 因为每台绘图仪有特定的 PMP 文件，所以一个 PMP 文件最好只附着到一个 PC3 文件上。

注意 只有在图形必须具有精确的比例，而打印机或绘图仪打印出的图形不准确时，才有必要执行绘图仪校准。 绘图仪校准操作使 AutoCAD 按比例重新调整所有发送到绘图仪的打印，以更正其硬件缩放带来的误差。 建议使用绘图仪提供的任何校准设置，而不要使用 AutoCAD 设置。

自定义图纸尺寸

对于非系统绘图仪，可以选择“添加”选项来创建自定义图纸尺寸或者修改标准或非标准图纸尺寸的可打印区域。 使用自定义图纸尺寸向导，可以创建新的图纸尺寸或从可用图纸尺寸的列表中进行选择（从 PMP 文件中）。 对于 Windows 系统打印机，可使用“自定义特性”选项调整图纸设置。

可以修改标准图纸尺寸并调整可打印区域以符合打印机的工作范围。 在“绘图仪配置编辑器”中不能为 Windows 系统打印机创建自定义图纸尺寸，但可以更正标准图纸尺寸的可打印区域中的错误。


校准绘图仪以及使用自定义图纸尺寸 - 操作步骤

使用绘图仪和打印机
校准绘图仪以及使用自定义图纸尺寸
概念
操作步骤
命令

校准绘图仪的步骤

将 PMP 文件附加到 PC3 文件的步骤

从 PC3 文件拆离 PMP 文件的步骤

以新文件名保存 PMP 文件的步骤

从头开始添加新的自定义图纸尺寸的步骤（仅适用于非系统 HDI 驱动程序）

从头开始添加新的自定义图纸尺寸的步骤（仅适用于系统打印机）

从现有图纸尺寸添加新的自定义图纸尺寸的步骤

编辑自定义图纸尺寸的步骤

删除自定义图纸尺寸的步骤

修改标准图纸尺寸的步骤

过滤图纸尺寸的步骤


校准绘图仪的步骤 - 操作步骤

使用绘图仪和打印机
校准绘图仪以及使用自定义图纸尺寸
概念
操作步骤
命令

校准绘图仪的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击“添加绘图仪向导”图标。
  3. 启动“添加绘图仪”向导并配置要添加的设备。
  4. 在“添加绘图仪 - 完成”对话框中选择“校准绘图仪”。

    5. 用户也可以在要校准设备的现有 PC3 文件上运行“绘图仪配置编辑器”来校准绘图仪。

  5. 在“图纸尺寸”列表中，为打印测试选择图纸尺寸。 选择“下一步”。
  6. 在“校准绘图仪 - 矩形大小”对话框的“单位”列表中选择测量单位。
  7. 在“长度”和“宽度”框中输入测试矩形的尺寸。 选择“下一步”。 AutoCAD 将打印测试矩形。
  8. 拿到打印件后测量测试矩形。 在“校准绘图仪 - 测量的打印”对话框的“测量的长度”和“测量的宽度”框中输入打印出来的测试矩形的实际尺寸。 选择“下一步”。

    9. AutoCAD 将实际打印的测量值与在前面的屏幕中指定的尺寸相比较，然后计算准确校准绘图仪所需的修正值。

  9. 在“校准绘图仪 -文件名”对话框中输入文件名。 选择“下一步”。

    10. 生成的 PMP 文件存储在 AutoCAD Drv 文件夹中。

  10. 在“校准绘图仪 - 完成”对话框中选择“检查校准”。

    11. AutoCAD 将再次打印测试矩形。 再次测量边的尺寸以验证校准是否正确。

  11. 选择“完成”，返回到“添加绘图仪”向导或“绘图仪配置编辑器”。

命令输入 PLOTTERMANAGER


将 PMP 文件附加到 PC3 文件的步骤 - 操作步骤

使用绘图仪和打印机
校准绘图仪以及使用自定义图纸尺寸
概念
操作步骤
命令

将 PMP 文件附加到 PC3 文件的步骤

创建 PMP 文件之后，该文件将被附着到用于启动校准绘图仪向导的 PC3 文件中。 可以使用“绘图仪配置编辑器”将现有 PMP 文件附着到其他 PC3 文件中。

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击要附着 PMP 文件的绘图仪配置。
  3. 在“设备和文档设置”选项卡的“用户定义图纸尺寸与校准”中，选择“PMP 文件名”<文件名>。

    4. 如果此 PC3 文件不包含附着的 PMP 文件，则“PMP 文件名”设置不显示附着的文件。 选择“附着”。

  4. 定位到要附着到该 PC3 文件的 PMP 文件，选择“打开”。
  5. 选择“确定”关闭绘图仪配置编辑器。

    6. 更新“PMP 文件名”设置。

命令输入 PLOTTERMANAGER


从 PC3 文件拆离 PMP 文件的步骤 - 操作步骤

使用绘图仪和打印机
校准绘图仪以及使用自定义图纸尺寸
概念
操作步骤
命令

从 PC3 文件拆离 PMP 文件的步骤

创建 PMP 文件之后，该文件将被附着到用于启动校准绘图仪向导的 PC3 文件中。 可以使用“绘图仪配置编辑器”从 PC3 文件拆离 PMP 文件。

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击要从中拆离 PMP 文件的绘图仪配置。
  3. 在“设备和文档设置”选项卡中选择的“用户定义图纸尺寸与校准”，然后选择“PMP 文件名”<文件名>。
  4. 选择“拆离”。 （如果此 PC3 文件不包含附着的 PMP 文件，则“拆离”选项不可用。）
  5. 选择“确定”关闭绘图仪配置编辑器。

命令输入 PLOTTERMANAGER


以新文件名保存 PMP 文件的步骤 - 操作步骤

使用绘图仪和打印机
校准绘图仪以及使用自定义图纸尺寸
概念
操作步骤
命令

以新文件名保存 PMP 文件的步骤

创建 PMP 文件之后，该文件将被附着到用于启动校准绘图仪向导的 PC3 文件中。 可以使用“绘图仪配置编辑器”以新文件名保存 PMP 文件。

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击保存 PMP 文件所需的绘图仪配置。
  3. 在绘图仪配置编辑器中，选择“设备和文档设置”选项卡。
  4. 双击“用户定义图纸尺寸与校准”，显示校准和图纸尺寸选项。
  5. 在“PMP 文件”下选择“保存 PMP”。
  6. 在“另存为”对话框中，为附着到用户正在编辑的 PC3 文件的 PMP 文件输入新的文件名。
  7. 选择“保存”。

    8. 在树状视图中，新文件名将显示在“PMP 文件名”选项旁边的尖括号中。

  8. 选择“确定”关闭绘图仪配置编辑器。

命令输入 PLOTTERMANAGER


从头开始添加新的自定义图纸尺寸的步骤（仅适用于非系统 HDI 驱动程序） - 操作步骤

使用绘图仪和打印机
校准绘图仪以及使用自定义图纸尺寸
概念
操作步骤
命令

从头开始添加新的自定义图纸尺寸的步骤（仅适用于非系统 HDI 驱动程序）

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击需要修改的绘图仪配置。
  3. 在绘图仪配置编辑器中，选择“设备和文档设置”选项卡。
  4. 双击“用户定义图纸尺寸与校准”，显示校准和图纸尺寸选项。 然后选择“自定义图纸尺寸”。
  5. 在“自定义图纸尺寸”下，选择“添加”。
  6. 在“自定义图纸尺寸 - 开始”向导中选择“从头开始”。 选择“下一步”。
  7. 在“介质边界”对话框的“单位”列表中，选择图纸尺寸的单位：“英寸”或“毫米”。

    8. 如果打印非矢量光栅图像，例如 BMP 或 TIFF 时，图形大小以像素点指定，而不是英寸或毫米。

  8. 在“宽度”和“长度”列表中选择图纸的宽度和长度。 选择“下一步”。

    9. 每台绘图仪都有一个最大的可打印区域，这取决于绘图仪夹图纸的位置和打印笔往返所及的距离。 验证绘图仪是否可以打印新尺寸。

  9. 在“可打印区域”对话框中，可在“上”、“下”、“左”和“右”框中指定可打印区域。 选择“下一步”。
  10. 在“图纸尺寸名”对话框中，输入图纸尺寸的名称。 选择“下一步”。
  11. 在“文件名”对话框中，输入 PMP 文件的名称。
  12. 在“完成”对话框中，指定纸张来源是单页送纸还是卷筒送纸。 选择“打印测试页面”，验证自定义尺寸。

    13. AutoCAD 将打印一个定义图纸尺寸的十字和一个定义可打印区域的矩形。 如果未打印出矩形的四条边，则需要增大可打印区域。

  13. 选择“完成”，退出自定义图纸尺寸向导。

命令输入 PLOTTERMANAGER


从头开始添加新的自定义图纸尺寸的步骤（仅适用于系统打印机） - 操作步骤

使用绘图仪和打印机
校准绘图仪以及使用自定义图纸尺寸
概念
操作步骤
命令

从头开始添加新的自定义图纸尺寸的步骤（仅适用于系统打印机）

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击需要修改的绘图仪配置。
  3. 在绘图仪配置编辑器中，选择“设备和文档设置”选项卡。
  4. 选择“自定义特性”。
  5. 在“访问自定义对话”区域选择“自定义特性”。

    6. 设备驱动程序特有的用户界面打开。

  6. 按照制造商的说明添加自定义图纸尺寸。

    7. 请选择“帮助”按钮以获得详细信息。

命令输入 PLOTTERMANAGER


从现有图纸尺寸添加新的自定义图纸尺寸的步骤 - 操作步骤

使用绘图仪和打印机
校准绘图仪以及使用自定义图纸尺寸
概念
操作步骤
命令

从现有图纸尺寸添加新的自定义图纸尺寸的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击需要修改的绘图仪配置。
  3. 在绘图仪配置编辑器中，选择“设备和文档设置”选项卡。
  4. 双击“用户定义图纸尺寸与校准”，显示校准和图纸尺寸选项。 然后选择“自定义图纸尺寸”。
  5. 在“自定义图纸尺寸”下，选择“添加”。
  6. 在“自定义图纸尺寸”向导的“开始”对话框中，选择“使用现有图纸”。
  7. 在现有的标准图纸尺寸列表中，选择一个图纸尺寸作为创建自定义图纸尺寸的基础。
  8. 在“介质边界”对话框选择图纸尺寸的单位：英寸或毫米，并指定图纸的宽度和长度。 选择“下一步”。

    9. 每台绘图仪都有一个最大的可打印区域，这取决于绘图仪夹图纸的位置和打印笔往返所及的距离。 验证绘图仪是否可以打印新尺寸。

  9. 在“可打印区域”对话框中，可在“上”、“下”、“左”和“右”框中指定可打印区域。 选择“下一步”。
  10. 在“图纸尺寸名”对话框中，输入图纸尺寸的名称。 选择“下一步”。
  11. 在“文件名”对话框中，输入 PMP 文件的名称。
  12. 在“完成”对话框中，指定纸张来源是单页送纸还是卷筒送纸。 选择“打印测试页面”，验证自定义尺寸。

    13. AutoCAD 将打印一个定义图纸尺寸的十字和一个定义可打印区域的矩形。 如果未打印出矩形的四条边，则需要增大可打印区域。

  13. 选择“完成”，退出自定义图纸尺寸向导。

命令输入 PLOTTERMANAGER


编辑自定义图纸尺寸的步骤 - 操作步骤

使用绘图仪和打印机
校准绘图仪以及使用自定义图纸尺寸
概念
操作步骤
命令

编辑自定义图纸尺寸的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击需要修改的绘图仪配置。
  3. 在绘图仪配置编辑器中，选择“设备和文档设置”选项卡。
  4. 双击“用户定义图纸尺寸与校准”，显示校准和图纸尺寸设置。
  5. 选择“自定义图纸尺寸”。
  6. 在“自定义图纸尺寸”下，从列表中选择图纸尺寸。 选择“编辑”。
  7. 在自定义图纸尺寸向导中，修改图纸尺寸、可打印区域、自定义图纸尺寸名称和来源。
  8. 选择“完成”，退出自定义图纸尺寸向导。
  9. 选择“确定”。

命令输入 PLOTTERMANAGER


删除自定义图纸尺寸的步骤 - 操作步骤

使用绘图仪和打印机
校准绘图仪以及使用自定义图纸尺寸
概念
操作步骤
命令

删除自定义图纸尺寸的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击需要修改的绘图仪配置。
  3. 在绘图仪配置编辑器中，选择“设备和文档设置”选项卡。
  4. 双击“用户定义图纸尺寸与校准”，显示校准和图纸尺寸设置。
  5. 选择“自定义图纸尺寸”。
  6. 在“自定义图纸尺寸”下，从列表中选择图纸尺寸。
  7. 选择“删除”。
  8. 选择“确定”。

命令输入 PLOTTERMANAGER


修改标准图纸尺寸的步骤 - 操作步骤

使用绘图仪和打印机
校准绘图仪以及使用自定义图纸尺寸
概念
操作步骤
命令

修改标准图纸尺寸的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击需要修改的绘图仪配置。
  3. 在绘图仪配置编辑器中，选择“设备和文档设置”选项卡。
  4. 双击“用户定义图纸尺寸与校准”，显示校准和图纸尺寸设置。
  5. 选择“修改标准图纸尺寸”。
  6. 在“修改标准图纸尺寸”下，选择要调整的图纸尺寸。 然后选择“修改”。
  7. 在自定义图纸尺寸向导中，根据需要调整可打印区域。 然后选择“完成”退出“自定义图纸尺寸”向导。

命令输入 PLOTTERMANAGER


过滤图纸尺寸的步骤 - 操作步骤

使用绘图仪和打印机
校准绘图仪以及使用自定义图纸尺寸
概念
操作步骤
命令

过滤图纸尺寸的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击需要修改的绘图仪配置。
  3. 在绘图仪配置编辑器中，选择“设备和文档设置”选项卡。
  4. 双击“用户定义图纸尺寸与校准”，显示校准和图纸尺寸设置。
  5. 选择“过滤图纸尺寸”。
  6. 在“过滤图纸尺寸”区域的“大小”列表中，核对要在“打印”和“页面设置”对话框中的“图纸尺寸”列表中列出的图纸尺寸。

命令输入 PLOTTERMANAGER


校准绘图仪以及使用自定义图纸尺寸 - 命令

使用绘图仪和打印机
使用绘图仪和打印机
校准绘图仪以及使用自定义图纸尺寸
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


解决与 Windows 打印管理器的冲突 - 概念

使用绘图仪和打印机
解决与 Windows 打印管理器的冲突
概念
操作步骤
命令

需要对本地连接的绘图仪使用适当的驱动程序。

如果为本地连接的绘图仪同时配置 HDI 硬拷贝驱动程序和 Windows 系统打印机，则 HDI 驱动程序不能直接连接到本地端口，因为 Windows 系统打印机驱动程序已经控制该端口。 驱动程序只能改变途径，通过 Windows 的后台打印进行输出。

如果绘图仪与串口相连接，请确保 “Windows 控制面板”中的串口设置正确。 此设置应与绘图仪的设置匹配，且连线正确。 通过打印到发生冲突的 Windows 系统打印机可检验设置是否正确。

使用 HDI 驱动程序通过后台打印进行打印类似于打印到文件，因为此时计算机与绘图仪之间只是单向通信。 具体操作过程由设备决定。


解决与 Windows 打印管理器的冲突 - 命令

使用绘图仪和打印机
使用绘图仪和打印机
解决与 Windows 打印管理器的冲突
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


端口设置 - 概念

使用绘图仪和打印机
端口设置
概念
操作步骤
命令

绘图仪配置编辑器中的“端口”选项卡包含有关绘图仪端口配置的信息。

  • 调整端口设置
    根据绘图仪的连接方式不同，计算机的端口有三种设置方案：
  • 使用后台打印
    使用后台打印可以打印到自动生成的文件名，该文件位于“选项”对话框中指定的文件夹中。
  • 设置设备的超时值
    某些绘图仪支持超时值，用于指定在接受下一批数据之前，绘图仪清空缓冲区所需的时间。
  • 配置串口
    如果设备支持，用户可以调整设备串口的波特率、协议、流控制和硬件握手等设置。


端口设置 - 操作步骤

使用绘图仪和打印机
端口设置
概念
操作步骤
命令

调整端口设置的步骤

使用后台打印的步骤

指定后台打印文件位置的步骤

为本地非系统绘图仪设置超时值的步骤

为网络打印机或 Windows 系统打印机设置超时值的步骤

调整串口设置的步骤


端口设置 - 命令

使用绘图仪和打印机
端口设置
概念
操作步骤
命令
命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


调整端口设置 - 概念

使用绘图仪和打印机
调整端口设置
概念
操作步骤
命令

根据绘图仪的连接方式不同，计算机的端口有三种设置方案：

绘图仪配置编辑器中的“端口”选项卡包含有关绘图仪端口配置的信息。 如果配置本地非系统绘图仪，则必须指定设备的连接端口。 可以选择串口（本地）、并口（本地）或网络端口。 对于并口，默认设置为 LPT1。 对于串口，默认设置为 COM1。 如果设备连接到其他端口，则要修改端口名称。

如果使用串口，AutoCAD 中的设置必须与绘图仪设置一致。 请选择“配置端口”以使 AutoCAD 设置与用户绘图仪设置一致。 显示绘图仪可用的协议。

注意 如果使用模拟已配置设备并且具有其他端口选项的设备，则选择“显示所有端口”。

还可以修改用于在 PC3 文件与计算机或网络系统之间进行通信的设置。 可以通过端口打印、打印到文件，或者使用后台打印特性在后台打印而不影响前台的工作。 如果通过并口打印，可指定超时值。 如果通过串口打印，可修改波特率、协议、流控制和输入/输出超时值。

根据绘图仪的连接方式不同，计算机的端口有三种设置方案：

本地连接的后台打印

如果将绘图仪插入运行 AutoCAD 的计算机上的端口，则绘图仪将被连接到本地。 如果还配置了 Windows 系统打印机，使其打印到使用同一本地端口的相同绘图仪上，那么 AutoCAD 将进行后台打印（通过 Windows 系统后台打印程序来发送打印作业）。 如果由于此类端口冲突而进行后台打印，AutoCAD 会显示警告信息，但是可以通过“选项”对话框的“打印和发布”选项卡中的设置来禁止显示此警告信息。

通过系统后台打印的打印方式较快。 然而，此方式可使发生冲突的 Windows 系统打印机控制输入/输出端口配置。 在此情况下，将忽略 AutoCAD 配置的端口设置。 要查看或调整端口设置，可启动“控制面板”中的“Windows 打印管理器”，并激活为绘图仪配置的打印机。 用户可以在 Windows 系统打印机的“属性”对话框中调整端口设置。 在“属性”对话框中可以打印一个测试页以检查绘图仪与计算机是否能正确通信。

本地连接，但不是后台打印

如果绘图仪连接到本地，并且没有冲突的系统打印机，则 AutoCAD 可以直接控制输入/输出端口设置。

通过网络

如果要在一台计算机上运行 AutoCAD，但打印到已连接至网络上另一台计算机的设备，则远程计算机将控制端口设置，并将忽略 AutoCAD 配置的端口设置。 Windows 系统打印机必须在远程计算机上配置。 （这是在网络上共享绘图仪的方法。） 远程系统打印机控制端口设置；在远程计算机上，用户可以在每个系统打印机文件的“属性”对话框中查看和更改这些设置。

请参见

使用后台打印


调整端口设置的步骤 - 操作步骤

使用绘图仪和打印机
调整端口设置
概念
操作步骤
命令

调整端口设置的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击需要修改其端口设置的绘图仪配置 (PC3) 文件。
  3. 在绘图仪配置编辑器中选择“端口”选项卡。
  4. 选择下列选项之一：
    • 打印到以下端口。 通过指定端口将图形发送到打印机。
    • 打印到文件。将图形发送到文件，其文件名在“选项”对话框的“文件”选项卡中指定。
    • 后台打印。使用在“选项”对话框的“文件”选项卡中指定的后台打印实用程序打印图形。
  5. 如果使用的设备与已配置的设备类似且具有其他端口选项，则选择“显示所有端口”。
  6. 要将非系统绘图仪连接到另一台设备的实例，请选择“浏览网络”。 在“浏览打印机”对话框中选择设备，然后选择“确定”。
  7. 选择“确定”。

命令输入 PLOTTERMANAGER


调整端口设置 - 命令

使用绘图仪和打印机
使用绘图仪和打印机
调整端口设置
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


使用后台打印 - 概念

使用绘图仪和打印机
使用后台打印
概念
操作步骤
命令

使用后台打印可以打印到自动生成的文件名，该文件位于“选项”对话框中指定的文件夹中。

一旦创建文件后，将执行“选项”对话框中指定的后台打印应用程序。

尽管不是必须使用后台打印才能打印到 Windows 网络打印机和绘图仪，但此机制允许用户在打印的同时运行其他应用程序，也允许其他网络用户使用网络设备。

在“添加绘图仪”向导中添加打印机或绘图仪时，选择“网络”端口类型以满足大多数网络连接的打印机和绘图仪的需要。

通过后台打印，用户可在将打印文件发送到指定设备的同时继续进行其他工作。 后台打印可满足特殊的打印需求，例如日志文件或非标准网络等。 用户还可以使用为 AutoCAD 早期版本开发的大多数打印例程。

在运行后台打印时，AutoCAD 将打印作业写入指定文件夹的随机文件名中。 接着，AutoCAD 以用户指定的参数列表运行打印队列提交程序。 此参数列表至少包含 AutoCAD 指定给打印作业的随机文件名。 参数列表用 %s 变量表示。 其他参数各有作用，例如，提高目标设备的分辨率或生成日志文件。

要设置后台打印，必须提供 AutoCAD 调用的可执行文件，并在“选项”对话框中指定可执行文件名和参数列表。 可执行文件通常是一个用户创建的批处理程序，但也可以是第三方程序。 如果使用第三方程序，设置本质上相同。 要确定第三方程序所需的参数变量，请参考该程序的文档。

可以有多种方法配置后台打印：

  • 使用 Windows 系统打印机驱动程序和打印管理器来启用后台打印
  • 将 HDI 驱动程序和 Windows 系统打印机驱动程序配置为使用同一 I/O 端口，以将 HDI 驱动程序输出强制指定到系统后台打印程序
  • 后台打印

如果使用后台打印配置 AutoCAD 以进行后台打印，必须配置打印机，指定后台打印的可执行文件和打印文件的位置。

创建后台打印批处理文件

以下样例文件 plot.bat 显示了一些可以包含在批处理文件中的函数。 此批处理文件确定目标硬拷贝设备，通过操作系统的 Copy 命令提交打印作业，然后删除由 AutoCAD 创建的临时打印文件。

此批处理文件需要从 AutoCAD 传递 %s 和 %c 两个参数，在批处理程序中这两个参数被分别内部参照为 %1 和 %2。 本样例假设设备连接在本地工作站和两个不同的网络打印机服务器上。 关于设备名和连接的说明，请参见下表。 注意参数传送给后台打印可执行文件的次序决定了在程序或批处理文件中引用参数的方式。 例如，第一个变量变为 %1，等等。

设备名和连接
说明 | 服务器 | 网络共享名 | AutoCAD 配置名
本地激光打印机 |  |  | my_laser
网络绘图仪 | milana | \\milana\hp755cm | hp755cm
网络激光打印机 | kilo | \\kilo\laser | net_laser

Rem PLOT.BAT
@echo off

Rem determine the destination

if %2 == my_laser goto PlotA

if %2 == hp755cm goto PlotB

if %2 == net_laser goto PlotC

Rem trap for undefined devices

echo *******************Warning**********************

echo %2 is not defined to the Plot Script, PLOT.BAT

echo The plot job has been canceled.

echo ************************************************

pause

goto END

Rem send the job

:PlotA

copy %1 /b LPT1

goto END

:PlotB

copy %1 /b \\milana\hp755cm

goto END

:PlotC

copy %1 /b \\kilo\laser

goto END

Rem clean up and exit

:END

erase %1

exit

注意 设备名是区分大小写的。 确保为 AutoCAD 中的设备配置的名称与批处理程序中的名称完全匹配。


使用后台打印 - 操作步骤

使用绘图仪和打印机
使用后台打印
概念
操作步骤
命令

使用后台打印的步骤

指定后台打印文件位置的步骤


使用后台打印的步骤 - 操作步骤

使用绘图仪和打印机
使用后台打印
概念
操作步骤
命令

使用后台打印的步骤

  1. 启动“添加绘图仪”向导。
  2. 在“端口”对话框中选择“后台打印”。
  3. 从“工具”菜单中选择“选项”。 然后选择“文件”选项卡。
  4. 双击“打印文件、后台打印文件和前导部分名称”，显示此区域中的选项。
  5. 双击“后台打印程序”。
  6. 双击箭头。 在“选择文件”对话框中，找到创建打印文件时要运行的程序。 添加要使用的命令行参数。 例如，输入 myspool.bat %s。

当 AutoCAD 打印到文件时，将使用唯一的打印文件名替换“后台打印程序”名称中的“%s”，并将生成的命令发送到 DOS。

后台打印程序命令行选项
选项 | 函数
%d 或 %D | 指定 AutoCAD 图形名，包括完整路径和扩展名
%e 或 %E | 指定等号 (=)
%h 或 %H | 以选定的打印单位返回打印区域的高度
%i 或 %I | 变为打印单位的第一个字母
%l 或 %L | 指定登录名，该登录名存储在 LOGINNAME 系统变量中
%m 或 %M | 返回 AutoCAD 绘图仪型号，AutoCAD 在配置过程中列出型号名
%n 或 %N | 成为绘图仪名称，AutoCAD 使用绘图仪名称来标识绘图仪的制造商和类型
%p 或 %P | 指定绘图仪编号，AutoCAD 为配置的绘图仪指定编号，并按此次序列出绘图仪
%s 或 %S | 指定后台打印文件名，包括路径和扩展名
%u 或 %U | 指定在安装时输入的用户名
%w 或 %W | 以选定的单位返回绘图仪区域的宽度
%% | 指定百分号 (%)
%c 或 %C | 指定设备说明 （这是在“绘图仪配置编辑器”的“基本”选项卡中输入的说明。 此说明与后台打印一起使用时，不应包含空格。）


指定后台打印文件位置的步骤 - 操作步骤

使用绘图仪和打印机
使用后台打印
概念
操作步骤
命令

指定后台打印文件位置的步骤

  1. 从“工具”菜单中选择“选项”。 选择“文件”选项卡。
  2. 双击“打印支持文件路径”。
  3. 双击“后台打印文件位置”。
  4. 双击箭头。
  5. 在“选择文件”对话框中，输入后台打印文件的路径。


使用后台打印 - 命令

使用绘图仪和打印机
使用绘图仪和打印机
使用后台打印
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


设置设备的超时值 - 概念

使用绘图仪和打印机
设置设备的超时值
概念
操作步骤
命令

某些绘图仪支持超时值，用于指定在接受下一批数据之前，绘图仪清空缓冲区所需的时间。

绘图仪清空其缓冲区之后，将接受更多来自 AutoCAD 的数据。 输入希望在 AutoCAD 提示中断打印之前等待的时间。 如果图形很复杂或笔速很慢，则需要把超时值设置得比默认值（30 秒）大。 如果收到大量超时提示，可能是超时值设置得太小。 对于支持超时值的绘图仪，可以在“添加绘图仪”向导的初始配置过程中，选择“端口”选项卡中的“配置端口”来设置此超时值。


设置设备的超时值 - 操作步骤

使用绘图仪和打印机
设置设备的超时值
概念
操作步骤
命令

为本地非系统绘图仪设置超时值的步骤

为网络打印机或 Windows 系统打印机设置超时值的步骤


为本地非系统绘图仪设置超时值的步骤 - 操作步骤

使用绘图仪和打印机
设置设备的超时值
概念
操作步骤
命令

为本地非系统绘图仪设置超时值的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击需要修改其超时值的绘图仪配置 (PC3) 文件。
  3. 在绘图仪配置编辑器中选择“端口”选项卡。
  4. 在“端口”选项卡中选择要使用的端口。
  5. 选择“配置端口”然后执行以下操作之一：
    • 如果配置并口，在“传输重试”框中输入超时值，单位为毫秒。
    • 对于串口，在“输入超时”和“输出超时”框中输入超时值，单位为毫秒。
  6. 选择“确定”。

命令输入 PLOTTERMANAGER


为网络打印机或 Windows 系统打印机设置超时值的步骤 - 操作步骤

使用绘图仪和打印机
设置设备的超时值
概念
操作步骤
命令

为网络打印机或 Windows 系统打印机设置超时值的步骤

  1. 从“开始”菜单中选择“设置”。 然后选择“打印机”。
  2. 在要使用的打印机上单击鼠标右键，然后选择“属性”。
  3. 在“属性”对话框中选择“端口”选项卡。
  4. 在“端口”选项卡中，选择打印机使用的 LPT 端口，然后选择“配置端口”。
  5. 在“传输重试”框中输入秒数。
  6. 选择“确定”，退出所有对话框。


设置设备的超时值 - 命令

使用绘图仪和打印机
使用绘图仪和打印机
设置设备的超时值
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


配置串口 - 概念

使用绘图仪和打印机
配置串口
概念
操作步骤
命令

如果设备支持，用户可以调整设备串口的波特率、协议、流控制和硬件握手等设置。

应使用最快的可用波特率和制造商推荐的协议。 详细信息请参见设备附带的文档。

注意 绘图仪的设置必须与 AutoCAD 中的设置匹配，否则将无法打印。

流控制和握手

计算机生成打印文件的速度比大多数绘图仪要快。 当绘图仪有限的内存被占满时，绘图仪必须能够通知计算机暂时停止发送数据。 绘图仪在处理完数据后释放内存，此时绘图仪必须能够通知计算机恢复发送打印文件。 此通信过程被称为流控制或握手。

有两种握手方法：硬件和软件。 硬件握手使用连接绘图仪和计算机的电缆中的附加电缆。 这种电缆专门用于握手信号或开/关电压。 软件握手使用单线发送命令流，其中包含开始/停止握手信号。 软件握手的通用类型为 XON/XOFF。 必须为硬件握手和软件握手提供不同的电缆。


调整串口设置的步骤 - 操作步骤

使用绘图仪和打印机
配置串口
概念
操作步骤
命令

调整串口设置的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击需要修改其串口设置的绘图仪配置 (PC3) 文件。
  3. 在“绘图仪配置编辑器”中选择“端口”选项卡，然后选择要使用的串口。
  4. 选择“配置端口”。
  5. 在“COM 端口设置”对话框中为设备选择波特率和协议。

    6. 显示当前设备的可用协议设置。 不能设置无效的协议。

  6. 选择一种数据流控制方法。

    7. 默认流控制设置为与 AutoCAD 早期版本兼容的 XON/XOFF（软件握手）。 如果选择“硬件”握手，可选择“高级”来指定其他设置。

    在“COM 端口高级设置”对话框中，下面的设置与串口上的不同插针相对应：

    • CTS。启用“清除发送”握手。 它监视 25 针串口的第 5 针或 9 针串口的第 8 针。 CTS 是一个输入位，用于监视绘图仪或打印机的输出。
    • DSR。启用“数据准备就绪”握手。 它监视 25 针串口的第 6 针或 9 针串口的第 6 针。 DSR 是一个输入位，用于监视打印机或绘图仪的输出。
    • RLSD。启用“接收线信号检测” 握手。 有时称为“数据传输侦测”或“DCD”。 它是一个输入针，可以用于监视来自绘图仪的输出。 它位于 25 针串口的第 8 针，以及 9 针串口的第 1 针。
    • RTS。控制“请求发送”输出位。 通过 25 针串口的第 4 针或 9 针串口的第 7 针向打印机或绘图仪发送信号。

      • 禁用。设备处于打开状态时，禁用 RTS 线。

      启用。设备处于打开状态时，启用 RTS 线。

      握手。启用 RTS 握手。 当“提前键入”（输入）缓冲区小于一半容量时驱动程序将提高 RTS 线，当缓冲区超过四分之三容量时驱动程序将降低 RTS 线。

      切换。如果字节可用于传输，则指定 RTS 线为高。 发送所有缓存的字节后，RTS 线将为低电平。

    • DTR。控制“数据终端就绪”输出引脚。 通过 25 针串口的第 20 针或 9 针串口的第 4 针向打印机或绘图仪发送信号。

      • 禁用。设备处于打开状态时，禁用 DTR 线。

      启用。设备处于打开状态时，启用 DTR 线。

      握手。启用 DTR 握手。

  7. 选择“确定”关闭“COM 端口高级设置”对话框。 然后选择“确定”以关闭“设置 COM 端口”对话框。


配置串口 - 命令

使用绘图仪和打印机
使用绘图仪和打印机
配置串口
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


设置设备特有的配置 - 概念

设置设备特有的配置
概念
操作步骤
命令

可以在 Autodesk 绘图仪管理器中设置设备特有的配置。

  • 配置 HP DesignJets
    HP 开发的 Windows 系统打印机驱动程序支持 HP DesignJet 绘图仪。 请访问 http://hp.com/go/designjet 以检查最新的 HP DesignJet 驱动程序。
  • 配置 Hewlett-Packard HP-GL 绘图仪
    Hewlett-Packard HP-GL 绘图仪通过 RS-232C 串行输入/输出端口而得到支持。
  • 配置 Hewlett-Packard HP-GL/2 设备
    HP-GL/2 非系统驱动程序支持各种 HP-GL/2 笔式绘图仪和喷墨绘图仪。
  • 配置 Océ 绘图仪
    虽然 Océ 绘图仪的首选配置是使用并口，但是，Océ 绘图仪也可以通过 RS-232C 串行 I/O 端口获得支持。
  • 配置 Xerox 设备
    强烈建议使用 Xerox HDI 驱动程序。
  • 配置 CalComp 绘图仪
    如果要使用 CalComp 绘图仪，则可以使用 Windows 系统打印机。
  • 配置 Houston Instruments 绘图仪
    如果使用新型的 Houston Instruments 绘图仪，可使用普通的 HP-GL 或 HP-GL/2 HDI 驱动程序并将绘图仪配置为 HP-GL 或 HP-GL/2 HDI 仿真模式。
  • 使用 Autodesk HDI 系统打印机驱动程序
    通过 HDI 系统打印机驱动程序，可以使用为 Windows 配置的绘图仪或打印机。


设置设备特有的配置 - 操作步骤

设置设备特有的配置
概念
操作步骤
命令

配置 HP-GL 绘图仪驱动程序的步骤

发送完所有矢量后停止长轴打印的步骤

在向绘图仪发送矢量时停止长轴打印的步骤

配置 HP-GL/2 绘图仪驱动程序的步骤

进行长轴打印的步骤

配置 Océ 绘图仪驱动程序的步骤

配置 HDI Xerox 绘图仪驱动程序的步骤

为系统打印机创建绘图仪配置的步骤


设置设备特有的配置 - 命令

设置设备特有的配置
概念
操作步骤
命令
命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


配置 HP DesignJets - 概念

设置设备特有的配置
配置 HP DesignJets
概念
操作步骤
命令

HP 开发的 Windows 系统打印机驱动程序支持 HP DesignJet 绘图仪。 请访问 http://hp.com/go/designjet 以检查最新的 HP DesignJet 驱动程序。

来自其他制造商并模拟 HP DesignJet 的绘图仪通过 HP-GL/2 HDI 驱动程序受到支持。

AutoCAD® 通过串口或并口支持 HP DesignJet 绘图仪型号。 最好使用并口。 如果使用串口，应将 DesignJet 设置为：9600 波特率、8 位数据位、1 位停止位、无奇偶校验和硬件握手 XON/XOFF。

所有 DesignJet 卷筒送纸型绘图仪都可以进行长轴打印。 对于页面格式和页边距，600 和 650C 都有一个可选的扩展模式。 在绘图仪的前面板上设置扩展模式。

注意 如果在使用 HP DesignJet 绘图仪时遇到打印问题（例如直线和着色实体的分辨率降低），请与 HP 联系寻求支持。


设置设备特有的配置
设置设备特有的配置
概念
操作步骤
命令

没有该主题的操作步骤。


配置 HP DesignJets - 命令

设置设备特有的配置
设置设备特有的配置
配置 HP DesignJets
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


配置 Hewlett-Packard HP-GL 绘图仪 - 概念

设置设备特有的配置
配置 Hewlett-Packard HP-GL 绘图仪
概念
操作步骤
命令

Hewlett-Packard HP-GL 绘图仪通过 RS-232C 串行输入/输出端口而得到支持。

将 HP 绘图仪设置为：9600 波特率、7 位数据位、1 位停止位和偶校验。

关于电缆布线、切换设置的详细信息以及其他与使用 HP-GL 驱动程序相关的信息，请参见“HP-GL 自定义特性”对话框。

关于使用此驱动程序的详细信息，可打开此设备的 PC3 文件，然后在绘图仪配置编辑器的“自定义特性”对话框中选择“帮助”。

硬剪裁界限

7580、7585、7586、DraftPro DXL/EXL、DraftMaster I、7586B 和 7596A 绘图仪将硬剪裁限制返回 AutoCAD。 这些限制要求在 AutoCAD 和绘图仪之间进行双向通信。 绘图仪向 AutoCAD 发送已安装图纸的精确打印区域，从而使 AutoCAD 可以根据实际图纸尺寸在图纸上确定打印位置。 如果关闭 AutoCAD 的硬剪裁限制请求，AutoCAD 将根据配置的图纸尺寸确定打印位置。 大多数情况下，如果关闭硬剪裁界限，必须调整配置的图纸尺寸以反映此设备的实际可打印区域。 否则，打印的内容可能会被剪裁掉。 当然，也可以通过改变打印原点来调整图纸上的打印位置。

如果通过 Windows 后台打印程序发送打印，将关闭 AutoCAD 的硬剪裁限制请求，因为该请求与 Windows 系统打印机冲突，或者因为用户要打印到网络端口。 如果看到警告消息，必须调整配置的图纸尺寸和打印原点。

AutoCAD 将打印发送到当前配置的端口，与将打印发送到文件的方式相同。 发送打印之后，可以直接打印到绘图仪缓冲区或通过网络打印。

HP-GL 长轴打印

对于卷筒送纸的介质，HP-GL 设备限制帧的高度。 帧的高度随卷筒宽度变化。 要打印超过帧的高度的图纸，则必须用长轴打印。

当配置使用长轴图纸尺寸并通过“绘图仪配置编辑器”中的“添加图纸尺寸”向导创建长轴打印图纸尺寸时，AutoCAD 将确定是否需要进行长轴打印。

驱动程序把所有矢量发送到绘图仪的缓冲区或硬盘。 笔式绘图仪自动翻页以打印每一帧。

按照《HP 用户手册》中的说明进行操作。 对于长轴、多帧打印，需要黑色 0.3 毫米的纤维尖笔（用于打印纸）或者置于笔座 8 的 0.35 毫米的绘图笔（用于羊皮纸或胶片）。 只有这些笔才能使绘图仪检测到用于对齐帧的注册标记。

当用 7586B 卷筒送纸绘图仪创建长轴打印时，“Out of Limit”指示灯偶尔会亮一下。 通常，这是在打印非常大的图形时 AutoCAD 和绘图仪相互作用的结果。


配置 Hewlett-Packard HP-GL 绘图仪 - 操作步骤

设置设备特有的配置
配置 Hewlett-Packard HP-GL 绘图仪
概念
操作步骤
命令

配置 HP-GL 绘图仪驱动程序的步骤

发送完所有矢量后停止长轴打印的步骤

在向绘图仪发送矢量时停止长轴打印的步骤


配置 HP-GL 绘图仪驱动程序的步骤 - 操作步骤

设置设备特有的配置
配置 Hewlett-Packard HP-GL 绘图仪
概念
操作步骤
命令

配置 HP-GL 绘图仪驱动程序的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击“添加绘图仪向导”快捷方式图标。
  3. 如果打印机已连接到计算机上，请在“开始”对话框中选择“我的电脑”。 如果从网络获得绘图仪，请选择“网络绘图仪服务器”。 选择“下一步”。
  4. 在“网络绘图仪”对话框中输入网络绘图仪的 UNC 名称。 选择“下一步”。 如果在步骤 3 中选择了“我的电脑”，则不显示此对话框。
  5. 在“绘图仪型号”对话框的“制造商”下选择“Hewlett-Packard”。 在“型号”下，选择正使用或模仿的 HP 绘图仪类型。 选择“下一步”。
  6. 在“输入 PCP 或 PC2”对话框中选择要输入的 PCP 或 PC2 文件（可选）。 选择“下一步”。
  7. 在“端口”对话框中选择打印机要连接的端口。 如果在步骤 3 中选择了“网络绘图仪服务器”，则不显示此对话框。 选择“下一步”。
  8. 在“绘图仪名称”对话框中，输入绘图仪配置文件的名称。 选择“下一步”。
  9. 在“完成”对话框中选择“完成”。

    10. 新的绘图仪配置文件 (PC3) 创建完毕。

命令输入 PLOTTERMANAGER


发送完所有矢量后停止长轴打印的步骤 - 操作步骤

设置设备特有的配置
配置 Hewlett-Packard HP-GL 绘图仪
概念
操作步骤
命令

发送完所有矢量后停止长轴打印的步骤

  • 按绘图仪“控制面板”上的“取消”按钮以清除绘图仪内存。


在向绘图仪发送矢量时停止长轴打印的步骤 - 操作步骤

设置设备特有的配置
配置 Hewlett-Packard HP-GL 绘图仪
概念
操作步骤
命令

在向绘图仪发送矢量时停止长轴打印的步骤

  • 按 ESC 键。 阅读 HP 手册中关于取消打印和清除内存缓冲区的信息。

取消打印后必须重置绘图仪，否则部分打印内容会覆盖下次打印。


配置 Hewlett-Packard HP-GL 绘图仪 - 命令

设置设备特有的配置
设置设备特有的配置
配置 Hewlett-Packard HP-GL 绘图仪
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


配置 Hewlett-Packard HP-GL/2 设备 - 概念

设置设备特有的配置
配置 Hewlett-Packard HP-GL/2 设备
概念
操作步骤
命令

HP-GL/2 非系统驱动程序支持各种 HP-GL/2 笔式绘图仪和喷墨绘图仪。

这是通用 HP-GL/2 驱动程序，尚未针对特定制造商的设备进行优化。 此驱动程序也支持老式笔式绘图仪和其他制造商（非 HP）生产的新式设备。

带有卷筒送纸器的 DesignJet、DraftPro Plus 和 DraftMaster 可以进行长轴打印。

关于使用此驱动程序的详细信息，可打开此设备的 PC3 文件，然后在绘图仪配置编辑器的“自定义特性”对话框中选择“帮助”。


配置 Hewlett-Packard HP-GL/2 设备 - 操作步骤

设置设备特有的配置
配置 Hewlett-Packard HP-GL/2 设备
概念
操作步骤
命令

配置 HP-GL/2 绘图仪驱动程序的步骤

进行长轴打印的步骤


配置 HP-GL/2 绘图仪驱动程序的步骤 - 操作步骤

设置设备特有的配置
配置 Hewlett-Packard HP-GL/2 设备
概念
操作步骤
命令

配置 HP-GL/2 绘图仪驱动程序的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击“添加绘图仪向导”快捷方式图标。
  3. 如果绘图仪已连接到计算机上，请在“开始”对话框中选择“我的电脑”。 如果从网络获得绘图仪，请选择“网络绘图仪服务器”。 选择“下一步”。
  4. 在“网络绘图仪”对话框中输入网络绘图仪的 UNC 名称。 选择“下一步”。 如果在步骤 3 中选择了“我的电脑”，则不显示此对话框。
  5. 在“绘图仪型号”对话框的“制造商”下选择“Hewlett-Packard”。 在“型号”下，选择正使用或模仿的 HP 绘图仪类型。 选择“下一步”。
  6. 在“输入 PCP 或 PC2”对话框中选择要输入的 PCP 或 PC2 文件（可选）。 选择“下一步”。
  7. 在“端口”对话框中选择打印机要连接的端口。 如果在步骤 3 中选择了“网络绘图仪服务器”，则不显示此对话框。 选择“下一步”。
  8. 在“绘图仪名称”对话框中，输入绘图仪配置文件的名称。 选择“下一步”。
  9. 在“完成”对话框中选择“完成”。

    10. 新的绘图仪配置文件 (PC3) 创建完毕。

命令输入 PLOTTERMANAGER


进行长轴打印的步骤 - 操作步骤

设置设备特有的配置
配置 Hewlett-Packard HP-GL/2 设备
概念
操作步骤
命令

进行长轴打印的步骤

  1. 以普通方式打印。 要获得最佳效果，请打印到图形范围，并且不要旋转打印。 显式使用 1:1 的比例（不能用“按图纸空间缩放”）。
  2. 要在 AutoCAD 发送完所有矢量后停止绘图仪，请使用绘图仪“控制面板”来清除绘图仪内存。
  3. 要在 AutoCAD 向绘图仪发送矢量时停止长轴打印，请按 ESC 键。
  4. 对于以下设备，请按指示清除绘图仪内存：
    • DraftMaster X 系列。按“取消”按钮。
    • HP 7600 240D/E。按绘图仪的“重置”按钮。
    • HP 7600 250/255/355。按“打印管理”按钮。 选择“Queuing Operations”，然后选择打印任务，将其从队列中删除。
    • HP DesignJet 系列。按“取消”按钮。
    • HP DraftPro Plus。按“取消”按钮。


配置 Hewlett-Packard HP-GL/2 设备 - 命令

设置设备特有的配置
设置设备特有的配置
配置 Hewlett-Packard HP-GL/2 设备
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


配置 Océ 绘图仪 - 概念

设置设备特有的配置
配置 Océ 绘图仪
概念
操作步骤
命令

虽然 Océ 绘图仪的首选配置是使用并口，但是，Océ 绘图仪也可以通过 RS-232C 串行 I/O 端口获得支持。

将 Océ 绘图仪设置为 9600 或 19,200 波特率、8 位数据位、1 位停止位并且无奇偶校验。 关于串口电缆布线说明，可向经销商或制造商索取。

关于使用此驱动程序的详细信息，可打开此设备的 PC3 文件，然后在绘图仪配置编辑器的“自定义特性”对话框中选择“帮助”。


配置 Océ 绘图仪驱动程序的步骤 - 操作步骤

设置设备特有的配置
配置 Océ 绘图仪
概念
操作步骤
命令

配置 Océ 绘图仪驱动程序的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击“添加绘图仪向导”快捷方式图标。
  3. 如果绘图仪已连接到计算机上，请在“开始”对话框中选择“我的电脑”。 如果从网络获得绘图仪，请选择“网络绘图仪服务器”。 选择“下一步”。
  4. 在“网络绘图仪”对话框中输入网络绘图仪的 UNC 名称。 选择“下一步”。 如果在步骤 3 中选择了“我的电脑”，则不显示此对话框。
  5. 在“生产商”的“绘图仪型号”页面上，选择“Océ”。 在“型号”下，选择要使用的 Océ 绘图仪。 选择“下一步”。
  6. 在“输入 PCP 或 PC2”对话框中选择要输入的 PCP 或 PC2 文件（可选）。 选择“下一步”。
  7. 在“端口”对话框中选择打印机要连接的端口。 如果在步骤 3 中选择了“网络绘图仪服务器”，则不显示此对话框。 选择“下一步”。
  8. 在“绘图仪名称”对话框中，输入绘图仪配置文件的名称。 选择“下一步”。
  9. 在“完成”对话框中选择“完成”。

    10. 新的绘图仪配置文件 (PC3) 创建完毕。

命令输入 PLOTTERMANAGER


配置 Océ 绘图仪 - 命令

设置设备特有的配置
设置设备特有的配置
配置 Océ 绘图仪
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


配置 Xerox 设备 - 概念

设置设备特有的配置
配置 Xerox 设备
概念
操作步骤
命令

强烈建议在 AutoCAD 中使用 Xerox HDI 驱动程序。 在提高性能的同时，该新驱动程序还提供了与现有 Windows 系统相同的设置以及从双向打印的打印机中获取信息（例如，卷筒状态和打印机安装的光栅戳记）的能力。

关于最新的 Xerox 设备和驱动程序的详细信息，请访问 Xerox 的网站。


配置 HDI Xerox 绘图仪驱动程序的步骤 - 操作步骤

设置设备特有的配置
配置 Xerox 设备
概念
操作步骤
命令

配置 HDI Xerox 绘图仪驱动程序的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击“添加绘图仪向导”快捷方式图标。
  3. 如果绘图仪已连接到计算机上，请在“开始”对话框中选择“我的电脑”。 如果从网络获得绘图仪，请选择“网络绘图仪服务器”。 选择“下一步”。
  4. 在“网络绘图仪”对话框中输入网络绘图仪的 UNC 名称。 选择“下一步”。 如果在步骤 3 中选择了“我的电脑”，则不显示此对话框。
  5. 在“绘图仪型号”对话框的“制造商”下选择“Xerox Engineering Systems”。 在“型号”下，选择使用的 Xerox 绘图仪类型。 选择“下一步”。
  6. 在“输入 PCP 或 PC2”对话框中选择要输入的 PCP 或 PC2 文件（可选）。 选择“下一步”。
  7. 在“端口”对话框中选择打印机要连接的端口。 如果在步骤 3 中选择了“网络绘图仪服务器”，则不显示此对话框。 选择“下一步”。
  8. 在“绘图仪名称”对话框中，输入绘图仪配置文件的名称。 选择“下一步”。
  9. 在“完成”对话框中选择“完成”。

    10. 新的绘图仪配置文件 (PC3) 创建完毕。

命令输入 PLOTTERMANAGER


配置 Xerox 设备 - 命令

设置设备特有的配置
设置设备特有的配置
配置 Xerox 设备
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


配置 CalComp 绘图仪 - 概念

设置设备特有的配置
配置 CalComp 绘图仪
概念
操作步骤
命令

如果要使用 CalComp 绘图仪，则可以使用 Windows 系统打印机。

如果绘图仪提供 HP-GL 或 HP-GL/2 仿真，则可以使用 HP-GL 或 HP-GL/2 HDI 驱动程序。

关于使用此驱动程序的详细信息，可打开此设备的 PC3 文件，然后在绘图仪配置编辑器的“自定义特性”对话框中选择“帮助”。


配置 CalComp 绘图仪 - 命令

设置设备特有的配置
设置设备特有的配置
配置 CalComp 绘图仪
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


配置 Houston Instruments 绘图仪 - 概念

设置设备特有的配置
配置 Houston Instruments 绘图仪
概念
操作步骤
命令

如果使用新型的 Houston Instruments 绘图仪，可使用普通的 HP-GL 或 HP-GL/2 HDI 驱动程序并将绘图仪配置为 HP-GL 或 HP-GL/2 HDI 仿真模式。


配置 Houston Instruments 绘图仪 - 命令

设置设备特有的配置
设置设备特有的配置
配置 Houston Instruments 绘图仪
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


使用 Autodesk HDI 系统打印机驱动程序 - 概念

设置设备特有的配置
使用 Autodesk HDI 系统打印机驱动程序
概念
操作步骤
命令

通过 HDI 系统打印机驱动程序，可以使用为 Windows 配置的绘图仪或打印机。

可使用任何 Windows 支持的打印设备（Windows 系统打印机）。

可以使用 HDI 系统打印机驱动程序来选择 AutoCAD 的打印机默认设置，这些设置与其他 Windows 应用程序的默认设置不同。

Autodesk 系统打印机驱动程序支持光栅输出。 但是，作为系统打印机来输出由 AutoCAD 发送的光栅和矢量数据的设备能力受其内存大小的限制。

如果拥有多个 Windows 系统打印机，可选择用于从 AutoCAD 打印的设备。 例如，可以将 LaserJet 打印机用于文字处理文档，将 BubbleJet 用于 AutoCAD 图形。

要达到最佳效果，请按如下方式使用 Windows 系统打印机和 AutoCAD 绘图仪驱动程序：

  • 除非拥有 Océ TDS/TCS 打印机或 HP DesignJet 绘图仪，否则，请优先使用适合用户的打印机/绘图仪（而不是 Windows 系统打印机）的 Autodesk HDI 驱动程序。 Océ 和 HP 已提供了针对 AutoCAD 使用而优化过的系统打印机驱动程序。
  • 对于无笔的输出设备（例如激光打印机），使用 Windows 系统打印机。

为 AutoCAD 设置 Windows 系统打印机分为两步：

  • 在 Windows 下配置系统打印机（请参见 Microsoft 关于操作系统的文档）
  • 使用“添加绘图仪向导”快捷方式图标将系统打印机配置为 AutoCAD 绘图仪


为系统打印机创建绘图仪配置的步骤 - 操作步骤

设置设备特有的配置
使用 Autodesk HDI 系统打印机驱动程序
概念
操作步骤
命令

为系统打印机创建绘图仪配置的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击“添加绘图仪向导”快捷方式图标。
  3. 在“开始”对话框中选择“系统打印机”。 选择“下一步”。
  4. 在“系统打印机”对话框中选择需要创建绘图仪配置文件的系统打印机。 选择“下一步”。
  5. 在“输入 PCP 或 PC2”对话框中选择“输入文件”，然后选择一个要输入的 PCP 或 PC2 文件（可选）。 选择“输入”。 然后选择“下一步”。
  6. 在“绘图仪名称”对话框中，输入绘图仪配置文件的名称。 选择“下一步”。
  7. 在“完成”对话框中选择“完成”。

    8. 新的绘图仪配置文件 (PC3) 创建完毕。

命令输入 PLOTTERMANAGER


使用 Autodesk HDI 系统打印机驱动程序 - 命令

设置设备特有的配置
设置设备特有的配置
使用 Autodesk HDI 系统打印机驱动程序
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


配置文件输出 - 概念

配置文件输出
概念
操作步骤
命令

AutoCAD® 提供用于创建以下类型的文件的绘图仪驱动程序：

  • Autodesk 电子打印 (DWF)
  • Adobe PDF
  • Adobe PostScript
  • DXB 文件格式
  • 光栅文件格式
配置 ePlot 以创建 DWF 文件

使用 ePlot，可以生成针对打印或查看而优化的电子图形文件。 所创建的文件以 Web 设计格式 (DWF) 存储。 任何人均可以使用 Autodesk DWF Viewer® 或 Autodesk Design Review 打开、查看以及打印 DWF 文件。 使用 Autodesk DWF Viewer 或 Autodesk Design Review，用户还可以在 Microsoft® Internet Explorer 5.01 或更高版本中查看 DWF 文件。 DWF 文件支持实时平移和缩放，以及图层和命名视图的显示。

配置 Adobe PDF 驱动程序

如果在添加绘图仪向导中配置 PDF 驱动程序，用户可以将图形输出为可移植文档格式 (PDF)。 要配置 PDF 驱动程序，请从添加绘图仪向导的“生产商”列表中选择“Autodesk ePlot (PDF)”，然后从“型号”列表中选择“PDF”。

配置 Adobe PostScript 驱动程序

如果在添加绘图仪向导中配置 PostScript 驱动程序，可以使用 PostScript 格式输出图形。 要配置 PostScript 驱动程序，请在“添加绘图仪”向导中，从“制造商”列表中选择“Adobe”，从“型号”列表中选择一个 PostScript 级别。

AutoCAD 支持三个级别的 PostScript。 Level 1 适用于大多数设备，但不支持彩色图像，而且比更新的 PostScript 级别生成的打印文件大。 Level 1 + 在 Level 1 的基础上添加了支持彩色图像的功能。 Level 2 适用于最新的打印机，在 Level 2 设备上，生成的文件更小且输出速度更快。

AutoCAD 支持 PostScript 打印机和绘图仪，并且支持使用 Centronics I/O 并口、RS-232C I/O 串口或者通过网络进行打印。 如果使用串口，请将打印机配置为与“端口”对话框“添加绘图仪”向导的“配置端口”对话框中选择的设置一致。

配置 DXB 文件格式

使用 AutoCAD DXB 非系统文件驱动程序支持 DXB（二进制图形交换）文件格式。

输出与 DXBIN 命令以及随早期版本一起提供的 ADI DXB 驱动程序兼容。 DXB 驱动程序和 ADI 驱动程序均有以下限制：

  • 驱动程序将生成仅包含矢量的 16 位整数 DXB 文件。
  • DXB 输出是单色的；所有矢量均为颜色 7。
  • 不支持光栅图像和嵌入的 OLE 对象。
  • 驱动程序将忽略对象和打印样式线宽。
配置光栅文件格式

AutoCAD 可查看包含光栅图像（例如 TIFF 或 JPEG）的图形。

通过光栅文件格式驱动程序，AutoCAD 还可以“添加绘图仪”向导中列出的格式输出光栅文件。 要配置光栅格式驱动程序，请在“制造商”列表中选择“光栅文件格式”。

请参见

《用户手册》中的以其他格式打印文件


配置文件输出 - 操作步骤

配置文件输出
概念
操作步骤
命令

为 DWF 文件输出配置绘图仪驱动程序的步骤

为 PDF 文件输出配置绘图仪驱动程序的步骤

为 PostScript 文件输出配置绘图仪驱动程序的步骤

为 DXB 文件输出配置绘图仪驱动程序的步骤

为光栅文件输出配置绘图仪驱动程序的步骤

查看自定义特性帮助的步骤


为 DWF 文件输出配置绘图仪驱动程序的步骤 - 操作步骤

配置文件输出
概念
操作步骤
命令

为 DWF 文件输出配置绘图仪驱动程序的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击“添加绘图仪向导”快捷方式图标。
  3. 在“开始”对话框中选择“我的电脑”。 选择“下一步”。
  4. 在“绘图仪型号”对话框的“制造商”下，选择“Autodesk 电子打印 (DWF)”。 在“型号”下选择要创建的 DWF 类型。 选择“下一步”。
  5. 在“输入 PCP 或 PC2”对话框中选择“输入文件”，然后选择一个要输入的 PCP 或 PC2 文件（可选）。 选择“输入”。 然后选择“下一步”。
  6. 在“端口”对话框中，选择“打印到文件”。 选择“下一步”。
  7. 在“绘图仪名称”对话框中，输入绘图仪配置文件的名称。 选择“下一步”。
  8. 在“完成”对话框中选择“完成”。

    9. 新的绘图仪配置文件 (PC3) 创建完毕。

命令输入 PLOTTERMANAGER


为 PDF 文件输出配置绘图仪驱动程序的步骤 - 操作步骤

配置文件输出
概念
操作步骤
命令

为 PDF 文件输出配置绘图仪驱动程序的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击“添加绘图仪向导”快捷方式图标。
  3. 在“开始”对话框中选择“我的电脑”。 选择“下一步”。
  4. 在“绘图仪型号”页面上的“制造商”下，选择“Autodesk ePlot (PDF)”。
  5. 在“输入 PCP 或 PC2”对话框中选择“输入文件”，然后选择一个要输入的 PCP 或 PC2 文件（可选）。 选择“输入”。 然后选择“下一步”。
  6. 在“端口”对话框中，选择“打印到文件”。 选择“下一步”。
  7. 在“绘图仪名称”对话框中，输入绘图仪配置文件的名称。 选择“下一步”。
  8. 在“完成”对话框中选择“完成”。

    9. 新的绘图仪配置文件 (PC3) 创建完毕。

命令输入 PLOTTERMANAGER


为 PostScript 文件输出配置绘图仪驱动程序的步骤 - 操作步骤

配置文件输出
概念
操作步骤
命令

为 PostScript 文件输出配置绘图仪驱动程序的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击“添加绘图仪向导”快捷方式图标。
  3. 在“开始”对话框中选择“我的电脑”。 选择“下一步”。
  4. 在“制造商”下的“绘图仪型号”对话框中选择“Adobe”。 在“型号”下选择要创建的 PostScript 文件级别。 选择“下一步”。
  5. 在“输入 PCP 或 PC2”对话框中选择“输入文件”，然后选择一个要输入的 PCP 或 PC2 文件（可选）。 选择“输入”。 然后选择“下一步”。
  6. 在“端口”对话框中，选择“打印到文件”。 选择“下一步”。
  7. 在“绘图仪名称”对话框中，输入绘图仪配置文件的名称。 选择“下一步”。
  8. 在“完成”对话框中选择“完成”。

    9. 新的绘图仪配置文件 (PC3) 创建完毕。

命令输入 PLOTTERMANAGER


为 DXB 文件输出配置绘图仪驱动程序的步骤 - 操作步骤

配置文件输出
概念
操作步骤
命令

为 DXB 文件输出配置绘图仪驱动程序的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击“添加绘图仪向导”快捷方式图标。
  3. 在“开始”对话框中选择“我的电脑”。 选择“下一步”。
  4. 在“绘图仪型号”对话框的“制造商”下，选择“AutoCAD DXB 文件”。 在“型号”下选择“DXB 文件”。 选择“下一步”。
  5. 在“输入 PCP 或 PC2”对话框中选择“输入文件”，然后选择一个要输入的 PCP 或 PC2 文件（可选）。 选择“输入”。 然后选择“下一步”。
  6. 在“端口”对话框中，选择“打印到文件”。 选择“下一步”。
  7. 在“绘图仪名称”对话框中，输入绘图仪配置文件的名称。 选择“下一步”。
  8. 在“完成”对话框中选择“完成”。

    9. 新的绘图仪配置文件 (PC3) 创建完毕。

命令输入 PLOTTERMANAGER


为光栅文件输出配置绘图仪驱动程序的步骤 - 操作步骤

配置文件输出
概念
操作步骤
命令

为光栅文件输出配置绘图仪驱动程序的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 双击“添加绘图仪向导”快捷方式图标。
  3. 在“开始”对话框中选择“我的电脑”。 选择“下一步”。
  4. 在“绘图仪型号”对话框的“制造商”下选择“光栅文件格式”。 在“型号”下选择要创建的光栅文件类型。 选择“下一步”。
  5. 在“输入 PCP 或 PC2”对话框中选择“输入文件”，然后选择一个要输入的 PCP 或 PC2 文件（可选）。 选择“输入”。 然后选择“下一步”。
  6. 在“端口”对话框中，选择“打印到文件”。 选择“下一步”。
  7. 在“绘图仪名称”对话框中，输入绘图仪配置文件的名称。 选择“下一步”。
  8. 在“完成”对话框中选择“完成”。

    9. 新的绘图仪配置文件 (PC3) 创建完毕。

命令输入 PLOTTERMANAGER


查看自定义特性帮助的步骤 - 操作步骤

配置文件输出
概念
操作步骤
命令

查看自定义特性帮助的步骤

  1. 从“文件”菜单中选择“绘图仪管理器”。
  2. 在“Autodesk 绘图仪管理器”中双击，以打开要查看其自定义特性帮助的 PC3 文件。
  3. 选择“设备和文档设置”选项卡。
  4. 选择“自定义特性”节点。
  5. 选择“自定义特性”。
  6. 在配置设备的“自定义特性”对话框中选择“帮助”。

    7. 帮助提供了特定的配置信息。

命令输入 PLOTTERMANAGER


配置文件输出 - 命令

配置文件输出
概念
操作步骤
命令

命令
PLOTTERMANAGER | 显示“绘图仪管理器”，从中可以添加或编辑绘图仪配置。
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


配置外部数据库 - 概念

配置外部数据库
概念
操作步骤
命令

配置数据库之后，即使系统上未安装创建数据的数据库系统，用户也可以从 AutoCAD 中访问这些数据库中的数据。 AutoCAD 可以从以下应用程序访问数据：

  • Microsoft Access
  • dBase
  • Microsoft Excel
  • Oracle
  • Paradox
  • Microsoft Visual FoxPro®
  • SQL Server

注意 使用 MDAC 2.1 版及更高版本，用户无法编辑 dBase 文件，除非计算机上已安装 Borland 数据库引擎 (BDE)。

成功配置通过 AutoCAD 使用的数据库后，即创建扩了展名为 .udl 的配置文件。 该配置文件包含 AutoCAD 访问配置数据库所需的信息。 默认情况下，.udl 文件存储在 AutoCAD 的 Data Links 文件夹中。 用户可以在“选项”对话框中给 .udl 文件指定其他位置。

以下主题说明如何使用 ODBC 设置数据源以及如何配置数据源，以便通过 AutoCAD 进行使用。 关于 ODBC 和 OLE DB 的详细信息，请参见以下联机 Microsoft 资源：

  • OLE DB 帮助
  • ODBC 帮助
  • ODBC Microsoft 桌面数据库驱动程序
跳过 ODBC，使用 OLE DB 直接驱动程序

AutoCAD 支持的多个数据库管理系统具有可用于 OLE DB 的直接驱动程序。 如果使用这些直接驱动程序，则无需在 ODBC 和 OLE DB 中建立配置文件，而仅需要一个 OLE DB 配置文件。

直接数据库驱动程序可用于以下数据库系统：

  • Microsoft Access
  • Oracle
  • Microsoft SQL Server
使用 ODBC 创建配置文件

ODBC 是一个过渡程序，它使一个应用程序中的数据可用于其他应用程序。

使用 OLE DB 配置数据源

可以使用 OLE DB 建立指向外部数据表的 UDL 配置文件。


配置外部数据库 - 操作步骤

配置外部数据库
概念
操作步骤
命令

给 .UDL 文件指定新位置的步骤

使用 OLE DB 设置直接 Microsoft Access 配置的步骤

使用 OLE DB 设置直接 Oracle 配置的步骤

使用 OLE DB 设置直接 SQL Server 配置的步骤

使用 ODBC 设置 Microsoft Access 数据源的步骤

使用 ODBC 设置 dBase 数据源的步骤

设置要通过 AutoCAD 使用的 Microsoft Excel 电子表格的步骤

使用 ODBC 设置 Microsoft Excel 数据源的步骤

使用 ODBC 设置 Oracle 数据源的步骤

使用 ODBC 设置 Paradox 数据源的步骤

使用 ODBC 设置 Microsoft Visual FoxPro 数据源的步骤

使用 ODBC 设置 SQL Server 数据源的步骤

使用 OLE DB 配置数据源的步骤


给 .UDL 文件指定新位置的步骤 - 操作步骤

配置外部数据库
概念
操作步骤
命令

给 .UDL 文件指定新位置的步骤

  1. 从“工具”菜单中选择“选项”。
  2. 从“文件”选项卡中选择“数据源位置”，然后选择“浏览”。
  3. 在“浏览文件夹”对话框中，定位并选择需要的文件夹，然后选择“确定”。
  4. 选择“确定”。

命令输入 OPTIONS


使用 OLE DB 设置直接 Microsoft Access 配置的步骤 - 操作步骤

配置外部数据库
概念
操作步骤
命令

使用 OLE DB 设置直接 Microsoft Access 配置的步骤

  1. 从“数据库连接”菜单中，依次选择“数据源”»“配置”。
  2. 在“数据链接特性”对话框的“提供者”选项卡中，选择“Microsoft Jet 3.51 OLE DB Provider”。 选择“下一步”。
  3. 在“选择或输入数据库名称”中输入要配置的数据库的名称和路径。
  4. 选择“连接测试”以验证配置是否正确。

    5. 如果连接失败，请验证设置是否正确。 例如，拼写错误和区分大小写都可能导致连接失败。

  5. 在“Microsoft 数据链接”对话框中选择“确定”。
  6. 选择“确定”。

命令输入 DBCONNECT


使用 OLE DB 设置直接 Oracle 配置的步骤 - 操作步骤

配置外部数据库
概念
操作步骤
命令

使用 OLE DB 设置直接 Oracle 配置的步骤

  1. 从“数据库连接”菜单中，依次选择“数据源”»“配置”。
  2. 在“数据链接特性”对话框的“提供者”选项卡中，选择“Microsoft OLE DB Provider for Oracle”。 选择“下一步”。
  3. 在“输入服务器名称”中输入 Oracle 服务器名。
  4. 输入有效的用户名和口令。
  5. 选择“连接测试”以验证设置是否正确。 例如，拼写错误和区分大小写都可能导致连接失败。
  6. 在“Microsoft 数据链接”对话框中选择“确定”。
  7. 选择“确定”。

命令输入 DBCONNECT


使用 OLE DB 设置直接 SQL Server 配置的步骤 - 操作步骤

配置外部数据库
概念
操作步骤
命令

使用 OLE DB 设置直接 SQL Server 配置的步骤

  1. 从“数据库连接”菜单中，依次选择“数据源”»“配置”。
  2. 在“数据链接特性”对话框的“提供者”选项卡中，选择“Microsoft OLE DB Provider for SQL Server”。 选择“下一步”。
  3. 在“选择或输入服务器名称”中输入服务器名。
  4. 输入有效的用户名和口令。
  5. 在“选择服务器上的数据库”中选择要配置的数据库。
  6. 选择“连接测试”以验证设置是否正确。 例如，拼写错误和区分大小写都可能导致连接失败。
  7. 在“Microsoft 数据链接”对话框中选择“确定”。
  8. 选择“确定”。

命令输入 DBCONNECT


使用 ODBC 设置 Microsoft Access 数据源的步骤 - 操作步骤

配置外部数据库
概念
操作步骤
命令

使用 ODBC 设置 Microsoft Access 数据源的步骤

  1. 从“开始”菜单 (Windows) 中，依次选择“设置”»“控制面板”。
  2. 双击“ODBC”图标。
  3. 在“ODBC 数据源管理员”对话框中，执行以下操作之一：
    • 选择“用户 DSN”选项卡，以创建只对用户本人可见的数据源，并且该数据源只能在创建它的计算机上使用。
    • 选择“系统 DSN”选项卡，以创建对所有有权访问该计算机的用户都可见的数据源。
    • 选择“文件 DSN”选项卡，以创建可以与其他用户共享的数据源，但是其他用户必须在其系统上安装相同 ODBC 驱动程序。
  4. 选择“添加”。
  5. 选择“Microsoft Access 驱动程序”，然后选择“完成”。
  6. 在“数据源名称”中输入数据源的名称。
  7. 选择“选择”，然后定位并选择要配置的数据库。 选择“确定”。
  8. 在“ODBC Microsoft Excel”对话框中选择“确定”。
  9. 在“ODBC 数据源管理员”对话框中选择“确定”。


使用 ODBC 设置 dBase 数据源的步骤 - 操作步骤

配置外部数据库
概念
操作步骤
命令

使用 ODBC 设置 dBase 数据源的步骤

  1. 从“开始”菜单 (Windows) 中，依次选择“设置”»“控制面板”。
  2. 双击“ODBC”图标。
  3. 在“ODBC 数据源管理员”对话框中，执行以下操作之一：
    • 选择“用户 DSN”选项卡，以创建只对用户本人可见的数据源，并且该数据源只能在创建它的计算机上使用。
    • 选择“系统 DSN”选项卡，以创建对所有有权访问该计算机的用户都可见的数据源。
    • 选择“文件 DSN”选项卡，以创建可以与其他用户共享的数据源，但是其他用户必须在其系统上安装相同 ODBC 驱动程序。
  4. 选择“添加”。
  5. 选择“Microsoft dBase 驱动程序”，然后选择“完成”。
  6. 在“数据源名称”中输入数据源名称，然后从“版本”列表中选择适当的 dBase 版本。
  7. 确保已清除“使用当前目录”。
  8. 选择“选择目录”，然后定位并选择包含要配置的数据库表的目录。 选择“确定”。
  9. 在“ODBC dBase 设置”对话框中，选择“确定”。
  10. 在“ODBC 数据源管理员”对话框中选择“确定”。


设置要通过 AutoCAD 使用的 Microsoft Excel 电子表格的步骤 - 操作步骤

配置外部数据库
概念
操作步骤
命令

设置要通过 AutoCAD 使用的 Microsoft Excel 电子表格的步骤

  1. 从 Microsoft Excel 中打开要从 AutoCAD 访问的工作簿或电子表格。
  2. 选择单元范围作为数据库表。
  3. 在“名称”框中输入单元范围的名称，然后按 ENTER 键。
  4. 如果需要，重复步骤 2 和 3 以指定附加数据库表。
  5. 从“文件”菜单 (Microsoft Excel) 中选择“保存”。

注意 Microsoft Excel 不是真正的数据库管理系统。 为了从 AutoCAD 访问 Excel 数据，必须先至少指定一个命名的 Excel 单元范围作为数据库表。 AutoCAD 将在电子表格中指定的各个命名的单元范围视为独立的表。


使用 ODBC 设置 Microsoft Excel 数据源的步骤 - 操作步骤

配置外部数据库
概念
操作步骤
命令

使用 ODBC 设置 Microsoft Excel 数据源的步骤

  1. 从“开始”菜单 (Windows) 中，依次选择“设置”»“控制面板”。
  2. 双击“ODBC”图标。
  3. 在“ODBC 数据源管理员”对话框中，执行以下操作之一：
    • 选择“用户 DSN”选项卡，以创建只对用户本人可见的数据源，并且该数据源只能在创建它的计算机上使用。
    • 选择“系统 DSN”选项卡，以创建对所有有权访问该计算机的用户都可见的数据源。
    • 选择“文件 DSN”选项卡，以创建可以与其他用户共享的数据源，但是其他用户必须在其系统上安装相同 ODBC 驱动程序。
  4. 选择“添加”。
  5. 选择“Microsoft Excel 驱动程序”，然后选择“完成”。
  6. 在“数据源名称”中输入数据源名称，然后从“版本”列表中选择适当的 Excel 版本。
  7. 确保已清除“使用当前目录”。
  8. 选择“选择工作簿”，然后定位并选择要配置的工作簿或电子表格。 选择“确定”。
  9. 在“ODBC Microsoft Excel”对话框中，选择“确定”。
  10. 在“ODBC 数据源管理员”对话框中选择“确定”。


使用 ODBC 设置 Oracle 数据源的步骤 - 操作步骤

配置外部数据库
概念
操作步骤
命令

使用 ODBC 设置 Oracle 数据源的步骤

  1. 从“开始”菜单 (Windows) 中，依次选择“设置”»“控制面板”。
  2. 双击“ODBC”图标。
  3. 在“ODBC 数据源管理员”对话框中，执行以下操作之一：
    • 选择“用户 DSN”选项卡，以创建只对用户本人可见的数据源，并且该数据源只能在创建它的计算机上使用。
    • 选择“系统 DSN”选项卡，以创建对所有有权访问该计算机的用户都可见的数据源。
    • 选择“文件 DSN”选项卡，以创建可以与其他用户共享的数据源，但是其他用户必须在其系统上安装相同 ODBC 驱动程序。
  4. 选择“添加”。
  5. 为选择“Microsoft ODBC for Oracle”，然后选择“完成”。
  6. 在“数据源名称”中输入数据源的名称。
  7. 输入用户名。
  8. 在“服务器”中输入 Oracle 服务器名称。
  9. 选择“确定”。
  10. 在“ODBC 数据源管理员”对话框中选择“确定”。


使用 ODBC 设置 Paradox 数据源的步骤 - 操作步骤

配置外部数据库
概念
操作步骤
命令

使用 ODBC 设置 Paradox 数据源的步骤

  1. 从“开始”菜单 (Windows) 中，依次选择“设置”»“控制面板”。
  2. 双击“ODBC”图标。
  3. 在“ODBC 数据源管理员”对话框中，执行以下操作之一：
    • 选择“用户 DSN”选项卡，以创建只对用户本人可见的数据源，并且该数据源只能在创建它的计算机上使用。
    • 选择“系统 DSN”选项卡，以创建对所有有权访问该计算机的用户都可见的数据源。
    • 选择“文件 DSN”选项卡，以创建可以与其他用户共享的数据源，但是其他用户必须在其系统上安装相同 ODBC 驱动程序。
  4. 选择“添加”。
  5. 选择“Paradox 驱动程序”，然后选择“完成”。
  6. 在“数据源名称”中输入数据源名称，然后从“版本”列表中选择适当的 Paradox 版本。
  7. 确保已清除“使用当前目录”。
  8. 选择“选择目录”，然后定位并选择要配置的数据库。 选择“确定”。
  9. 在“ODBC Paradox 设置”对话框中，选择“确定”。
  10. 在“ODBC 数据源管理员”对话框中选择“确定”。


使用 ODBC 设置 Microsoft Visual FoxPro 数据源的步骤 - 操作步骤

配置外部数据库
概念
操作步骤
命令

使用 ODBC 设置 Microsoft Visual FoxPro 数据源的步骤

  1. 从“开始”菜单 (Windows) 中，依次选择“设置”»“控制面板”。
  2. 双击“ODBC”图标。
  3. 在“ODBC 数据源管理员”对话框中，执行以下操作之一：
    • 选择“用户 DSN”选项卡，以创建只对用户本人可见的数据源，并且该数据源只能在创建它的计算机上使用。
    • 选择“系统 DSN”选项卡，以创建对所有有权访问该计算机的用户都可见的数据源。
    • 选择“文件 DSN”选项卡，以创建可以与其他用户共享的数据源，但是其他用户必须在其系统上安装相同 ODBC 驱动程序。
  4. 选择“添加”。
  5. 选择“Microsoft Visual FoxPro 驱动程序”，然后选择“完成”。
  6. 在“数据源名称”中输入数据源名称，然后在“数据库类型”中选择类型。
  7. 选择“浏览”，然后定位并选择要配置的数据库。 选择“打开”。
  8. 在“ODBC Visual FoxPro 安装”对话框中，选择“确定”。
  9. 在“ODBC 数据源管理员”对话框中选择“确定”。

    10. 关于设置 Microsoft Visual FoxPro 数据源的详细信息，请参见 Microsoft Visual FoxPro ODBC 驱动程序文档。


使用 ODBC 设置 SQL Server 数据源的步骤 - 操作步骤

配置外部数据库
概念
操作步骤
命令

使用 ODBC 设置 SQL Server 数据源的步骤

  1. 从“开始”菜单 (Windows) 中，依次选择“设置”»“控制面板”。
  2. 双击“ODBC”图标。
  3. 在“ODBC 数据源管理员”对话框中，执行以下操作之一：
    • 选择“用户 DSN”选项卡，以创建只对用户本人可见的数据源，并且该数据源只能在创建它的计算机上使用。
    • 选择“系统 DSN”选项卡，以创建对所有有权访问该计算机的用户都可见的数据源。
    • 选择“文件 DSN”选项卡，以创建可以与其他用户共享的数据源，但是其他用户必须在其系统上安装相同 ODBC 驱动程序。
  4. 选择“添加”。
  5. 选择“SQL Server”，然后选择“完成”。
  6. 按照向导中的说明完成数据源设置。

    7. Microsoft 提供了其他帮助主题，说明向导中每页的界面元素。 要查看向导对话框的帮助，请选择“帮助”。

  7. 在“ODBC 数据源管理员”对话框中选择“确定”。


使用 OLE DB 配置数据源的步骤 - 操作步骤

配置外部数据库
概念
操作步骤
命令

使用 OLE DB 配置数据源的步骤

可以使用 OLE DB 建立指向外部数据表的 UDL 配置文件。

  1. 使用 Microsoft ODBC 设置数据源（参见使用 ODBC 创建配置文件）。
  2. 从“数据库连接”菜单中，依次选择“数据源”»“配置”。
  3. 在“数据链接特性”对话框的“提供者”选项卡中，选择“Microsoft OLE DB Provider for ODBC Drivers”。 选择“下一步”。
  4. 在“使用数据源名称”中输入要配置的数据源名称。
  5. 选择“连接测试”以验证配置是否正确。

    6. 如果连接失败，请验证设置是否正确。 例如，拼写错误和区分大小写都可能导致连接失败。

  6. 在“Microsoft 数据链接”对话框中选择“确定”。
  7. 选择“确定”。


配置外部数据库 - 命令

配置外部数据库
概念
操作步骤
命令

命令
DBCONNECT | 提供到外部数据库表的接口
OPTIONS | 自定义程序设置
系统变量
没有条目。 |
实用程序
没有条目。 |
命令修饰符
没有条目。 |


评论？

请使用该表格将注释发送至负责该文档的 Autodesk 技术出版组。

主题标题和位置（请勿编辑）：
姓名（可选）：
         电子邮件（可选）：
评论：

注意：该表并不作为用户接收反馈或技术支持的途径。用户提供的信息可使我们将来更好地更新该文档。谢谢！