AutoCAD 2007 自述：简介

AutoCAD 2007 自述

本自述文件包含有关 AutoCAD® 2007 的重要信息，这些信息可能未包含在印刷文档或帮助中。

  • 安装、配置和硬件
  • 图形卡驱动程序更新
  • 绘图和编辑
  • 打印和发布
  • 文字和语言
  • 开发人员信息
  • 命令和系统变量历史记录
  • 其他自述项
  • 商标


安装、配置和硬件

安装和配置

从双 CD/DVD ROM 驱动器系统安装

  • 如果尝试在双 CD/DVD ROM 驱动器系统中的每个驱动器中分别放入安装 CD 来安装 AutoCAD，安装将失败。在请求第二张安装光盘时，安装例行程序将无法识别第二个 CD 驱动器中的光盘。必须在同一个驱动器中用第二张光盘替换第一张光盘，才能完成安装。

从网络驱动器调用 HTML 帮助时失败

  • 由于 Microsoft 的 Windows Security Update #896258 设置了限制，因此从网络驱动器调用帮助系统失败。具体而言，即用于从目录表中启动帮助主题的 ActiveX 控件不再起作用。用户将遇到“无法显示页面”警告。

磁盘映像

  • 如果计算机处在 SATA RAID 环境中，而且许可不稳定，则使用磁盘映像软件分发 Autodesk 产品可能导致产品激活问题。如果尝试在 SATA RAID 环境中激活产品，可能会收到“超出激活码限制”消息。

错误报告

  • 当 AutoCAD 任务意外终止时将显示“错误报告”消息，提醒您将错误报告发送到 Autodesk。错误报告有助于 Autodesk 识别及解决产品的许多问题。“错误报告”消息与运行 Microsoft® Windows® XP 的计算机上的某个应用程序意外终止时显示的消息类似。错误报告记录工作任务终止时正在使用的产品部分。在“错误报告”消息中，单击“可选数据”，输入以下信息，然后单击“发送报告”：
    • 任务意外终止之前用户在 AutoCAD 中所执行操作的信息
    • 用户的联系信息

    提供此信息有助于 Autodesk 再现错误并尽快修复错误。如果 AutoCAD 任务意外终止而未显示“错误报告”消息，请确保 REPORTERROR 系统变量设置为 1。

    Autodesk 不保证您在“客户错误报告”中所报告的全部错误均将得到修正。

64 位操作系统展开

  • 在 XP 64 位系统上创建 AutoCAD 的展开比在 XP 32 位系统上进行同一操作要慢。展开向导可以在 64 位系统上成功创建展开映像，但是此过程占用的时间大约是在 32 位系统上进行此操作所占用时间的 5 倍。

如果已安装 2007 产品，则某些非英文的 2006 产品线安装程序将失败

  • Autodesk 2007 产品线的安装程序将安装 .NET Framework 2.0。安装 2007 产品后，这将阻止安装某些非英文的 Autodesk 2006 产品。重新安装 .NET 1.1 及其相关 Service Pack 以安装基于 2006 的产品。
    1. 将基于 2006 的产品 CD 放入驱动器中。
    2. 浏览到“\Bin\acadFeui\support\dotnetfx\”，然后双击“dotnetfx.exe”安装 .NET 1.1。
    3. 从同一文件夹中，双击“NDP1.1sp1-KB867460-X86.exe”安装 .NET 1.1 Service Pack1。

      安装非英文版的步骤：

    4. 浏览到“\Bin\acadFeui\support\dotnetfx\language\”，然后安装“langpack.exe”。
    5. 安装基于 2006 的产品。

许可

将忽略更新的 PLIST 信息

  • 在分布式许可服务器环境中，将忽略更新的 PLIST 信息。Autodesk 将定期更新网络许可文件中的产品列表 (PLIST) 信息。

    例如，用户现有的许可文件包含 PLIST 信息，此许可文件位于分布式许可服务器环境的第一个服务器上。如果购买了另一个 Autodesk 产品，此产品附带包含更新的 PLIST 信息的许可文件，而该文件位于分布式服务器环境中的另一个服务器上，将识别第一个服务器上的较旧的 PLIST 数据，而非较新的 PLIST 数据。

    为确保读取更新的 PLIST 文件，请从 Autodesk 获取包含最新 PLIST 信息的新许可文件。或者，可以将更新的 PLIST 添加到分布式许可服务器环境中的第一个服务器，以确保始终读取此文件。

硬件

SATA RAID 环境失败

  • 激活并重新启动产品后，将收到错误 0.1.0011 或 11.1.6011，并且需要重新激活。在带有 SATA RAID 控制器的计算机上，基于 Autodesk 2006 和 2007 的产品可能发生此问题。

    有关该问题的产品支持解决方案，请参见 Autodesk 激活更新。

图形卡驱动程序更新

  • 为了获得程序的最佳性能，应验证并更新图形卡驱动程序。详细信息请参见“图形卡驱动程序更新”。

远程访问应用程序

  • 当配置 AutoCAD 以使用硬件加速时，建议不要将任何类型的远程访问应用程序与 AutoCAD 配合使用。大部分远程访问应用程序不支持硬件加速，因此可能导致无法正常显示和不稳定。如果需要使用远程访问应用程序，请禁用硬件加速或使用 /NOHARDWARE 命令行开关在“软件”模式下启动 AutoCAD。

HP DesignJet 打印机驱动程序

  • Autodesk 不再在产品 CD 上为 HP Designjet 系列提供 Windows 系统打印机驱动程序。如果您需要此驱动程序，可以从 http://www.designjet.hp.com 下载。


图形卡驱动程序更新

建议验证并更新图形卡驱动程序以优化 AutoCAD。使用以下操作步骤识别当前的图形卡驱动程序。

识别图形卡驱动程序的步骤

  1. 启动 AutoCAD。
  2. 在命令行上，输入 3dconfig。
  3. 在“自适应降级和性能调节”对话框中，单击“查看调节日志”。
  4. 有关系统的图形卡驱动程序和驱动程序版本的信息，请查看“三维设备”一节。

如果发现确实需要更新驱动程序，请访问图形卡供应商的网站，然后下载并安装图形卡和操作系统的最新驱动程序。

注意：如果图形卡制造商未提供更新的驱动程序，请查阅系统制造商的网站。IBM、Hewlett Packard 和 Dell 这些公司通常提供它们自己的系统驱动程序。


绘图和编辑

《打造新世界》手册

文档中的菜单更改

  • 在《打造新世界》手册中，“绘图”菜单 >“实体”应为“绘图”菜单 >“建模”。

图形环境

DWF 参考底图

  • 建议在锁定的图层上插入 DWF 参考底图文件，以避免不慎编辑了这些文件。如果在 DWF 参考底图文件上进行放大操作并随后使用窗口选择方法，则即使参考底图中的几何图形看起来未被选定，也可能选定了 DWF 参考底图。
  • 重新打开附着 DWF 参考底图的图形时，已卸载 DWF 参考底图的状态将被更改为已加载。这是因为在打开图形时自动重载了 DWF 参考底图文件。
  • 如果 DWF 文件是在启用了“倒置”选项的情况下打印的，则在将它们作为 DWF 参考底图附着时，这些文件不会正确显示。建议避免倒置打印 DWF 文件并且不要附着已倒置打印的 DWF 文件。
  • 在图形中使用 REFEDIT 时，如果使用 PASTECLIP 粘贴 DWF 参考底图，则可能无法存回用户的更改。可能会显示以下消息：
    无法存回更改，因为工作集中的对象参照了工作集以外的对象。参照编辑任务仍然处于激活状态。在关闭对话框后按 F2 键以查看缺失参照的列表。
    在执行 REFEDIT 期间，如果在宿主图形中附着 DWF 参考底图，然后又尝试对外部参照中的同一 DWF 参考底图文件执行 DWFATTACH，也可能会显示此错误消息。建议在使用 REFEDIT 时不要对 DWF 参考底图执行 DWFATTACH 或 PASTECLIP。存回用户的其他 REFEDIT 更改的方法为：删除执行 REFEDIT 期间附着或粘贴的 DWF 参考底图。
  • 在将 DWF 作为参考底图附着时，DWF 参考底图的搜索路径与附着的图形参照（外部参照）或图像文件的搜索路径不同。例如，如果在“\My Documents”文件夹中存在相同名称的 DWF 参考底图，则将使用该参考底图作为当前图形文件，而不使用同一文件夹中的 DWF 参考底图。为了便于数据管理，建议不要在“\My Documents”文件夹中进行存储。

工具选项板

  • 不应在早期版本中使用在当前版本中创建的工具选项板。

同名的自定义文件

  • 加载局部菜单时，AutoCAD 将先搜索支持文件搜索路径（在“选项”对话框的“文件”选项卡中定义）。如果尝试加载与另一个文件同名的自定义 (CUI) 文件，则无论指定哪个文件，程序都将自动加载位于支持文件搜索路径中的文件。为避免混淆，请确保文件名是唯一的。

工作空间

  • 如果选中了“工作空间设置”对话框中的“自动保存工作空间修改”选项 (WSSETTINGS)，则关闭产品时将自动保存当前工作空间。但是，如果在没有打开图形的情况下关闭 AutoCAD，则不会保存工作空间。要确保在关闭时保存工作空间，请在关闭最后一个图形之前使用 WSSAVE 保存工作空间，或者确保在关闭 AutoCAD 时至少有一个图形处于打开状态。

三维环境

AutoCAD 2007 提供了一个新的三维建模环境，用户可以通过 VISUALSTYLES 命令并选择任一非二维样式来访问该环境。三维环境与传统的二维绘图环境相比存在某些行为上的区别，例如：

  • 三维中不支持绘图次序
  • 三维中的内存占用量较大
  • 由于在二维和非二维样式之间循环使用 VISUALSTYLES 可以重置显示，所以 REGEN 和 REGENALL 无需清理杂乱显示内容

光源

块中的光源不照亮模型

  • 如果光源是使用 BLOCK 命令创建的块的一部分，则这些光源不会照亮模型。仅当包含光源的图形曾被插入到另一图形中时，块中的光源才会照亮模型。也可以分解包含光源的块，从而使光源照亮模型。

材质

“材质”选项板中的 REDO 命令

  • REDO 命令不恢复在“材质”选项板中放弃的更改。例如，如果将材质的颜色从红色更改为蓝色，则执行 UNDO 将恢复为原始的红色。而执行 REDO 却不会恢复为蓝色。

过程化材质不通过 CONVERTOLDMATERIALS 进行转换

  • 应用到 AutoCAD 2006 模型中的对象的过程化材质不通过 AutoCAD 2007 中的 CONVERTOLDMATERIALS 命令进行转换。

动画和渲染

动画输出

  • 要将动画输出为 MOV 或 WMV 文件格式，必须安装 Quicktime 或 Media Player 9（或更高版本）。
  • Quicktime Player 无法播放使用非当前操作系统自带的字符保存的 MOV 文件。

动态输入

动态输入和命令窗口

  • 动态输入并非用于替换命令窗口。可以隐藏命令窗口以增加绘图区域，但是在执行某些操作时需要显示该窗口。按 F2 键可根据需要隐藏和显示命令提示和错误消息。也可以浮动命令窗口，并使用“自动隐藏”展开或卷起窗口。

动态输入指南

  • 现在，可以在工具栏提示中（而不是在命令行中）输入坐标值。默认情况下，为大多数命令输入的 (X,Y) 坐标值被解释为相对极坐标，而不是 像产品的早期版本一样解释为绝对坐标。要输入相对坐标，通常无需输入 at 符号 (@)；而只需输入相对偏移值。要指示绝对坐标，请使用磅符号 (#) 前缀。例如，要将对象移到图形原点，请在第二点提示下输入 #0,0。
  • DYNPICOORDS 系统变量用于控制指针输入是使用相对坐标格式还是使用绝对坐标格式。可以使用符号前缀来临时替代这些设置：
    • 要在工具栏提示中显示相对坐标时输入绝对坐标，请输入 #。
    • 要在显示绝对坐标时输入相对坐标，请输入 @。
    • 要输入绝对世界坐标系 (WCS) 坐标，请输入 *（星号）。
  • 当标注输入处于打开状态（DYNMODE = 2 或 3）时，如果输入逗号 (,) 或尖括号 (<)，或者选择多个夹点，则程序将切换为指针输入。
  • 输入标注值并按 TAB 键后，字段将显示锁定图标，并且光标受输入的值的约束。
  • 当光标位于绘图区域以外并且工具栏提示不可见时，如果在“动态输入”工具栏提示中输入值，可能会得到意外的结果。

标注输入和夹点

  • 当标注输入处于打开状态（DYNMODE = 2 或 3）时，使用夹点来拉伸顶点的操作方式已改变。输入单向距离值时的方式与早期版本有所不同，因为所编辑的是线段的总长度或角度值，而不是顶点的位置。要获得最佳结果，请通过将 DYNMODE 设置为 0 或 1、按 F12 或者单击状态栏中的“动态输入”按钮 (DYN)，关闭标注输入。

标注输入 - 夹点编辑和角度

  • 使用夹点拉伸对象时或创建新对象时，标注输入指针将仅显示锐角。即，所有角度都显示为 180 度或小于 180 度。因此，270 度角将显示为 90 度，与“图形单位”对话框中设置的角度方向无关。角度规格根据光标移动的方向来确定正角方向。

循环选择对象

  • 根据动态输入设置的不同，使用 TAB 键循环选择对象将导致不同的行为：
    • 对于标注输入 (DYNMODE=3)：如果选择共享一个公用夹点的多个对象并单击该夹点，TAB 键将循环选择每个选定对象的所有标注。
    • 对于指针输入 (DYNMODE=1)：如果在执行命令时输入值，请使用左尖括号 (<) 或逗号 (,) 来显示其他输入字段，而不要使用 TAB 键。

在动态提示工具栏提示中粘贴值

  • 要使用 PASTECLIP 将值从 Windows 剪贴板粘贴到动态提示工具栏提示中，请在粘贴输入内容之前，先键入某个字母，然后按 Backspace 键删除该字母。否则，输入内容将作为文字粘贴到图形中。

其他绘图问题

透视中的 FLATSHOT

  • 在透视视图中使用 FLATSHOT 命令时，可能无法正确生成结果几何体。

关联标注

  • 要在每次打开图形时默认打开关联标注，请在“Support”目录中的“acad2007doc.lsp”文件中添加下行：

    (setvar "DIMASSOC" 2)

打开用早期版本修改的图形，或者打开带有已修改的外部参照的图形后，请使用 DIMREGEN 来更新标注。 如果要自动更新标注，可以在“Support”目录中的“acad2007doc.lsp”文件中添加下行：

(command "DIMREGEN")

实体图案填充

  • 包含实体图案填充的图形生成的打印文件可能比包含其他类型的图案填充的图形生成的打印文件大。

非矩形视口

  • 为非矩形视口指定非连续线型，可能导致该视口中的模型空间几何图形被不规则剪裁，也可能导致 AutoCAD 变得不稳定。
  • 选定所有对象和视口后，如果在包含非矩形视口、具有三维视觉样式的布局中使用 JPGOUT、PNGOUT、BMPOUT 和 TIFOUT 命令，则其他视口的某些部分可能会被遮挡，并且对象可能不可见。可以使用 PUBLISH 命令创建更加精确的光栅输出。
  • 不要冻结包含非矩形视口的图层，而应将该图层关闭或将该图层的“打印”特性设置为“不打印”。如果冻结包含非矩形视口的图层，视口边界将变为矩形。视口中应由非矩形视口边界剪裁的对象显示为已剪裁，但重生成或打印图形时，对象未剪裁成预期样式。要在此问题出现时予以更正，必须解冻该图层，然后重生成图形。

嵌套外部参照

  • 可以使用相对路径融入嵌套外部参照。相对路径基于外部参照的原始宿主图形的位置，而非当前打开的图形。当报告“未找到”嵌套外部参照时，请编辑其在原始宿主图形中的路径，而非在当前打开的图形中的路径。VISRETAIN 系统变量的设置不再确定 融入嵌套外部参照相对路径的方式。

外部参照

  • 由于外部参照轮询循环，在尝试使用“管理外部参照”图标来重载 DWG 外部参照时可能遇到延迟情况。只有在“管理外部参照”图标上看到气泡式通知之后，才能通过这种方法重载参照 DWG 文件。要加速重载过程，请使用以下方法之一：

    • 在“外部参照”选项板的“文件引用”列表中的参照图形上单击鼠标右键，然后单击“重载”。
    • 从位于“外部参照”选项板顶部的按钮控件选择“重载所有参照”。
    • 在命令提示下输入 -XREF，然后使用“重载”选项。
  • 如果选择在单文档界面模式（SDI 系统变量）中进行操作，“外部参照”选项板将不能用于管理附着到图形的文件参照，而将显示传统对话框版本。如果在 SDI 模式中附着文件参照并随后关闭 SDI 模式以返回标准多文档界面，则直到保存图形或重载参照之后，“外部参照”选项板才能正确显示当前的附着文件。
  • 当“外部参照”选项板处于固定状态时，不能使用鼠标尝试更改 DWG 参照的“类型”设置。当您拖动光标以选择一个新设置时，“类型”下拉菜单将不会保持打开状态。通过使用箭头键从菜单中进行选择，您就可以避开这种情况，也可以浮动“外部参照”选项板，然后使用光标选择新的设置。

项目组织

图纸集

  • 图纸集管理器在以下情况下不能正常运行：
    • 命令处于活动状态。
    • 未打开任何图形。
    • 其他用户已锁定图纸集。
    • “图纸集管理器”中图纸集名称前面显示的锁定图标指明该图纸集已锁定。将光标置于锁定图标上可以查看显示锁定该图纸集的用户的工具栏提示。
  • 在图纸集管理器中选择图纸后，图纸的状态可能会在“详细信息”区域中错误地显示为“不明人员编辑锁定”。要更新图纸的状态，请打开该图纸。
  • 如果从图纸集中删除图纸后又将图纸输入回图纸集，则块属性中显示图纸集信息的字段将显示为磅符号。要更正这些字段，可以重新创建字段，也可以重新插入块。由于图纸集中已经存在该图纸，重新创建字段时，应使用图纸集特性字段，而不要使用占位符字段。
  • 图纸集字段（从图纸集类别中选定的字段）的行为与其他类型字段不同。默认情况下，保存图形或使用 REGEN 时，其他类型的字段会自动更新。而图纸集字段将存储最后使用的值，如果无法访问图纸集字段引用的信息，它们将显示这些存储的值。要更新图纸集字段中的值，请使用 UPDATEFIELD 命令。如果仍然无法访问图纸集字段引用的信息，字段的值将显示为 ####。

在网络上将同一个 DWT 用于页面设置和块

  • 当两个网络用户访问标签和标注块、图纸样板以及页面设置替代都使用同一图形样板文件 (DWT) 的图纸集时，某些图纸集功能不可用。为了避免此问题，请不要使用同一 DWT 文件存储页面设置和块库。


打印和发布

打印和发布图形

图纸和图像方向

  • 某些绘图仪可以用两种不同方式装载同样大小的纸张：横向和纵向。通常滚筒式绘图仪在“图纸尺寸”菜单中将同一图纸尺寸列出两次。例如，ANSI A (8.5" x 11") 和 ANSI A (11" x 8.5")。多数桌面打印机只有一种图纸装载方向，通常为纵向。

    AutoCAD 会自动旋转打印，因此即使图纸以纵向装载到绘图仪，图纸图像在屏幕上仍显示为横向。使用“完整打印预览”查看实际图纸方向。

    “页面设置”和“打印”对话框的“图形方向”区域将显示表明图纸装载到绘图仪时的方向的图像。字母 A 显示打印对象的方向。多数桌面打印机使用纵向图纸方向，通过旋转打印进行横向查看。

    通过单击打印机的“属性”对话框中的图像可以修改 Windows 系统打印机的方向显示。修改此设置将仅影响可打印区域的尺寸，不会改变在“页面设置”和“打印”对话框中设置的打印图像方向。所以在打印图形时，请将“自定义特性”中的“横向”或“纵向”设置与创建图形时的设置保持一致。

不始终打印相交边

  • 将视觉样式设置为除“二维线框”以外的任何样式时，可能不始终打印相交边。方法如下：
    1. 将视觉样式设置为“二维线框”。
    2. 打开 INTERSECTIONDISPLAY。
    3. 设置 INTERSECTIONCOLOR。
    4. 打印“着色视口”选项设置为“隐藏”的图形。

打印大型光栅图像

  • 以下两个新增的系统变量使您在打印包含大型光栅图像附件的图形时，或在大尺寸介质上打印高分辨率的大型渲染/着色视口时，可以更有效地进行控制。
    • RASTERTHRESHOLD
      • 类型：整数
      • 保存位置：注册表
      • 初始值： 20
      • 以兆字节指定一个光栅阈值。如果打印的光栅图像超出了该阈值，将检查系统内存的可用性。如果图像对于可用内存来说太大，将中断打印。
    • RASTERPERCENT
      • 类型：整数
      • 保存位置：注册表
      • 初始值：20
      • 设置可用于打印光栅图像的可用虚拟内存的最大百分比。

发布图形

渐变色对象

  • 渐变色对象在发布到 DWF 文件时可能会移动，也可能消失。如果渐变色分辨率与矢量分辨率的值不同，就会出现此问题。要解决此问题，请编辑 DWF6 ePlot 驱动程序的“自定义特性”，并将“渐变色分辨率”设置为等于“矢量分辨率”。要编辑自定义特性，请在“打印”对话框中依次单击“特性”按钮 >“自定义特性”节点 >“自定义特性”按钮。

DWF 文件

  • 当打印到 DWF 时，将不打印 DWF 参考底图中的光栅图像。
  • 打印包含光栅图像的 DWF 参考底图文件可能产生意外的结果。

网上发布

  • 这种情况下，使用 PUBLISHTOWEB 命令时选择“图形列表”和“列表及概要”样板将无法在 6.5 版的 DWF 查看器中使用。如果使用高于 6.5 版的 DWF 查看器则可以解决此问题。


文字和语言

文字

DXF 文件中的字体替代

  • 保存 DXF 文件时，字体替代信息将自动应用于已应用大字体 SHX 样式的整个多行文字对象。因此，如果修改当前文字样式以指定不同字体，除非重新将样式应用于整个多行文字对象，否则所做的修改不会应用于该多行文字。

语言

多种语言支持

  • 在 AutoCAD 2007，将使用 Unicode 字符来保存图形特性。例如，如果将包含多种语言图形特性的 2007 格式图形保存为 2004 格式图形，则图形特性将转换为当前 Windows 语言的本地字符。如果无法将文字转换为本地字符，则将其保存为 CIF 代码 (\U+nnnn)。
  • 将 2007 格式图形保存为 2004 格式图形时，在 AutoCAD 2007 中创建的所有新符号或词典名称（例如布局名称、文字样式名称、标注样式名称）将以创建符号名称时使用的语言进行保存。
  • 复制和粘贴使用系统语言之外的语言创建的字符时，字符可能无法正确显示。可以使用在位文字编辑器更正此显示。

    更正显示以显示原始语言的步骤
    1. 双击文字，在“在位文字编辑器”中将其打开。
    2. 在编辑器中单击鼠标右键。单击“字符集”，然后选择原始语言。
  • 当图形中包含的某些字符不包括在操作系统上指定的语言中时，如果要查看和编辑这些图形，请确保计算机的操作系统上安装了补充语言支持。可以在 Windows“控制面板”中的“区域和语言选项”对话框中指定语言。（可以查看使用 SHX 字体的文字，而无需指定额外的语言支持。）
  • 使用 SHX 和大字体的亚洲语言的文字样式只能支持相同代码页的字符。例如，使用日语大字体的文字样式不支持德语或朝鲜语字符。（支持英语字符，因为它是每个代码页的一部分。）如果文字样式中使用了不支持大字体的 SHX 字体，则该文字样式可支持多种非亚洲语言。（SHX 字体中必须定义所需的字符。）
  • 要更轻松地在支持不同语言的操作系统中使用多语言多行文字，请使用“在位文字编辑器”中的 TrueType 字体设置。
  • 某些早期版本的 AutoCAD 中不提供多种语言支持。例如，将文件保存为 AutoCAD® 2000 格式时，多语言多行文字的内容可能会损坏。如果打开并保存图形时所使用的操作系统上的系统语言设置与最后一次保存图形时所使用的操作系统不同，就很可能会发生此问题。

文件夹名称或文件名

  • Windows 不区分仅大小写不同的双字节字符文件名。这可能会导致输入问题并有覆盖文件的可能。

    AutoCAD 2006、AutoCAD LT 2006 和早期版本不是 Unicode 应用程序。在与早期非 Unicode 版本共享图形时，请使用 ASCII 字符以确保在保存文件、插入外部参照和指定文件夹路径时的兼容性。

双字节字符问题

工具栏名称

  • 不能创建名称中仅包含单字节数字的新工具栏。工具栏名称中只能使用英语字母字符或双字节文字。

数据源名称

  • 数据源名称中使用的字符代码（例如 0xx??41 和 0xx??61）可能无法正确处理。使用数据库配置中指定的可选名称（日语）创建多个数据源时，会出现此问题。因此，某些数据源名称可能不会列出。出现此问题时，可以将未列出的数据源名称改为其他名称。

子对象和对象循环选择

  • 无法在 Microsoft Windows 的中文（中华人民共和国和台湾地区）版本中使用 CTRL + 空格键组合键和 SHIFT + 空格键组合键来循环选择子对象和对象。使用中文 IME 时，这些组合键具有以下功能：
    • CTRL + 空格键组合键切换中文 IME。
    • SHIFT + 空格键组合键切换双字节和单字节英文字符。

    在 IME 中，可以更改组合加速键。用户可以将 CTRL + 空格键组合键和 SHIFT + 空格键组合键的默认动作更改为与 AutoCAD CTRL + 空格键组合键和 SHIFT + 空格键组合键的行为不冲突的动作。

文字显示

亚洲语言的垂直文字

  • SHX 字体 - 可以使用 SHX 字体和大字体创建垂直显示的文字，创建方式与早期版本中的方式相同。要获得最佳结果，请使用单行 TEXT 命令，而不是 MTEXT。可以在“文字样式”对话框中选择垂直样式。

    TrueType 字体 - 仍选择以 @ 符号开始的字体，但现在文字将自动旋转 270 度。（在早期版本中，必须手动旋转文字。）现在，垂直文字支持光标垂直移动。

字体显示

  • 如果默认字体不支持您用在位文字编辑器（MTEXT 命令）输入的字符，通常会使用替换字体。
  • 使用在位文字编辑器（MTEXT 命令）或 DTEXT 命令输入的 CIF 或 MIF 代码现在会自动转换以显示实际的字符。

命令输入

AltGR 和键的组合

  • AltGR + 任意键的组合键将导致命令输入的终止。这是由用于隐含面拉伸的 Ctrl+Alt 组合键引起的。如果使用 AltGR 键盘布局，则解决方法为：将 IMPLIEDFACE 设置为 0（零）。

产品附带的亚洲语言大字体

产品附带以下大字体：

  • @extfont2.shx - 与 SHX 字体一起使用以获得垂直写入的日语字体（一些字符将旋转以在垂直文字中正常显示）
  • bigfont.shx - 日语字体
  • chineset.shx - 繁体中文字体
  • extfont.shx - 日语字体
  • extfont2.shx - 日语字体
  • gbcbig.shx - 简体中文字体
  • whgdtxt.shx - 朝鲜语字体
  • whgtxt.shx - 朝鲜语字体
  • whtgtxt.shx - 朝鲜语字体
  • whtmtxt.shx - 朝鲜语字体

更新的“bigfont.ini”

  • AutoCAD 2007 处理自定义 SHX 大字体的方式与 AutoCAD 2006 及更早版本不同。如果图形文件中使用了自定义 SHX 大字体，则需要将 SHX 大字体名称及其代码页 ID 添加到“Support”文件夹中的“bigfont.ini”文件中。要了解如何进行添加，请参阅“bigfont.ini”文件的标题部分。


开发人员信息

可能影响脚本的更改

对以下命令或系统变量的修改可能会影响已存在的脚本：

  • ADCNAVIGATE - 如果使用 ADCNAVIGATE 打开设计中心，则不必再按 ENTER 键或 ESC 键显示“输入路径名”提示。
  • EXTEND - 对于 EXTEND 命令，如果在“选择要延伸的对象”提示下不选择对象，那么现在程序将提示您指定窗交窗口的对角点。此修改可能会影响已存在的用于调用 EXTEND 并提供未选择对象的拾取点的脚本。通过忽略未选择对象的点可以修复传统脚本。
  • -INSERT - 如果您使用“块定义”对话框中新的“按统一比例缩放”选项，则在使用 -INSERT 命令插入块时，不再提示您为 X,Y,Z 坐标分别输入比例因子。
  • MENULOAD - 默认情况下，MENULOAD 命令仅加载 AutoCAD 2006 或更高版本中的 CUI 文件。要加载 AutoCAD 2006 或更高版本中的 MNU 或 MNS 文件，必须将扩展名明确地包含在文件名中，如下例所示：

    (command "menuload" "myMenu.mnu")

    但是，强烈建议您不要更改代码，而是在运行使用传统菜单文件的应用程序之前，在 AutoCAD 2007 中打开这些菜单文件。AutoCAD 会自动将它们转换为 CUI 文件，并且 CUI 文件将通过使用不带扩展名的文件名的现有代码进行加载。

    应更改指定 MNU、MNS 或 MNC 扩展名的传统代码，以使其参照 CUI 文件，而且基于 AutoCAD 2007 的应用程序应附带 CUI 文件，而不是 MNU、MNS 或 MNC 文件。

  • TRIM - 对于 TRIM 命令，如果在“选择要修剪的对象”提示下不选择对象，那么现在程序将提示您指定窗交窗口的对角点。此修改可能会影响已存在的用于调用 TRIM 并提供未选择对象的拾取点的脚本。通过忽略未选择对象的点可以修复传统脚本。

Visual LISP

AutoCAD 进程的可见性

  • 启动时运行的 AutoLISP® 脚本应检查 AutoCAD 进程是否可见。如果进程不可见，则不应执行脚本，因为该进程可能在执行后台打印或后台发布操作。要检查 AutoCAD 进程是否可见，可以使用 AutoCAD 对象模型中 Application 对象的 Visible 特性。

通知

  • 在某些情况下，一个系统变量的更改会触发多次 vlr-sysVarWillChange 和 vlr-sysVarChanged 通知。

夹点

  • AutoCAD 不再支持未选定对象上的夹点。因此，AutoLISP sssetfirst 函数的 gripset 参数将被忽略，ssgetfirst 将为第一个返回的选择集返回 nil。

真彩色

  • 如果完全安装了 AutoCAD，则使用“真彩色”的实用程序位于 \Sample\VisualLISP 文件夹中的 color-util.lsp 文件中。这些实用程序用于与真彩色相关的操作，例如获取真彩色编号的部件，将颜色索引或颜色名转换为真彩色值，返回 DXF 组码列表，以及使用图元列表。

    使用以下 AutoLISP 函数可以访问“真彩色”用户界面：

    (acad_truecolordlg color [allowbylayer] [currentlayercolor])。
    通过对话框提示输入颜色。颜色参数是一个说明默认颜色的点对；点对的第一个元素必须是颜色相关 DXF 组码（62、420 或 430）之一。如果 allowbylayer 参数存在且不为 nil，则显示“随层”和“随块”按钮。如果操作成功，该函数返回说明选定颜色的一个或多个点对的列表。列表中最后一个点对指示选定的颜色。如果用户取消对话框，则该函数返回 nil。

    (acad_truecolorcli color [allowbylayer] [alternatePrompt])。
    在命令行提示输入颜色。前两个参数与 acad_truecolordlg 相同，第三个参数是一个可选提示字符串。如果省略此字符串，则默认值为“新颜色”。

entmod 和 entmake 函数

  • 在 AutoCAD 2004 以及更高版本中，entmod 和 entmake 函数在颜色操作方面中具有新的行为。DXF 组码 62 保留 AutoCAD 颜色索引 (ACI) 值，而组码 420 保留真彩色值。如果真彩色值与 ACI 值冲突，AutoCAD 将使用 420 值，因此在试图使用组码 62 值之前应删除组码 420 值。有关详细信息，请完整安装 AutoCAD 并参见 \Sample\VisualLISP 文件夹中的 color-util.lsp 文件。

加载错误

  • 如果 LOAD 加载独立名称空间 VLX 时出现错误，某些函数可能在检测到错误之前已输出到当前的文档名称空间中。必须确保修复此错误、重新编译并重载 VLX，才能确保所有函数的正确版本输出到当前文档。
  • 使用 CUILOAD 命令在 MDI 中加载部分菜单时，该菜单的 MNL 文件将为每个打开的文档加载一次，同时所有用户交互操作都发生在当前文档中。为避免在用 AutoCAD 打开多个图形时出现多余的打印信息或用户提示，建议在设置 MNL LISP 代码时不要包含任何用户交互操作。而使用 MNL 代码为后续菜单项选择加载任何所需的 AutoLISP 文件。使用 acad.lsp 或 acaddoc.lsp 文件执行打开图形时要处理的 AutoLISP 代码。

“多文档设计环境”对话框的显示

  • “多文档设计环境”对话框使用户可以更改 AutoLISP 环境初始化的默认功能。此对话框在以下情况下显示：
    • AcadLspAsDocDlg 注册键的“Do Not Show”值设置为 0。
    • 未运行任何脚本，并且未运行 AutoLISP 或 ActiveX 应用程序。
    • ACADLSPASDOC 系统变量设置为 0。
    • AutoCAD 搜索路径中存在 acad.lsp 文件。
    • AutoCAD 搜索路径中不存在 acaddoc.lsp 文件。
    • SDI 系统变量设置为 0。
    如果所有这些条件都为真，则在每个任务中首次打开第二个文档时，将显示“多文档设计环境”对话框。

ActiveX 和 VBA

AutoCAD 进程的可见性

  • 启动时运行的 VBA 脚本应检查 AutoCAD 进程是否可见。如果进程不可见，则不应执行脚本，因为该进程可能在执行后台打印或后台发布操作。要检查 AutoCAD 进程是否可见，可以使用 AutoCAD 对象模型中 Application 对象的 Visible 特性。

COM 扩展接口变更

以下 COM 扩展接口已被合并到下面指明的主接口中：
旧接口 | 合并到
IAcadAttribute2 | IAcadAttribute
IAcadAttributeReference2 | IAcadAttributeReference
IAcadBlock2、IAcadBlock3 | IAcadBlock
IAcadBlockReference2 | IAcadBlockReference
IAcadExternalReference2 | IAcadExternalReference
IAcadHatch2 | IAcadHatch
IAcadLayer2 | IAcadLayer
IAcadLayers2 | IAcadLayers
IAcadMInsertBlock2 | IAcadMInsertBlock
IAcadMLine2 | IAcadMLine
IAcadModelSpace2、IAcadModelSpace3 | IAcadModelSpace
IAcadMText2 | IAcadMText
IAcadPaperSpace2、IAcadPaperSpace3 | IAcadPaperSpace
IAcadPreferencesFiles2 | IAcadPreferencesFiles
IAcadPreferencesOutput2 | IAcadPreferencesOutput
IAcadPViewport2 | IAcadPViewport
IAcadTable2 | IAcadTable
IAcadText2 | IAcadText
IAcadUtility2 | IAcadUtility
IAcadView2 | IAcadView

此更改将仅影响直接使用 COM 接口的代码。此更改应对相应 VBA 自动化类的客户端透明。


命令和系统变量历史记录

了解 AutoCAD 的途径

以下资源有助于用户了解有关本产品及其新功能的详细信息：

  • 新功能专题研习（“帮助”菜单）
  • 帮助系统（“帮助”菜单）
  • 开发人员帮助（“帮助”菜单 >“其他资源”）
  • Autodesk 国际用户组 (AUGI)（“帮助”菜单 >“其他资源”）
  • Autodesk 网站 http://www.autodesk.com.cn

命令

新命令

命令 | 说明
3DALIGN | 在二维和三维中将对象与其他对象对齐。
-3DCONFIG | 为三维图形系统的配置设置提供命令行界面。
3DDWF | 显示“输出三维 DWF”对话框。
3DFLY | 激活穿越飞行模式，使用户可以在任何方向上（可以离开 XY 平面）导航。
3DFORBIT | 使用不受约束的动态观察控制三维中对象的交互式观察。
3DMOVE | 在三维视图中显示移动夹点工具，并在指定的方向上将对象移动指定的距离。
3DROTATE | 在三维视图中显示旋转夹点工具，并绕基点旋转对象。
3DWALK | 交互式更改三维图形的视图，从而使用户就像在模型中穿越漫游一样。
ANIPATH | 保存在三维模型中沿路径形成的动画。
BREP | 从三维实体图元和复合实体中删除历史记录。
CHSPACE | 将对象从模型空间移动到图纸空间，或按相反方向移动。（集成的 Express Tool）
CONVERTOLDLIGHTS | 将在早期版本中创建的光源转换为 AutoCAD 2007 格式的光源。
CONVERTOLDMATERIALS | 将在早期版本中创建的材质转换为 AutoCAD 2007 格式的材质。
CONVTOSOLID | 将具有厚度的多段线和圆转换为三维实体。
CONVTOSURFACE | 将对象转换为曲面。
COPYTOLAYER | 将一个或多个对象复制到另一个图层。（集成的 Express Tool）
-COPYTOLAYER | 将一个或多个对象复制到另一个图层。（命令行版本）
DASHBOARD | 打开“面板”窗口。
DASHBOARDCLOSE | 关闭“面板”窗口。
DISTANTLIGHT | 创建平行光。
DWFADJUST | 可以通过命令行对 DWF 参考底图进行调整。
DWFATTACH | 将 DWF 参考底图附着到当前图形。
DWFCLIP | 使用剪裁边界定义 DWF 参考底图的子面域。
-EXPORTTOAUTOCAD | 创建分解了所有 AEC 对象的新 DWG 文件。（命令行）AECTOACAD 是该命令的别名。
EXTERNALREFERENCES | 显示“外部参照”选项板。
EXTERNALREFERENCESCLOSE | 关闭“外部参照”选项板。
FLATSHOT | 创建当前视图中所有三维对象的二维表示法。
GEOGRAPHICLOCATION | 指定一个位置的纬度和经度。
HELIX | 创建二维或三维螺旋。
IMPRINT | 在三维实体上压印一条边。
-INTERFERE | 亮显重叠的三维实体。（命令行版本）
JOGSECTION | 向截面对象中添加折弯的段。
LAYCUR | 将选定对象所在的图层更改为当前图层。（集成的 Express Tool）
LAYDEL | 删除选定对象所在的图层以及该图层上的所有对象，然后将该图层从图形中清理掉。（集成的 Express Tool）
-LAYDEL | 删除选定对象所在的图层以及该图层上的所有对象，然后将该图层从图形中清理掉。(（命令行版本）
LAYFRZ | 冻结选定对象所在的图层。（集成的 Express Tool）
LAYISO | 隔离选定对象所在的图层，从而关闭其他所有图层。（集成的 Express Tool）
LAYLCK | 锁定选定对象所在的图层。（集成的 Express Tool）
LAYMCH | 更改选定对象所在的图层，以使其匹配目标图层。（集成的 Express Tool）
-LAYMCH | 更改选定对象所在的图层，以使其匹配目标图层。（命令行版本）
LAYMCUR | 使选定对象所在的图层成为当前图层。（已重命名的 AI_MOLC）
LAYMRG | 将选定的图层合并到目标图层。（集成的 Express Tool）
-LAYMRG | 将选定的图层合并到目标图层。（命令行版本）
LAYOFF | 关闭选定对象所在的图层。（集成的 Express Tool）
LAYON | 打开所有图层。（集成的 Express Tool）
LAYTHW | 解冻所有图层。（集成的 Express Tool）
LAYULK | 解除选定对象所在图层的锁定。（集成的 Express Tool）
LAYUNISO | 打开最后使用 LAYISO 命令关闭的图层。（集成的 Express Tool）
LAYVPI | 将对象所在的图层隔离到当前视口。（集成的 Express Tool）
LAYWALK | 动态显示图形中的图层。（集成的 Express Tool）
LIGHTLIST | 打开“模型中的光源”窗口以添加和修改光源。
LIGHTLISTCLOSE | 关闭“模型中的光源”窗口。
LIVESECTION | 为选定截面对象打开活动截面。
LOFT | 通过在一组曲线（两条或更多）上放样来创建三维实体或曲面。
MATERIALATTACH | 将材质随层附着到对象。
MATERIALMAP | 显示材质贴图器夹点工具以调整面或对象上的贴图。
MATERIALS | 管理、应用和修改材质。
MATERIALSCLOSE | 关闭“材质”窗口。
PLANESURF | 创建平面曲面。
POINTLIGHT | 创建点光源。
POLYSOLID | 创建三维多段体。
PRESSPULL | 按住或拖动有限区域。
PYRAMID | 创建三维实心棱锥面。
RENDERCROP | 选择图像中用于渲染的特定面域（修剪窗口）。
RENDERENVIRONMENT | 提供对象的能见距离的视觉提示。
RENDERPRESETS | 指定用于渲染图像的渲染预设，即可重复使用的渲染参数。
RENDERWIN | 显示“渲染窗口”而无需调用渲染任务。
RPREFCLOSE | 如果已显示“高级渲染设置”选项板，则将其关闭。
SECTIONPLANE | 创建充当穿过三维对象的剪切平面的截面对象。
SPOTLIGHT | 创建聚光灯。
SUNPROPERTIES | 打开“阳光”选项板，然后设置阳光的特性。
SUNPROPERTIESCLOSE | 关闭“阳光特性”窗口。
SWEEP | 通过沿路径扫掠二维曲线来创建三维实体或曲面。
THICKEN | 通过加厚曲面来创建三维实体。
VISUALSTYLES | 创建和修改视觉样式，并将视觉样式应用于视口。
-VISUALSTYLES | 创建和修改视觉样式，并将视觉样式应用于视口。（命令行版本）
VISUALSTYLESCLOSE | 关闭视觉样式管理器。
VSCURRENT | 设置当前视口中的视觉样式。
VSSAVE | 保存视觉样式。
WALKFLYSETTINGS | 指定漫游和飞行设置。
XEDGES | 通过从三维实体或曲面提取边来创建线框几何图形。

修改的命令

命令 | 说明
3DCONFIG | 提供三维图形系统配置设置。
3DORBIT | 控制三维中对象的交互式观察。
3DPAN | 启动交互式三维视图，使用户可以在透视视图中水平和垂直拖动视图。
3DSWIVEL | 更改拖动方向上的视图目标。
3DZOOM | 在透视视图中进行缩放。
ALIGN | 在二维和三维中将对象与其他对象对齐。
BOX | 创建三维实心长方体。
CAMERA | 设置用于创建和保存对象的三维透视视图的相机和目标位置。
CHANGE | 更改现有对象的特性。
CHPROP | 更改对象的特性。
CONE | 创建一个三维实体，其底面为圆形或椭圆形，且对称地向一点或一个圆形或椭圆形平整面倾斜。
CUI | 管理自定义用户界面元素，例如工作空间、工具栏、菜单、快捷菜单和键盘快捷键。
CYLINDER | 创建一个三面三维实体，其底面和顶面均为圆形或椭圆形。
DSETTINGS | 设置栅格和捕捉、极轴追踪和对象捕捉、对象捕捉模式和动态输入。
DVIEW | 通过使用相机和目标来定义平行投影或透视视图。
ETRANSMIT | 将一组文件打包以进行 Internet 传递。
-ETRANSMIT | 将一组文件打包以进行 Internet 传递。（命令行版本）
EXPLODE | 将复合对象分解为该对象的部件对象。
EXTRUDE | 通过沿指定方向将对象或平整面拉伸指定距离来创建三维实体或曲面。
FIELD | 创建一个多行文字对象，它具有一个可以在字段值变化时自动更新的字段。
GRID | 在当前视口中显示不打印的栅格。
HIDE | 重生成不显示隐藏线的三维线框模型。
HLSETTINGS | 更改二维线框中线条的显示特性。
IMAGE | 启动 EXTERNALREFERENCES 命令以便能够进行图像管理。
-IMAGE | 可以通过命令行访问图像选项。
IMAGEADJUST | 控制图像显示，包括图像的亮度、对比度和褪色度值。
-IMAGEADJUST | 控制图像显示，包括图像的亮度、对比度和褪色度值。（命令行版本）
IMAGEATTACH | 将新图像附着到当前图形。
IMAGECLIP | 使用剪裁边界定义图像对象的子面域。
IMAGEQUALITY | 控制图像的显示质量。
INTERFERE | 亮显重叠的三维实体。
JOIN | 合并对象以形成单个完整对象。
LIGHT | 创建光源。
LIST | 显示选定对象的数据库信息。
MATCHPROP | 将选定对象的特性应用于其他对象。
MVIEW | 创建和控制布局视口。
OPTIONS | 自定义程序设置。
PAGESETUP | 控制每个新布局的页面布局、打印设备、图纸尺寸和其他设置。
PLOT | 将图形打印到绘图仪、打印机或文件。
PUBLISH | 将图形发布到 DWF 文件或绘图仪。
PURGE | 删除图形中未使用的命名项，例如块定义和图层。
-PURGE | 删除图形中未使用的命名项，例如块定义和图层。（命令行版本）
QSELECT | 根据过滤条件创建选择集。
RECTANG | 绘制矩形多段线。
REFCLOSE | 存回或放弃于在位编辑参照（外部参照或块）期间所做的更改。
REFEDIT | 选择要进行编辑的外部参照或块参照。
RENDER | 创建三维线框或实体模型的真实照片级图像或真实感着色图像。
REVOLVE | 通过绕轴旋转二维对象来创建三维实体或曲面。
RPREF | 显示“高级渲染设置”选项板以访问高级渲染设置。
SAVEIMG | 将已渲染的图像保存到文件。
SELECT | 将选定对象置于“上一个”选择集内。
SHADEMODE | 启动 VSCURRENT 命令。
SHEETSET | 打开图纸集管理器。
SLICE | 使用平面或曲面剖切实体。
SNAP | 限制光标在指定的间隔内移动。
SOLIDEDIT | 编辑三维实体对象的面和边。
SPHERE | 创建三维实心球体。
TORUS | 创建三维圆环形实体。
UCS | 管理用户坐标系。
VIEW | 保存和恢复命名视图、相机视图、布局视图和预设视图。
-VPORTS | 在模型空间或图纸空间中创建多个视口。（命令行版本）
WBLOCK | 将对象或块写入新图形文件。
-WBLOCK | 将对象或块写入新图形文件。（命令行版本）
WEDGE | 创建一个五面三维实体，它的一个斜面沿 X 轴倾斜。
XREF | 启动 EXTERNALREFERENCES 命令。

已删除或已废弃的命令

命令 | 说明
3DDWFPUBLISH | 创建三维模型的三维 DWF 文件。（已由 3DDWF 取代）
3DSOUT | 输出到 3D Studio (3DS) 文件。（无取代命令）
BACKGROUND | 设置场景的背景。（已与 VIEW 合并）
FOG | 提供对象的能见距离的视觉提示。（已由 RENDERENVIRONMENT 取代）
LSEDIT | 编辑配景对象。（无取代命令）
LSLIB | 维护配景对象库。（无取代命令）
LSNEW | 向图形中添加真实配景项目，例如树木和灌木。（无取代命令）
MATLIB | 向材质库中输入材质或从中输出材质。（已由 MATERIALS 取代）
RENDSCR | 除保持脚本的完整性外没有任何影响。（无取代命令）
REPLAY | 显示 BMP、TGA 或 TIFF 图像。（无取代命令）
RMAT | 管理渲染材质。（已由 MATERIALS 取代）
SCENE | 管理模型空间中的场景。（无取代命令）
SETUV | 将材质贴图到对象上。（已由 MATERIALMAP 取代）
SHOWMAT | 列出选定对象的材质类型和附着方法。（已由 LIST 取代）
STATS | 显示渲染统计信息。（已与 RENDERWIN 合并）

系统变量

新的系统变量

系统变量 | 说明
3DDWFPREC | 控制三维 DWF 发布的精度。
CAMERADISPLAY | 控制是否在当前图形中显示相机对象。
CAMERAHEIGHT | 存储新建相机对象的默认高度。
CLEANSCREENSTATE | 存储一个值，指明清除屏幕状态是否处于打开状态。（只读）
CMATERIAL | 设置新对象的材质。
CSHADOW | 设置三维对象的阴影显示特性。
DASHBOARDSTATE | 确定“面板”窗口是否处于活动状态。
DEFAULTLIGHTING | 打开和关闭默认光源。
DEFAULTLIGHTINGTYPE | 指定默认光源的类型。
DIMARCSYM | 控制弧长标注中圆弧符号的显示。
DIMFXL | 设置始于尺寸线截止于标注原点的尺寸界线的总长度。
DIMFXLON | 控制是否将尺寸界线设置为固定长度。
DIMJOGANG | 确定折弯半径标注中尺寸线的横向段角度。
DIMLTEX1 | 设置第一条尺寸界线的线型。
DIMLTEX2 | 设置第二条尺寸界线的线型。
DIMLTYPE | 设置尺寸线的线型。
DIMTFILL | 控制标注文字的背景。
DIMTFILLCLR | 设置标注中文字背景的颜色。
DRAGVS | 设置创建三维对象时的视觉样式。
DWFFRAME | 确定 DWF 边框是否可见以及是否打印该边框。
DWFOSNAP | 确定是否已为附着到 DWG 的 DWF 启用了对象捕捉。
ERSTATE | 确定“外部参照”窗口处于不活动、活动/可见还是活动/自动隐藏状态。
GRIDDISPLAY | 控制栅格的显示行为和显示限制。
GRIDMAJOR | 控制主栅格线相对辅栅格线的显示频率。
GRIDUNIT | 为当前视口指定 X 和 Y 栅格间距。
GTAUTO | 控制在三维空间中选择对象时夹点工具是否自动显示。
GTDEFAULT | 控制在三维视图中（分别）启动 MOVE、ROTATE 和 SCALE 命令时，是否自动启动 3DMOVE、3DROTATE 和 3DSCALE 命令。
GTLOCATION | 为夹点工具设置默认位置。
IMPLIEDFACE | 控制隐含面的检测。
INTERFERECOLOR | 设置干涉对象的颜色。
INTERFEREOBJVS | 为干涉对象设置视觉样式。
INTERFEREVPVS | 设置在使用 INTERFERENCE 命令时当前视口的视觉样式。
LATITUDE | 指定图形模型的纬度。
LEGACYCTRLPICK | 为选择循环指定按键，并为 CTRL 键 + 单击鼠标左键指定行为。
LIGHTGLYPHDISPLAY | 控制是否显示光线轮廓。
LIGHTLISTSTATE | 指明“模型中的光源”窗口处于打开还是关闭状态。
LOFTANG1 | 设置放样操作中穿过第一个横截面的拔模斜度。
LOFTANG2 | 设置放样操作中穿过最后一个横截面的拔模斜度。
LOFTMAG1 | 设置放样操作中穿过第一个横截面的拔模斜度的幅值。
LOFTMAG2 | 设置放样操作中穿过最后一个横截面的拔模斜度的幅值。
LOFTNORMALS | 控制放样对象在其穿过横截面处的法线。
LOFTPARAM | 控制放样实体和曲面的形状。
LONGITUDE | 指定图形模型的经度。
MATSTATE | 指明“材质”窗口处于打开还是关闭状态。
NORTHDIRECTION | 指定阳光与北方相差的角度。
OSOPTIONS | 自动抑制在图案填充对象上进行对象捕捉，并在使用动态 UCS 时自动抑制对象捕捉。
PERSPECTIVE | 指定当前视口是否显示透视工作视图。
PSOLHEIGHT | 为使用 POLYSOLID 命令创建的扫掠实体对象设置默认高度。
PSOLWIDTH | 为使用 POLYSOLID 命令创建的扫掠实体对象设置默认宽度。
PUBLISHALLSHEETS | 控制“发布”对话框列表的填充方式。
RENDERPREFSSTATE | 存储一个值，指明“高级渲染设置”选项板是否处于打开状态。
SHADOWPLANELOCATION | 控制用于显示阴影的不可见地平面的位置。
SHOWHIST | 控制图形中实体的显示历史记录特性。
SOLIDHIST | 控制新对象和现有对象的默认历史记录特性设置。
STEPSIZE | 以当前单位指定用户处于漫游模式时的步长。
STEPSPERSEC | 指定当用户处于漫游模式时每秒前进的步数。
SUNPROPERTIESSTATE | 指明“阳光特性”窗口处于打开还是关闭状态。
SUNSTATUS | 控制阳光是否要在视口中投射光线。
TIMEZONE | 为阳光设置设置时区。
UCSDETECT | 控制动态 UCS 获取是否处于活动状态。
VSBACKGROUNDS | 控制是否在当前视口中显示背景。
VSCURRENT | 存储应用于当前视口的视觉样式的名称。
VSEDGECOLOR | 设置边的颜色。
VSEDGEJITTER | 控制使线条看起来就像是使用铅笔勾画的程度。
VSEDGEOVERHANG | 使直线延伸到交点之外，以达到手绘效果。
VSEDGES | 控制显示在视口中的边的类型。
VSEDGESMOOTH | 指定折缝边的显示角度。
VSFACECOLORMODE | 控制面颜色的计算方式。
VSFACESTYLE | 控制当前视口中面的显示方式。
VISUALSTYLES | 显示“视觉样式管理器”选项板，使用户可以创建和修改视觉样式，或将视觉样式应用于视口。
VSHALOGAP | 设置应用于当前视口的视觉样式中的光晕间隔。
VSHIDEPRECISION | 控制应用于当前视口的视觉样式中隐藏和着色的精度。
VSINTERSECTIONCOLOR/P> | 指定应用于当前视口的视觉样式中相交多段线的颜色。
VSINTERSECTIONEDGES | 指定应用于当前视口的视觉样式中相交边的显示。
VSINTERSECTIONLTYPE | 控制是否在当前视口中显示遮挡线并设置其线型。
VSLIGHTINGQUALITY | 设置当前视口中的光源质量。
VSMATERIALMODE | 控制当前视口中材质的显示。
VSMONOCOLOR | 设置面的单色显示的颜色。
VSOBSCUREDCOLOR | 指定应用于当前视口的视觉样式中遮挡线的颜色。
VSOBSCUREDEDGES | 控制是否显示遮挡（隐藏）边。
VSOBSCUREDLTYPE | 指定应用于当前视口的视觉样式中遮挡线的线型。
VSOPACITY | 控制当前视口中面的透明度。
VSSHADOWS | 控制视觉样式是否显示阴影。
VSSILHEDGES | 控制应用于当前视口的视觉样式中实体对象的轮廓曲线的显示。
VSSILHEDGEWIDTH | 以像素为单位指定当前视口中轮廓边的显示宽度。
VSSPECULAR | 控制当前视口中未应用材质的面上镜面亮显的显示。
VSSTATE | 存储一个值，指明“视觉样式”窗口是否处于打开状态。
ZOOMWHEEL | 使用户可以切换鼠标滚轮缩放操作的行为。

修改的系统变量

系统变量 | 说明
AUTOSNAP | 控制自动捕捉标记、工具栏提示和磁吸的显示。
BACKZ | 以绘图单位存储始于当前视口目标平面的后向剪裁平面偏移量。
DBLCLKEDIT | 控制双击行为。
DELOBJ | 控制从图形数据库中保留还是删除用于创建其他对象的对象。
DISPSILH | 控制线框模式下实体对象的轮廓曲线的显示。
FRONTZ | 存储始于当前视口目标平面的前向剪裁平面偏移量。
LENSLENGTH | 存储焦距。（只读）
PICKADD | 控制后续选择替换还是添加到当前选择集。
POLARMODE | 控制极轴追踪和对象捕捉的设置。
PROJECTNAME | 为当前图形指定工程名称。
SURFU | 设置 PEDIT 命令“平滑”选项在 M 方向上的曲面密度。
SURFV | 设置 PEDIT 命令“平滑”选项在 N 方向上的曲面密度。
TRACKPATH | 控制极轴追踪和对象捕捉追踪对齐路径的显示。

已删除或已废弃的系统变量

  • 无


其他自述项

大字体

如果未选定大字体，文字将不能正确显示。

选择大字体的方法：

  1. 打开图纸
  2. 使用“_tablestyle”命令查看当前表格样式中使用的字体。
  3. 选择当前表格样式，然后单击“修改...”。
  4. 使用左侧的选项卡，可以查看关联的字体。
  5. 使用“_style”命令更新字体。

字体

要在绘图区域中正确查看双字节字符，必须通过在“样式”对话框中选择字体来设置内部字体。要访问“样式”对话框，请在命令行上输入 style。

帮助系统的“咨询”选项卡

AutoCAD® 2006 的韩文版、简体中文版和繁体中文版不提供帮助系统的“咨询”选项卡。

安装了 AutoCAD 2006 之后，AnswerWorks 4.0 将安装到“C:\Program files\AnswerWorks 4.0”下。但韩文版、简体中文版和繁体中文版并不支持 AnswerWorks 功能。

安装

如果为安装目录选择双字节名称而不是默认名称，可能会改变产品的某些功能。强烈建议仅为安装目录名称使用单字节字符。

向图形文件添加密码的限制

如果将同一个密码用于多个图形，则密码对话框仅在打开第一个图形时才显示。建议为每一个图形添加不同的密码。

Windows 资源管理器搜索工具

Windows 资源管理器搜索工具无法查找 dwg、dxf 和 dwf 文件中包含的双字节字符串。此问题与操作系统有关。解决办法是在 XP 操作系统上查找这些字符串。

适用于“材质编辑器”面板的已翻译的样板名称

在“材质”窗口和“工具特性”对话框中，材质样板名称没有翻译出来。 下面是已翻译的样板名称列表（供您参考）：
英文 | 简体中文
Ceramic Tile, Glazed | 瓷砖，光滑
Fabric | 织物
Glass - Clear | 玻璃 - 清晰
Glass - Translucent | 玻璃 - 半透明
Ideal Diffuse | 理想漫射
Masonry | 砖石
Metal | 金属
Metal - Brushed | 金属 - 拉丝
Metal - Flat | 金属 - 光滑
Metal - Polished | 金属 - 磨光
Mirror | 镜像
Paint Flat | 光滑油漆
Paint Gloss | 反光油漆
Paint Semi Gloss | 半反光油漆
Paper | 纸质
Paper - Translucent | 纸质 - 半透明
Plastic | 塑料
Stone | 石材
Stone Polished | 磨光的石材
Water | 水
Wood Unfinished | 未涂漆木材
Wood Varnished | 涂漆木材


商标

以下是 Autodesk, Inc. 在美国和/或其他国家/地区的注册商标：3D Studio、3D Studio MAX、3D Studio VIZ、3ds max、ActiveShapes、ActiveShapes（徽标）、Actrix、ADI、AEC-X、ATC、AUGI、AutoCAD、AutoCAD LT、Autodesk、Autodesk Design Review、Autodesk Envision、Autodesk Inventor、Autodesk Map、Autodesk MapGuide、Autodesk RealDWG、Autodesk Streamline、Autodesk WalkThrough、Autodesk World、AutoLISP、AutoSketch、backdraft、Biped、bringing information down to earth、Buzzsaw、CAD Overlay、Character Studio、Cinepak、Cinepak（徽标）、cleaner、Codec Central、combustion、Design Your World、Design Your World（徽标）、EditDV、Education by Design、gmax、Heidi、HOOPS、Hyperwire、i-drop、IntroDV、lustre、Mechanical Desktop、ObjectARX、Physique、Powered with Autodesk Technology（徽标）、ProjectPoint、RadioRay、Reactor、Revit、VISION*、Visual、Visual Construction、Visual Drainage、Visual Hydro、Visual Landscape、Visual Roads、Visual Survey、Visual Toolbox、Visual Tugboat、Visual LISP、Volo、WHIP! 和 WHIP!（徽标）。

以下是 Autodesk, Inc. 在美国和/或其他国家/地区的商标：AutoCAD Learning Assistance、AutoCAD LT Learning Assistance、AutoCAD Simulator、AutoCAD SQL Extension、AutoCAD SQL Interface、AutoSnap、AutoTrack、Built with ObjectARX（徽标）、burn、Buzzsaw.com、CAiCE、Cinestream、Civil 3D、cleaner central、ClearScale、Colour Warper、Content Explorer、Dancing Baby（图像）、DesignCenter、Design Doctor、Designer's Toolkit、DesignKids、DesignProf、DesignServer、Design Web Format、DWF、DWFit、DWG Linking、DXF、Extending the Design Team、GDX Driver、gmax（徽标）、gmax ready（徽标）、Heads-up Design、jobnet、mass、ObjectDBX、onscreen onair online、Plasma、PolarSnap、Productstream、Real-time Roto、Render Queue、Visual Bridge、Visual Syllabus 和 Where Design Connects。