Autodesk 产品管理器

本节内容包括：

  • 定义搜索
  • 运行或恢复运行搜索
  • 打印或输出报告视图
请将关于此页的评论发送给我们


定义搜索

Autodesk 产品管理器
Autodesk 产品管理器
定义搜索

使用搜索定义指定要寻找的 Autodesk 产品和要搜索的计算机。可以根据需要创建若干搜索定义并将其保存以便以后运行。

要搜索的产品以组的形式列出，可以选择一组、多组或所有组。在“帮助”菜单中可以找到一个列表，其中包含 Autodesk 产品管理器可以搜索到的所有产品。

创建搜索定义时，指定要搜索的计算机。可以选择网络名或域名，也可以选择单个计算机。还可以通过名称将计算机添加到搜索定义中。

Autodesk 产品管理器通过搜索每台计算机的注册表来工作。要访问网络中的计算机（而不是用户自己的计算机）的注册表，必须要具有管理员权限。要搜索运行 Microsoft Windows 95 或 98 的计算机，必须具有远程注册表服务。

注意 请注意，“可用的网络计算机”列表仅显示当前可用的计算机的名称。可用的计算机是当前登录到网络的计算机，或已启动且处于登录屏幕或锁定状态的计算机。（运行 Microsoft Windows 95 或 98 的计算机必须登录。） 无论计算机当前是否可用，都可以通过名称将其添加到“添加到搜索的计算机”列表中。运行搜索时，如果计算机不可用，Autodesk 产品管理器会报告未搜索到该计算机。

创建并保存搜索定义的步骤
  • 在“文件”菜单中，单击“新搜索”。
  • 在“产品搜索定义”对话框中，输入一个搜索定义的名称或使用默认名称。
  • 在“要定位的产品”下，选择要搜索的产品组或选择“所有产品”。

要显示一组中所有产品的列表，请单击组名称左侧的加号。

  • 在“要搜索的计算机”下的“可用的网络计算机”列表中选择网络、域或单个计算机，然后单击“添加到搜索”按钮以将其添加到“添加到搜索的计算机”列表。

要在任一列表中选择多项，请在选择项时按住 CTRL 键。要选择连续的项，请按住 SHIFT 键并选择第一项和最后一项。

  • 要从“添加到搜索的计算机”列表中删除网络、域或计算机，请选择要删除的一项或多项，然后单击“从搜索中删除”按钮。
  • 要按名称添加计算机，请在“添加到搜索的计算机”列表中单击右键，并单击快捷菜单上的“输入计算机名称”。在列表的新框中键入计算机名称并按 ENTER 键。
  • 单击“确定”保存搜索定义。
修改现有搜索定义的步骤
  • 在“文件”菜单中，单击“修改搜索”。
  • 在“修改搜索定义”对话框中，选择一个搜索定义并单击“修改”。
  • 在“产品搜索定义”对话框中，输入搜索定义的新名称或使用现有名称。
  • 在“要定位的产品”下，选择要搜索的产品组或选择“所有产品”。

要显示一组中所有产品的列表，请单击组名称左侧的加号。

  • 在“要搜索的计算机”下，在“可用的网络计算机”列表中选择网络、域或单个计算机，并单击“添加到搜索”按钮以将其添加到“添加到搜索的计算机”列表。

要在任一列表中选择多项，请在选择项时按住 CTRL 键。要选择连续的项，请按住 SHIFT 键并选择第一项和最后一项。

  • 要从“添加到搜索的计算机”列表中删除网络、域或计算机，请选择要删除的一项或多项，然后单击“从搜索中删除”按钮。
  • 要按名称添加计算机，请在“添加到搜索的计算机”列表中单击右键，并单击快捷菜单上的“输入计算机名称”。在列表的新框中键入计算机名称并按 ENTER 键。
  • 单击“确定”保存已修改的搜索定义。
刷新“可用的网络计算机”列表的步骤
  • 在“产品搜索定义”对话框的“可用的网络计算机”列表中选择任意项。
  • 在所选项上单击右键以显示快捷菜单，并单击“刷新计算机列表”。

列表将更新以显示当前可用于搜索的计算机。可用的计算机是当前登录到网络的计算机，或已启动且处于登录屏幕或锁定状态的计算机。（运行 Microsoft Windows 95 或 98 的计算机必须登录。）


运行或恢复运行搜索

Autodesk 产品管理器
Autodesk 产品管理器
运行或恢复运行搜索

可以多次运行定义的搜索。每次都可以生成新报告或添加到以前的搜索结果中。Autodesk 产品管理器窗口中的报告视图将显示指定的列。

在运行搜索之前可以设置选项，以控制 Autodesk 产品管理器尝试搜索初次运行期间未搜索到的计算机的次数。

也可以控制显示在报告视图中的数据列。可以重新排序“要显示的列”列表。

注意 请注意，Autodesk 产品管理器通过搜索每台可用计算机的注册表来工作。可用的计算机是当前登录到网络的计算机，或已启动且处于登录屏幕或锁定状态的计算机。（运行 Microsoft Windows 95 或 98 的计算机必须登录。） 如果在搜索定义中通过选择单个计算机或输入其名称来输入某个计算机，并且该计算机在运行搜索时处于不可用状态，Autodesk 产品管理器会报告没有搜索到该计算机。

要获得最完整的结果，建议在网络中的多数计算机处于可用状态时运行搜索。也可以选择单个计算机或通过名称输入计算机，以确保任何在运行搜索时处于不可用状态的计算机被报告为未搜索到。

如果在运行搜索时暂停搜索，然后再次运行，则新结果将添加到最初的搜索结果中。要再次从头开始搜索，请从报告视图中清除搜索结果。

报告列出了包含在搜索定义中的每台计算机的结果。如果希望报告仅列出与搜索条件匹配的计算机，请选择过滤选项。

可以指定要显示在报告视图中的列。也可以显示工具栏按钮旁边的标签并恢复警告和警报的显示。

指定运行搜索次数的步骤
  • 在“选项”菜单中，单击“搜索和查看器选项”。
  • 在“搜索和查看器选项”对话框的“性能选项”下，选择以下选项之一：
  • 运行一次搜索。搜索将只对搜索定义中列出的计算机进行一次搜索。
  • 重试未找到的计算机 x 次。该搜索首先搜索一次搜索定义中列出的计算机，然后尝试搜索在第一次运行期间未搜索到的计算机。需要指定在停止搜索前进行尝试的次数。
  • 单击“确定”。
指定要显示在搜索结果中列的步骤
  • 在“选项”菜单中，单击“搜索和查看器选项”。
  • 在“搜索和查看器选项”对话框的“要显示的列”下，选择“所有列”或选择要显示在报告视图中的列。
  • 要在列表中向上或向下移动列名称，请选择该列名称并单击“上移”或“下移”按钮将其移动一个位置。
  • 单击“确定”。
仅显示与搜索条件匹配的计算机的步骤
  • 在“选项”菜单中，单击“搜索和查看器选项”。
  • 在“搜索和查看器选项”对话框中，选择“过滤与搜索不匹配的计算机”。

如果不选择此选项，将显示包含在搜索定义中的所有计算机的搜索结果。

  • 单击“确定”。
显示工具栏按钮旁边标签的步骤
  • 在“选项”菜单中，单击“搜索和查看器选项”。
  • 在“搜索和查看器选项”对话框中，选择或清除“显示工具栏按钮文字”选项。
  • 单击“确定”。
恢复默认的消息和警告框的步骤
  • 在“选项”菜单中，单击“搜索和查看器选项”。
  • 在“搜索和查看器选项”对话框中，选择“恢复默认的消息和警告框”。
  • 单击“确定”。
运行搜索的步骤
  • 在“文件”菜单中，单击“打开搜索”。
  • 在“打开搜索定义”对话框中，选择要运行的搜索并单击“确定”关闭对话框。

如果选定的搜索定义具有未保存的搜索结果，可以在再次运行搜索之前保存或放弃这些搜索结果。

  • 在“选项”菜单中，单击“搜索和查看器选项”。
  • 在“搜索和查看器选项”对话框的“性能选项”下，选择运行搜索的次数。
  • 在“查看器选项”下，选择要显示在报告视图中的列，或选择“所有列”。
  • 单击“确定”关闭对话框。
  • 在“搜索”菜单中，单击“运行搜索”。
恢复运行已停止的搜索并将新数据添加到结果中的步骤
  • 在“搜索”菜单中，单击“运行”。
清除不完整的结果并重新开始已停止的搜索的步骤
  • 在“搜索”菜单中，单击“清除搜索”。
  • 在“搜索”菜单中，单击“运行搜索”。


打印或输出报告视图

Autodesk 产品管理器
Autodesk 产品管理器
打印或输出报告视图

可以从“Autodesk 产品管理器”窗口打印报告视图，也可以将结果输出到文件以用于电子表格或数据库程序。

可以使用“搜索和查看器选项”对话框中的过滤选项，以便仅显示与搜索条件匹配的计算机。

Autodesk 产品管理器为安装在计算机中的每种 Autodesk 产品报告以下信息。在报告视图中，如果在一台计算机上发现安装了多种产品，则该计算机将在新的一行中列出，并给出其他产品的信息。

  • 搜索的计算机的名称
  • 在计算机上找到的 Autodesk 产品的名称和版本或版本号
  • 找到的 Autodesk 产品的位置
  • 找到的 Autodesk 产品的序列号和语言
  • 个人信息：用户名、公司名称、代理商名称和代理商电话号码
  • Service Pack 名称
  • 安装产品的方式：单机安装、网络服务器安装、网络客户端安装或网络共享（瘦客户端）安装
  • 搜索计算机所需的时间（秒）
  • 搜索计算机的状态，包括 Autodesk 产品管理器是否处于无法访问计算机或被拒绝访问的状态
  • 搜索计算机的日期和时间

可以在报告视图中使用标准的 Microsoft Windows 操作步骤来更改列宽、隐藏列和移动列。也可以按列排序结果（例如，按找到的产品）。使用 CTRL+C 组合键以 CSV（逗号分隔的）文件格式将数据复制到剪贴板。

对于其他格式选项，可以将结果输出到文件以便用于电子表格或数据库程序。

Autodesk 产品管理器工具栏上的“Subscription”按钮提供了对 Autodesk Software Subscription Coverage Report 的访问。Subscription 报告包含以下信息：

  • 合同号
  • 合同协调人（采购代理或财政决策制定者）
  • 合同有效日期
  • 经销商（如果有）
  • 许可证
  • 序列号
  • 客户端
  • 合同履行协调人（通常是 CAD 管理员）
  • 合同技术协调人
  • 支持
  • 展开
  • 产品组总数
更改列宽的步骤
  • 在要隐藏的列和其右侧列之间的分隔直线上移动光标。

光标变成一个水平的双向箭头。

  • 向左拖动可以减小列宽，向右拖动可以增加列宽。
  • 双击可以扩展列使其适合最长内容的显示。

当扩展列以适合其内容时，列标题并不受影响。可以通过拖动的方法扩展列标题。

在报告视图中按列排序搜索结果的步骤
  • 单击列标题按该列排序列表。再次单击可以反向排序列表。

快捷菜单：单击鼠标右键以显示快捷菜单，然后单击“升序排序”或“降序排序”。

隐藏列的步骤
  • 在要隐藏的列和其右侧列之间的分隔直线上移动光标。

光标变成一个水平的双向箭头。

  • 在列标题的右侧向左拖动列分隔符，直到列标题消失。要恢复隐藏的列，请向右拖动。

快捷菜单：单击鼠标右键以显示快捷菜单，然后单击“隐藏列”。要恢复所有隐藏的列，请单击“显示所有列”。

移动列的步骤
  • 将要移动的列的列标题拖动至要在其前面放置该列的某个列的列标题中。
从报告视图打印结果的步骤
  • 在“文件”菜单中，单击“打印报告”。

打印的报告包括所有列和行，而不只是可见的列和行。

从报告视图输出结果的步骤
  • 在“文件”菜单中，单击“输出报告”。
  • 在“输出报告”对话框的“保存在”中，为输出的报告文件指定位置。
  • 在“文件名”中，输入报告文件的文件名，或者使用显示的默认名称。
  • 在“保存类型”中，选择一种文件格式：
  • Microsoft Excel 2000 工作簿 (*.xls)
  • 逗号分隔文本 (*.csv)

默认格式为 XLS。

  • 单击“保存”以输出文件。


APM (Autodesk 产品管理器)

在网络中的计算机上搜索 Autodesk 产品

“开始”菜单 (Windows): “所有程序”»“Autodesk”»“CAD 管理器工具”»“Autodesk 产品管理器”

将显示 Autodesk 产品管理器窗口。

还可以运行 DOS 提示符下的 Autodesk 产品管理器。

本节内容包括：

  • Autodesk 产品管理器窗口
  • “产品搜索定义”对话框
  • “打开搜索定义”对话框
  • “修改搜索定义”对话框
  • “搜索和查看器选项”对话框
  • Autodesk 产品管理器报告视图
  • “输出报告”对话框
  • DOS 提示符下的 Autodesk 产品管理器


Autodesk 产品管理器窗口

Autodesk 产品管理器窗口

“开始”菜单 (Windows): “所有程序”»“Autodesk”»“CAD 管理器工具”»“Autodesk 产品管理器”

提供创建搜索定义和搜索 Autodesk 产品的菜单。结果以表的形式显示在同一窗口中，在“帮助”中引用为 Autodesk 产品管理器报告视图。

Autodesk 产品管理器工具栏上的“Subscription”按钮提供了对 Autodesk Software Subscription Coverage Report 的访问。

“文件”菜单

控制搜索定义和结果报告。

新搜索

显示“产品搜索定义”对话框，从中可以创建新的搜索定义。

打开搜索

显示“打开搜索定义”对话框，从中可以打开要运行的已保存的搜索定义。

修改搜索

显示“修改搜索定义”对话框，从中可以打开、复制、重命名或删除已保存的搜索定义。

输出报告

显示“输出报告”对话框，从中可以将搜索结果以三种文件格式之一输出到文件。

打印报告

打印显示在 Autodesk 产品管理器报告视图中的结果。

退出

关闭 Autodesk 产品管理器。

“搜索”菜单

运行、暂停和清除搜索。

运行搜索

运行当前指定的搜索。运行搜索时，结果显示在 Autodesk 产品管理器窗口中。如果暂停搜索，然后再次运行而不首先清除该搜索，结果将附加到已显示的结果中。

暂停搜索

在搜索完成前停止搜索。可以恢复运行搜索或清除目前结果并再次开始搜索。

清除搜索

清除当前搜索定义的任何搜索数据。仅当暂停搜索或在报告视图中存在使用了相同搜索定义的以前搜索中的数据时，此选项才可用。

“选项”菜单

指定运行搜索的次数和显示结果的方式。

搜索和查看器选项

显示“搜索和查看器选项”对话框，从中可以控制运行搜索的方式以及显示结果的方式。还可以控制工具栏和消息的显示。

“帮助”菜单

提供对“帮助”的访问以及对 Autodesk 产品管理器可以搜索到的完整产品列表的访问。

帮助

显示“帮助”。

搜索的产品

显示“搜索的产品”对话框，其中列出了 Autodesk 产品管理器可以搜索的产品。

关于 Autodesk 产品管理器

显示关于 Autodesk 产品管理器的信息，包括版本和版权。


“产品搜索定义”对话框

“产品搜索定义”对话框

工具栏：

“文件”菜单: “新搜索”

定义、命名和保存搜索定义。

搜索名称

命名搜索定义。如果不输入名称，搜索将自动命名为“搜索 1”、“搜索 2”，以此类推。

Autodesk 产品

列出要查找的产品组。要显示一组中所有产品的列表，请单击组名称左侧的加号。

可用的网络计算机

列出网络中当前可用的计算机。可用的计算机是当前登录到网络的计算机，或已启动且处于登录屏幕或锁定状态的计算机。（运行 Windows 95 或 98 的计算机必须登录。）

添加到搜索的计算机

列出要搜索的计算机。要按名称添加计算机，请在“添加到搜索的计算机”列表中单击右键，并单击快捷菜单上的“输入计算机名称”。在列表的新框中键入计算机名称并按 ENTER 键。可以按照以下方式输入域名：domainname\\。

添加到搜索

将在“可用的网络计算机”列表中选择的计算机、网络或域添加到“添加到搜索的计算机”列表。也可以在“可用的网络计算机”列表中单击右键，并在快捷菜单中单击“添加到搜索”。

从搜索中删除

从搜索中删除在“添加到搜索的计算机”列表中选择的计算机、网络或域。也可以在“添加到搜索的计算机”列表中单击右键，并在快捷菜单中单击“从搜索中删除”。

刷新计算机列表（快捷菜单）

刷新“可用的网络计算机”列表以包含自对话框打开后已经可用的计算机。


“打开搜索定义”对话框

“打开搜索定义”对话框

工具栏：

“文件”菜单: “打开搜索”

打开保存的搜索定义以便运行搜索。

搜索定义

列出保存的搜索定义。


“修改搜索定义”对话框

“修改搜索定义”对话框

“文件”菜单: “修改搜索”

复制、重命名、删除或修改保存的搜索定义。

复制

复制选定的搜索并将其添加到列表，同时在搜索名称中添加“副本”字样。如果进行多次复制，则在名称中添加一个数字，例如“Basic 副本 1”。

重命名

在选定的搜索定义周围放置一个框，以便输入新名称。

删除

删除选定的搜索定义。

修改

关闭“修改搜索定义”对话框，并打开“产品搜索定义”对话框，从中可以修改选定的搜索定义。


“搜索和查看器选项”对话框

“搜索和查看器选项”对话框

“选项”菜单: “搜索和查看器选项”

控制运行搜索和显示结果的方式；同时控制工具栏和消息的显示。

运行一次搜索

在搜索定义列出的计算机中运行一次搜索。

重试未找到的计算机 x 次

搜索以前不可用于搜索的计算机，并将此过程重复指定的次数，或者重复此过程直到搜索到搜索定义中的所有计算机。

要显示的列

控制在搜索结果中显示哪些列。

上移

将“要显示的列”列表中的选定列名称上移一个位置。

下移

将“要显示的列”列表中的选定列名称下移一个位置。

过滤与搜索不匹配的计算机

在搜索结果中仅显示与搜索条件匹配的计算机。

显示工具栏按钮文字

控制工具栏按钮的显示。选择此选项时，工具栏按钮的名称将显示在按钮图标旁边。不选择此选项时，仅显示工具栏按钮图标。

恢复默认的消息和警告框

恢复已关闭的消息的显示。


Autodesk 产品管理器报告视图

Autodesk 产品管理器报告视图

“开始”菜单 (Windows): “所有程序”»“Autodesk”»“CAD 管理器工具”»“Autodesk 产品管理器”

以表的形式报告搜索结果。信息显示在以下各列中。

PC 名称

搜索的计算机的名称。如果未搜索该计算机，其名称前的图标将显示为灰色。

Autodesk 产品

在计算机中找到的 Autodesk 产品的名称。如果未找到产品，则该条目为“无”。

版本

找到的产品的版本或版本号。如果未找到产品，则该条目为空。

安装位置

找到的 Autodesk 产品的位置。如果未找到产品，则该条目为空。

序列号

找到的 Autodesk 产品的序列号。如果未找到产品，则该条目为空。

语言

找到的产品的语言。

用户名

找到的产品的个人化信息（如果有）中的用户名。

组织

找到的产品的个人化信息（如果有）中的公司名称。

经销商名称

找到的产品的个人化信息（如果有）中的经销商名称。

经销商电话

找到的产品的个人化信息（如果有）中的经销商电话号码。

Service Pack 名称

找到的产品安装的 Service Pack（如果有）名称。

安装类型

找到的产品的安装类型。安装类型包括单机安装、网络服务器安装、网络客户端安装和网络共享（瘦客户端）安装。

查询时间

搜索计算机所需的时间（秒）。

查询状态

搜索此计算机的状态。状态消息包括“好”、“未找到计算机”、“拒绝访问计算机”和“搜索计算机时出现未知错误”。

查询日期和时间

搜索计算机的日期和时间。


“输出报告”对话框

“输出报告”对话框

工具栏：

“文件”菜单: “输出搜索”

将搜索结果以三种文件格式之一输出到文件。

保存在

指定要保存文件的文件夹。

文件名

指定输出的搜索结果的文件名。如果没有输入文件名，则使用搜索名称并添加文件扩展名 .xls，以 Microsoft Excel 2000 格式输出结果。

保存类型

指定报告文件的文件格式。文件格式包括

  • Microsoft Excel 2000 工作簿 (*.xls)
  • Microsoft Access 2000 数据库 (*.mdb)
  • 逗号分隔文本 (*.csv)

如果没有选择文件格式，则以文件扩展名 .xls 保存文件以便在 Microsoft Excel 2000 中使用。


DOS 提示符下的 Autodesk 产品管理器

DOS 提示符下的 Autodesk 产品管理器

在 DOS 提示符下，可以在 Autodesk 产品管理器目录中输入 apm 来运行 Autodesk 产品管理器。要运行已定义的搜索并将结果输出到文件，请在一行中使用以下语法：

apm [搜索定义] /mb [/r [驱动器:][路径][报告文件名]]

如果没有输入搜索定义，将在整个网络中搜索所有产品。可以使用以下开关：

/? 开关

在 DOS 窗口中显示运行 Autodesk 产品管理器的说明。

/mb 开关

显示表明搜索过程的对话框并提供可用于取消搜索的按钮。使用此开关时，需要 /r 开关和报告文件名。

/mf 开关

显示 Autodesk 产品管理器窗口。在所提供的对话框中运行搜索。如果指定此开关，/r 开关和报告文件名将被忽略。

/* 开关

列出保存的搜索定义。

/r 开关

创建搜索结果报告。所输入文件名的文件扩展名确定了文件格式。文件扩展名包括 .xls（Microsoft Excel 2000 工作簿）、.mdb（Microsoft Access 2000 数据库）和 .csv（逗号分隔文本）。

按 ENTER 键时，Autodesk 产品管理器将在 DOS 窗口中运行搜索，直到完成搜索或取消搜索。不能暂停和恢复运行搜索。要停止搜索，请按 CTRL+C 组合键。不完整的搜索结果将被保存。


评论？

请使用该表格将注释发送至负责该文档的 Autodesk 技术出版组。

主题标题和位置（请勿编辑）：
姓名（可选）：
         电子邮件（可选）：
评论：

注意：该表并不作为用户接收反馈或技术支持的途径。用户提供的信息可使我们将来更好地更新该文档。谢谢！