AutoCAD 2008 开发人员帮助

欢迎使用 AutoCAD 2008 开发人员帮助

AutoCAD 开发人员帮助提供了有关自定义和扩展 AutoCAD 的完整信息。请单击右侧的链接或使用“目录”选项卡浏览帮助主题。

概述

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF 参考手册

ActiveX 和 VBA 开发人员手册

ActiveX and VBA Reference

Sheet Set Objects Reference

Connectivity Automation Reference

ObjectARX

我的帮助
网上资源


AutoCAD 2008 帮助

自定义手册

《自定义手册》向有经验的用户介绍如何自定义 AutoCAD。要浏览《自定义手册》，请使用“帮助”窗口左侧的“目录”选项卡。

  • 基本自定义
  • 自定义线型
  • 自定义填充图案
  • 自定义用户界面
  • DIESEL
  • 幻灯片和命令脚本
  • 编程接口简介
  • 形和形字体
概述

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF 参考手册

ActiveX 和 VBA 开发人员手册

ActiveX and VBA Reference


AutoLISP Reference

《AutoLISP Reference》提供了有关 AutoLISP® 的全面参考，AutoLISP 是一种功能全面的解释性编程语言，可用于调用 AutoCAD 命令、系统变量和对话框。《AutoLISP Reference》包括以下主题：

  • AutoLISP 函数：运算符、A、B、C、D、E、F、G、H、I、J、K、L、M、N、O、P、Q、R、S、T、U、V、W、X、Y、Z。
  • 外部定义命令
概述

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial

DXF 参考手册


AutoLISP Developer's Guide

《AutoLISP Developer's Guide》提供了有关使用 Visual LISP® 交互式开发环境开发以及测试 AutoLISP® 程序的信息。同时还描述了如何使用 Visual LISP 提供的扩展来创建 ActiveX® Automation。《AutoLISP Developer's Guide》中包括以下主题：

  • 简介
  • 使用 Visual LISP 环境
  • 使用 AutoLISP 语言
  • 使用可编程对话框
  • 附录
概述

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial


AutoLISP Tutorial

《AutoLISP Tutorial》提供了逐步说明如何使用 Visual LISP™ 开发 AutoLISP® 应用程序的课程。《AutoLISP Tutorial》包括以下主题：

  • 简介
  • 设计和开始编程
  • 使用 Visual LISP 调试工具
  • 绘制小路边界
  • 创建工程和添加界面
  • 绘制砖
  • 使用反应器
  • 程序集成
概述

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial


DXF 参考手册

《DXF 参考手册》提供了关于 DXF™ 文件格式的全面参考。《DXF 参考手册》包括以下主题：

  • DXF 格式
  • HEADER 段
  • CLASSES 段
  • TABLES 段
  • BLOCKS 段
  • ENTITIES 段
  • OBJECTS 段
  • THUMBNAILIMAGE 段
  • 图形交换文件格式
  • 高级 DXF 问题
概述

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial


ActiveX 和 VBA 开发人员手册

《ActiveX 和 VBA 开发人员手册》说明了如何使用 ActiveX 和 VBA 开发应用程序来自定义 AutoCAD。本手册还包括样例代码和逐步说明的操作步骤。《ActiveX 和 VBA 开发人员手册》包括以下主题：

  • 简介
  • VBA 快速入门
  • ActiveX Automation 基础知识
  • 控制 AutoCAD 环境
  • 创建和编辑 AutoCAD 图元
  • 标注和公差
  • 自定义工具栏和菜单
  • 使用事件
  • 在三维空间中工作
  • 定义布局并打印
  • 高级绘图与组织技术
  • 使用 VBA 开发应用程序
  • 与其他应用程序和 Windows API 交互
  • ActiveX/VBA 教程：设计花园小路
  • Visual LISP 与 ActiveX/VBA 的比较
概述

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial


ActiveX and VBA Reference

《ActiveX and VBA Reference》提供了关于 ActiveX 对象模型及其关联接口组件的参考。《ActiveX and VBA Reference》包含以下主题：

  • 对象模型
  • 事件
  • 方法
  • 特性
  • 对象
  • 代码样例
概述

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial


Sheet Set Objects Reference

《Sheet Set Objects Reference 》提供了有关图纸集管理器对象的参考。《Sheet Set Objects Reference 》包括以下主题：

  • 图纸集管理器对象概述
  • 对象
  • 方法
  • 特性
  • 枚举
概述

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial


Connectivity Automation Reference

《Connectivity Automation Reference》提供了关于 Connectivity Automation 对象模型及其关联接口组件的参考。《Connectivity Automation Reference》包括以下主题：

  • Connectivity Automation 对象
  • 对象模型
  • 对象
  • 方法
  • 特性
  • 事件
概述

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial


ObjectARX

ObjectARX®（即 AutoCAD® Runtime Extension 编程环境）包括可构造块的 C++ 库，这些构造块可用于开发 AutoCAD 应用程序、扩展 AutoCAD 类和协议，以及创建操作方式与 AutoCAD 内置命令相同的新命令。

如果此帮助项目在“目录”选项卡中显示为页面图标 ( [image])，则 ObjectARX 文档在帮助系统中将不可用。

AutoCAD ObjectARX 文档可以从 Autodesk 网站的 开发中心部分下载。要将 ObjectARX 文档和 AutoCAD 文档整合，请将 ObjectARX 帮助文件复制到“AutoCAD \HELP\”文件夹中。
概述

帮助文件

自定义手册

AutoLISP Reference

AutoLISP Developer's Guide

AutoLISP Tutorial


我的帮助

用户可以创建自己的帮助主题组，称为“我的帮助”。用户将“我的帮助”主题添加到 AutoCAD 帮助之后，这些主题即可从“帮助”窗口左侧窗格中的“目录”选项卡、“索引”选项卡（如果用户添加了索引条目）和“搜索”选项卡中找到。在“目录”选项卡中单击“我的帮助”主题，可以访问用户添加到 AutoCAD 帮助中的帮助主题。

有关设置“我的帮助”的信息，请参见设置“我的帮助”。
概述

帮助文件

自定义手册

AutoLISP Referece

AutoLISP Developer's Guide

AutoLISP Tutorial

ActiveX and VBA Developer's Guide


评论？

请使用该表格将注释发送至负责该文档的 Autodesk 技术出版组。

主题标题和位置（请勿编辑）：
姓名（可选）：
         电子邮件（可选）：
评论：

注意：该表并不作为用户接收反馈或技术支持的途径。用户提供的信息可使我们将来更好地更新该文档。谢谢！


版权和商标

版权所有 © 2007 Autodesk, Inc.

保留所有权利

不能以任何形式、任何方式或任何目的复制该版本或其中的内容。

Autodesk, Inc. 对这些资料不作任何明确或隐含的担保，包括但不仅限于对适销性和针对特定用途的适用性的担保。Autodesk, Inc. 仅按照其实际状态(以“AS-IS”方式)提供这些资料。

在任何情况下，对由购买或使用这些资料引起的或与之相关的直接、间接、偶然或必然的任何损失，Autodesk, Inc. 均不承担赔偿责任。无论涉及何种诉讼，Autodesk, Inc. 所承担的赔偿责任以不超过此处所述资料的售价为限。

Autodesk, Inc. 保留在适当的时候修订和改进其产品的所有权利。本出版物描述的是其出版时产品的状态，可能并不总是反映产品未来的情况。

Autodesk 商标

以下是 Autodesk, Inc. 在美国和其他国家/地区的注册商标或商标：3DEC（设计/徽标）、3December、3December.com、3ds Max、ActiveShapes、Actrix、ADI、Alias、Alias（Swirl 设计/徽标）、AliasStudio、Alias|Wavefront（设计/徽标）、ATC、AUGI、AutoCAD、AutoCAD Learning Assistance、AutoCAD LT、AutoCAD Simulator、AutoCAD SQL Extension、AutoCAD SQL Interface、Autodesk、Autodesk Envision、Autodesk Insight、Autodesk Intent、Autodesk Inventor、Autodesk Map、Autodesk MapGuide、Autodesk Streamline、AutoLISP、AutoSnap、AutoSketch、AutoTrack、Backdraft、Built with ObjectARX（徽标）Burn、Buzzsaw、CAiCE、Can You Imagine、Character Studio、Cinestream、Civil 3D、Cleaner、Cleaner Central、ClearScale、Colour Warper、Combustion、Communication Specification、Constructware、Content Explorer、Create>what's>Next>（设计/徽标）、Dancing Baby（图像）、DesignCenter、Design Doctor、Designer's Toolkit、DesignKids、DesignProf、DesignServer、DesignStudio、Design|Studio（设计/徽标）、Design Your World、Design Your World（设计/徽标）、DWF、DWG、DWG（徽标）、DWG TrueConvert、DWG TrueView、DXF、EditDV、Education by Design、Extending the Design Team、FBX、Filmbox、FMDesktop、GDX Driver、Gmax、Heads-up Design、Heidi、HOOPS、HumanIK、i-drop、iMOUT、Incinerator、IntroDV、Kaydara、Kaydara（设计/徽标）、LocationLogic、Lustre、Maya、Mechanical Desktop、MotionBuilder、ObjectARX、ObjectDBX、Open Reality、PolarSnap、PortfolioWall、Powered with Autodesk Technology、Productstream、ProjectPoint、Reactor、RealDWG、Real-time Roto、Render Queue、Revit、Showcase、SketchBook、StudioTools、Topobase、Toxik、Visual、Visual Bridge、Visual Construction、Visual Drainage、Visual Hydro、Visual Landscape、Visual Roads、Visual Survey、Visual Syllabus、Visual Toolbox、Visual Tugboat、Visual LISP、Voice Reality、Volo 和 Wiretap。

以下是 Autodesk Canada Co. 在美国和/或加拿大和其他国家/地区的注册商标或商标：Backburner、Discreet、Fire、Flame、Flint、Frost、Inferno、Multi-Master Editing、River、Smoke、Sparks、Stone 和 Wire。

第三方商标

所有其他品牌名称、产品名称或商标均属于其各自的持有者。

第三方软件程序声明

ACIS 版权所有 © 1989-2001 Spatial Corp.

版权所有 © 1999-2000 The Apache Software Foundation。保留所有权利。本产品包括 Apache Software Foundation (http://www.apache.org) 开发的软件，遵守其许可条款 (http://xml.apache.org/dist/LICENSE.txt) 的限定。

字体来自 Bitstream © 字体库版权所有 © 1992。

HLM © 版权所有 D-Cubed Ltd. 1996-2006。HLM 是 D-Cubed Ltd. 的商标。

AutoCAD © 2008 和 AutoCAD LT © 2008 的出品已获得授权，允许使用从 Dainippon Ink and Chemicals, Inc. 的 DIC Color Guide © 获得的数据。版权所有 © Dainippon Ink and Chemicals, Inc.。保留所有权利。DIC 和 DIC Color Guide 是 Dainippon Ink and Chemicals, Inc 的注册商标。

此软件的某些部分基于 Independent JPEG Group 的工作。

Active Delivery© 2.0 © 1999-2004 Inner Media, Inc.。保留所有权利。

ISYS 和 ISYS 徽标是 ISYS© Search Software Inc. 的注册商标或商标。

版权所有 © 1988-1997 Sam Leffler。 版权所有 © 1991-1997 Silicon Graphics, Inc.。

版权所有 © Lingea s.r.o. 2006

新功能专题研习包括 Macromedia, Inc. 的 Macromedia Flash© Player 软件。版权所有 © 1995-2005 Macromedia, Inc.。保留所有权利。Macromedia © 和 Flash © 是 Adobe Systems Incorporated 在美国或其他国家/地区的注册商标或商标。

版权所有 © 1996-2006 Macrovision Corporation。保留所有权利。

版权所有 © 1996-2006 Microsoft Corporation。保留所有权利

版权所有 © 2002 Joseph M. O'Leary。

在软件应用程序或用户文档内所显示的PANTONE © 颜色与 PANTONE 认可的标准可能并不相符。请参考最新的 PANTONE Color 版本以了解精确的颜色。

PANTONE © 和其他 Pantone, Inc. 商标属于 Pantone, Inc. 所有。版权所有 © Pantone, Inc., 2004。

PANTONE, Inc. 是授权给 Autodesk, Inc. 的颜色数据和/或软件的版权拥有者，它们只提供与特定的Autodesk 软件产品一起使用。除非作为此 Autodesk 软件产品操作的一部分，否则不要将 PANTONE Color 数据和/或软件复制到另一个磁盘上或复制进内存中。

字体来自 Payne Loving Trust © 1992, 1996。保留所有权利。

RAL DESIGN © RAL, Sankt Augustin, 2004。

RAL CLASSIC © RAL, Sankt Augustin, 2004。

颜色的显示已获得了 RAL Deutsches Institut für Gütesicherung und Kennzeichnung e.V. (RAL 德国质量保证和认证协会，re.Assoc.), D-53757 Sankt Augustin 的批准。

本产品包括 RSA Security, Inc. 授权的代码。IBM 授权的部分内容位于 http://oss.software.ibm.com/icu4j/。

Sentry Spelling-Checker Engine 版权所有 © 1994-2003 Wintertree Software, Inc.。

本产品的某些部分包括一个或多个 Boost 库。Boost 库的使用必须遵守以下许可协议：http://www.boost.org/LICENSE_1_0.txt。


设置“我的帮助”

如果要设置“我的帮助”，用户必须以 HTML 格式创建帮助主题，然后使用 Microsoft HTML Help Workshop 对其进行编译，以创建一个名为 myhelp.chm 的编译帮助文件。将此文件复制到“AutoCAD\Help”文件夹。

在“我的帮助”的主要主题中显示带超链接的主题标题的步骤

  • 在 CHM 文件中包含一个文件，该文件列出了这些主题标题。将此包含的文件命名为 myhelp_toc.html 。

在“目录”选项卡中显示主题标题的步骤

  • 在 CHM 文件中包含一个文件，在该文件中列出这些主题标题的 HHC（帮助目录）。

显示用户添加到帮助主题的所有索引条目的步骤

  • 在 CHM 文件中包含一个 HHK（帮助索引）文件。

即使未包含 myhelp_toc.html 文件、HHC 文件或 HHK 文件，CHM 文件中的内容也可以从“搜索”选项卡中找到。