网络管理快速入门

如何进行展开前的准备工作
AutoCAD 2008 网络管理员手册 >
网络管理快速入门

对本程序进行网络展开需要进行仔细地规划和执行。本节就如何进行展开准备工作、设置许可服务器以及设置和分发程序给出了分步的快速指导。

如果不熟悉网络管理和展开，请先通读《网络管理员手册》，然后再尝试在网络中展开和管理程序。

本节内容

  • 如何进行展开前的准备工作
  • 如何设置许可服务器
  • 如何设置和分发程序
请将关于此页的评论发送给我们


如何进行展开前的准备工作

网络管理快速入门
网络管理快速入门
如何选择安装类型
AutoCAD 2008 网络管理员手册 > 网络管理快速入门 >
如何进行展开前的准备工作

进行展开前的准备工作时，需要选择安装类型和许可服务器模式。

本节内容

  • 如何选择安装类型
  • 如何选择许可服务器模式


如何选择安装类型

如何进行展开前的准备工作
如何进行展开前的准备工作
如何选择许可服务器模式
AutoCAD 2008 网络管理员手册 > 网络管理快速入门 > 如何进行展开前的准备工作 >
如何选择安装类型

设置展开时，需要选择所要展开的安装类型。在 AutoCAD 2008 安装向导中，指定下列某个安装类型：

网络许可证安装

通过此安装类型，可以将程序安装到工作站上，包括程序用来与 Network License Manager 进行通信的文件和注册表项。也可以定义 Network License Manager 的配置，以便可以访问许可证。运行基于网络安装的程序的工作站不需要单独激活。至少有一台许可服务器管理本程序的许可。

主要优点是可以在多于所购买的许可证数量的系统上安装 AutoCAD（例如，购买了 25 个许可证，但能在 40 个工作站上安装）。任何时候，AutoCAD 都能在最大数量的系统（具有许可证）上运行。这表示用户获得了真实浮动许可证。

多套单机安装（“单机”选项）

选择单机安装的安装类型（使用单个序列号在多台计算机上进行安装）。多套单机安装不使用 Network License Manager 管理产品许可证；但仍可使用 AutoCAD 2008 安装向导创建管理映像和展开。多套单机安装的注册和激活将更加自动化。使用多套单机序列号首次激活后，基于此展开的所有工作站都将自动激活（只要系统连接到 Internet）。

单机安装（“单机”选项）

选择单机安装的安装类型（用单个序列号在单台计算机上进行安装）。如同多套单机安装一样，用户不能使用 Network License Manager 管理产品许可，但可以在每个工作站进行安装、注册和激活。

如果选择单击安装类型的一种，可以转至如何设置和分发程序一节。


如何选择许可服务器模式

如何选择安装类型
如何进行展开前的准备工作
如何设置许可服务器
AutoCAD 2008 网络管理员手册 > 网络管理快速入门 > 如何进行展开前的准备工作 >
如何选择许可服务器模式

如果选择“网络安装”选项，则需确定使用哪种许可服务器模式来分发产品许可证。

提示如果展开单机安装或多套单机安装类型，则不要使用许可服务器模式。转至如何设置和分发程序一节。

对于网络安装，请使用下列某个许可服务器模式：

  • 单一许可服务器模式。因为 Network License Manager 安装在单一服务器上，所以许可证管理和活动仅限于此服务器。单一许可证文件表示服务器上可用许可证的总数。
  • 分布式许可服务器模式。许可证分布在多台服务器上。每台服务器都要求具有唯一的许可证文件。要创建分布式许可服务器，必须在分布式服务器池中的每台服务器上运行 Network License Manager。
  • 冗余许可服务器模式。使用三台服务器验证单一许可证文件。一台服务器作为主服务器，另外两台服务器在主服务器无法工作时提供备份。使用此配置，只要有两台服务器正常工作，即可继续监视和分发许可证。三台服务器上的许可证文件是同一文件。每台服务器上都必须安装 Network License Manager。

每种许可服务器模式在《网络许可手册》中均有详细说明。强烈建议在展开程序之前阅读该手册。您可以通过单击 AutoCAD 2008 安装向导左下角的“文档”链接找到《网络许可手册》，或在帮助系统中找到该手册。


如何设置许可服务器

如何选择许可服务器模式
网络管理快速入门
如何安装 Network License Manager
AutoCAD 2008 网络管理员手册 > 网络管理快速入门 >
如何设置许可服务器

如果打算使用网络许可证运行程序，则需使用 Network License Manager 和网络许可证激活实用程序。

使用 Network License Manager 可以配置和管理许可服务器。网络许可证激活实用程序有助于用户在 Internet 上获取和注册许可证。

本节内容

  • 如何安装 Network License Manager
  • 如何安装和使用网络许可证激活实用程序
  • 如何配置许可服务器


如何安装 Network License Manager

如何设置许可服务器
如何设置许可服务器
如何安装和使用网络许可证激活实用程序
AutoCAD 2008 网络管理员手册 > 网络管理快速入门 > 如何设置许可服务器 >
如何安装 Network License Manager

Network License Manager 用于配置和管理许可服务器。

安装 Network License Manager 的步骤

  1. 在 AutoCAD 2008 安装向导中，单击“安装工具和实用程序”。
  2. 在“欢迎使用 AutoCAD 2008 安装向导”页面上，单击“下一步”。
  3. 查看适用于您所在国家或地区的 Autodesk 软件许可协议。必须接受协议才能继续安装。选择您所在国家或地区，单击“我接受”，然后单击“下一步”。
    注意如果不同意协议的条款并且要终止安装，请单击“取消”。
  4. 在“选择安装项目”页面上，请确保选定“Network License Manager”，然后单击“下一步”。
  5. 在“查看 - 配置 - 安装”页面上，单击“配置”。
  6. 如果已选定多个工具和实用程序，请单击“Network License Manager”选项卡。
  7. 在“设置 Network License Manager”页面上，接受默认安装路径 (C:\Program Files\Autodesk\NLM\) 或单击“浏览”以指定其他路径。如果输入的路径不存在，将根据您提供的名称和位置创建一个新文件夹。单击“下一步”。
    警告请勿在远程驱动器上安装 Network License Manager。安装 Network License Manager 文件时，必须提供一个本地驱动器路径。必须指定驱动器号；不支持通用命名约定 (UNC)。
  8. 在“联机访问工具”页面上，单击“下一步”可以安装“Network License Manager”以及任何其他选定的工具和实用程序。
  9. 显示“安装完成”页面时，单击“完成”。


如何安装和使用网络许可证激活实用程序

如何安装 Network License Manager
如何设置许可服务器
如何配置许可服务器
AutoCAD 2008 网络管理员手册 > 网络管理快速入门 > 如何设置许可服务器 >
如何安装和使用网络许可证激活实用程序

使用网络许可证激活实用程序可以在 Internet 上获取许可证，这样可以节省设置网络许可版本程序所用的时间和精力。此外，如果无法通过 Internet 获取许可证，可以通过电子邮件注册产品、获得自动支持，并且许可证文件将自动保存和移植。

安装网络许可证激活实用程序的步骤

  1. 在 AutoCAD 2008 安装向导中，单击“安装工具和实用程序”。
  2. 在“欢迎使用 AutoCAD 2008 安装向导”页面上，单击“下一步”。
  3. 查看适用于您所在国家或地区的 Autodesk 软件许可协议。必须接受协议才能继续安装。选择您所在国家或地区，单击“我接受”，然后单击“下一步”。
    注意如果不同意协议的条款并且要终止安装，请单击“取消”。
  4. 在“选择安装项目”页面上，请确保选定“网络许可证激活实用程序”，然后单击“下一步”。
  5. 在“查看 - 配置 - 安装”页面上，单击“配置”。
  6. 如果已选定多个工具和实用程序，请单击“网络许可证激活实用程序”选项卡。
  7. 在“设置网络许可证激活实用程序”页面上，可接受默认安装路径 (C:\Program Files\Autodesk\NLA\) 或单击“浏览”以指定其他路径。如果输入的路径不存在，将根据您提供的名称和位置创建一个新文件夹。单击“下一步”。
  8. 在“联机访问工具”页面上，单击“下一步”可以安装“网络许可证激活实用程序”以及任何其他选定的工具和实用程序。
  9. 显示“安装完成”页面时，单击“完成”。

使用网络许可证激活实用程序的步骤

  1. 在“开始”菜单 (Windows) 上，依次单击“所有程序”（或“程序”） [image] “Autodesk” [image] “Network License Manager” [image] “AutoCAD 2008 网络许可证激活实用程序”。
  2. 在“获取网络许可证”页面上，查看该实用程序的工作方式及其使用要求，然后单击“下一步”。
  3. 在“服务器信息”页面上，输入产品序列号。
    注意如果是在修改现有许可证文件或是获取现有产品的新许可证，那么页面上可能会显示先前输入的信息。请确保所显示的序列号是要许可的产品序列号。如果不是，请输入正确的产品序列号。
  4. 在“许可服务器模式”部分，单击一种许可服务器模式。要获取每种许可服务器模式的详细信息，请单击“?”按钮。
  5. 在“服务器主机名”框中，输入服务器主机名，或单击“...”按钮查找计划使用的所有服务器的名称。
  6. 在“主机 ID”框中，针对上一步骤中输入的服务器主机名，单击“查找”让实用程序自动查找相应的服务器主机 ID 或手动输入该主机 ID。
    注意如果服务器具有多个网络适配器，请选择与物理网络适配器相对应的网络适配器。要确定哪些适配器是物理适配器，请在 Windows 命令提示符下输入 ipconfig /all，然后查看每个物理地址上方的“Description”字段。如果有多个物理网络适配器，则可以使用其中任意一个，只要运行 ipconfig /all 时列出了该适配器即可。此外，还可能列出一些逻辑设备（例如 VPN 适配器、PPP 适配器和调制解调器），但是它们在许可操作中不可用。
  7. 如果在步骤 4 中选择“分布式服务器”，还将显示“套数”框。在“套数”框中，输入每个许可服务器的套数，然后单击“下一步”。
  8. 在“确认服务器信息”页面上，检查所输入的服务器信息，然后单击“下一步”。
  9. 如果显示“注册并激活 Autodesk 产品”页面，请执行以下所有操作，然后单击“下一步”。
    • 在“本产品将注册给”选项中，选择“公司”或“个人”。
    • 在“选择国家或地区”部分，选择您所居住的国家或地区。
    • 在“是否是升级版”部分，选择“是”或“否”。
  10. 如果显示“注册信息”页面，请输入注册信息，然后单击“下一步”。
  11. 如果显示“确认信息”页面，请检查注册信息，然后单击“下一步”。
  12. 如果显示“正在连接”页面，请单击“下一步”连接到 Internet 以获取网络许可证。
  13. 在“已收到许可证”页面的“保存 [计算机名] 的许可证文件”对话框中，输入希望保存许可证文件的位置，或单击“浏览”以浏览到相应的位置。
    注意建议将许可证文件保存在安装 Network License Manager 的位置。
  14. 如果拥有其他 Autodesk 产品的现有许可证文件，请选择下列选项之一：
    • 将新的许可证信息插入到其中。将新的许可证信息添加到现有许可证文件中。
    • 覆盖现有的许可证文件。用新的许可证信息替换现有许可证文件的全部内容。仅当不再需要现有许可证文件中的任何内容时，才能选择此选项。
  15. 单击“下一步”。
  16. 在“许可证激活成功”页面上，单击“打印”以保存许可证信息的打印副本，或单击“完成”以完成此事务并退出网络许可证激活实用程序。


如何配置许可服务器

如何安装和使用网络许可证激活实用程序
如何设置许可服务器
如何设置和分发程序
AutoCAD 2008 网络管理员手册 > 网络管理快速入门 > 如何设置许可服务器 >
如何配置许可服务器

要能够管理运行网络许可证激活实用程序时收到的 Autodesk 产品许可证，需要配置许可服务器。请使用 lmtools.exe 实用程序配置许可服务器。

配置许可服务器的步骤

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 执行下列操作之一：
    • 依次单击“开始”菜单 (Windows XP & 2000) [image] “所有程序”（或“程序”） [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • 在桌面上的 LMTOOLS 图标（适用于 Windows Vista）上单击鼠标右键，然后选择“以管理员身份运行”。
  2. 在 Lmtools 程序的“Service/License File”选项卡中，选择“Configuration Using Services”选项。
  3. 单击“Config Services”选项卡。
  4. 在“Config Services”选项卡下的“Service Name”列表中，选择一个服务名，或执行下列操作之一：
    • 如果已选择某个服务名，请确认它是否是您要用来管理许可证的服务名。
    • 如果不存在服务名，请输入要用来管理许可证的服务名。
    注意如果有多个软件供应商使用 FLEXlm® 进行许可证管理，则“Service Name”列表中将包含多个选项。
  5. 在“Path to the lmgrd.exe file”框中，输入指向 Network License Manager 守护程序 (lmgrd.exe) 的路径，或单击“Browse”以定位文件。

    默认情况下，此守护程序安装在 \Program Files\Autodesk Network License Manager 文件夹中。

  6. 在“Path to the license file”框中，输入指向许可证文件的路径，或单击“Browse”以定位文件。
  7. 在“Path to the debug log file”框中，输入路径以创建调试日志，或单击“Browse”以定位一个现有的日志文件。
  8. 要将 lmgrd.exe 作为服务来运行，请选择“Use Services”。
  9. 要在系统启动时自动启动 lmgrd.exe，请选择“Start Server at Power Up”。
  10. 单击“Save Service”，将新的配置信息保存到步骤 4 中选定的服务名下。然后单击“是”。
  11. 单击“Start/Stop/Reread”选项卡。
  12. 在“Start/Stop/Reread”选项卡中，执行以下操作之一：
    • 如果尚未针对 Autodesk 定义服务，请单击“Start Server”以启动许可服务器。
    • 如果已经定义了某一个 Autodesk 服务并且该服务正在运行，请单击“ReRead License File”使用对许可文件或选项文件所做的修改来刷新 Network License Manager。

      许可服务器开始运行，并准备响应客户端请求。

  13. 关闭 lmtools.exe。


如何设置和分发程序

如何配置许可服务器
网络管理快速入门
如何创建网络共享
AutoCAD 2008 网络管理员手册 > 网络管理快速入门 >
如何设置和分发程序

完成展开前的准备工作并使用了 Network License Manager 和网络许可证激活实用程序之后，就可以通过使用 AutoCAD 2008 安装向导和选择展开方法来设置和分发本程序。

本节内容

  • 如何创建网络共享
  • 如何使用安装向导设置展开
  • 如何展开本程序


如何创建网络共享

如何设置和分发程序
如何设置和分发程序
如何使用安装向导设置展开
AutoCAD 2008 网络管理员手册 > 网络管理快速入门 > 如何设置和分发程序 >
如何创建网络共享

网络共享是向网络上的用户的计算机提供的安装文件夹。您可以将用户指向此位置，来安装程序。创建网络共享，以供 AutoCAD 2008 安装向导在创建客户端展开过程中使用。

注意创建展开映像时，必须为共享文件夹设置“完全控制”权限。要访问网络共享，读取权限是必需的，而且还需要对展开程序的工作站的管理权限。

创建网络共享的步骤

  1. 在网络服务器的桌面，创建名为“Autodesk”的文件夹。
  2. 在“Autodesk”文件夹上单击鼠标右键，并单击“共享和安全”（或“共享”）。
  3. 在“<文件夹名称> 特性”对话框中的“共享”选项卡下，选择“共享该文件夹”。
  4. 如果需要，可以指定一个共享名称，如“Autodesk”或“MyDeployments”。
  5. 单击“权限”按钮。请确保在“权限”对话框中已激活“完全控制”。单击“确定”。

    该操作在创建展开映像时十分重要。

  6. 单击“确定”关闭“特性”对话框。
  7. 在“Autodesk”文件夹中，为计划安装的每个产品创建一个子文件夹。以相关产品名称命名每个文件夹。


如何使用安装向导设置展开

如何创建网络共享
如何设置和分发程序
如何展开本程序
AutoCAD 2008 网络管理员手册 > 网络管理快速入门 > 如何设置和分发程序 >
如何使用安装向导设置展开

可以从 AutoCAD 2008 安装向导直接创建展开。用户可以通过展开在各自的计算机上安装程序。

注意以下步骤仅介绍了设置展开的方法之一。该过程详细介绍了单一服务器的网络展开，其类型为“典型”客户端安装并且无自定义设置。有关设置展开的详细信息，请参见使用安装向导设置展开。

使用安装向导创建默认展开的步骤

  1. 在 AutoCAD 2008 安装向导中，单击“创建展开”。
  2. 在“欢迎使用 AutoCAD 2008 安装向导”页面上，单击“下一步”。
  3. 在“开始展开”页面上，需要指定以下内容：展开位置、展开名称以及是否要在静默模式下运行客户端安装。
    • 在“展开位置”字段中，输入要创建管理映像的现有共享网络位置，或者单击“...”按钮定位某个共享网络位置。用户将从此位置安装程序。
      注意如果不知道如何创建网络共享，请参见如何创建网络共享。
    • 在“展开名称”字段中，输入新展开的名称。此处输入的名称是快捷方式的名称，用户将通过访问该快捷方式来安装产品。
    • 要防止用户在安装产品时修改此处的安装设置，请选择“客户端安装运行于静默模式”。

    单击“下一步”。

  4. 在“选择要安装的产品”页面上，选择要展开的产品，然后单击“下一步”。
  5. 查看适用于您所在国家或地区的 Autodesk 软件许可协议。必须接受协议才能继续安装。选择您所在国家或地区，单击“我接受”，然后单击“下一步”。
    注意如果不同意协议的条款并且要终止安装，请单击“取消”。
  6. 在“个性化产品”页面上，输入用户的信息并击“下一步”。

    在此输入的信息是永久性的，它们将显示在计算机的“AutoCAD”窗口中（使用“帮助” [image] “关于”可以访问该窗口）。由于以后无法更改此信息（除非删除安装该产品），因此请确保在此处输入的信息正确。

  7. 在“写入日志”页面上，选择创建以下日志：网络日志和/或客户端日志。
    • 选择创建网络日志文件时，还必须通过输入网络上的有效 UNC（通用命名约定）路径或硬编码路径指定创建日志文件的位置。网络日志文件可选。
      注意网络日志所在的文件夹必须是一个共享文件夹，安装程序的用户对该文件具有修改权限。否则，用户安装是成功还是失败均无法写入日志文件。
    • 选择是否要创建客户端日志文件。

    有关日志文件的详细信息，请参见指定日志文件的位置。

    单击“下一步”。

  8. 在“查看 - 配置 - 创建展开”页面上，单击“创建展开”。

    通过单击“创建展开”，向导使用“当前设置”字段中列出的展开选项在共享文件夹中创建管理映像。

  9. 在“展开完成”页面上，单击“完成”。

使用安装向导创建配置展开的步骤

  1. 在 AutoCAD 2008 安装向导中，单击“创建展开”。
  2. 在“欢迎使用 AutoCAD 2008 安装向导”页面上，单击“下一步”。
  3. 在“开始展开”页面上，需要指定以下内容：展开位置、展开名称以及是否要在静默模式下运行客户端安装。
    • 在“展开位置”字段中，输入要创建管理映像的现有共享网络位置，或者单击“...”按钮定位某个共享网络位置。用户将从此位置安装程序。
      注意如果不知道如何创建网络共享，请参见如何创建网络共享。
    • 在“展开名称”字段中，输入新展开的名称。此处输入的名称就是用户将要访问以安装产品的快捷方式的名称。
    • 要防止用户在安装产品时修改此处的安装设置，请选择“客户端安装运行于静默模式”。

    单击“下一步”。

  4. 在“选择要安装的产品”页面上，选择要展开的产品，然后单击“下一步”。
  5. 查看适用于您所在国家或地区的 Autodesk 软件许可协议。必须接受协议才能继续安装。选择您所在国家或地区，单击“我接受”，然后单击“下一步”。
    注意如果不同意协议的条款并且要终止安装，请单击“取消”。
  6. 在“个性化产品”页面上，输入用户的信息并击“下一步”。

    在此输入的信息是永久性的，它们将显示在计算机的“AutoCAD”窗口中（使用“帮助” [image] “关于”可以访问该窗口）。由于以后无法更改此信息（除非删除安装该产品），因此请确保在此处输入的信息正确。

  7. 在“写入日志”页面上，选择创建以下日志：网络日志和/或客户端日志。
    • 选择创建网络日志文件时，还必须通过输入网络上的有效 UNC（通用命名约定）路径或硬编码路径指定创建日志文件的位置。网络日志文件可选。
      注意网络日志所在的文件夹必须是一个共享文件夹，安装程序的用户对该文件具有修改权限。否则，用户安装是成功还是失败均无法写入日志文件。
    • 选择是否要创建客户端日志文件。

    有关日志文件的详细信息，请参见指定日志文件的位置。

    单击“下一步”。

  8. 在“查看 - 配置 - 创建展开”页面上，单击“配置”可以对管理映像进行更改。
  9. 在“选择安装类型”页面上，可以选择进行以下配置更改：
    • 典型 - 安装最常用的应用程序功能并可以对可选的工具进行以下更改：
      Express Tools | 包含 AutoCAD 支持工具和实用程序。
      材质库 | 包含 300 多种专业打造的材质，均可应用于模型。
    • 自定义 - 将仅安装用户从“选择要安装的功能”列表中选择的应用程序功能：
      CAD 标准 | 包含用于检查设计文件是否符合标准的工具。
      数据库 | 包含数据库访问工具。
      词典 | 包含多语言词典。
      图形加密 | 允许用户通过“安全选项”对话框使用口令保护图形。
      Express Tools | 包含 AutoCAD 支持工具和实用程序。
      字体 | 包含程序字体。（True Type 字体会随程序自动安装。）
      材质库 | 包含 300 多种专业打造的材质，均可应用于模型。
      新功能专题研习 | 包含帮助用户学习新功能的动画演示、练习和样例文件。
      许可证转移实用程序 | 包含用于在计算机之间移动单机许可证的工具。
      移植自定义设置 | 允许用户从早期版本中移植自定义设置和文件。有关详细信息，请参见 移植自定义设置。
      参照管理器 | 允许用户查看和编辑与图形关联的外部参照文件的路径。
      样例 | 包含各种功能的样例文件。
      教程 | 包含产品课程。
      VBA 支持教程 | 包含“Microsoft Visual Basic for Applications”支持文件。
    • 产品安装路径 - 指定安装 AutoCAD 的驱动器和位置。

    单击“下一步”继续配置过程。

  10. 在“选择许可类型”的页面上，选择“网络许可”然后进行以下设置：许可服务器模式以及将运行 Network License Manager 的服务器的名称。
    • 可以从三种许可服务器模式中选择一种，但是在此例中，保留设置为“单一许可服务器”。
      注意有关所有安装和服务器类型的完整说明，请参见选择许可类型。
    • 输入将运行 Network License Manager 的服务器的名称，或单击“...”按钮查找该服务器。

    单击“下一步”。

  11. 在“选择系统配置”页面上，进行以下设置：
    选择“默认文本编辑器”。

    文本编辑器用于编辑文本文件，如 PGP 和 CUS 词典文件。可以接受默认编辑器，也可以从可用文本编辑器列表中选择。还可以单击“浏览”以定位未列出的文本编辑器。

    创建桌面快捷方式。

    选择是否在桌面上显示 AutoCAD 快捷方式图标。默认情况下，产品图标将在桌面上显示。如果不希望显示快捷方式图标，请清除该复选框。

    单击“下一步”。

  12. 在“定义搜索路径和文件位置”页面上，单击“下一步”。
  13. 在“安装其他文件”页面上，单击“下一步”。
  14. 在“指定用户的工作站设置”上，输入默认配置名称，然后单击“下一步”。
  15. 在“包含 Service Pack”页面上，单击“下一步”。
  16. 在“配置信息中心通信”页面上，单击“下一步”。
  17. 在“配置信息中心通信搜索结果”页面上，单击“下一步”。
  18. 在“配置对联机资源的访问”页面上，单击“配置完成”。
  19. 单击“创建展开”。
  20. 在“展开完成”页面上，单击“完成”。


如何展开本程序

如何使用安装向导设置展开
如何设置和分发程序
系统需求
AutoCAD 2008 网络管理员手册 > 网络管理快速入门 > 如何设置和分发程序 >
如何展开本程序

可以从多种展开程序的方法中进行选择。默认方法是网络共享。

  • 网络共享。用户可以启动在如何使用安装向导设置展开过程的步骤 3 中的使用安装向导创建的快捷方式（例如：\\Server1\Autodesk\deployment\AutoCAD 2008）。程序将安装在用户的本地计算机上，产品图标将显示在桌面上。
    注意用户必须具有访问网络共享的读取权限和对安装本程序的工作站的管理权限。
  • 编写脚本。请参见使用脚本展开程序。
  • 组策略对象 (GPO)。请参见使用组策略安装展开。
  • 映像软件。请参见使用映像软件分发产品。


系统需求

如何展开本程序
本程序的系统需求
AutoCAD 2008 网络管理员手册 >
系统需求

本节介绍对所创建的管理映像的位置、网络许可服务器和客户端工作站的系统需求。

本节内容

  • 本程序的系统需求


本程序的系统需求

系统需求
系统需求
展开程序
AutoCAD 2008 网络管理员手册 > 系统需求 >
本程序的系统需求

在网络上开始安装程序之前，请确保服务器和客户端工作站满足展开所需的最低硬件和软件需求。

关于管理映像、许可服务器和客户端工作站系统需求的信息，请参见以下各表。

管理映像位置的硬件和软件需求
硬件/软件 | 需求 | 注意
硬盘 | 750 MB（建议） | 创建管理映像的位置必须是一个共享位置，这样用户才能访问该管理映像。

网络许可服务器的硬件和软件需求
硬件/软件 | 需求 | 注意
操作系统 | Windows Server 2003 Windows XP Professional Service Pack 2 Windows 2000 Server Edition Windows 2000 Service Pack 4 | Network License Manager 仅支持以太网网络配置。 仅在 Windows 2000 Server Edition 和 Windows 2003 Server 上支持冗余许可服务器模式。
计算机/处理器 | Pentium III 或更高 450 Mhz（最低要求） |
网络接口卡 | 与现有的以太网网络基础构造兼容 | Network License Manager 支持多个网络接口卡。
通讯协议 | TCP/IP | Network License Manager 使用 TCP 包类型。

客户端工作站的硬件和软件需求

硬件/软件

需求

注意

操作系统

（32 位）

Windows® XP Professional Service Pack 2

Windows XP Home Service Pack 2

Windows 2000 Service Pack 4

Windows Vista Enterprise

Windows Vista Business

Windows Vista Ultimate

Windows Vista Home Premium

Windows Vista Home Basic

Windows Vista Starter

（64 位）

Windows XP Professional

Windows Vista Enterprise

Windows Vista Business

Windows Vista Ultimate

Windows Vista Home Premium

Windows Vista Home Basic

建议在用户界面语言与 AutoCAD 语言的代码页匹配的操作系统上安装非英文版本的 AutoCAD。代码页为不同语言的字符集提供支持。

安装 AutoCAD 时，将自动检测 Windows 操作系统是 32 位还是 64 位版本。然后安装相应版本的 AutoCAD。32 位版本的 AutoCAD 不能安装在 64 位版本的 Windows 上。

Web 浏览器

Microsoft Internet Explorer 6.0 Service Pack 1（或更高版本）

如果安装工作站上未安装具有 Service Pack 1（或更高版本）的 Microsoft Internet Explorer 6.0，则无法安装 AutoCAD。可以从以下 Microsoft 网站下载 Internet Explorer：

http://www.microsoft.com/downloads/

处理器

Pentium III 或 IV（建议 Pentium IV）

800 Mhz

RAM

512 MB（建议）

图形卡

1024 x 768 VGA 真彩色（最低要求）

Open GL® 兼容三维视频卡（可选）

  • 需要支持 Windows 的显示适配器。
  • 必须安装支持硬盘加速的 DirectX 9.0c 或更高版本的图形卡。
  • 从 ACAD.msi 文件进行安装时，将不安装 DirectX 9.0c 或更高版本。在此情况下，要配置硬盘加速，需要手动安装 DirectX。

硬盘

安装 750 MB

定点设备

鼠标、轨迹球或其他设备

CD-ROM

任意速度（仅用于安装）

可选硬件

打印机或绘图仪

数字化仪

调制解调器或其他访问 Internet 连接的设备

网络接口卡

三维使用的其他建议配置

硬件/软件

需求

注意

操作系统

Windows® XP Professional Service Pack 2

建议在用户界面语言与 AutoCAD 语言的代码页匹配的操作系统上安装非英文版本的 AutoCAD。代码页为不同语言的字符集提供支持。

处理器

3.0 GHz 或更快的处理器

RAM

2 GB（或更大）
图形卡 128 MB 或更高，OpenGL 工作站类
  • 必须安装支持硬盘加速的 DirectX 9.0c 或更高版本图形卡。
  • 从 ACAD.msi 文件进行安装时，将不安装 DirectX 9.0c 或更高版本。要配置的硬盘加速在此情况下需要手动安装 DirectX。

有关经过测试和认证的图形卡的详细信息，请访问 http://www.autodesk.com/autocad-graphicscard/。

硬盘

2 GB（除去安装需要的 750 MB）


展开程序

本程序的系统需求
网络展开前的准备工作
AutoCAD 2008 网络管理员手册 >
展开程序

在本节中，用户将了解有关使用安装向导创建或修改展开的更多详细信息。

本节内容

  • 网络展开前的准备工作
  • 使用安装向导设置展开
  • 将用户指向管理映像
  • 卸载程序


网络展开前的准备工作

展开程序
展开程序
将安装失败的几率降到最低
AutoCAD 2008 网络管理员手册 > 展开程序 >
网络展开前的准备工作

在网络上安装本程序需要进行仔细地规划和执行。此展开核对表提供了在展开过程中用户应熟悉的信息类型的简要总结。

展开核对表
 | 用户已查看系统需求。请务必确保网络、服务器和工作站满足系统需求。请参见本程序的系统需求。
 | 如果展开计划涉及使用映像软件将程序分发至客户端工作站，请查看使用映像软件分发产品一节。
 | 已安装并激活所有支持工具和实用程序。请参见安装、激活工具和实用程序。
 | 识别展开将定位的位置，例如计划要展开的每个程序的共享文件夹。请参见为展开创建共享文件夹。
 | 已关闭所有其他程序并禁用防病毒软件。请参见将安装失败的几率降到最低。
 | 指定是否要创建包含展开和安装数据的日志文件。请参见指定日志文件的位置。
 | 了解已购买的许可的类型。如果计划进行网络许可展开，则用户还应该熟悉要使用的许可服务器模式的类型和许可服务器的名称。请参见选择许可类型。
 | 用户已明确是执行典型安装还是执行自定义安装。请参见选择安装类型。
 | 用户可能希望设置自定义文件的搜索路径，或者可能已在该版本软件中发生了更改的文件位置。请参见定义搜索路径和文件位置（可选）。
 | 可以包含在展开中的其他文件，例如图形文件、AutoLISP® 例程或脚本文件。请参见安装其他文件（可选）。
 | 已查看可能适用于产品的 Service Pack。如果 Service Pack 可用，则下载该 Service Pack 并提取 MSP 文件。请参见包含 Service Pack（可选）。
 | 使用实时更新通知，用户可以了解发布产品更新的时间，而通过配置通讯中心，用户则可以获取技术信息。请参见配置信息中心通讯中心（可选）和配置信息中心搜索结果（可选）。
 | 可以允许已展开的产品的用户访问和参与各种功能（如联机设计中心、Subscription 中心、客户错误报告和客户体验改善方案）。请参见允许用户访问联机资源（可选）。
 | 使用一致的注册数据十分重要。请确保知道如何在注册过程中个性化程序。请参见注册产品。

完成这些任务后，即可开始从安装向导创建展开。

本节内容

  • 将安装失败的几率降到最低
  • 为展开创建共享文件夹
  • 安装、激活工具和实用程序


将安装失败的几率降到最低

网络展开前的准备工作
网络展开前的准备工作
为展开创建共享文件夹
AutoCAD 2008 网络管理员手册 > 展开程序 > 网络展开前的准备工作 >
将安装失败的几率降到最低

如果创建展开时某些应用程序（例如 Microsoft® Outlook® 或病毒检查程序）正在运行，则 AutoCAD 2008 安装过程可能停止。关闭所有正在运行的应用程序并暂时禁用病毒检查实用程序。


为展开创建共享文件夹

将安装失败的几率降到最低
网络展开前的准备工作
安装、激活工具和实用程序
AutoCAD 2008 网络管理员手册 > 展开程序 > 网络展开前的准备工作 >
为展开创建共享文件夹

网络许可和多套单机安装方式均需要共享文件夹。共享文件夹（网络共享）在运行安装向导前创建，是存储产品展开的位置。

建议用户在要存储展开的系统的桌面上，将网络共享文件夹命名为“Deployments”。然后可以在共享的“Deployments”文件夹中添加子文件夹，清楚地表示计划要展开的产品名称。如果用户计划展开多个产品，此方法同样适用。例如：

放置在共享文件夹中的所有子文件夹均将自动共享。

提示在创建展开映像时，必须为共享文件夹设置“完全控制”权限。要访问网络共享，读取权限是必需的，而且还需要对展开程序的工作站的管理权限。

创建共享文件夹的步骤

  1. 在网络服务器上，创建名为“Deployments”的文件夹。
  2. 在“Deployments”文件夹上单击鼠标右键。单击“共享和安全”（或“共享”）。
  3. 在“属性”对话框的“共享”选项卡中，选择“共享该文件夹”。
  4. 在“权限”对话框中，单击“权限”按扭。请确保“完全控制”已激活。单击“确定”。

    该操作在创建展开映像时十分重要。

  5. 单击“确定”关闭“属性”对话框。
  6. 在“Deployments”文件夹中，为计划安装的每个产品创建一个子文件夹。以相关产品名称命名每个文件夹。


安装、激活工具和实用程序

为展开创建共享文件夹
网络展开前的准备工作
使用安装向导设置展开
AutoCAD 2008 网络管理员手册 > 展开程序 > 网络展开前的准备工作 >
安装、激活工具和实用程序

如果计划让用户使用网络许可证来运行程序，则需要使用若干支持工具和实用程序。可能需要安装的辅助程序包括：

  • Network License Manager
  • 网络许可证激活实用程序
  • CAD 管理器工具
  • SAMreport Lite

有关如何设置许可服务器的详细信息，请参见《网络许可手册》。可以通过安装向导的“文档”链接和帮助系统找到《网络许可手册》。


使用安装向导设置展开

安装、激活工具和实用程序
展开程序
启动展开过程
AutoCAD 2008 网络管理员手册 > 展开程序 >
使用安装向导设置展开

展开过程从安装向导开始。创建展开，使用户可以从该展开将程序安装到计算机上。在展开过程中进行选择，以创建各种客户端展开映像和展开类型，从而满足用户的要求和公司的需求。

展开过程使用户可以执行下列任何操作：

  • 创建展开。
  • 将修补程序应用到展开。
  • 将自定义文件添加到展开。
  • 修改搜索路径和文件位置。
注意由于展开过程提供了大量创建和自定义展开的选项，因此需要完成许多展开页面并进行许多选择。每次安装时，都应留出足够的时间以完成展开过程。

展开过程开始后，可以执行下列操作：

本节内容

  • 启动展开过程
  • 创建展开
  • 输入用户信息
  • 指定日志文件的位置
  • 选择许可类型
  • 选择安装类型
  • 定义搜索路径和文件位置（可选）
  • 安装其他文件（可选）
  • 指定用户系统配置（可选）
  • 包含 Service Pack（可选）
  • 配置信息中心通讯中心（可选）
  • 配置信息中心搜索结果（可选）
  • 允许用户访问联机资源（可选）
  • 最终查看和完成安装
  • 注册产品
  • 修改展开（可选）


启动展开过程

使用安装向导设置展开
使用安装向导设置展开
创建展开
AutoCAD 2008 网络管理员手册 > 展开程序 > 使用安装向导设置展开 >
启动展开过程

启动安装向导后，即开始了设置展开的展开过程。

启动展开过程的步骤

  • 在 AutoCAD 2008 安装向导中，单击“创建展开”。


创建展开

启动展开过程
使用安装向导设置展开
输入用户信息
AutoCAD 2008 网络管理员手册 > 展开程序 > 使用安装向导设置展开 >
创建展开

展开中包含一个 Microsoft 转换 (MST) 文件，用于修改安装程序的默认行为。开始展开时，需要选择展开位置、展开名称并指定是否为客户端安装激活静默模式。

静默模式

如果用户在静默模式处于激活状态时开始展开，则安装将在无需任何用户专门输入的情况下进行。不显示要求用户进行交互操作的对话框。

创建展开的步骤

  1. 在“开始展开”页面上，输入展开位置或单击“...”按钮以浏览驱动器，寻找某个位置。
    注意展开位置应为共享网络文件夹。要创建共享文件夹，请参见为展开创建共享文件夹。
  2. 在“指定展开名称”字段中，输入新展开的名称。此处输入的名称是用户将要访问以安装产品的快捷方式的名称。
  3. 要防止用户在安装产品时修改此处的安装设置，请确保“客户端安装运行于静默模式”处于激活状态。
  4. 单击“下一步”。


输入用户信息

创建展开
使用安装向导设置展开
指定日志文件的位置
AutoCAD 2008 网络管理员手册 > 展开程序 > 使用安装向导设置展开 >
输入用户信息

“个性化产品”页面用于为公司个性化程序。此处输入的信息是永久性的，并且显示在安装展开的所有工作站的“关于 <产品名称>”窗口（可通过使用“帮助” [image] “关于”进行访问）中。由于以后无法更改此信息（除非卸载该产品），因此请确保在此处输入的信息正确。

要运行产品，还必须输入产品序列号。产品序列号位于产品的包装上。序列号必须包含三位数前缀，后跟八位数字。

输入用户个人信息和序列号的步骤

  1. 在“个性化产品”页面上，输入所需的用户信息。
    注意尽管必须在此页面上的每个框中都输入信息，但可以输入希望提供给安装此展开的用户的任何信息。
  2. 输入产品序列号。
  3. 单击“下一步”。


指定日志文件的位置

输入用户信息
使用安装向导设置展开
选择许可类型
AutoCAD 2008 网络管理员手册 > 展开程序 > 使用安装向导设置展开 >
指定日志文件的位置

程序有两种类型的日志文件，可用于监视有关展开和安装的信息。

  • 网络日志。网络日志文件记录运行展开的所有工作站。在展开过程的“写入日志”页面上，选择是否创建网络日志文件。该日志列出了用户名、工作站名称和安装的状态。关于状态信息以及用户在安装过程中可能遇到的问题（例如，磁盘空间不足或权限不够）的详细信息，请参见该文件。网络日志的名称与用户为展开所选的名称相同。通过输入网络上的有效 UNC（通用命名约定）路径或硬编码路径可以指定创建日志文件的位置，例如“\\MyComputer\Autodesk\AutoCAD 2008”。
    注意网络日志所在的文件夹必须是一个共享文件夹，安装程序的用户对该文件具有修改权限。否则，用户安装是成功还是失败均无法写入日志文件。
  • 客户端日志。客户端日志中包含每个工作站的详细安装信息。这些信息有助于诊断安装问题。客户端日志位于每个客户端工作站的“\Temp”目录中。客户端日志的名称与用户为展开所选的名称相同。

指定日志文件位置的步骤

  1. 创建展开时，在“写入日志”页面上，选择“创建网络日志”框旁边的复选框。输入要存放网络日志的文件夹的名称。
  2. 要创建客户端日志，请选择“创建客户端日志”选项。
  3. 单击“下一步”。


选择许可类型

指定日志文件的位置
使用安装向导设置展开
选择安装类型
AutoCAD 2008 网络管理员手册 > 展开程序 > 使用安装向导设置展开 >
选择许可类型

设置展开时，需要根据所购买的软件许可证类型来选择要展开的安装类型。可以购买以下三种产品许可类型中的一种：网络、多套单机和单机。

指定展开过程中要使用的许可类型

网络许可

通过此安装类型，可以将程序安装到工作站上，包括程序用来与 Network License Manager 进行通信的文件和注册表项。也可以定义 Network License Manager 的配置，以便可以访问许可。运行基于网络安装的程序的工作站不需要单独激活。至少有一台许可服务器管理本程序的许可。

  • 选择网络许可证。
多套单机许可证（单个序列号用于多台计算机）

注册数据集中在“现在注册”页面上。使用多套单机序列号首次激活后，基于此展开的所有工作站都将自动激活（只要系统连接到 Internet）。

  • 选择单机许可证。
单机许可（单个序列号用于单台计算机）。

不要使用 Network License Manager 来管理产品许可。对于单机版安装，需要在每个工作站上安装、注册和激活程序。

  • 选择单机许可证。

使用单一许可服务器模式展开网络许可的步骤

  1. 创建展开时，在“选择许可类型”页面上选择“网络许可”选项。
  2. 选择“单一许可服务器”作为要与 Network License Manager 配合使用的许可服务器模式。

    如果已经使用 Network License Manager 创建了许可服务器模式，则在此步骤中必须选择相同的许可服务器模式。如果尚未使用 Network License Manager 创建许可服务器模式，请确保在 Network License Manager 中选择与此处相同的设置。

    有关许可证服务器模式的详细信息，请参见《网络许可手册》中的“许可服务器模式”，可以在帮助系统中和安装向导的“文档”链接上找到该手册。

  3. 输入将运行 Network License Manager 的服务器的名称，或单击“...”按钮查找该服务器。单击“下一步”。

使用分布式许可服务器模式展开网络许可的步骤

  1. 创建展开时，在“选择许可类型”页面上选择“网络许可”选项。
  2. 选择“分布式许可管理器”作为要与 Network License Manager 配合使用的许可服务器模式。

    如果已经使用 Network License Manager 创建了许可服务器模式，则在此步骤中必须选择相同的许可服务器模式。如果尚未使用 Network License Manager 创建许可服务器模式，请确保在 Network License Manager 中选择与此处相同的设置。

    有关许可服务器模式的详细信息，请参见《网络许可手册》中的“许可服务器模式”，可以在帮助系统中和安装向导的“文档”链接上找到该手册。

  3. 输入将运行 Network License Manager 的某个服务器的名称，或单击“...”按钮查找该服务器。单击“添加”可以将服务器添加到服务器池。将所有服务器添加到“服务器池”列表中后，使用“上移”和“下移”按钮，按照用户希望工作站搜索到服务器的先后顺序排列服务器。至少必须输入两台服务器。单击“下一步”。

使用冗余许可服务器模式展开网络许可的步骤

  1. 创建展开时，在“选择许可类型”页面上选择“网络许可”选项。
  2. 选择“冗余许可服务器”作为要与 Network License Manager 配合使用的许可服务器模式。

    如果已经使用 Network License Manager 创建了许可服务器模式，则在此步骤中必须选择相同的许可服务器模式。如果尚未使用 Network License Manager 创建许可服务器模式，请确保在 Network License Manager 中选择与此处相同的设置。

    有关许可服务器模式的详细信息，请参见《网络许可手册》中的“许可服务器模式”，可以在帮助系统中和安装向导的“文档”链接上找到该手册。

  3. 在“第一台服务器名称”字段中，输入将运行 Network License Manager 的服务器的名称，或单击“...”按钮查找该服务器。输入其余两台要在冗余服务器池中使用的服务器的名称。单击“下一步”。

    注意如果不确定如何获取服务器主机名，请参见《网络许可手册》中的“规划许可服务器配置”。可以通过安装向导的“文档”链接和帮助系统找到《网络许可手册》。

展开多套单机或单机许可的步骤

  1. 创建展开时，在“选择许可类型”页面上选择“单机安装”选项。

  2. 单击“下一步”。


选择安装类型

选择许可类型
使用安装向导设置展开
定义搜索路径和文件位置（可选）
AutoCAD 2008 网络管理员手册 > 展开程序 > 使用安装向导设置展开 >
选择安装类型

作为展开选择的一部分，需要选择安装此程序时用户接收的安装类型，选择要包含的可选工具或功能，并指定产品在每个工作站上进行安装的位置。

  • 典型。安装最常用的应用程序功能。建议大多数用户选择此选项。
  • 自定义。仅安装选定的应用程序功能。

也可以选择使该展开包含 Express Tools 和材质库。

  • Express Tools。Express Tools 仅提供英文版，且不提供支持。未对这些工具进行任何更新。不支持双字节字符。
    注意某些 Express Tools 已集成到 AutoCAD 2008 中。有关已经集成的工具的完整列表，请参见 Express Tools 帮助中的 FAQ 一节。也可以在产品帮助系统获取有关每个集成命令的帮助。
  • 材质库。材质库包含 300 多种专业打造的材质，均可应用于模型。该库是以一系列工具选项板的形式构建的。

在“产品安装路径”中选择在客户端工作站上安装程序文件的位置。为了有助于确定产品安装的位置，将提供驱动器和磁盘空间的图表。

要展开典型安装，请选择可选工具并指定产品位置

  1. 展开过程中，在“选择安装类型”页面上选择“典型”选项作为要使用的安装类型。

  2. 如果不希望在该展开中包括工具，请清除“ Express Tools”选项的复选框。默认情况下，将安装 Express Tools。
  3. 如果要安装材质库，请选择“材质库”复选框。

    默认情况下，已清除“材质库”选项。

  4. 输入要在客户端工作站上安装此程序的路径（例如“C:\Program Files\AutoCAD 2008”）或单击“...”按钮以指定安装位置。

    通过硬盘空间需求图表可以查看可用的驱动器和磁盘空间。

  5. 单击“下一步”。

要展开自定义安装，请选择可选工具并指定产品位置

  1. 展开过程中，在“选择安装类型”页面上选择“自定义”选项作为要使用的安装类型。

  2. 从“选择要安装的功能”列表中选择要安装的功能。

    有下列选项可供选择：

    CAD 标准 | 包含用于检查设计文件是否符合标准的工具。
    数据库 | 包含数据库访问工具。
    词典 | 包含多语言词典。
    图形加密 | 允许用户通过“安全选项”对话框使用密码保护图形。
    Express Tools | 包含 AutoCAD 支持工具和实用程序。
    字体 | 包含程序字体。（True Type 字体会随程序自动安装。）
    “Autodesk Impression”工具栏 | 允许访问 Autodesk Impression 命令。如果当前未安装 Autodesk Impression ，则可以选择安装此程序。
    新功能专题研习 | 包含帮助用户学习新功能的动画演示、练习和样例文件。
    许可证转移实用程序 | 包含用于在计算机之间移动单机许可证的工具。
    移植自定义设置 | 允许用户从早期版本中移植自定义设置和文件。有关详细信息，请参见 移植自定义设置。
    参照管理器 | 允许用户查看和编辑与图形关联的外部参照文件的路径。
    样例 | 包含各种功能的样例文件。样例是默认安装的一部分。（默认情况下，不安装 Visual Lisp 样例。）
    VBA 支持 | 包含 Microsoft Visual Basic for Applications 支持文件。

    如果对功能进行更改后，想要恢复原始设置，请单击“恢复默认设置”按钮。

  3. 输入要在客户端工作站上安装此程序的路径（例如“C:\Program Files\AutoCAD 2008”）或单击“...”按钮以指定安装位置。

    通过硬盘空间需求图表可以查看可用的驱动器和磁盘空间。

  4. 单击“下一步”。


定义搜索路径和文件位置（可选）

选择安装类型
使用安装向导设置展开
安装其他文件（可选）
AutoCAD 2008 网络管理员手册 > 展开程序 > 使用安装向导设置展开 >
定义搜索路径和文件位置（可选）

在“定义搜索路径和文件位置”页面上，可以修改默认搜索路径和某些程序文件的位置。用户可能会因为以下原因而希望修改默认设置：

  • 如果 CAD 环境使用的文件（例如自定义文件或插入模块）不是随程序一同安装的默认文件，则可以立即指向该文件，这样就不必在每个工作站上添加该文件了。
  • 在这一版本的程序中，某些默认文件位置可能已经有所变化。如果已安装了早期版本的程序，并且要将这些文件移动到与早期版本的程序相同的文件位置，则可以使用此页面。
注意安装程序后，还可以修改各个工作站的搜索路径和文件位置。此操作可以使用“选项”对话框来完成。有关详细信息，请参见《用户手册》中的 指定搜索路经和文件位置。

使用搜索路径和文件位置的默认程序设置的步骤

  • 创建展开时，在“定义搜索路径和文件位置”页面上单击“下一步”。

修改搜索路径和文件位置的默认程序设置的步骤

  1. 创建展开时，在“定义搜索路径和文件位置”页面上的“定义搜索路径、文件名和文件位置”列表中，单击搜索路径或文件位置左侧的加号 (+) 以选择并展开该搜索路径或文件位置。

  2. 在列表中选择项目，并执行下列操作之一：
    • 要浏览文件位置，单击“浏览”。
    • 要向当前选中的搜索路径或文件位置添加新条目，单击“添加”。
    • 要从当前选中的搜索路径或文件位置删除条目，单击“删除”。
    • 要在列表中上下移动选择的内容，单击“上移”或“下移”。
    注意这些按钮是否可用取决于上一步骤中选定的项目。
  3. 完成指定搜索路径或文件位置后，单击“下一步”。


安装其他文件（可选）

定义搜索路径和文件位置（可选）
使用安装向导设置展开
指定用户系统配置（可选）
AutoCAD 2008 网络管理员手册 > 展开程序 > 使用安装向导设置展开 >
安装其他文件（可选）

在“安装其他文件”页面上单击“浏览”，可以指定要包含在展开中的其他文件。默认情况下，运行展开时，这些文件安装在客户端工作站上的程序的安装目录中。如果需要，可以将文件安装到多个目录中。

可以执行下列操作：

  • 指定要包含在展开中的其他文件（例如，图形文件、AutoLISP® 例程或脚本文件）。
  • 将不同类型的文件安装到不同的工作站目录中。
  • 在安装文件夹下添加子文件夹（例如，添加名为 LSP 的文件夹以存放自定义 AutoLISP 例程）。
  • 将文件添加到程序文件所在的位置（例如，添加工程样例图形）。
  • 向安装根目录添加文件。
注意建议将这些文件安装到程序目录结构中的某个位置。不能使用与安装的程序文件相同的文件名安装这些文件。例如，不能添加名为 acad.cui 的文件。

安装其他文件

  1. 创建展开时，在“安装其他文件”页面上设置安装文件的位置。

  2. 执行下列操作之一：
    • 单击“...”按钮打开“添加文件”对话框，从中可以选择要添加到安装目录中的文件。
    • 单击“添加文件夹”在安装目录中创建新文件夹。
    • 单击“添加驱动器”在安装目录中创建新驱动器名称。
    • 单击“删除”从安装目录中删除文件、文件夹或驱动器。
  3. 单击“下一步”。


指定用户系统配置（可选）

安装其他文件（可选）
使用安装向导设置展开
包含 Service Pack（可选）
AutoCAD 2008 网络管理员手册 > 展开程序 > 使用安装向导设置展开 >
指定用户系统配置（可选）

在“指定用户系统配置”页面上，可以指定如果未安装 Microsoft Internet Explorer，是否可以继续执行基于此展开的安装、指定默认配置名称、选择在桌面上显示产品快捷方式图标或创建自定义桌面快捷方式。

指定用户系统配置设置的步骤

  1. 创建展开时，如果在安装 AutoCAD 之前不需要安装 Microsoft Internet Explorer，请在“指定用户系统配置”页面上清除“Internet Explorer”复选框。

  2. 在“默认配置名称”框中，指定默认配置名称，该名称将作为运行该展开的所有用户的当前配置名称。
  3. 如果不希望在用户的桌面上显示产品快捷方式图标，请清除“创建 AutoCAD 2008 桌面快捷方式”复选框。
  4. 如果希望创建自定义桌面快捷方式，请指定快捷方式名称和所有参数（例如调用配置、启动脚本的开关等）。

  5. 单击“下一步”。


包含 Service Pack（可选）

指定用户系统配置（可选）
使用安装向导设置展开
配置信息中心通讯中心（可选）
AutoCAD 2008 网络管理员手册 > 展开程序 > 使用安装向导设置展开 >
包含 Service Pack（可选）

在展开过程中，可以选择包含已发布的适用于用户产品的 Service Pack。

包含 Service Pack 时，还可以指定如何处理该 Service Pack。可以选择下列处理方式：

  • 将 Service Pack 附加至展开。附加 Service Pack 时，Service Pack 仅应用于当前展开。可以将多个 Service Pack 附加到同一个展开。Service Pack 文件包含在展开中并且在产品展开后应用。
  • 将 Service Pack 合并到管理映像 MSI 文件。合并 Service Pack 时，该 Service Pack 将被合并到管理映像中。合并后，Service Pack 可能将无法从管理映像中删除。多个 Service Pack 可以包含在单个管理映像中。

从 Service Pack 提取 MSP 文件的步骤

  1. 从 Autodesk 产品支持站点下载 Service Pack。
  2. 有关修补程序的信息，请查看 Service Pack“Readme”文件。
  3. 打开 Windows 命令提示并输入修补程序文件名，后跟 /e 切换符号和目标文件名，例如：

    ProductSP1.exe /e ./ProductSP1.msp

    其中，<ProductSP1.exe> 是已下载的修补程序的名称而 <ProductSP1.msp> 是已提取的文件的名称。在在提取文件的名称前使用“./”，可以将提取的文件与原始可执行文件放置在同一文件夹中。

    注意要确认 Service Pack 是否可用，请访问 http://www.autodesk.com.cn/support 上的“Autodesk 产品支持”页面。

将 Service Pack 包含在展开中的步骤

要将 Service Pack 包含在展开中，必须从已下载的 Service Pack 可执行文件中提取 MSP 文件。

  1. 在“包含 Service Pack”页面上，单击“...”按钮。
  2. 在“打开”对话框中，找到要包含在展开中的 Service Pack。
  3. 选择 MSP 文件并单击“打开”。
  4. 指定是要将 Service Pack 附加至展开还是要将 Service Pack 合并到管理映像中。
  5. 单击“下一步”。


配置信息中心通讯中心（可选）

包含 Service Pack（可选）
使用安装向导设置展开
配置信息中心搜索结果（可选）
AutoCAD 2008 网络管理员手册 > 展开程序 > 使用安装向导设置展开 >
配置信息中心通讯中心（可选）

通讯中心可以通过信息中心访问。实时更新使用“通讯中心”将修补程序下载到产品中，从而对产品进行更新。除实时更新外，其他的信息频道和提要也可以通过通讯中心显示。

可对通讯中心进行的设置包括：

  • 启用实时更新。建立 Web 连接后，用户可以使用实时更新检查更新。如果产品修补程序可用，程序的状态栏上将收到可用通知，可以直接从 Autodesk 服务器上下载修补程序，也可以在将修补程序复制到用户工作站之前对其进行修改。如果不希望用户收到更新或通告，可以关闭“实时更新”。
    注意也可以在 CAD 管理员控制实用程序中打开或关闭“实时更新”选项。请参见 如何安装和启动 CAD 管理员控制实用程序
  • 启用信息频道。信息频道处于激活状态时，将通知用户多种信息（例如 subscription 通告和产品支持信息）。
  • 启用 CAD 管理器频道。控制 CAD 管理器频道在信息中心中的显示。除能够切换 CAD 管理器频道外，还可以定义 CAD 管理器提要位置并为 CAD 管理器频道设置显示名称。
  • 启用 RSS 提要。用户可以订阅任意数量的 RSS 提要。各个提要分别包含在独立的信息中心类别中。此外，还可以指定用户是否可以添加 RSS 提要。

配置通讯中心的步骤

  1. 创建展开时，在“配置信息中心通讯中心”页面上，进行以下实时更新设置：
    • 启用实时更新。用户可以从 Autodesk 服务器接收产品更新或支持通告。
    • 从 Autodesk 接收实时更新。用户可以使用实时更新从 Autodesk 服务器接收产品更新和支持通告。
    • 从内部服务器接收实时更新。可以在本地服务器上维护修补程序列表。如果选中此选项，“本地修补程序列表位置”框将可用。使用“...”按钮定位指向服务器上希望存放修补程序列表的位置的路径。通过安装 Autodesk CAD Manager Tools 4.0，运行 CAD 管理员控制实用程序，然后在“CAD 管理员控制实用程序”窗口中单击“帮助”，可获取有关如何使用本地修补程序列表的详细信息。
      注意可以指命名将用于输入修补程序信息的文件。现在通过命名文件并使用扩展名 .npl，可以创建一个占位符文件，而不是创建该文件本身。必须在“本地修补程序列表位置”框所指定的位置处创建一个名称与此处指定的名称相同的文本文件。
  2. 指定是否启用信息频道。
  3. 指定是否启用 CAD 管理器频道。处于激活状态时，可以进行下列设置：
    • 提要位置。定义 CAD 管理器频道 RSS 提要的位置。RSS 提要采用 XML 格式。
    • 显示名称。设置 CAD 管理器频道的显示名称。
  4. 指定是否启用 RSS 提要以及是否允许用户添加提要。
  5. 单击“下一步”。


配置信息中心搜索结果（可选）

配置信息中心通讯中心（可选）
使用安装向导设置展开
允许用户访问联机资源（可选）
AutoCAD 2008 网络管理员手册 > 展开程序 > 使用安装向导设置展开 >
配置信息中心搜索结果（可选）

可以配置信息中心的“搜索结果”选项卡，以显示各种来源（例如产品帮助系统、CAD 管理器频道或 Internet）的内容。

可以指定从展开进行安装的用户是否可以自定义对其信息中心搜索位置的访问。

配置信息中心搜索结果的步骤

  1. 创建展开时，在“配置信息中心搜索结果”页面上指定用户是否可以选择自定义其信息中心搜索位置。
  2. 单击“下一步”。


允许用户访问联机资源（可选）

配置信息中心搜索结果（可选）
使用安装向导设置展开
最终查看和完成安装
AutoCAD 2008 网络管理员手册 > 展开程序 > 使用安装向导设置展开 >
允许用户访问联机资源（可选）

在“配置访问联机资源”页面上可以指定用户是否能够访问联机资源（例如设计中心和 Subscription 中心）。还可以确定用户报告的错误已解决时，是否将从 Autodesk 接收通知；以及用户是否希望参与客户参与计划。

设计中心和 Subscription 中心

使用 DesignCenter® 中的“网上设计中心”选项卡可以访问预绘制的内容（例如块、符号库、制造商内容和联机目录）。可以在一般的设计应用程序中使用这些内容，以帮助用户创建图形。如果关闭网上设计中心，则“网上设计中心”选项卡将从基于该展开的所有安装中删除。默认情况下，“启用网上设计中心”选项处于激活状态。

使用 Subscription Center，Autodesk Subscription 成员可以访问一些资源，例如，电子学习（可自行掌握进度的交互式课程）以及 Web 支持（客户可以从中向 Autodesk 支持工作人员在线提交技术问题）。

可以确定对 Subscription 资源具有访问权限的用户是否可以通过单击“帮助”，然后单击“Subscription 资源”来访问这些资源。没有此访问权限的用户仍可以使用“帮助”菜单上的相同选项来了解 Subscription 资源。

注意也可以从 CAD 管理员控制实用程序启用或禁用对联机设计中心和 Subscription 中心的访问。

客户错误报告 (CER)

如果 AutoCAD 意外关闭，用户可以直接向 Autodesk 发送错误报告，这将帮助 Autodesk 确定并解决错误。用户可以确定报告的错误已解决时，是否将从 Autodesk 接收通知。

注意也可以在 CAD 管理员控制实用程序中打开或关闭“客户错误报告”通知选项。

客户参与计划 (CIP)

如果选择参与客户参与计划，AutoCAD 将自动发送来自 Autodesk 的信息，其中涉及用户最常使用的功能和遇到的问题，以及介绍产品未来发展方向的其他信息。

有关 CIP 的详细信息，请参见 合并客户参与计划。

注意也可以通过 CAD 管理员控制实用程序启用或禁用客户参与计划。

配置访问联机资源的步骤

  1. 创建展开时，在“配置访问联机资源”页面上，执行下列操作之一以配置联机设计中心：
    • 要禁用联机设计中心，请确保已清除“启用网上设计中心”旁边的复选框。
    • 要启用联机设计中心，请选择“启用网上设计中心”旁边的复选框。
  2. 要允许访问 Subscription 中心，请选择或清除“允许从 Autodesk 产品中访问 Subscription 中心 (建议)”旁的复选框。默认情况下，此选项已启用。
  3. 如果用户希望接收问题解决的通知，请执行下列操作：
    • 选择“允许用户接收解决通知”旁边的复选框，以便使用户可以了解问题的解决方法并下载 Autodesk 提供的合适的更新。默认情况下，此选项已启用。
      注意用户必须有管理权限才能安装 Autodesk 提供的更新。
    • 选择“包括计算机名称”旁边的复选框，以在错误报告中包括用户的计算机名称。计算机名称将包括在发送给用户的通知以及 Subscription 管理员可以查看的报告中。默认情况下，此选项已禁用。
  4. 如果用户希望参与客户参与计划，请确保已启用“允许用户参与 Autodesk CIP 计划”旁的复选框。
  5. 单击“配置完成”。


最终查看和完成安装

允许用户访问联机资源（可选）
使用安装向导设置展开
注册产品
AutoCAD 2008 网络管理员手册 > 展开程序 > 使用安装向导设置展开 >
最终查看和完成安装

要完成展开安装，请确认已选的设置。

确认并完成网络展开安装的步骤

  1. 完成所有展开设置后，请在“查看 - 配置 - 创建展开”页面上，滚动当前设置的列表并确认您的安装选择。

  2. 如果要更改对展开所做的任何选择，请单击“配置”按钮。
  3. 如果需要显示在此页面上的安装信息的硬拷贝，请单击“打印”按钮。
  4. 如果可以完成展开，请单击“创建展开”。
  5. 在“展开完成”页面上，单击“完成”。

确认并完成多套单机展开安装的步骤

  1. 完成所有展开设置后，请在“查看 - 配置 - 创建展开”页面上，滚动当前设置的列表并确认您的安装选择。

  2. 如果要更改对展开所做的任何选择，请单击“配置”按钮。
  3. 如果需要显示在此页面上的安装信息的硬拷贝，请单击“打印”按钮。
  4. 如果可以完成展开，请单击“创建展开”。
  5. 在“展开完成”页面上，单击“在线注册产品”。

    在此阶段注册可以确保使用一致的数据从而简化产品激活。用户从展开进行安装并运行产品时，注册数据将自动引入以激活产品。请参见注册产品。

  6. 单击“完成”。

Autodesk 产品展开已创建完毕，该展开中具有特定于用户组的精确选项。现在可以将管理映像所在的位置通知给使用此展开的用户，以便他们可以安装程序。


注册产品

最终查看和完成安装
使用安装向导设置展开
修改展开（可选）
AutoCAD 2008 网络管理员手册 > 展开程序 > 使用安装向导设置展开 >
注册产品

注册和激活产品时，用户提供的注册数据（例如，公司名称和联系信息）要与安装的所有 Autodesk 产品中的数据保持一致，这一点十分重要。如果用户输入的数据不正确或不一致，则会遇到激活问题。

产品注册的方式取决于创建展开时所选的许可类型。产品必须已注册才能够接收激活码。

注册网络许可展开的步骤

  1. 在“开始”菜单 (Windows) 上，依次单击“所有程序”（或“程序”） [image] “Autodesk” [image] “Network License Manager” [image] “AutoCAD 2008 网络许可证激活实用程序”。
  2. 在“获取网络许可”页面上，查看该实用程序的工作方式及其使用要求，然后单击“下一步”。
  3. 按照屏幕上的说明完成注册和激活。

注册多套单机许可展开的步骤

  1. 在“展开完成”页面上，单击“在线注册产品”。

    将显示“现在注册”页面。完成“现在注册”，以便使所有用户具有相同的默认注册信息。

  2. 在现在注册向导中，按照屏幕上的说明完成注册。
注意该过程仅注册产品。如果用户已连接至 Internet，则产品将在启动时自动激活。


修改展开（可选）

注册产品
使用安装向导设置展开
将用户指向管理映像
AutoCAD 2008 网络管理员手册 > 展开程序 > 使用安装向导设置展开 >
修改展开（可选）

创建展开后，可能需要修改某些客户端工作站的展开。用户可以应用修补程序或选择基础管理映像以外的各种自定义文件。也可以进行修改，例如将安装目录从驱动器 C 改到驱动器 D。

修改展开的步骤

  1. 打开用户初始选择的放置产品展开的共享网络文件夹。
  2. 双击此共享文件夹中的“修改<展开名称>”的快捷方式。

    此操作将重新打开安装向导。

  3. 单击各个展开页面并进行所需更改。
  4. 完成所有修改后，单击“创建展开”。


将用户指向管理映像

修改展开（可选）
展开程序
卸载程序
AutoCAD 2008 网络管理员手册 > 展开程序 >
将用户指向管理映像

完成展开过程后，即可安装新创建或新修改的展开。需要将在管理映像中创建的快捷方式通知给用户。快捷方式名称与在创建展开中选择的名称相同。

将用户指向管理映像

  • 通知用户如何安装展开的最简单的方法就是向用户发送电子邮件，告诉他们如何使用快捷方式。说明中至少应包括展开的位置以及如何双击展开的快捷方式。
注意有关使用快捷方式和安装展开的更多高级方法，请参见使用脚本展开程序、使用组策略安装展开或 使用 Microsoft 系统管理服务器安装展开。


卸载程序

将用户指向管理映像
展开程序
使用脚本展开程序
AutoCAD 2008 网络管理员手册 > 展开程序 >
卸载程序

在卸载 AutoCAD 2008 时，系统将删除所有组件。这意味着即使以前添加或删除了组件，或者已经重新安装或修复了程序，卸载操作仍会从系统中删除所有程序安装文件。

注意如果以后需要修改管理映像（例如，向其中添加修补程序），则不要删除该映像。

卸载程序

  1. 在 Windows 的“控制面板”中单击“添加/删除程序”。
  2. 在“添加/删除程序”窗口中，选择“AutoCAD 2008”，然后单击“更改/删除”。
  3. 安装向导打开后，请选择“卸载 AutoCAD 2008”。
  4. 在“卸载 AutoCAD 2008”页面上，单击“下一步”以从系统卸载 AutoCAD。
  5. 通知产品已成功卸载时，请单击“完成”。
注意卸载 AutoCAD 时，不会自动删除与此程序一起使用的 Autodesk 程序，例如 Autodesk DWF Viewer。必须使用“添加/删除程序”单独卸载这些程序。


使用脚本展开程序

卸载程序
创建用于安装程序的脚本
AutoCAD 2008 网络管理员手册 >
使用脚本展开程序

脚本用于执行一条命令或一组命令。脚本与批处理文件类似，但比批处理文件灵活。安装脚本对于在与网络相连接的计算机上进行单机版程序安装时最为有用。此外，在网络上安装 Service Pack、扩展程序和对象激活器时，脚本也很有用。

为了使 AutoCAD 正常运行，必须在要安装本程序的计算机上安装下列软件并且满足下列必要条件：

  • Microsoft Internet Explorer 6.0 Service Pack 1 或更高版本（可以从 Microsoft 网站 www.microsoft.com 下载 Microsoft Internet Explorer）。
  • Microsoft Scripting Engine

    本节中的样例脚本基于同时使用 VBScripts 和 JavaScript 的 Microsoft Scripting Engine 5.6。如果未安装脚本引擎，可以从 Microsoft 网站（网址为 www.msdn.microsoft.com/scripting）免费下载。还可以从此处下载样例脚本和帮助文件。

  • 管理权限

本节内容

  • 创建用于安装程序的脚本
  • 安装脚本样例
  • 在脚本中使用开关和标志
  • 自定义安装脚本
  • 运行脚本


创建用于安装程序的脚本

使用脚本展开程序
使用脚本展开程序
安装脚本样例
AutoCAD 2008 网络管理员手册 > 使用脚本展开程序 >
创建用于安装程序的脚本

使用文本编辑器（例如记事本）创建脚本，然后以 ASCII 格式将其保存在扩展名为 .vbs 的文件中。脚本由一条或多条命令、指定选项的命令开关以及修改选项的标志组成。安装脚本还包含路径名。

安装脚本指向产品的 setup.exe 文件的位置。必须指向产品 CD 上的 setup.exe 文件。例如：

AutoCAD 2008 CDROM1\setup.exe


安装脚本样例

创建用于安装程序的脚本
使用脚本展开程序
在脚本中使用开关和标志
AutoCAD 2008 网络管理员手册 > 使用脚本展开程序 >
安装脚本样例

本节中的样例脚本将在典型配置中安装程序。为了便于复制此样例脚本以及替换用户信息，所有变量项目使用相同的名称。日志文件名以所安装的产品为依据。可以在脚本中使用日志文件名，也可以将其更改为其他内容。

序列号前缀：123

序列号：12345678

姓氏：您的姓氏

名字：您的名字

组织：您的公司名

本程序静默安装的样例脚本使用本节所示的语法。

AutoCAD 2008 脚本安装

' AutoCAD 2008 脚本安装
option explicit
'
' 创建变量
dim x64bit
dim shell
dim productType
dim featuresToInstall
dim strADSKFirstName
dim strADSKLastName
dim strADSKOrganization
dim strADSKSercirity
dim strADSKSerialIsvalid
dim strADSKAccept
dim strADSKEula
dim strADSKReInstall
dim strADSKRemove
dim strADSKSNPrefix
dim strADSKSNNumber
dim strInstallLevel
dim strACADStandaloneNetworkType
dim strADSKLicenseServerType
dim strADSKLicenseType
dim strADSKServerFmtPath
dim strADSKServerPath
dim strADSKServerHostID
dim strADSKPath
dim strSourcePath
dim strAdditionalStuff
'
' 脚本安装
Set shell = CreateObject("WScript.Shell")
x64bit = false ' 如果为 AutoCAD 2008 x64，则更改为 true
productType = "acad"
strInstallLevel=3 ' 5 完全安装 3 典型安装
'
' 名称和组织信息
strADSKFirstName = "Your First Name"
strADSKLastName = "Your Last Name"
strADSKOrganization = "Your Organization Name"
'
' 序列号信息
strADSKSNPrefix = "123"
strADSKSNNumber = "12345678"
'
' 安装源（例如，假设 D: 为安装介质）
strSourcePath = "d:\"
'
' 安装目标
strADSKPath = Shell.ExpandEnvironmentStrings("%ProgramFiles%") + "\AutoCAD 2008"
'
' 要安装的功能
' ACS - AutoCAD 样例
' CADStandards - CAD 标准
' Database - 数据库 (DBCONNECT)
' DCS - 设计中心样例
' DigSig - 数字签名
' Dictionaries - 词典
' DrawingEncryption - 图形加密
' Express_Tools - Express Tools
' Fonts - 字体
' Impression - “Autodesk Impression”工具栏（不包含在 64 位 AutoCAD 2008 中）
' Materials - 材质库
' Migrate - 移植自定义设置
' NFW - 新功能专题研习
' PLM - 许可证转移实用程序
' RefMan - 参照管理器
' System_Files - 	所需系统文件（在此脚本中默认安装）
' TM - 纹理贴图
' VBA - Visual Basic for Applications
' VLS - Visual LISP 样例
' VLT - Visual LISP 教程
'
' Sample is below - 请注意前导逗号
featuresToInstall = ",DigSig,TM,CADStandards,Database,Dictionaries,DrawingEncryption,Express_Tools,Fonts,NFW,Migrate,RefMan,Samples,ACS,DCS,VBA,Materials,PLM,VLS,VLT"
if not x64bit then
' 在安装中添加 Autodesk Impression
featuresToInstall = featuresToInstall & ",Impression"
strAdditionalStuff = "ACADSHOWIMPR=" & """" & "1" & """"
end if
'''''' 取消注释安装的相关版本 - 默认为单机
' 对于单机
RunStandaloneInstall()
'
' 对于单一许可服务器
' RunSingleLicenseServerInstall()
'
' 对于冗余网络许可服务器
' RunRedundantLicenseServerInstall()
'
' 对于分布式网络许可服务器
' RunDistributedLicenseServerInstall()
'
' 脚本结束
Wscript.quit()
'
Function RunStandaloneInstall
shell.run DefaultCommand(),2,1
end function
'
Function RunSingleLicenseServerInstall
' 使用正确信息更新许可服务器
strACADStandaloneNetworkType = "3"
strADSKLicenseServerType = "Single Server License"
strADSKLicenseType = "Network License"
strADSKServerPath = "myFlexServer"
' HOSTID 或 MAC 地址
strADSKServerHOSTID = "001122334455"
'
' 合并两个值
strADSKServerPath = strADSKServerPath & " " & strADSKServerHOSTID
shell.run MakeCommand(),2,1
end function
'
Function RunRedundantLicenseServerInstall
' 使用正确信息更新许可服务器
strACADStandaloneNetworkType = "3"
strADSKLicenseServerType = "Redundant Server License"
strADSKLicenseType = "Network License"
'
' 格式为 SERVERNAME1 MACADDR1 PORT1;SERVERNAME2 MACADDR2 PORT2; SERVERNAME3 MACADDR3 PORT3; - 冗余服务器仅允许 3
strADSKServerPath = " myFlexServer 001122334455 27005; myFlexServer2 006622334455 27005;"
shell.run MakeCommand(),2,1
end function
'
Function RunDistributedLicenseServerInstall
' 使用正确信息为许可服务器更新
strACADStandaloneNetworkType = "3"
strADSKLicenseServerType = "Distributed Server License"
strADSKLicenseType = "Network License"
'
' 格式为 @SERVERNAME1;SERVERNAME2;SERVERNAME3;
strADSKServerPath = "@ myFlexServer;@ myFlexServer2;@ myFlexServer3;"
'
shell.run MakeCommand() & "ACAD_LICENSESERVER_DISTRIBUTED=1",2,1
end function
'
Function DefaultCommand
dim retString
' /q 表示静默安装 ' /c [关键字] 替代参数表示关键字
retString = strSourcePath & "\setup.exe /t /q /c " & productType & ": "
retString = retString & "INSTALLDIR=" & """" & strADSKPath & """" & " "
retString = retString & "ACADSERIALPREFIX=" & strADSKSNPrefix & " "
retString = retString & "ACADSERIALNUMBER=" & strADSKSNNumber & " "
retString = retString & "ACADFIRSTNAME=" & """" & strADSKFirstName & """" & " "
retString = retString & "ACADLASTNAME=" & """" & strADSKLastName & """" & " "
retString = retString & "ACADORGANIZATION=" & """" & strADSKOrganization & """" & " "
retString = retString & "InstallLevel=" & strInstallLevel & " "
' retString = retString & "ADSK_LAUNCH_MODE=Standalone" & " "
if strInstallLevel = 3 then
retString = retString & "ADDLOCAL=" & """" & "System_Files" & featuresToInstall & """" & " "
end if
retString = retString & strAdditionalStuff ' 专门用于 Impression 工具栏
DefaultCommand = retString & " "
end function
'
Function MakeCommand
dim retString
retString = DefaultCommand() & " "
retString = retString & "ACADSTANDALONENETWORKTYPE=" & """" & strACADStandaloneNetworkType & """" & " "
retString = retString & "ACADLICENSESERVERTYPE=" & """" & strADSKLicenseServerType & """" & " "
retString = retString & "ACADLICENSETYPE=" & """" & strADSKLicenseType & """" & " "
retString = retString & "ACADSERVERPATH=" & """" & strADSKServerPath & """" & " "
MakeCommand = retString
end function


在脚本中使用开关和标志

安装脚本样例
使用脚本展开程序
自定义安装脚本
AutoCAD 2008 网络管理员手册 > 使用脚本展开程序 >
在脚本中使用开关和标志

下表列出了与安装相关的所有开关和标志。

注意必须将安装开关设置为 INSTALLDIR=，否则将不安装在 AutoCAD 之外运行的程序（例如许可证转移实用程序）。
安装脚本中的开关
开关 | 说明
INSTALLDIR= | 指定安装产品的位置。
ACADSERIALPREFIX= | 指定序列号中连字符前面的数字。
ACADSERIALNUMBER= | 指定序列号。
INSTALLLEVEL= | 指定安装类型：3=典型
ACADFIRSTNAME= | 指定用户的姓氏。
ACADLASTNAME= | 指定用户的名字。
ACADORGANIZATION= | 指定公司名称。
ADDLOCAL= | 用于自定义安装，在自定义安装中，指定要安装的特定功能。 请参见自定义安装脚本。
用户界面标志
标志 | 说明
q | 指定安装在静默模式下进行。


自定义安装脚本

在脚本中使用开关和标志
使用脚本展开程序
运行脚本
AutoCAD 2008 网络管理员手册 > 使用脚本展开程序 >
自定义安装脚本

要为自定义安装创建脚本，请使用语法 ADDLOCAL="....."。

以下样例演示了如何在脚本的 DefaultCommand 段使用组件标志。

Function DefaultCommand
dim retString
' /q 表示静默安装 ' /c [关键字] 替代参数表示关键字
retString = strSourcePath & "\setup.exe /t /q /c " & productType & ": "
retString = retString & "INSTALLDIR=" & """" & strADSKPath & """" & " "
retString = retString & "ACADSERIALPREFIX=" & strADSKSNPrefix & " "
retString = retString & "ACADSERIALNUMBER=" & strADSKSNNumber & " "
retString = retString & "ACADFIRSTNAME=" & """" & strADSKFirstName & """" & " "
retString = retString & "ACADLASTNAME=" & """" & strADSKLastName & """" & " "
retString = retString & "ACADORGANIZATION=" & """" & strADSKOrganization & """" & " "
retString = retString & "InstallLevel=" & strInstallLevel & " "
' retString = retString & "ADSK_LAUNCH_MODE=Standalone" & " "
if strInstallLevel = 3 then
retString = retString & "ADDLOCAL=" & """" & "System_Files,ACS,Impression,NFW" & featuresToInstall & """" & " "
end if
retString = retString & strAdditionalStuff ' 专门用于 Impression 工具栏
DefaultCommand = retString & " "

下表列出了所有可用的组件标志。

组件标志
标志 | 组件
ACS | AutoCAD 样例
CADStandards | CAD 标准
Database | 数据库 (DBCONNECT)
DCS | 设计中心样例
DigSig | 数字签名
Dictionaries | 词典
DrawingEncryption | 图形加密
Express_Tools | Express Tools
Fonts | 字体
Materials | 材质库
Migrate | 移植自定义设置
NFW | 新功能专题研习
PLM | 许可证转移实用程序
RefMan | 参照管理器
样例 | 样例文件
System_Files | 所需系统文件
TM | 纹理贴图
教程 | 教程
VBA | Visual Basic
VLS | Visual LISP 样例
VLT | Visual LISP 教程


运行脚本

自定义安装脚本
使用脚本展开程序
使用组策略安装展开
AutoCAD 2008 网络管理员手册 > 使用脚本展开程序 >
运行脚本

创建脚本后，可以将其移至服务器或者使用映射驱动器号或 UNC（通用命名约定）路径。如果将其置于服务器上供用户运行，则可以在服务器上创建共享，然后将用户添加至共享中，使其具有所需的权限。由于用户只需运行脚本，因此应提供对共享目录的只读访问权限。

然后在同一台服务器或另一台服务器上，为要安装的每个产品创建一个目录。为该目录选择一个固定位置，以便在脚本中指向 MSI 文件。将产品 CD 中的内容复制到该目录中。此外，还可以为 Service Pack、扩展程序和自定义工具创建目录。

可以使用以下任何一种方法运行安装脚本：

  • 在每个单独的工作站上手动运行脚本。要运行安装程序，请将脚本粘贴到“运行”对话框中，或者从 Windows 命令提示符下运行脚本。
  • 向每个要运行脚本的用户发送带有 UNC 路径的电子邮件。要运行该脚本，请按照说明操作。
  • 将脚本连同使用说明通过电子邮件发送给每个用户。
  • 对脚本进行设置，以便它在登录时运行。


使用组策略安装展开

运行脚本
简介
AutoCAD 2008 网络管理员手册 >
使用组策略安装展开

使用组策略，可以通过向计算机指定展开来公布本程序。

为了使 AutoCAD 正常运行，必须在要安装本程序的计算机上安装下列软件：

  • Microsoft .NET 2.0（在产品 CD 中）
  • Microsoft Internet Explorer 6.0 Service Pack 1 或更高版本（可以从 Microsoft 网站 www.microsoft.com 下载 Microsoft Internet Explorer）。
  • Microsoft Installer Package (MSI) 3.1
  • Macromedia Flash™ Player 9.0
  • Autodesk DWF Viewer® 7.0
  • Microsoft Data Access Components (MDAC) 2.7 Service Pack 1

本节内容

  • 简介
  • 通过组策略分发展开
  • 将展开指定给计算机
  • 确认展开的安装


简介

使用组策略安装展开
使用组策略安装展开
使用组策略指定展开
AutoCAD 2008 网络管理员手册 > 使用组策略安装展开 >
简介

使用组策略对象，可以将本程序公布到 Windows 2000、Windows XP 和 Windows 2003 Server Active Directory 环境中的任何计算机。

本节内容

  • 使用组策略指定展开
  • 使用组策略的优缺点


使用组策略指定展开

简介
简介
使用组策略的优缺点
AutoCAD 2008 网络管理员手册 > 使用组策略安装展开 > 简介 >
使用组策略指定展开

通过安装向导，将在展开过程中创建的展开指定给计算机。将展开指定给计算机后，将在下次重新启动计算机时安装程序。

计算机的任何用户均可以使用指定给该计算机的展开。通常，如果使用某台计算机的用户较多，则应将程序指定给该计算机。

注意Autodesk 产品被设计为安装在计算机上，以便登录到此计算机的任何用户都可以运行。如果尝试将本程序指定给特定用户（而不是计算机），则在另一个指定用户尝试安装或卸载程序副本时，可能会出现问题。


使用组策略的优缺点

使用组策略指定展开
简介
通过组策略分发展开
AutoCAD 2008 网络管理员手册 > 使用组策略安装展开 > 简介 >
使用组策略的优缺点

下表概述了使用组策略的优缺点。

组策略的优缺点

优点

缺点

  • 与安装向导的展开功能配合的很好。
  • 无法向 MSI 可执行文件传递命令行参数。解决方法是使用脚本。
  • 易于通过安装向导的展开功能添加自定义文件。
  • 展开到工作站。
  • 只能自定义使用安装向导创建展开时设置的应用程序设置。
  • 易于实现。


通过组策略分发展开

使用组策略的优缺点
使用组策略安装展开
将展开指定给计算机
AutoCAD 2008 网络管理员手册 > 使用组策略安装展开 >
通过组策略分发展开

通过组策略分发本程序包括三个主要步骤。

  1. 创建应用程序分发共享点。使用展开向导创建应用程序分发共享点。按照使用安装向导设置展开中列出的步骤创建展开。
  2. 将程序指定给计算机。
  3. 确认安装。确保已正确安装程序。


将展开指定给计算机

通过组策略分发展开
使用组策略安装展开
确认展开的安装
AutoCAD 2008 网络管理员手册 > 使用组策略安装展开 >
将展开指定给计算机

将程序指定给计算机后，该计算机的所有用户都可以使用它。要将本程序指定给计算机，必须从能够访问 Windows 2003 Server、Windows XP 或 Windows 2000 Active Directory 的服务器中执行下列步骤。

将展开指定给计算机的步骤

  1. 在“开始”菜单 (Windows) 中，依次单击“所有程序”（或“程序”） [image] “管理工具” [image] “Active Directory 用户和计算机”。
  2. 在“Active Directory 用户和计算机”窗口中，在要在其中创建组策略对象的组织单位上单击鼠标右键。然后单击“特性”。

    将显示选定组织单位的“特性”对话框。

    注意要使组策略对象生效，计算机对象必须位于选定的组织单位中。
  3. 在“特性”对话框的“组策略”选项卡中，单击“新建”。输入组策略对象的名称。例如，输入 AutoCAD Computer Assigned Installation。

    将创建组策略，并将其添加到“组策略对象链接”列表中。

  4. 在“组策略对象链接”列表中，单击刚创建的策略，然后单击“编辑”。
  5. 执行下列操作之一：
    • 对于 Windows 2003 Server：在“组策略对象编辑器”窗口的“计算机配置”下，单击 Software Settings 文件夹旁的加号 (+) 展开此文件夹。
    • 对于 Windows 2000 Server：在“组策略”窗口的“计算机配置”下，单击 Software Settings 文件夹旁的加号 (+) 展开此文件夹。
  6. 在“软件设置”下，在“软件安装”上单击鼠标右键，然后单击“特性”。
  7. 在“软件安装特性”对话框的“常规”选项卡中，单击“浏览”。
  8. 在“浏览文件夹”对话框中，定位在展开向导中创建的应用程序分发共享位置，然后选择 AdminImage 文件夹。然后单击“确定”。

    “软件安装特性”对话框中将以 UNC 格式显示默认的软件包位置、服务器名称、选定的共享文件夹和 AdminImage 文件夹。例如：

    \\server123\Deployment\AdminImage

  9. 执行下列操作之一：
    • 对于 Windows 2003 Server：在“常规”选项卡的“新建软件包”下，单击“高级”以指定创建新软件包的方法。使用此方法还可以选择通过展开向导创建的转换文件。
    • 对于 Windows 2000 Server：在“常规”选项卡的“新建软件包”下，单击“高级发布或指定”以指定创建新软件包的方法。使用此方法还可以选择通过展开向导创建的转换文件。
  10. 单击“确定”关闭“软件安装特性”对话框。
  11. 执行下列操作之一：
    • 对于 Windows 2003 Server：在“组策略对象编辑器”对话框的“软件设置”下，在“软件安装”上单击鼠标右键，然后依次单击“新建” [image] “软件包”。
    • 对于 Windows 2000 Server：在“组策略”对话框的“软件设置”下，在“软件安装”上单击鼠标右键，然后依次单击“新建” [image] “软件包”。
  12. 在“打开”对话框中，确保已选择 Windows Installer 软件包文件 (acad.msi)，然后单击“打开”。此默认选择是以前设置的应用程序分发共享位置。

    如果在应用程序分发共享位置之外的位置创建了管理映像，请找到该管理映像的位置，然后单击 acad.msi。

  13. 在“<产品名> 特性”对话框中，单击“展开”选项卡。在“展开类型”下，确认是否选择了“指定”。
  14. 在“修改”选项卡中，单击“添加”。
  15. 在“打开”对话框中，单击通过展开向导创建的转换软件包文件 (.mst)，然后单击“打开”。

    如果在应用程序分发共享位置之外的位置创建了管理映像，请找到该管理映像的位置，然后选择转换软件包文件 (.mst)。

  16. 在“<产品名> 特性”对话框的“修改”选项卡上，选定的转换软件包将添加到“修改”列表中。单击“确定”。
    注意必须选择创建组策略对象时通过展开向导创建的转换软件包文件。创建组策略对象后，将无法添加或删除转换软件包文件。如果未选择转换软件包文件，程序将无法安装在客户端计算机上。
  17. 执行下列操作之一：
    • 对于 Windows 2003 Server：在“组策略对象编辑器”窗口的“计算机配置”下，单击“软件安装”。新创建的程序软件包将显示在右侧窗格中。
    • 对于 Windows 2000 Server：在“组策略”窗口的“计算机配置”下，单击“软件安装”。新创建的程序软件包将显示在右侧窗格中。
  18. 执行下列操作之一：
    • 对于 Windows 2003 Server：关闭“组策略对象编辑器”窗口以及其他任何打开的 Active Directory 窗口。
    • 对于 Windows 2000 Server：关闭“组策略”窗口以及其他任何打开的 Active Directory 窗口。

程序将指定给为其创建了组策略对象的组织单位中的所有计算机。下次重新启动组织单位中的计算机时，将安装程序，并且该计算机的所有用户都可以使用它。参见确认展开的安装以验证是否正确创建了组策略。


确认展开的安装

将展开指定给计算机
使用组策略安装展开
确认是否已将程序指定给计算机
AutoCAD 2008 网络管理员手册 > 使用组策略安装展开 >
确认展开的安装

重新启动计算机时，操作系统通常在“Windows 登录”对话框出现之前或之后显示有关组策略的信息。这些信息包括：

  • Windows 启动
  • 应用计算机设置
  • 安装管理软件<应用程序>
  • 应用软件安装设置
  • 加载用户的个人设置
  • 应用用户的个人设置

用户从 Windows XP 或 Windows 2000 工作站登录到为其创建了组策略的组织单位或计算机。

注意如果出现问题，将在系统的“事件查看器”中的“应用程序”下记录一个条目。

本节内容

  • 确认是否已将程序指定给计算机


确认是否已将程序指定给计算机

确认展开的安装
确认展开的安装
使用映像软件分发产品
AutoCAD 2008 网络管理员手册 > 使用组策略安装展开 > 确认展开的安装 >
确认是否已将程序指定给计算机

要确认是否已将本程序正确指定给计算机，请重新启动为其创建了组策略的组织单位中的计算机。将在显示登录提示之前安装程序。登录后，双击桌面上的程序图标。将开始第二次安装。安装完成后，程序将启动。


使用映像软件分发产品

确认是否已将程序指定给计算机
使用主映像将多套单机产品分发至多个系统
AutoCAD 2008 网络管理员手册 >
使用映像软件分发产品

为使用映像软件（例如 Norton Ghost）的用户提供了下列信息，用于创建主映像以分发 Autodesk 产品。一旦创建，主映像将通过设备复制到其他的计算机上。

请谨慎使用映像软件，因为其使用可能导致以下情况：

  • 与产品许可证冲突
  • 不完全安装和激活问题
注意如果许可在 SATA RAID 环境中不稳定，则使用映像软件分发 Autodesk 产品可能导致产品激活问题，例如，尝试激活时，显示“超出激活码限制”。

本节内容

  • 使用主映像将多套单机产品分发至多个系统
  • 使用主映像将网络许可产品分发至多个系统
  • 恢复主映像
  • 清理主系统并恢复操作系统


使用主映像将多套单机产品分发至多个系统

使用映像软件分发产品
使用映像软件分发产品
使用主映像将网络许可产品分发至多个系统
AutoCAD 2008 网络管理员手册 > 使用映像软件分发产品 >
使用主映像将多套单机产品分发至多个系统

可以使用多套单机版产品的主映像来分发产品。

注意使用 Norton Ghost 时，必须使用 -ib 开关以在主映像中包含引导扇区。有关使引导扇区作为一部分包含在主映像中的详细信息，请参见用户的映像软件。

如果之前已经在主机计算机上运行了 Autodesk 产品，则请勿创建主映像。可能需要清理系统。请参见清理主系统并恢复操作系统。

使用主映像将多套单机版产品分发到多台计算机的步骤

  1. 创建多套单机版产品的网络展开。有关详细信息，请参见使用安装向导设置展开。
  2. 将展开中的 Autodesk 产品安装到主机计算机上。
  3. 在主机计算机上执行以下操作之一：
    • 创建主映像（包括引导扇区）。分发产品前，请在一台计算机（非主机计算机）上测试该产品。在另一台计算机上启动产品，然后注册并激活该产品。用户在其计算机上注册并激活产品的宽限期为 30 天。
    • 启动产品并根据需要自定义产品。创建主映像并将其分发给用户。如果用户的计算机已连接到 Internet，则产品将被自动激活。其计算机未连接到 Internet 的用户拥有 7 天宽限期来注册并激活产品。
  4. 将主映像应用到目标计算机。


使用主映像将网络许可产品分发至多个系统

使用主映像将多套单机产品分发至多个系统
使用映像软件分发产品
恢复主映像
AutoCAD 2008 网络管理员手册 > 使用映像软件分发产品 >
使用主映像将网络许可产品分发至多个系统

可以使用网络许可产品的主映像来分发产品。

使用主映像将网络许可产品分发至多台计算机的步骤

  1. 创建网络许可产品的网络展开。有关详细信息，请参见使用安装向导设置展开。
  2. 将展开中的 Autodesk 产品安装到主机计算机上。
    注意为了使产品获取许可证，许可证服务器必须正在运行，并且每台计算机必须连接到网络。
  3. 安装了 Autodesk 产品后，请使用映像软件创建系统硬盘驱动器的主映像。
  4. 将主映像应用到目标计算机。


恢复主映像

使用主映像将网络许可产品分发至多个系统
使用映像软件分发产品
清理主系统并恢复操作系统
AutoCAD 2008 网络管理员手册 > 使用映像软件分发产品 >
恢复主映像

以下步骤假定重新格式化工作站之前，已将每个工作站的“Software Licenses”文件夹（和“Product Licenses”文件夹，如果存在）的副本保存至其他工作站或 DVD。

使用主映像恢复产品的步骤

  1. 退出应用程序。在完成此过程之前不要再次运行应用程序。
  2. 在 Windows 资源管理器中，将“Software Licenses”文件夹从以下显示的相应路径复制到某个位置（要恢复的磁盘除外）。

    C:\Documents and Settings\All Users\Application Data\Autodesk\Software Licenses

  3. 重新格式化工作站并恢复主映像。
    注意请勿对硬盘驱动器执行低级格式化。
  4. 将在步骤 2 中创建的 Software Licenses 文件夹复制到其所在的原工作站及在工作站上所处的位置。
注意恢复磁盘映像后，更改过的任何文件都将恢复到原始状态，以供再次使用。许可文件被保留，无需重新激活产品。


清理主系统并恢复操作系统

恢复主映像
使用映像软件分发产品
词汇表
AutoCAD 2008 网络管理员手册 > 使用映像软件分发产品 >
清理主系统并恢复操作系统

如果已经在主机计算机上运行了 Autodesk 产品，则首先应正确清理该主机计算机。

清理主机计算机并恢复操作系统的步骤

  1. 清理硬盘驱动器（包括引导扇区）。

    例如，如果使用的是 Norton 的 GDISK 实用程序，请使用以下命令：

    gdisk 1/diskwipe

    其中 1 代表正在擦除的硬盘。

    注意如果使用的是 Norton Ghost 之外的实用程序，请确保该实用程序可以清理引导扇区；否则将无法激活 Autodesk 产品。
  2. 创建新的分区并使用恢复 CD 或产品 CD 来安装操作系统。


词汇表

清理主系统并恢复操作系统
AutoCAD 2008 网络管理员手册 >
词汇表
Active Directory

Microsoft 提供的目录服务，是 Windows 2000 和 Windows 2003 Server 的一部分。

AutoCAD 启动加速器 (acstart17.exe)

一种运行时进程，可以加快 AutoCAD 的初始启动速度。

FLEXlm

Macrovision Software, Inc. 提供的许可管理技术。FLEXlm 提供了有助于简化网络许可管理的管理工具。FLEXlm 可用于监视网络许可证的状态、重置因系统故障而丢失的许可证、对许可证服务器进行故障排除以及更新现有许可证文件。

MSI

Microsoft Installer，支持各种可用于脚本编写的参数。

MSP

Microsoft 修补程序文件（参见修补程序）

MST

Microsoft 转换文件。修改通过 MSI 文件安装的组件。例如，展开向导使用指定的设置创建 MST 文件。通过展开向导创建的展开结合使用 MST 文件和 MSI 文件以及 MSIEXEC 在本地工作站上安装。

Service Pack

Autodesk 术语，表示应用程序的修补程序。

SMS

Microsoft 系统管理服务器。一种工具，通过进行远程配置、推入展开和用户管理帮助用户管理联网计算机。SMS 是一种成本很高的技术，必须作为附加服务器购买。

安装映像

一种展开，由 MSI 文件、关联的转换、用户指定的附加自定义文件以及配置和注册表设置组成。

编写脚本

使用脚本语言（例如 VB Script）简化软件包展开的过程。

超级用户

对注册表的“Program Files”文件夹和“HKEY_Local_Machine”文件夹具有访问权限和写入权限的用户。

多套单机安装

一种安装类型，使用一个序列号安装程序的多套单机安装。

公布

一种拉技术，用于通知用户已有更新的软件产品可供安装。通常情况下，用户双击快捷方式（或执行类似的操作）即可完成已公布产品的安装。

管理映像

通过展开向导创建的共享文件资源集合，展开使用它将程序安装到网络工作站。可以使用展开向导将 Service Pack（修补程序）应用到管理映像。

激活

Autodesk 软件注册过程的一部分，允许用户按产品的最终用户许可协议运行产品。

静默安装

一种无需用户专门输入即可进行的安装方式。不显示要求用户进行交互操作的对话框。

局部配置

一种包含部分注册信息的配置，这些信息与“选项”对话框“文件”选项卡中可用选项的子集相对应。

拉技术

一种安装技术，需要用户进行交互才能完成安装。

目录服务

一种网络服务，用于标识网络上的所有资源，并使资源可供用户和应用程序使用。资源包括电子邮件地址、计算机和外围设备（例如打印机）。理想情况下，目录服务应使物理网络拓扑结构和协议透明，使网络用户不必了解网络的实际连接方式和位置即可访问所有资源。几乎所有目录服务都基于 X.500 ITU 标准。

推技术

一种安装技术，可将文件安装到远程桌面而无需用户进行交互。

修补程序

应用程序的软件更新。

展开

将 Autodesk 产品安装到网络中的一台或多台计算机上的过程。

展开

指向用作安装基础的唯一的 MST（Microsoft 转换）文件的链接。使用展开向导，管理员可以为用户创建多个用于不同安装类型的展开。

转换

参见 MST。

组策略

Microsoft 服务器技术，用于通过标准 Microsoft 2000 Server 管理组件，执行推安装和基于公布的安装。


评论？

请使用该表格将注释发送至负责该文档的 Autodesk 技术出版组。

主题标题和位置（请勿编辑）：
姓名（可选）：
         电子邮件（可选）：
评论：

注意：该表并不作为用户接收反馈或技术支持的途径。用户提供的信息可使我们将来更好地更新该文档。谢谢！