Autodesk 网络许可快速入门

如何安装 Network License Manager
Autodesk 网络许可手册 >
Autodesk 网络许可快速入门

设置 Autodesk 产品的网络许可证需要进行仔细地规划和执行。本节提供了逐步介绍有关如何设置网络许可证环境的快速指导，其中假定您对成功设置在网络上运行的 Autodesk 产品时所需的术语和过程有所了解。如果对网络许可没有什么了解，则在尝试设置网络许可服务器之前，请通读《网络许可指南》，以获取详细信息。

本节内容

  • 如何安装 Network License Manager
  • 如何安装和使用网络许可证激活实用程序
  • 如何配置许可服务器
  • 如何安装和使用 SAMreport-Lite（可选）
请将关于此页的评论发送给我们


如何安装 Network License Manager

Autodesk 网络许可快速入门
Autodesk 网络许可快速入门
如何安装和使用网络许可证激活实用程序
Autodesk 网络许可手册 > Autodesk 网络许可快速入门 >
如何安装 Network License Manager

Network License Manager 用于配置和管理许可服务器。

安装 Network License Manager 的步骤

  1. 在 AutoCAD 2008 安装向导中，单击“安装工具和实用程序”。
  2. 在“欢迎使用 AutoCAD 2008 安装向导”页面上，单击“下一步”。
  3. 查看适用于您所在国家或地区的 Autodesk 软件许可协议。必须接受协议才能继续安装。选择国家或地区，单击“我接受”，然后单击“下一步”。
    注意如果不同意协议的条款并希望终止安装，请单击“取消”。
  4. 在“选择要安装的项目”页面上，确保“Network License Manager”处于选定状态，然后单击“下一步”。
  5. 在“查看 - 配置 - 安装”页面上，单击“配置”。
  6. 单击“Network License Manager”选项卡。
  7. 在“选择安装位置”页面上，接受默认安装路径 (C:\Program Files\Autodesk\Network License Manager\) 或单击“浏览”以指定其他路径。如果输入的路径不存在，将根据您提供的名称和位置创建一个新文件夹。单击“下一步”。
    警告请勿在远程驱动器上安装 Network License Manager。安装 Network License Manager 文件时，必须提供一个本地驱动器路径。必须指定驱动器号；不支持通用命名约定 (UNC)。
  8. 在“配置完成”页面上，单击“配置完成”以返回到“查看 - 配置 - 安装”页面。单击“安装”。

    这样可以安装 Network License Manager 和用户选择的任何其他工具和实用程序。

  9. 显示“安装完成”页面时，单击“完成”。


如何安装和使用网络许可证激活实用程序

如何安装 Network License Manager
Autodesk 网络许可快速入门
如何配置许可服务器
Autodesk 网络许可手册 > Autodesk 网络许可快速入门 >
如何安装和使用网络许可证激活实用程序

使用网络许可证激活实用程序可以在 Internet 上获取许可证，这样可以节省设置网络许可版本程序所用的时间和精力。此外，如果无法通过 Internet 获得许可证，还可以通过电子邮件注册产品、获取自动支持，然后可以自动保存和移植许可证文件。

安装网络许可证激活实用程序的步骤

  1. 在 AutoCAD 2008 安装向导中，单击“安装工具和实用程序”。
  2. 在“欢迎使用 AutoCAD 2008 安装向导”页面上，单击“下一步”。
  3. 查看适用于您所在国家或地区的 Autodesk 软件许可协议。必须接受协议才能继续安装。选择国家或地区，单击“我接受”，然后单击“下一步”。
    注意如果不同意协议的条款并希望终止安装，请单击“取消”。
  4. 在“选择要安装的项目”页面上，确保网络许可证激活实用程序处于选定状态，然后单击“下一步”。
  5. 在“查看 - 配置 - 安装”页面上，单击“配置”。
  6. 单击“网络许可证激活实用程序”选项卡。
  7. 在“选择安装位置”页面上，接受默认安装路径 (C:\Program Files\Autodesk Network License Manager\Network License Activation Utility\) 或单击“浏览”以指定其他路径。如果输入的路径不存在，将根据您提供的名称和位置创建一个新文件夹。单击“下一步”。
  8. 在“配置完成”页面上，单击“配置完成”以返回到“查看 - 配置 - 安装”页面。单击“安装”。

    这样可以安装网络许可证激活实用程序和用户选择的任何其他工具和实用程序。

  9. 显示“安装完成”页面时，单击“完成”。

使用网络许可证激活实用程序（联机请求）的步骤

  1. 在“开始”菜单 (Windows) 上，依次单击“所有程序”（或“程序”） [image] “Autodesk” [image] “Network License Manager” [image] “AutoCAD 2008 网络许可证激活实用程序”。
  2. 在“获取网络许可证”页面上，确保直接连接（通过 Internet）处于激活状态，然后单击“下一步”。
  3. 在“服务器信息”页面上，输入以下数据：
    • 产品序列号或编组 ID
      注意如果是在修改现有许可证文件或是获取现有产品的新许可证，那么页面上可能会显示先前输入的信息。请确保所显示的序列号是要许可的产品序列号。如果不是，请输入正确的产品序列号。
    • 许可服务器模式

      要获取每种许可服务器模式的详细信息，请单击“?”按钮。

    • 服务器主机名

      如果不知道主机名，单击“...”按钮查找计划使用的每个服务器的名称。

      注意在分布式服务器模式中，用户最多具有 20 台服务器。一旦达到 20 台服务器的限制，“添加”按钮将消失。
    • 主机 ID，为每台服务器输入的主机名

      如果不能找到主机 ID，单击“查找”以使实用程序自动查找服务器的主机 ID。

      注意如果服务器具有多个网络适配器，请选择与物理网络适配器相对应的网络适配器。要确定哪些适配器是物理适配器，请在 Windows 命令提示下输入 ipconfig /all，然后查看每个物理地址上方的“Description”字段。如果有多个物理网络适配器，则可以使用其中任意一个，只要运行 ipconfig /all 时列出了该适配器即可。此外，还可能列出一些逻辑设备（例如 VPN 适配器、PPP 适配器和调制解调器），但是它们在许可操作中不可用。
    • 每个许可服务器的套数

      如果选择分布式服务器模式，则显示“套数”对话框。为每个许可服务器输入套数。

    单击“下一步”。

  4. 在“确认服务器信息”页面上，检查所输入的服务器信息，然后单击“下一步”。
  5. 在“登录”页面上，输入用户 ID 和密码，然后单击“登录”。

    如果您没有用户帐号，则单击“现在创建用户 ID”链接，然后按照说明创建一个新的用户帐号。

  6. 在“确认用户信息”页面上，选择一个配置，然后单击“下一步”。
  7. 在“已收到许可证”页面的“保存 [计算机名称] 的许可证文件”字段中，输入要保存许可证文件的位置，或单击“浏览”以浏览到相应的位置。
    注意建议将许可证文件保存在安装 Network License Manager 的位置。

    该页面的内容根据用户所选择的服务器模式的不同而不同。

    单击“下一步”。

  8. 在“许可证激活成功”页面上，单击“打印”以保存许可证信息的打印副本，或单击“完成”以完成此事务并退出网络许可证激活实用程序。

接收许可证文件并将它保存到本地后，请参见如何配置许可服务器以配置您的许可证管理器。

使用网络许可证激活实用程序（脱机请求）的步骤

  1. 在“开始”菜单 (Windows) 上，依次单击“所有程序”（或“程序”） [image] “Autodesk” [image] “Network License Manager” [image] “AutoCAD 2008 网络许可证激活实用程序”。
  2. 在“获取网络许可证”页面上，确保直接连接（通过 Internet）处于激活状态，然后单击“下一步”。
  3. 在“服务器信息”页面上，输入以下数据：
    • 产品序列号或编组 ID
      注意如果是在修改现有许可证文件或是获取现有产品的新许可证，那么页面上可能会显示先前输入的信息。请确保所显示的序列号是要许可的产品序列号。如果不是，请输入正确的产品序列号。
    • 许可服务器模式

      要获取每种许可服务器模式的详细信息，请单击“?”按钮。

    • 服务器主机名

      如果不知道主机名，单击“...”按钮查找计划使用的每个服务器的名称。

      注意在分布式服务器模式中，用户最多具有 20 台服务器。一旦达到 20 台服务器的限制，“添加”按钮将消失。
    • 主机 ID，为每台服务器输入的主机名

      如果不能找到主机 ID，单击“查找”以使实用程序自动查找服务器的主机 ID。

      注意如果服务器具有多个网络适配器，请选择与物理网络适配器相对应的网络适配器。要确定哪些适配器是物理适配器，请在 Windows 命令提示下输入 ipconfig /all，然后查看每个物理地址上方的“Description”字段。如果有多个物理网络适配器，则可以使用其中任意一个，只要运行 ipconfig /all 时列出了该适配器即可。此外，还可能列出一些逻辑设备（例如 VPN 适配器、PPP 适配器和调制解调器），但是它们在许可操作中不可用。
    • 每个许可服务器的套数

      如果选择分布式服务器模式，则显示“套数”对话框。为每个许可服务器输入套数。

    单击“下一步”。

  4. 在“确认服务器信息”页面上，检查所输入的服务器信息，然后单击“下一步”。
  5. 如果显示“产品注册”页面，请执行以下所有操作：
    • 选择将产品注册给公司还是个人。
    • 选择您所在国家或地区。
    • 指定这是否为产品升级。

    单击“下一步”。

  6. 在“客户信息”页面上输入个人数据，然后选择您希望接收激活码的方式。单击“下一步”。
  7. 在“确认信息”页面上查看个人数据，然后选择将用来提交请求的方法。单击“关闭”。
    • 如果通过电子邮件提交您的请求，则将通过在“客户信息”页面上指定的方法发送您的激活码。
    • 如果通过传真、电话或邮件提交您的请求，则将显示包含 Autodesk 传真号码、电话号码和邮寄地址的“与 Autodesk 联系”页面。也可以打印您的激活申请表。

接收许可证文件并将它保存到本地后，请参见如何配置许可服务器以配置您的许可证管理器。

注意建议将许可证文件保存在安装 Network License Manager 的位置。


如何配置许可服务器

如何安装和使用网络许可证激活实用程序
Autodesk 网络许可快速入门
如何安装和使用 SAMreport-Lite（可选）
Autodesk 网络许可手册 > Autodesk 网络许可快速入门 >
如何配置许可服务器

要能够管理运行网络许可证激活实用程序时收到的 Autodesk 产品许可证，需要配置许可服务器。请使用 lmtools.exe 实用程序配置许可服务器。

配置许可服务器的步骤

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 执行下列操作之一:
    • 依次单击“开始”菜单（适用于 Windows XP 和 Windows 2000） [image] “所有程序”（或“程序”） [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • 在桌面上的 LMTOOLS 图标（适用于 Windows Vista）上单击鼠标右键并选择“以管理员身份运行”。
  2. 在 Lmtools 程序中的“Service/License File ”选项卡上，确保“Configure Using Services”选项处于激活状态。
  3. 单击“Config Services”选项卡。
  4. 在“Service Name”列表中，执行下列操作之一:
    • 如果已选择某个服务名，请确认它是否是您要用来管理许可证的服务名。
    • 如果不存在服务名，请输入要用来管理许可证的服务名。

    默认情况下，服务名为 Flexlm Service 1。服务名可能会不同。

    注意如果有多个软件供应商使用 FLEXlm® 进行许可证管理，则“Service Name”列表将包含多个选项。确保仅列出一个 Autodesk 服务。
  5. 在“Path to Lmgrd.exe File”字段中，输入指向 Network License Manager 守护程序 (lmgrd.exe) 的路径，或单击“Browse”以定位文件。

    默认情况下，此守护程序安装在“\Program Files\Autodesk Network License Manager\License”文件夹中。

  6. 在“Path to the license file”框中，输入指向许可证文件的路径，或单击“Browse”以定位文件。

    这是通过网络许可证激活实用程序获得的许可证文件的路径，或脱机获得的许可证文件的放置位置。

  7. 在“Path to the debug log file”框中，输入路径以创建调试日志，或单击“Browse”以定位一个现有的日志文件。

    建议将它保存至“\Program Files\Autodesk Network License Manager”文件夹。日志文件必须具有“.log”文件扩展名。对于新的日志文件，用户必须手动输入“.log”扩展名。

  8. 要将 lmgrd.exe 作为服务来运行，请选择“Use Services”。
  9. 要在系统启动时自动启动 lmgrd.exe，请选择“Start Server at Power Up”。
  10. 单击“Save Service”，将新的配置信息保存到步骤 4 中选定的服务名下。如果要将设置保存到服务，则在提示时单击“是”。
  11. 单击“Start/Stop/Reread”选项卡，然后执行下列操作之一：
    • 如果尚未针对 Autodesk 定义服务，请单击“Start Server”以启动许可服务器。
    • 如果已经定义了某一个 Autodesk 服务并且该服务正在运行，请单击“ReRead License File”，使用对许可证文件或选项文件所做的所有更改来刷新 Network License Manager。

      许可服务器开始运行，并准备响应客户端请求。

  12. 关闭 lmtools.exe。


如何安装和使用 SAMreport-Lite（可选）

如何配置许可服务器
Autodesk 网络许可快速入门
Autodesk 网络许可简介
Autodesk 网络许可手册 > Autodesk 网络许可快速入门 >
如何安装和使用 SAMreport-Lite（可选）

SAMreport-Lite 是一个报告工具，帮助跟踪网络许可证的使用情况。使用 Macrovision Corporation 的 SAMreport-Lite 技术，可以监视所有使用 FLEXlm® 来管理网络许可证的软件在客户端上的使用情况。

要了解有关安装和使用 SAMreport-Lite 的详细信息，请参见《SAMreport-Lite 用户手册》，通过单击安装向导左下角的“文档”链接和在 Autodesk 产品的帮助系统中可找到该手册。


Autodesk 网络许可简介

如何安装和使用 SAMreport-Lite（可选）
Network License Manager
Autodesk 网络许可手册 >
Autodesk 网络许可简介

Autodesk 网络许可工具包括 Network License Manager、网络许可证激活实用程序、FLEXlm 配置工具和 SAMreport-Lite。以下各节中分别对每种工具进行了介绍。

本节内容

  • Network License Manager
  • 网络许可证激活实用程序
  • FLEXlm 配置工具
  • SAMreport-Lite 许可证报告工具


Network License Manager

Autodesk 网络许可简介
Autodesk 网络许可简介
Network License Manager 的系统需求
Autodesk 网络许可手册 > Autodesk 网络许可简介 >
Network License Manager

可以将 Network License Manager 用作 Autodesk® 产品的网络安装和展开的一部分。Network License Manager 用于配置和管理许可服务器。创建展开时，安装向导将提示用户有关许可证管理器的信息（例如，许可服务器模式和服务器名称）。

有关从网络位置展开 Autodesk 产品的详细信息，请通过单击安装向导左下角的“文档”链接或在帮助系统中参见《网络管理员手册》。

本节内容

  • Network License Manager 的系统需求


Network License Manager 的系统需求

Network License Manager
Network License Manager
网络许可证激活实用程序
Autodesk 网络许可手册 > Autodesk 网络许可简介 > Network License Manager >
Network License Manager 的系统需求

确保网络许可服务器达到所建议的最低需求。请参见下面的硬件和软件需求表。

作者注：更新所有有关 Windows Vista 的表格和 64 位内容。

网络许可服务器的硬件和软件需求
硬件/软件 | 需求 | 注意
操作系统 | Windows 2003 Server Edition Windows XP Professional Service Pack 2 Windows 2000 Server Edition Windows 2000 Service Pack 4 | Network License Manager 仅支持以太网网络配置。 仅在 Windows 2000 Server Edition 和 Windows 2003 Server 上支持冗余许可服务器模式。
计算机/处理器 | Pentium III 或更高 450 Mhz（最低要求） |
网络接口卡 | 与现有的以太网网络基础构造兼容 | Network License Manager 支持多个网络接口卡。
通讯协议 | TCP/IP | Network License Manager 使用 TCP 包类型。


网络许可证激活实用程序

Network License Manager 的系统需求
Autodesk 网络许可简介
FLEXlm 配置工具
Autodesk 网络许可手册 > Autodesk 网络许可简介 >
网络许可证激活实用程序

使用网络许可证激活实用程序可以通过 Internet 获取许可证，这样可以节省设置网络许可版本的 Autodesk 产品所用的时间和精力。使用该实用程序，可以简化或自动执行在早期版本的 Autodesk 产品中必须手动执行的任务。

此外，此实用程序还用于注册产品、提供有关电子邮件的自动支持（如果不能通过 Internet 获取许可证）以及自动保存并移植许可证文件，从而使用户无需进行手动操作。

注意建议使用网络许可证激活实用程序来获取许可证文件。然而，如果无法通过连接到 Internet 来获取许可证文件，请参见手动获取服务器主机名和主机 ID。


FLEXlm 配置工具

网络许可证激活实用程序
Autodesk 网络许可简介
从早期版本更新 FLEXlm
Autodesk 网络许可手册 > Autodesk 网络许可简介 >
FLEXlm 配置工具

Network License Manager 使用 Macrovision Corporation 的 FLEXlm® 许可证管理技术。FLEXlm 提供了有助于简化网络许可证管理的管理工具。可以使用 FLEXlm 工具监视网络许可证的状态、重置因系统故障而丢失的许可证、对许可服务器进行故障排除以及动态更新现有许可证文件。

本节内容

  • 从早期版本更新 FLEXlm
  • 许可服务器管理实用程序
  • 选项文件


从早期版本更新 FLEXlm

FLEXlm 配置工具
FLEXlm 配置工具
许可服务器管理实用程序
Autodesk 网络许可手册 > Autodesk 网络许可简介 > FLEXlm 配置工具 >
从早期版本更新 FLEXlm

基于 AutoCAD 2008 的产品需要使用 FLEXlm 10.8 版或更高版本。如果当前正在使用的 FLEXlm 的版本低于 10.8 版，则需要升级到 10.8 版或更高版本。

要确定所安装的 FLEXlm 的版本，需要确认下列四个文件的版本：

  • lmgrd.exe
  • lmtools.exe
  • lmutil.exe
  • adskflex.exe
注意如果要安装 Autodesk Network License Manager 的服务器上已经安装了用于其他产品的 FLEXlm，请务必确保 lmgrd.exe 的版本是最新版本。

确认 lmutil.exe、lmtools.exe 或 adskflex.exe 的版本的步骤

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 执行下列操作之一：
    • 依次单击“开始”菜单（适用于 Windows XP 和 Windows 2000） [image] “所有程序”（或“程序”） [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • 在桌面上的 LMTOOLS 图标（适用于 Windows Vista）上单击鼠标右键并选择“以管理员身份运行”。
  2. 在 lmtools.exe 中，单击“Utility”选项卡。
  3. 在“Utility”选项卡中，输入文件的位置，或单击“Browse”按钮定位相应文件并单击“打开”。文件位置应与下面内容相似：

    C:\Program Files\Autodesk Network License Manager\lmutil.exe

  4. 在“Utility”选项卡中，单击“Find Version”。

    将显示选定文件的版本号。如果需要，请使用以下步骤更新 FLEXlm 的版本。

更新 FLEXlm 的步骤

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 备份许可证文件。
  2. 执行下列操作之一：
    • 依次单击“开始”菜单（适用于 Windows XP 和 Windows 2000） [image] “所有程序”（或“程序”） [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • 在桌面上的 LMTOOLS 图标（适用于 Windows Vista）上单击鼠标右键并选择“以管理员身份运行”。
  3. 在 LMTOOLS 程序中，单击“Start/Stop/Reread”选项卡。
  4. 在“Start/Stop/Reread”选项卡中，单击“Stop Server”。
  5. 关闭 lmtools.exe。
  6. 删除安装 Network License Manager。关于删除安装 Network License Manager 的详细信息，请参见删除安装 Network License Manager。
  7. 安装 Network License Manager。关于安装 Network License Manager 的详细信息，请参见安装 Autodesk Network License Manager。
注意基于 AutoCAD 2008 的产品所附带的 10.8 版 FLEXlm 许可证管理器是向后兼容的，它可以管理基于 Autodesk 2006、Autodesk 2005、Autodesk 2004 和 Autodesk 2002 的产品的许可证。


许可服务器管理实用程序

从早期版本更新 FLEXlm
FLEXlm 配置工具
选项文件
Autodesk 网络许可手册 > Autodesk 网络许可简介 > FLEXlm 配置工具 >
许可服务器管理实用程序

FLEXlm 提供了两个用于管理许可服务器的实用程序。这些工具位于 [Autodesk 产品名]\ Program Files\Autodesk Network License Manager 文件夹中。

lmtools.exe

提供了一个用于管理许可服务器的 Microsoft® Windows 图形用户界面。

lmutil.exe

提供了一组用于管理许可服务器的命令行选项。

可以使用 lmtools.exe 或 lmutil.exe 执行以下服务器管理任务：

  • 启动、停止和重新启动服务器。
  • 配置、更新和重新读取许可证文件。
  • 诊断系统或许可证问题。
  • 查看服务器状态，包括活动的许可证状态。


选项文件

许可服务器管理实用程序
FLEXlm 配置工具
SAMreport-Lite 许可证报告工具
Autodesk 网络许可手册 > Autodesk 网络许可简介 > FLEXlm 配置工具 >
选项文件

FLEXlm 的另一个组件是选项文件。您可以创建该文件以设置特定的配置选项。关于创建和使用选项文件的信息，请参见设置和使用选项文件。

使用选项文件可以为以下服务器相关的特性设置参数：

报告日志文件

将创建一个压缩的加密文件，用于生成有关许可证活动的精确使用情况报告，以供 SAMreport-Lite 使用。有关 SAMreport-Lite 的详细信息，请参见《SAMreport-Lite User's Guide》，可以通过媒体浏览器的“文档”选项卡上访问该手册。

许可证借用

如果 Autodesk 产品支持许可证借用功能，则可以允许用户从网络许可服务器借用 Autodesk 产品许可证，以便他们可以使用产品而无需建立许可服务器连接。许可证借用具有时间限制。

许可证超时

使用许可证超时功能，可以在许可服务器上设置超时时段。设置许可证超时后，当出现以下情况时许可证将被返回给许可服务器：与工作站的连接断开；或者许可证已签出，但由于超过了指定的超时时间而导致 Autodesk 产品在工作站上处于空闲状态。

关于配置选项的详细信息，请参见配置许可服务器。

关于使用 FLEXlm 配置工具的特定信息，请浏览至 C:\Program Files\Autodesk Network License Manager\Docs\FlexUser\TOC.htm，参见该 FLEXlm 文档。


SAMreport-Lite 许可证报告工具

选项文件
Autodesk 网络许可简介
规划网络许可
Autodesk 网络许可手册 > Autodesk 网络许可简介 >
SAMreport-Lite 许可证报告工具

尽管不是网络安装的组成部分，但 SAMreport 的 SAMreport-Lite 版本将有助于追踪网络许可证的使用情况。使用 Macrovision Corporation 的 SAMreport-Lite 技术，可以监视所有使用 FLEXlm 来管理网络许可证的软件在客户端上的使用情况。

SAMreport-Lite 以多种输出格式（包括 HTML、文本和报告交换格式）生成使用情况报告。有关 SAMreport-Lite 功能的详细信息以及 SAMreport-Lite 的安装说明，请参见《SAMreport-Lite User's Guide》。

注意可以通过 Autodesk 产品媒体浏览器来安装 SAMreport-Lite 和访问《SAMreport-Lite User's Guide》。

关于 SAMreport-Lite 的其他信息以及此功能的更新和更正，请访问 Autodesk 站点：

www.autodesk.com/samreportlite


规划网络许可

SAMreport-Lite 许可证报告工具
规划许可服务器配置
Autodesk 网络许可手册 >
规划网络许可

本节中包括在设置网络许可服务器之前需要知道的信息。本节包括有关所支持的许可服务器模式、许可证操作和可用性、网络许可证文件定义和参数、许可证文件样例、许可证类型和行为以及许可服务器心跳信号的信息。

本节内容

  • 规划许可服务器配置
  • 了解许可证


规划许可服务器配置

规划网络许可
规划网络许可
单一许可服务器模式
Autodesk 网络许可手册 > 规划网络许可 >
规划许可服务器配置

您必须确定使用哪种许可服务器模式管理服务器上的 Autodesk® 产品许可证。Autodesk 支持以下网络许可服务器模式：

  • 单一许可服务器模式
  • 分布式许可服务器模式
  • 冗余许可服务器模式

本节内容

  • 单一许可服务器模式
  • 分布式许可服务器模式
  • 冗余许可服务器模式


单一许可服务器模式

规划许可服务器配置
规划许可服务器配置
分布式许可服务器模式
Autodesk 网络许可手册 > 规划网络许可 > 规划许可服务器配置 >
单一许可服务器模式

在单一许可服务器模式中，Network License Manager 安装在一台服务器上，因此许可证管理和活动只能在此服务器上进行。单一许可证文件表示服务器上可用许可证的总数。

单一许可服务器模式的优点

  • 由于所有许可证管理都在一台服务器上进行，所以只有一个管理点和一个故障点。
  • 在三种许可服务器模式中，此配置要求的维护工作量最少。

单一许可服务器模式的缺点

  • 如果单一许可服务器出现故障，在服务器恢复工作之前，Autodesk 产品将无法运行。


分布式许可服务器模式

单一许可服务器模式
规划许可服务器配置
冗余许可服务器模式
Autodesk 网络许可手册 > 规划网络许可 > 规划许可服务器配置 >
分布式许可服务器模式

在分布式许可服务器模式中，许可证分布在多台服务器上。每台服务器都要求具有唯一的许可证文件。要创建分布式许可服务器，必须在分布式服务器池中的每台服务器上运行 Network License Manager。

分布式许可服务器模式的优点

  • 服务器可分布在广域网 (WAN) 范围内，而不必位于同一个子网中。
  • 当分布式服务器池中的一台服务器出现故障时，其他服务器中的许可证仍然可用。
  • Windows XP® Professional 以及 Windows® 2000 与 Windows 2003 Server 的工作站和服务器均支持分布式许可服务器模式。
  • 需要替换分布式服务器池中的服务器时，不必重新建立整个服务器池。
  • 这比在冗余服务器池中替换服务器更容易，因为在冗余服务器池中替换服务器时必须重新激活整个服务器池。

分布式许可服务器模式的缺点

  • 如果分布式服务器池中的某台服务器出现故障，该服务器中的许可证将不可用。


冗余许可服务器模式

分布式许可服务器模式
规划许可服务器配置
了解许可证
Autodesk 网络许可手册 > 规划网络许可 > 规划许可服务器配置 >
冗余许可服务器模式

在冗余许可服务器模式下，可以使用三台服务器验证单个许可证文件。一台服务器作为主服务器，另外两台服务器在主服务器无法工作时提供备份。使用此配置，只要有两台服务器正常工作，即可继续监视和分发许可证。三台服务器上的许可证文件都是相同的。必须在每台服务器上都安装 Network License Manager。

在冗余许可服务器模式下，所有服务器必须位于同一子网中并具有稳定的网络通信。（不支持低速、不稳定或拨号连接。）

冗余许可服务器模式的优点

  • 如果三台服务器中有一台服务器出现故障，服务器池中管理的所有许可证仍然可用。

冗余许可服务器模式的缺点

  • 如果多台服务器出现故障，所有许可证都将不可用。
  • 三台服务器必须位于同一个子网中，且必须具有可靠的网络通信。冗余服务器池不提供网络容错。
  • 仅在 Windows 2000 Server Edition 和 Windows 2003 Server Edition 中支持冗余许可服务器模式。在 Windows XP 和 Windows 2000 中不支持冗余许可服务器模式。
  • 如果更换三台服务器中的一台，则必须重新建立整个冗余服务器池。
  • 如果 Autodesk 产品支持许可证借用功能，并且许可证是从冗余许可服务器池借用的，则在停止 Network License Manager 之后必须重新启动许可服务器。


了解许可证

冗余许可服务器模式
规划网络许可
许可证操作及可用性
Autodesk 网络许可手册 > 规划网络许可 >
了解许可证

本节介绍许可证的操作和可用性、许可证文件、许可证类型和行为以及心跳信号。

本节内容

  • 许可证操作及可用性
  • 许可证文件
  • 许可证文件样例
  • 软件包许可证文件样例
  • 许可证类型和行为
  • 心跳信号


许可证操作及可用性

了解许可证
了解许可证
许可证文件
Autodesk 网络许可手册 > 规划网络许可 > 了解许可证 >
许可证操作及可用性

当用户启动 Autodesk 产品时，产品自己会决定应该从哪台服务器上获取许可证。然后，产品将通过 TCP/IP 网络协议向许可服务器请求许可证。

如果许可服务器上还有可用许可证，Network License Manager 则为工作站分配一个许可证。然后，工作站上将启动一个产品任务，许可服务器上的可用许可证数目也相应减少一个。

同样，当用户退出产品时， Network License Manager 将释放许可证以供其他用户使用。如果用户在单个工作站上运行 Autodesk 产品的多个任务，则只使用一个许可证。当最后一个任务关闭时，许可证才被释放。

以下三个过程用于管理许可证的分发和可用性：

  • 许可证管理器守护程序 (lmgrd.exe)。处理与应用程序的初始联系，然后将连接传递给供应商守护程序。lmgrd.exe 守护程序仅用于与供应商守护程序进行通信；lmgrd.exe 不能验证或分发许可证，而只能将用户请求传递给供应商守护程序。使用此方法，多家软件供应商可以使用一个 lmgrd.exe 守护程序提供许可证验证。lmgrd.exe 守护程序可以根据需要启动和重新启动供应商守护程序。
  • Autodesk 供应商守护程序 (adskflex.exe)。维持对已检出的许可证和使用这些许可证的工作站的追踪。每个软件供应商都具有唯一的供应商守护程序，用来管理特定供应商的许可证。顾名思义，adskflex.exe 供应商守护程序针对的是 Autodesk 产品。
注意如果 adskflex.exe 供应商守护程序因为某种原因而终止，所有用户都将丢失许可证，除非 lmgrd.exe 重新启动供应商守护程序或导致终止的问题已被解决。
  • 许可证文件。包含特定于供应商的许可证信息的文本文件。


许可证文件

许可证操作及可用性
了解许可证
许可证文件样例
Autodesk 网络许可手册 > 规划网络许可 > 了解许可证 >
许可证文件

从 Autodesk 收到的网络许可证文件包含网络安装所需的许可证信息。可以在注册 Autodesk 产品时获取许可证文件数据。

许可证文件包含关于网络服务器节点和供应商守护程序的信息，还包含 Autodesk 生成该文件时创建的加密数字签名。

许可证文件位于用户在展开向导中指定的网络位置。对于从网络安装运行该产品的每一个用户，该网络位置都必须是可访问的。

下表定义了所有许可证文件参数。

许可证文件参数的定义
行 | 参数 | 定义 | 样例
SERVER | Host Name | Network License Manager 所在服务器的主机名 | labserver
 | Host ID | Network License Manager 所在服务器的以太网地址 | 03D054C0149B
USE_SERVER | [无] |  |
VENDOR | 供应商守护程序 | 服务器端 Autodesk 供应商守护程序的名称 | adskflex.exe
 | Port Number | 保留并指定仅由运行 Autodesk 供应商守护程序的 Autodesk 产品使用的网络端口号 | port=2080
PACKAGE | 名称 | 功能代码编组的名称 | SERIES_1
 | 供应商守护程序 | 服务器端 Autodesk 供应商守护程序的名称 | adskflex.exe
 | Version | 内部版本号参照 | 1.000
 | COMPONENTS | 软件包中支持的功能代码列表 | COMPONENTS= "526000REVIT_9_OF\ 51200ACD_2007_OF\ 513001INVBUN_11_OF"
 | OPTIONS |  | OPTIONS=SUITE
 | SUPERSEDE | 同一许可服务器上日期早于定义的“Issue Date”（发布日期）的任何许可证文件中，相同功能代码的任何现有“Increment”（增量）行的替换 | SUPERSEDE
 | Issue Date | 许可证的发布日期 | ISSUED=15-jul-2006
 | SIGN | 用于验证许可证文件属性的加密签名 | SIGN=0 SIGN2=0
INCREMENT | Feature Code | 许可证文件支持的产品 | 51200ACD_2007_0F
 | PLIST | 如果许可证文件中包含 INCREMENT PLIST 参数，则它将定义当同一功能代码存在于 INCREMENT 行中时许可证使用的优先级。 有关详细信息，请参见 许可证文件中附加参数的样例 | INCREMENT PLIST
 | 供应商守护程序 | 服务器端 Autodesk 供应商守护程序的名称 | adskflex.exe
 | Version | 内部版本号参照 | 1.000
 | Expiration Date | 许可证的有效期 | permanent
 | Number of Licenses | 许可证文件支持的许可证数目 | 25
 | VENDOR_STRING | 许可证文件支持的产品的许可证使用类型和许可证行为。 位于某 INCREMENT PLIST 行下的 VENDOR_STRING 参数根据功能代码列表确定使用产品许可证的顺序。 有关详细信息，请参见许可证文件中附加参数的样例。 | COMMERCIAL
 | SUPERSEDE | 同一许可服务器上日期早于定义的“Issue Date”（发布日期）的任何许可证文件中，相同功能代码的任何现有“Increment”（增量）行的替换 | SUPERSEDE
 | BORROW | 在同一增量行下定义的许可证的许可证借用时间定义。 在本样例中，许可证可借用的最长时间为 4320 小时（180 天），除非另有说明（例如，BORROW=2880 表示该许可证最长可借用 2880 小时，即 120 天） 如果许可证文件中没有此参数，将禁用许可证借用功能 | BORROW=4320
 | DUP_GROUP | 同一用户和同一主机共享同一许可证时的多个许可证请求定义 | DUP_GROUP=UH
 | ISSUED | Autodesk 生成 许可证文件的日期 | 15-jul-2006
 | Serial Number | Autodesk 产品的序列号 | 123-12345678
 | SIGN | 用于验证许可证文件属性的加密签名 | SIGN=6E88EFA8D44C


许可证文件样例

许可证文件
了解许可证
不特定于产品的许可证文件样例
Autodesk 网络许可手册 > 规划网络许可 > 了解许可证 >
许可证文件样例

本文档中提供的许可证文件样例可以帮助您理解在特定的网络设置中许可证文件的作用方式。Autodesk 为每个产品都提供标准许可证文件，并为既可单独销售又可作为产品集一部分销售的产品提供具有附加参数的许可证文件。

  • 标准许可证文件。如果用户购买了一个或多个不是作为产品套件的一部分提供的产品，将收到标准许可证文件。
  • 具有附加参数的标准许可证文件。如果用户购买了包括在产品套件中并且还可以作为单个产品销售的 Autodesk 产品，将收到一个标准许可证文件，该许可证文件中包括了附加参数。附加参数定义了许可证使用的次序，以便在使用产品集许可证之前使用单个产品许可证。

Autodesk 许可证文件样例包括一个不特定于某产品的许可证文件，针对单一服务器模式、分布式服务器模式和冗余服务器模式的完整许可证文件，一个已合并的产品版本许可证文件和已添加至标准许可证文件的附加参数的样例。

本节内容

  • 不特定于产品的许可证文件样例
  • 单一或分布式服务器的许可证文件样例
  • 冗余服务器的许可证文件样例
  • 已合并的 Autodesk 产品版本的许可证文件样例
  • 许可证文件中附加参数的样例


不特定于产品的许可证文件样例

许可证文件样例
许可证文件样例
单一或分布式服务器的许可证文件样例
Autodesk 网络许可手册 > 规划网络许可 > 了解许可证 > 许可证文件样例 >
不特定于产品的许可证文件样例

以下是包括某一个许可证文件的内容以及与其每一行相关联的参数的样例：

SERVER ServerName HostID
USE_SERVER
VENDOR adskflex port=portnumber
INCREMENT feature_code Adskflex Version ExpDate NumberofLicenses \
VENDOR_STRING=UsageType:Behavior BORROW=4320 SUPERSEDE \ DUP_GROUP=DupGrp ISSUED=IssueDate SN=SerialNumber SIGN= \


单一或分布式服务器的许可证文件样例

不特定于产品的许可证文件样例
许可证文件样例
冗余服务器的许可证文件样例
Autodesk 网络许可手册 > 规划网络许可 > 了解许可证 > 许可证文件样例 >
单一或分布式服务器的许可证文件样例

以下是单一或分布式许可服务器模式的完整许可证文件的样例：

SERVER Server1 1a34567c90d2
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 54600ACD_2008_0F adskflex 1.000 permanent 5 \
    VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
    DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 SIGN="0247 \
    45D6 87C4 27A5 7F9E F24A ED3D 61E4 6B3B CC5C AD77 B865 9EA8 \
    3D62 0792 0F67 19E7 57E7 FAFA A48B D582 335A EC16 1FE5 B70D \
    76AB 6488 61CC DE5E F5B7" SIGN2="09FD 0850 7CF1 F447 9F05 9FA3 \
    2A0A 38D6 83FC 1746 F3F5 5A72 6250 E002 DE0B 0E6E F88C AC95 \
    136F 87F2 A945 E4C4 A97F 44B5 74EE 83F3 3F3E 1579 B981 8994"


冗余服务器的许可证文件样例

单一或分布式服务器的许可证文件样例
许可证文件样例
已合并的 Autodesk 产品版本的许可证文件样例
Autodesk 网络许可手册 > 规划网络许可 > 了解许可证 > 许可证文件样例 >
冗余服务器的许可证文件样例

以下是冗余许可服务器模式的完整许可证文件的样例：

SERVER Server1 1a34567c90d2 27005
SERVER Server2 2a34567f90d3 27005
SERVER Server3 3a34567b90d4 27005
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 54600ACD_2008_0P adskflex 1.000 permanent 5 \
    VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
    DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 SIGN="15A0 \
    9FD4 0108 1BDE F05D 8960 55C5 0142 1D4F 5570 D4F5 C6D2 949E \
    AAA6 1195 1616 50BD 2A07 14A9 898D 69C9 F833 7EED 4D56 ADCC \
    5CD3 1173 F04A 1A63 8335" SIGN2="1239 48BA 591E 20B8 7EB9 CDF5 \
    2FCF 31F1 62DF 8BED 839D 8A20 5C41 673E 06F9 0B97 179E 4398 \
    9C10 8C5F 8020 EB0D 9AA6 772D FB67 2208 C211 096F E44C F086"
注意冗余服务器模式需要为每台服务器都添加一个端口号（默认值为 27005）。


已合并的 Autodesk 产品版本的许可证文件样例

冗余服务器的许可证文件样例
许可证文件样例
许可证文件中附加参数的样例
Autodesk 网络许可手册 > 规划网络许可 > 了解许可证 > 许可证文件样例 >
已合并的 Autodesk 产品版本的许可证文件样例

可以合并同一 Autodesk 产品的不同版本或是不同 Autodesk 产品的许可证文件，然后从一个许可服务器运行所有产品。例如，可以合并 AutoCAD 2008 的许可证文件和 AutoCAD 与 AutoCAD Map 的许可证文件。

以下是已合并的许可证文件内容的样例：

SERVER Server1 1a34567c90d2
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 42600ACD_2004_0F adskflex 1.000 permanent 3 \
    VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
    DUP_GROUP=UH ISSUED=22-jun-2003 SN=123-12345678 SIGN=6E88EFA8D44C \
INCREMENT 54600ACD_2008_0F adskflex 1.000 permanent 5 \
    VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
    DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 SIGN="0247 \
    45D6 87C4 27A5 7F9E F24A ED3D 61E4 6B3B CC5C AD77 B865 9EA8 \
    3D62 0792 0F67 19E7 57E7 FAFA A48B D582 335A EC16 1FE5 B70D \
    76AB 6488 61CC DE5E F5B7" SIGN2="09FD 0850 7CF1 F447 9F05 9FA3 \
    2A0A 38D6 83FC 1746 F3F5 5A72 6250 E002 DE0B 0E6E F88C AC95 \
    136F 87F2 A945 E4C4 A97F 44B5 74EE 83F3 3F3E 1579 B981 8994"
INCREMENT 51700MAP_2008_0F adskflex 1.000 permanent 5 \
    VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
    DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 SIGN="1707 \
    9EAC CBCB 2405 692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 \
    5A1B 4A44 083A BE5F 3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E \
    3EBD 0B48 4E75 193A DA82" SIGN2="004A FC90 AB47 3F6B 59BC \
    6681 6971 A76A BA52 98E2 5671 26B3 0E78 791B 109F 0591 7DC3 \
    F09F 4D8D 4FB7 E341 4A03 CD68 1D77 27F8 8555 9CF7 DEDD 9380"


许可证文件中附加参数的样例

已合并的 Autodesk 产品版本的许可证文件样例
许可证文件样例
软件包许可证文件样例
Autodesk 网络许可手册 > 规划网络许可 > 了解许可证 > 许可证文件样例 >
许可证文件中附加参数的样例

对于包括在产品集中并且还可以作为单个产品销售的 Autodesk 产品，将根据许可证文件中定义的优先级次序来分配许可证。对于这些产品，许可证文件中将显示类似于以下样例的信息：

SERVER Server1 1a34567c90d2
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 54600ACD_2008_0F adskflex 1.000 permanent 5 \
    VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
    DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 SIGN="0247 \
    45D6 87C4 27A5 7F9E F24A ED3D 61E4 6B3B CC5C AD77 B865 9EA8 \
    3D62 0792 0F67 19E7 57E7 FAFA A48B D582 335A EC16 1FE5 B70D \
    76AB 6488 61CC DE5E F5B7" SIGN2="09FD 0850 7CF1 F447 9F05 9FA3 \
    2A0A 38D6 83FC 1746 F3F5 5A72 6250 E002 DE0B 0E6E F88C AC95 \
    136F 87F2 A945 E4C4 A97F 44B5 74EE 83F3 3F3E 1579 B981 8994"
INCREMENT PLIST adskflex 1.000 permanent 1 \
    VENDOR_STRING=A07:51600ACDLAND_2007_0F: 52200CIV3D_2007_0F;B07:51900AMECH_PP_2007_0F: 51300INVBUN_11_0F:51400INVPRO_11_0F07: 51900AMECH_PP_2007_0F: 51300INVBUN_11_0F:51400INVPRO_11_0F
    SUPERSEDE ISSUED=15-jul-2006 SIGN="14C8 A29F BA92 C89A F132 \
    BE66 0206 D8BE F9B7 3FB5 9229 FEB8 2E8D 995E EBB5 1B9E 0142 \
    C933 9483 D0D0 CA94 6532 1CB5 37D7 03CD B085 7301 7484 CA71 \
    2861" SIGN2="0B21 109E EED0 4863 A6E9 6A65 8C7B 6D0B 0B04 \
    2F22 355F 433B 2D81 A540 1D45 55A1 DA71 4024 DA50 35E2 \
    0089 3081 724E 860B A11F EBBE 3641 A1D5"


软件包许可证文件样例

许可证文件中附加参数的样例
了解许可证
单一服务器的软件包许可证文件样例
Autodesk 网络许可手册 > 规划网络许可 > 了解许可证 >
软件包许可证文件样例

Autodesk 提供了一个软件包许可证文件选项，该选项允许用户使用一组打包销售的产品，同时控制购买的许可证总数。

通过软件包许可证，用户可以收到单个许可证文件以运行打包产品的任意组合，最多可达购买的套数总数。

例如，如果购买了三个 Autodesk 产品的 100 套，则可以使用单个许可证文件来运行该软件包中的三个产品的任意组合，最多可达 100 套。

以下是一些适用于单一许可服务器、分布式许可服务器和冗余许可服务器的软件包许可证文件样例，以及一个适用于已合并的 Autodesk 产品版本的软件包许可证文件样例。

本节内容

  • 单一服务器的软件包许可证文件样例
  • 分布式服务器的软件包许可证文件样例
  • 冗余服务器的软件包许可证文件样例
  • 已合并的 Autodesk 产品版本的软件包许可证文件样例


单一服务器的软件包许可证文件样例

软件包许可证文件样例
软件包许可证文件样例
分布式服务器的软件包许可证文件样例
Autodesk 网络许可手册 > 规划网络许可 > 了解许可证 > 软件包许可证文件样例 >
单一服务器的软件包许可证文件样例

以下是单一许可服务器模式的完整许可证文件的样例：

SERVER Server1 1a34567c90d2
USE_SERVER
VENDOR adskflex port=2080
PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="54700REVIT_2008_0F \
    54600ACD_2008_0F 51300INVBUN_11_0F" OPTIONS=SUITE SUPERSEDE \
    ISSUED=09-Jan-2007 SIGN="1707 9EAC CBCB 2405 692E 4A89 \
    AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 193A DA82" \
    FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F 3827 \
    SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 98E2 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
    CD68 1D77 27F8 8555 9CF7 DEDD 9380"
INCREMENT SERIES_1 adskflex 1.000 permanent 100 \
    VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \
    SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \
    692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 BE5F \
    3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \
    SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
    CD68 1D77 27F8 8555 9CF7 DEDD 9380"


分布式服务器的软件包许可证文件样例

单一服务器的软件包许可证文件样例
软件包许可证文件样例
冗余服务器的软件包许可证文件样例
Autodesk 网络许可手册 > 规划网络许可 > 了解许可证 > 软件包许可证文件样例 >
分布式服务器的软件包许可证文件样例

以下是分布式许可服务器模式的完整许可证文件的样例：

SERVER Server1 1a34567c90d2
USE_SERVER
VENDOR adskflex port=2080
PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="54700REVIT_2008_0F \
    54600ACD_2008_0F 51300INVBUN_11_0F" OPTIONS=SUITE SUPERSEDE \
    ISSUED=09-Jan-2007 SIGN="1707 9EAC CBCB 2405 692E 4A89 \
    FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F 3827 \
    AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 DA82" \
    SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
    CD68 1D77 27F8 8555 9CF7 DEDD 9380"
INCREMENT SERIES_1 adskflex 1.000 permanent 100 \
    VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \
    SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \
    692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A \
    3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \
    SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
    CD68 1D77 27F8 8555 9CF7 DEDD 9380"


冗余服务器的软件包许可证文件样例

分布式服务器的软件包许可证文件样例
软件包许可证文件样例
已合并的 Autodesk 产品版本的软件包许可证文件样例
Autodesk 网络许可手册 > 规划网络许可 > 了解许可证 > 软件包许可证文件样例 >
冗余服务器的软件包许可证文件样例

以下是冗余许可服务器模式的完整许可证文件的样例：

SERVER Server1 1a34567c90d2 27005
SERVER Server2 2a34567f90d3 27005
SERVER Server3 3a34567b90d4 27005
USE_SERVER
VENDOR adskflex port=2080
PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="54700REVIT_2008_0F \
    54600ACD_2008_0F 51300INVBUN_11_0F" OPTIONS=SUITE SUPERSEDE \
    ISSUED=09-Jan-2007 SIGN="1707 9EAC CBCB 2405 692E 4A89 \
    FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F \
    AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 DA82" \
    SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
    CD68 1D77 27F8 8555 9CF7 DEDD 9380"
INCREMENT SERIES_1 adskflex 1.000 permanent 100 \
    VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \
    SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \
    692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 BE5F \
    3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \
    SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
    CD68 1D77 27F8 8555 9CF7 DEDD 9380"


已合并的 Autodesk 产品版本的软件包许可证文件样例

冗余服务器的软件包许可证文件样例
软件包许可证文件样例
许可证类型和行为
Autodesk 网络许可手册 > 规划网络许可 > 了解许可证 > 软件包许可证文件样例 >
已合并的 Autodesk 产品版本的软件包许可证文件样例

在本例中，借用的前 50 个 AutoCAD 2008 产品 (54600ACD_2008_0F) 许可证已从第一个“增量”行减去。借用的第 51 个许可证将从“软件包”行减去：

SERVER Server1 1a34567c90d2 27005
USE_SERVER
VENDOR adskflex port=2080
INCREMENT 54600ACD_2008_0F adskflex 1.000 permanent 50 \
    VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
    DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 SIGN=6E88EFA8D44C \
PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="54700REVIT_2008_0F \
    54600ACD_2008_0F 51300INVBUN_11_0F" OPTIONS=SUITE SUPERSEDE \
    ISSUED=09-Jan-2007 SIGN="1707 9EAC CBCB 2405 692E 4A89 \
    FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F \
    AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 DA82" \
    SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A 98E2 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
    CD68 1D77 27F8 8555 9CF7 DEDD 9380"
INCREMENT SERIES_1 adskflex 1.000 permanent 100 \
    VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \
    SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \
    692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A \
    3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \
    SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
    CD68 1D77 27F8 8555 9CF7 DEDD 9380"
在以下样例中，借用的前 150 个 AutoCAD 2008 产品 (54600ACD_2008_0F) 许可证已从“软件包”/“增量”行减去。借用的第 151 个许可证将从“增量”行减去：
SERVER Server1 1a34567c90d2 27005
USE_SERVER
VENDOR adskflex port=2080
PACKAGE SERIES_1 adskflex 1.000 COMPONENTS="54700REVIT_2008_0F \
     54600ACD_2008_0F 51300INVBUN_11_0F" OPTIONS=SUITE SUPERSEDE \
    ISSUED=09-Jan-2007 SIGN="1707 9EAC CBCB 2405 692E 4A89 \
    FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 083A BE5F \
    30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 4E75 193A DA82" \
    SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 \
    CD68 1D77 27F8 8555 9CF7 DEDD 9380"
INCREMENT SERIES_1 adskflex 1.000 permanent 150 \
    VENDOR_STRING=commercial:permanent BORROW=4320 DUP_GROUP=UH \
    SUITE_DUP_GROUP=UHV SN=123-12345678 SIGN="1707 9EAC CBCB \
    692E 4A89 FC45 C009 E360 944A 14BA E99C 9B24 5A1B 4A44 \
    3827 AA26 30CC 2AC2 D6B3 A61B AB5E 492E 3EBD 0B48 DA82" \
    SIGN2="004A FC90 AB47 3F6B 59BC 0E6D 6681 6971 A76A BA52 \
    5671 26B3 0E78 791B 109F 0591 7DC3 F09F 4D8D 4FB7 E341 4A03 \
    CD68 1D77 27F8 8555 9CF7 DEDD 9380"
INCREMENT 54600ACD_2008_0F adskflex 1.000 permanent 50 \
    VENDOR_STRING=commercial:permanent BORROW=4320 SUPERSEDE \
    DUP_GROUP=UH ISSUED=09-Jan-2007 SN=123-12345678 \
    SIGN=6E88EFA8D44C


许可证类型和行为

已合并的 Autodesk 产品版本的软件包许可证文件样例
了解许可证
心跳信号
Autodesk 网络许可手册 > 规划网络许可 > 了解许可证 >
许可证类型和行为

Autodesk 支持动态产品使用和许可证行为。这意味着用户可以使用特定许可证购买特定的行为类型，并且以后更改许可证时不必删除安装和重新安装 Autodesk 产品。

许可证类型包括以下几种：

  • 商业许可证。以商业方式购买的产品的许可证。
  • 非销售许可证。非商业销售产品的许可证。
  • Educational (EDU)/Institution 许可证。专门用于教育机构的许可证。
  • 学习许可证。用于使用 Autodesk 产品作为课程内容的学生的许可证。

许可证行为包括以下几种：

  • 永久性。允许永久使用 Autodesk 产品。
  • 可延长期限。允许在有限时间内使用 Autodesk 产品。该期限可以随时延长。
  • 不可延长期限。允许在有限时间内使用 Autodesk 产品。该期限不能延长。


心跳信号

许可证类型和行为
了解许可证
网络许可工具
Autodesk 网络许可手册 > 规划网络许可 > 了解许可证 >
心跳信号

Autodesk 产品运行时，会定期与许可服务器进行通信，它使用的通信方法称为“心跳”信号。如果心跳信号丢失，服务器会尝试重新连接。如果服务器无法重新连接，用户将收到许可证错误信息。

如果产品因丢失与服务器的连接而停止工作，必须关闭该产品然后重新启动。如果最初导致心跳信号丢失的问题得到解决，且服务器上有可用的许可证，则可以重新启动程序。


网络许可工具

心跳信号
安装 Autodesk Network License Manager
Autodesk 网络许可手册 >
网络许可工具

本节包括有关在网络中安装和配置 Autodesk Network License Manager，以及安装和使用网络许可证激活实用程序的信息。

本节内容

  • 安装 Autodesk Network License Manager
  • 安装网络许可证激活实用程序
  • 使用网络许可证激活实用程序
  • 手动获取服务器主机名和主机 ID
  • 配置许可服务器
  • 停止和重新启动许可服务器
  • 设置和使用选项文件
  • 删除安装 Network License Manager


安装 Autodesk Network License Manager

网络许可工具
网络许可工具
安装网络许可证激活实用程序
Autodesk 网络许可手册 > 网络许可工具 >
安装 Autodesk Network License Manager

可以在使用安装向导之前或之后安装 Network License Manager。安装网络应用程序的顺序无关紧要，只要您安装所有所需应用程序并为所有网络应用程序提供一致的许可服务器信息。

如果该计算机中已经安装了早期版本的 Network License Manager，则应进行升级，方法是将 Autodesk Network License Manager 安装到该早期版本所在的文件夹中。如果选择其他安装文件夹，计算机中将有两种版本的 Network License Manager。

安装 Autodesk Network License Manager 的步骤

  1. 在 AutoCAD 2008 安装向导中，单击“安装工具和实用程序”。
  2. 在“欢迎使用 AutoCAD 2008 安装向导”页面上，单击“下一步”。
  3. 查看适用于您所在国家或地区的 Autodesk 软件许可协议。必须接受协议才能继续安装。选择国家或地区，单击“我接受”，然后单击“下一步”。
    注意如果不同意协议的条款并希望终止安装，请单击“取消”。
  4. 在“选择要安装的项目”页面上，确保“Network License Manager”处于选定状态，然后单击“下一步”。
  5. 在“查看 - 配置 - 安装”页面上，单击“配置”。
  6. 单击“Network License Manager”选项卡。
  7. 在“设置 Network License Manager”页面上，接受默认安装路径 (C:\Program Files\Autodesk\NLM\) 或单击“浏览”以指定其他路径。如果输入的路径不存在，将根据您提供的名称和位置创建一个新文件夹。单击“下一步”。
    警告请勿在远程驱动器上安装 Network License Manager。安装 Network License Manager 文件时，必须提供一个本地驱动器路径。必须指定驱动器号；不支持通用命名约定 (UNC)。
  8. 在“在线访问工具”页面上，单击“下一步”以安装 Network License Manager 和任何其他选定的工具和实用程序。
  9. 显示“安装完成”页面时，单击“完成”。


安装网络许可证激活实用程序

安装 Autodesk Network License Manager
网络许可工具
使用网络许可证激活实用程序
Autodesk 网络许可手册 > 网络许可工具 >
安装网络许可证激活实用程序

安装网络许可证激活实用程序，以便可以通过 Internet 获取许可证文件。

安装网络许可证激活实用程序的步骤

  1. 在 AutoCAD 2008 安装向导中，单击“安装工具和实用程序”。
  2. 在“欢迎使用 AutoCAD 2008 安装向导”页面上，单击“下一步”。
  3. 查看适用于您所在国家或地区的 Autodesk 软件许可协议。必须接受协议才能继续安装。选择国家或地区，单击“我接受”，然后单击“下一步”。
    注意如果不同意协议的条款并希望终止安装，请单击“取消”。
  4. 在“选择要安装的项目”页面上，确保网络许可证激活实用程序处于选定状态，然后单击“下一步”。
  5. 在“查看 - 配置 - 安装”页面上，单击“配置”。
  6. 单击“网络许可证激活实用程序”选项卡。
  7. 在“设置网络许可证激活实用程序”页面上，接受默认安装路径 (C:\Program Files\Autodesk\NLA\) 或单击“浏览”以指定其他路径。如果输入的路径不存在，将根据您提供的名称和位置创建一个新文件夹。单击“下一步”。
  8. 在“在线访问工具”页面上，单击“下一步”以安装网络许可证激活实用程序和任何其他选定的工具和实用程序。
  9. 显示“安装完成”页面时，单击“完成”。


使用网络许可证激活实用程序

安装网络许可证激活实用程序
网络许可工具
手动获取服务器主机名和主机 ID
Autodesk 网络许可手册 > 网络许可工具 >
使用网络许可证激活实用程序

使用网络许可证激活实用程序，可以通过 Internet 获取许可证。此外，此实用程序还用于注册产品、提供有关电子邮件的自动支持（如果不能通过 Internet 获取许可证）以及自动保存并移植许可证文件。

如果要使用网络许可证激活实用程序来获取许可证文件，请确保提供了以下信息：

  • 许可服务器信息，包括主机名和主机 ID
  • 早期产品的序列号（仅对于升级）
  • 对可以保存许可证文件的位置的访问权限

使用网络许可证激活实用程序（联机请求）的步骤

  1. 在“开始”菜单 (Windows) 上，依次单击“所有程序”（或“程序”） [image] “Autodesk” [image] “Network License Manager” [image] “AutoCAD 2008 网络许可证激活实用程序”。
  2. 在“获取网络许可证”页面上，确保直接连接（通过 Internet）处于激活状态，然后单击“下一步”。
  3. 在“服务器信息”页面上，输入以下数据：
    • 编组 ID 的产品序列号
      注意如果是在修改现有许可证文件或是获取现有产品的新许可证，那么页面上可能会显示先前输入的信息。请确保所显示的序列号是要许可的产品序列号。如果不是，请输入正确的产品序列号。
    • 许可服务器模式

      要获取每种许可服务器模式的详细信息，请单击“?”按钮。

    • 服务器主机名

      如果不知道主机名，单击“...”按钮查找计划使用的每个服务器的名称。

      注意在分布式服务器模式中，用户最多具有 20 台服务器。一旦达到 20 台服务器的限制，“添加”按钮将消失。
    • 主机 ID，为每台服务器输入的主机名

      如果不能找到主机 ID，单击“查找”以使实用程序自动查找服务器的主机 ID。

      注意如果服务器具有多个网络适配器，请选择与物理网络适配器相对应的网络适配器。要确定哪些适配器是物理适配器，请在 Windows 命令提示下输入 ipconfig /all，然后查看每个物理地址上方的“Description”字段。如果有多个物理网络适配器，则可以使用其中任意一个，只要运行 ipconfig /all 时列出了该适配器即可。此外，还可能列出一些逻辑设备（例如 VPN 适配器、PPP 适配器和调制解调器），但是它们在许可操作中不可用。
    • 每个许可服务器的套数

      如果选择分布式服务器模式，则显示“套数”对话框。为每个许可服务器输入套数。

    单击“下一步”。

  4. 在“确认服务器信息”页面上，检查所输入的服务器信息，然后单击“下一步”。
  5. 从“登录”页面，输入用户 ID 和密码，然后单击“登录”。

    如果您没有用户帐号，则单击“现在创建用户 ID”链接，然后按照说明创建一个新的用户帐号。

  6. 在“确认用户信息”页面上，选择一个配置，然后单击“下一步”。
  7. 在“已收到许可证”页面的“保存 [计算机名称] 的许可证文件”字段中，输入要保存许可证文件的位置，或单击“浏览”以浏览到相应的位置。
    注意建议将许可证文件保存在安装 Network License Manager 的位置。

    该页面的内容根据用户所选择的服务器模式的不同而不同。

    单击“下一步”。

  8. 在“许可证激活成功”页面上，单击“打印”以保存许可证信息的打印副本，或单击“完成”以完成此事务并退出网络许可证激活实用程序。

接收许可证文件并将它保存到本地后，请参见如何配置许可服务器以配置您的许可证管理器。

使用网络许可证激活实用程序（脱机请求）的步骤

  1. 在“开始”菜单 (Windows) 上，依次单击“所有程序”（或“程序”） [image] “Autodesk” [image] “Network License Manager” [image] “AutoCAD 2008 网络许可证激活实用程序”。
  2. 在“获取网络许可证”页面上，确保直接连接（通过 Internet）处于激活状态，然后单击“下一步”。
  3. 在“服务器信息”页面上，输入以下数据：
    • 编组 ID 的产品序列号
      注意如果是在修改现有许可证文件或是获取现有产品的新许可证，那么页面上可能会显示先前输入的信息。请确保所显示的序列号是要许可的产品序列号。如果不是，请输入正确的产品序列号。
    • 许可服务器模式

      要获取每种许可服务器模式的详细信息，请单击“?”按钮。

    • 服务器主机名

      如果不知道主机名，单击“...”按钮查找计划使用的每个服务器的名称。

      注意在分布式服务器模式中，用户最多具有 20 台服务器。一旦达到 20 台服务器的限制，“添加”按钮将消失。
    • 主机 ID，为每台服务器输入的主机名

      如果不能找到主机 ID，单击“查找”以使实用程序自动查找服务器的主机 ID。

      注意如果服务器具有多个网络适配器，请选择与物理网络适配器相对应的网络适配器。要确定哪些适配器是物理适配器，请在 Windows 命令提示下输入 ipconfig /all，然后查看每个物理地址上方的“Description”字段。如果有多个物理网络适配器，则可以使用其中任意一个，只要运行 ipconfig /all 时列出了该适配器即可。此外，还可能列出一些逻辑设备（例如 VPN 适配器、PPP 适配器和调制解调器），但是它们在许可操作中不可用。
    • 每个许可服务器的套数

      如果选择分布式服务器模式，则显示“套数”对话框。为每个许可服务器输入套数。

    单击“下一步”。

  4. 在“确认服务器信息”页面上，检查所输入的服务器信息，然后单击“下一步”。
  5. 如果显示“产品注册”页面，请执行以下所有操作：
    • 选择将产品注册给公司还是个人。
    • 选择您所在国家或地区。
    • 指定这是否为产品升级。

    单击“下一步”。

  6. 在“客户信息”页面上输入个人数据，然后选择您希望接收激活码的方式。单击“下一步”。
  7. 在“确认信息”页面上查看个人数据，然后选择将用来提交请求的方法。单击“关闭”。
    • 如果通过电子邮件提交您的请求，则将通过在“客户信息”页面上指定的方法发送您的激活码。
    • 如果通过传真、电话或邮件提交您的请求，则将显示包含 Autodesk 传真号码、电话号码和邮寄地址的“与 Autodesk 联系”页面。也可以打印您的激活申请表。

接收许可证文件并将它保存到本地后，请参见如何配置许可服务器以配置您的许可证管理器。

注意建议将许可证文件保存在安装 Network License Manager 的位置。


手动获取服务器主机名和主机 ID

使用网络许可证激活实用程序
网络许可工具
配置许可服务器
Autodesk 网络许可手册 > 网络许可工具 >
手动获取服务器主机名和主机 ID

如果无法使用网络许可证激活实用程序获取服务器主机名和主机 ID，则可以手动获取这些信息。Autodesk 使用服务器主机名、主机 ID 和产品序列号生成许可证文件。

要手动获取这些信息，可以使用 Windows 命令提示符或运行 lmtools.exe 实用程序。如果使用 lmtools.exe，请勿在远程工作站上运行。

使用 Windows 命令提示符获取主机名和主机 ID 的步骤

  1. 依次单击“开始”菜单（适用于 Windows ） [image] “所有程序”（或“程序”） [image] “附件” [image] “命令提示符”。
  2. 在 Windows 命令提示符下，输入以下命令，然后按 ENTER 键：

    ipconfig /all

  3. 找到“Host Name”行，记下主机名。
  4. 找到“Physical Address”行。记下物理地址，并删除破折号。这就是十二个字符的主机 ID。
    注意如果服务器具有多个网络适配器，请选择与物理网络适配器相对应的网络适配器。确定哪些适配器是物理适配器的步骤：在 Windows 命令提示中，输入 ipconfig /all，然后查看每个物理地址上方的“Description”字段。如果有多个物理网络适配器，则可以使用其中的任意一个。只需确保所使用的物理网络适配器安装正确并可以正常工作。VPN 适配器、PPP 适配器和调制解调器等设备无效。
  5. 关闭 Windows 命令提示。

使用 lmtools.exe 获取主机名和主机 ID 的步骤

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 执行下列操作之一：
    • 依次单击“开始”菜单（适用于 Windows XP 和 Windows 2000） [image] “所有程序”（或“程序”） [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • 在桌面上的 LMTOOLS 图标（适用于 Windows Vista）上单击鼠标右键并选择“以管理员身份运行”。
  2. 在 Lmtools 程序中，单击“System Settings”选项卡。
  3. 在“System Settings”选项卡中，找到“Computer/Hostname”框。复制主机名并将该信息粘贴到文本编辑器中。
  4. 找到“Ethernet Address”框。以太网地址即是主机 ID，它包含十二个字符。记下相应信息。如果以太网地址包含的字符超过十二个，则只需记下前十二个字符。
    注意如果服务器具有多个以太网适配器，请选择与物理网络适配器相对应的以太网适配器。
  5. 关闭 lmtools.exe。


配置许可服务器

手动获取服务器主机名和主机 ID
网络许可工具
停止和重新启动许可服务器
Autodesk 网络许可手册 > 网络许可工具 >
配置许可服务器

配置许可服务器，以便管理 Autodesk 产品许可证。请使用 lmtools.exe 实用程序配置许可服务器。

配置许可服务器的步骤

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 执行下列操作之一：
    • 依次单击“开始”菜单（适用于 Windows XP 和 Windows 2000） [image] “所有程序”（或“程序”） [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • 在桌面上的 LMTOOLS 图标（适用于 Windows Vista）上单击鼠标右键并选择“以管理员身份运行”。
  2. 在 Lmtools 程序的“Service/License File”选项卡中，选择“Configuration Using Services”选项。
  3. 单击“Config Services”选项卡。
  4. 在“Config Services”选项卡下的“Service Name”列表中，选择一个服务名，或执行下列操作之一：
    • 如果已选择某个服务名，请确认它是否是您要用来管理许可证的服务名。
    • 如果不存在服务名，请输入要用来管理许可证的服务名。
    注意如果有多个软件供应商使用 FLEXlm® 进行许可证管理，则“Service Name”列表将包含多个选项。
  5. 在“Path to the lmgrd.exe file”框中，输入指向 Network License Manager 守护程序 (lmgrd.exe) 的路径，或单击“Browse”以定位文件。

    默认情况下，此守护程序安装在 \Program Files\Autodesk Network License Manager 文件夹中。

  6. 在“Path to the license file”框中，输入指向许可证文件的路径，或单击“Browse”以定位文件。
  7. 在“Path to the debug log file”框中，输入路径以创建调试日志，或单击“Browse”以定位一个现有的日志文件。
  8. 要将 lmgrd.exe 作为服务来运行，请选择“Use Services”。
  9. 要在系统启动时自动启动 lmgrd.exe，请选择“Start Server at Power Up”。
  10. 单击“Save Service”，将新的配置信息保存到步骤 4 中选定的服务名下。单击“是”。
  11. 单击“Start/Stop/Reread”选项卡。
  12. 在“Start/Stop/Reread”选项卡中，执行下列操作之一：
    • 如果尚未针对 Autodesk 定义服务，请单击“Start Server”以启动许可服务器。
    • 如果已经定义了某一个 Autodesk 服务并且该服务正在运行，请单击“ReRead License File”，使用对许可证文件或选项文件所做的所有更改来刷新 Network License Manager。

      许可服务器开始运行，并准备响应客户端请求。

  13. 关闭 lmtools.exe。


停止和重新启动许可服务器

配置许可服务器
网络许可工具
设置和使用选项文件
Autodesk 网络许可手册 > 网络许可工具 >
停止和重新启动许可服务器

对许可服务器进行系统维护之前，必须停止该许可服务器。完成维护后，可以重新启动该许可服务器。

停止许可服务器的步骤

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 执行下列操作之一：
    • 依次单击“开始”菜单（适用于 Windows XP 和 Windows 2000） [image] “所有程序”（或“程序”） [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • 在桌面上的 LMTOOLS 图标（适用于 Windows Vista）上单击鼠标右键并选择“以管理员身份运行”。
  2. 在 Lmtools 程序的“Service/License File”选项卡中，选择“Configuration Using Services”选项。
  3. 选择要手动启动的许可服务器的服务名。
  4. 单击“Start/Stop/Reread”选项卡。
  5. 在“Start/Stop/Reread”选项卡中，单击“Stop Server”。
  6. 关闭 lmtools.exe。

重新启动许可服务器的步骤

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 执行下列操作之一：
    • 依次单击“开始”菜单（适用于 Windows XP 和 Windows 2000） [image] “所有程序”（或“程序”） [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • 在桌面上的 LMTOOLS 图标（适用于 Windows Vista）上单击鼠标右键并选择“以管理员身份运行”。
  2. 在 Lmtools 程序的“Service/License File”选项卡中，选择“Configuration Using Services”选项。
  3. 选择要手动启动的许可服务器的服务名。
  4. 单击“Start/Stop/Reread”选项卡。
  5. 在“Start/Stop/Reread”选项卡中，单击“Start Server”以重新启动许可服务器。


设置和使用选项文件

停止和重新启动许可服务器
网络许可工具
创建报告日志
Autodesk 网络许可手册 > 网络许可工具 >
设置和使用选项文件

使用选项文件可以设置配置选项，以管理所设置的每台许可服务器上的许可证。选项文件设置由许可证文件读取并由 Lmgrd 程序执行的参数。

如果希望某些或所有许可服务器具有相同的许可证行为，则必须将同一个选项文件保存到每个许可服务器中。如果要在不同的许可服务器上指定不同的许可证行为，则必须为每个许可证行为都创建一个选项文件。必须将每个选项文件保存到需要特定许可证行为的服务器中。

注意要使对选项文件所做的修改在许可服务器中生效，必须保存该选项文件，然后使用 lmtools.exe 重新读取该许可证文件。

使用选项文件可以完成以下操作：

  • 创建报告日志
  • 配置许可证借用功能
  • 设置许可证超时

以下是选项文件内容的样例：

REPORTLOG=c:\test\report.rl

BORROW_LOWWATER Autodesk_f1 3

TIMEOUT Autodesk_f1 7200

还可以设置高级许可证参数，例如，保留许可证、限制许可证的使用或定义用户组。关于设置高级选项文件参数的详细信息，请参见 Program Files\Autodesk Network License Manager\docs\FlexUser 文件夹中的 FLEXlm 文档。

创建选项文件的步骤

使用 LMTOOLS 实用程序工作时，应该使用管理员权限登录。

  1. 打开文本编辑器，输入所需参数，然后将文档命名为 adskflex.opt 并将其保存到许可证文件所在位置。
    注意确保使用扩展名 .opt 保存该文件。Network License Manager 无法识别默认的扩展名 .txt。
  2. 执行下列操作之一：
    • 依次单击“开始”菜单（适用于 Windows XP 和 Windows 2000） [image] “所有程序”（或“程序”） [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • 在桌面上的 LMTOOLS 图标（适用于 Windows Vista）上单击鼠标右键并选择“以管理员身份运行”。
  3. 在 Lmtools 程序的“Start/Stop/Reread”选项卡中，单击“ReRead License File”。
  4. 关闭 lmtools.exe。

本节内容

  • 创建报告日志
  • 配置许可证借用功能
  • 设置许可证超时


创建报告日志

设置和使用选项文件
设置和使用选项文件
配置许可证借用功能
Autodesk 网络许可手册 > 网络许可工具 > 设置和使用选项文件 >
创建报告日志

可以在选项文件中创建与 SAMreport-Lite 一起使用的报告日志文件。

创建报告日志的步骤

  1. 在文本编辑器中，打开选项文件 adskflex.opt。
  2. 在选项文件中，在单独的行中输入以下语法（以大写形式输入 REPORTLOG，如下所示）：

    REPORTLOG [+]report_log_path

    例如，语法 REPORTLOG +"c:\My Documents\report.rl" 表示名为 report.rl 的报告日志位于文件夹“c:\My Documents”中。

    注意包含空格的路径名必须用引号括起。

    在 REPORTLOG 语法中，“[+]”表示每次重新启动 Network License Manager 时，将向所创建的日志文件中附加条目而不是替换其中的条目。（建议您使用此选项，这样可以保留日志条目的历史记录。）


配置许可证借用功能

创建报告日志
设置和使用选项文件
设置许可证超时
Autodesk 网络许可手册 > 网络许可工具 > 设置和使用选项文件 >
配置许可证借用功能

如果 Autodesk 产品支持许可证借用功能，则可以使用选项文件配置许可证借用选项。例如，可以定义一次最多可以从网络上借用的许可证数。另外，还可以定义哪些用户可以借用 Autodesk 产品许可证。许可证是按用户借用，而不是按计算机借用的。

注意如果 Autodesk 产品支持许可证借用功能，并且许可证是从冗余许可服务器池借用的，则在停止 Network License Manager 之后必须重新启动许可服务器。

当借用到期时，借用的许可证将自动在用户计算机上被禁用，而在许可服务器上重新变为可用状态。用户也可以在借用到期之前返还许可证。

设置许可证借用参数的步骤

  1. 在选项文件中，在单独的行中输入以下语法（以大写形式输入 BORROW_LOWWATER，如下所示）：

    BORROW_LOWWATER feature_code n

    在 BORROW 语法中，“feature_code”表示许可证文件中的产品名称，“n”表示无法借用的许可证数目。

    例如，语法 BORROW_LOWWATER Autodesk_f1 3 表示对于产品 Autodesk_f1，有三个许可证无法从许可服务器借用。

  2. 在下一行输入以下语法（以大写形式输入 MAX_BORROW_HOURS，如下所示）：

    MAX_BORROW_HOURS feature_code n

    在此语法中，“n”表示许可证可以借用的小时数。

    例如，语法 MAX_BORROW_HOURS Autodesk_f1 360 表示对于产品 Autodesk_f1，许可证可以借用 360 小时，即 15 天。

    注意许可证的借用仅以 24 小时为增量单位，不使用任何大于 24 小时的增量。例如，365 将舍入为 360 小时，即 15 天。

关于设置许可证借用功能的详细信息，请参见 Program Files\Autodesk Network License Manager\Docs\FlexUser 文件夹中的 FLEXlm 文档。

注意用户可以通过在 Autodesk 产品中依次单击“工具”菜单 [image] “许可证借用”，或者在 Autodesk 产品命令行中输入 borrowlicense，来借用许可证。可以从“借用 [Autodesk 产品名] 的许可证”窗口中，以及 \Program Files\[Autodesk 产品名]\Help\[Autodesk 产品名]_brw.chm 文件中获取关于此功能的帮助信息。


设置许可证超时

配置许可证借用功能
设置和使用选项文件
删除安装 Network License Manager
Autodesk 网络许可手册 > 网络许可工具 > 设置和使用选项文件 >
设置许可证超时

许可证超时是在选项文件中设置的，用于指定在许可服务器收回许可证之前产品任务处于空闲状态的时间。在选项文件中设置此标志后，如果产品在工作站上空闲的时间超过定义的超时时间，则许可服务器将收回用户的许可证。

如果因空闲时间超时而导致用户许可证丢失，则当用户再次使用该产品时，它将尝试获取新的许可证。如果无可用许可证，用户可以在产品关闭之前保存工作。

设置许可证超时参数的步骤

  • 在选项文件中，在单独的行中输入以下语法（以大写形式输入 TIMEOUT，如下所示）：

    TIMEOUT feature_code n

    在 TIMEOUT 语法中，“feature_code”表示产品的名称（在许可证文件中的 INCREMENT 行），“n”表示距离许可服务器收回不活动许可证的秒数。

    例如，语法 TIMEOUT Autodesk_f1 7200 表示对于产品 Autodesk_f1，许可证超时时间设置为 7200 秒，即两小时。

关于使用许可证超时功能的详细信息，请参见 Program Files\Autodesk Network License Manager\Docs\FlexUser 文件夹中的 FLEXlm 文档。


删除安装 Network License Manager

设置许可证超时
网络许可工具
词汇表
Autodesk 网络许可手册 > 网络许可工具 >
删除安装 Network License Manager

可以从许可服务器删除安装 Network License Manager。删除安装 Network License Manager 后，用户将无法再使用许可证。

删除安装 Network License Manager 的步骤

  1. 执行下列操作之一：
    • 依次单击“开始”菜单（适用于 Windows XP 和 Windows 2000） [image] “所有程序”（或“程序”） [image] “Autodesk” [image] “Network License Manager” [image] “LMTOOLS”。
    • 在桌面上的 LMTOOLS 图标（适用于 Windows Vista）上单击鼠标右键并选择“以管理员身份运行”。
  2. 在 Lmtools 程序的“Service/License File”选项卡中，选择“Configuration Using Services”选项。
  3. 在 Lmtools 程序中，单击“Start/Stop/Reread”选项卡。
  4. 在“Start/Stop/Reread”选项卡中，单击“Stop Server”。
  5. 关闭 lmtools.exe。
  6. 在 Windows“控制面板”窗口中，双击“添加/删除程序”。
  7. 在“添加/删除程序”窗口中，单击“Autodesk Network License Manager”。单击“删除”。
  8. 如果出现提示，请重新启动计算机。
注意必须手动删除所创建的用来与 Network License Manager 一起使用的文件（例如日志文件、许可证文件和选项文件）。删除安装 Network License Manager 时，系统不会自动删除这些文件。


词汇表

删除安装 Network License Manager
Autodesk 网络许可手册 >
词汇表
ADSKFLEX_LICENSE_FILE

分布式许可服务器配置中的环境变量，用于将工作站指向分布式许可服务器。

adskflex.exe

Autodesk 供应商守护程序，与 FLEXlm 许可证技术一起使用。此守护程序用于跟踪签出的 Autodesk 许可证和使用这些许可证的工作站。

FLEXlm

在 Autodesk 系列产品中应用的 Macrovision Corporation 许可证管理技术。

JRE（Java 运行时环境）

运行 Java 程序所需的程序。此程序必须与 SAMreport-Lite 一起安装。

licpath.lic

在单个服务器和冗余服务器配置中，用来将工作站指向 FLEXlm 许可服务器的文件。Licpath.lic 位于根安装文件夹中。

lmgrd.exe

许可证管理器守护程序。此守护程序处理与程序的初始连接，然后将连接传递给供应商守护程序 adskflex.exe。

lmtools.exe

一个图形用户界面实用程序，用来管理 FLEXlm 许可证技术。（Lmutil.exe 是此实用程序的命令行版本。）

lmutil.exe

一个命令行实用程序，用来管理 FLEXlm 许可证技术。（Lmtools.exe 是此实用程序的图形用户界面版本。）

Network License Manager

Autodesk 用来管理网络许可证的技术。

SAMreport-Lite

Macrovision Corporation 的 SAMreport 工具版本。SAMreport-Lite 包含在 Autodesk 产品 CD-ROM 中。

报告日志文件

与 FLEXlm 和 SAMreport-Lite 一起使用的文件。此日志文件提供有关网络许可证使用情况的信息。报告日志由选项文件中创建。

调试日志文件

与 FLEXlm 一起使用的文件，用以记录 Network License Manager 和工作站之间的连接活动（例如，许可证故障、启动或停止）。

分布式服务器

一个许可服务器配置选项，在其中使用若干台服务器来管理许可证的分发。每台分布式许可服务器都有自己的许可证文件和一定数量的许可证。如果一台分布式许可服务器出现故障，其他服务器仍能分发它们的许可证。

工作站

由网络中的单个用户使用的桌面计算机。

供应商守护程序

参见 adskflex.exe。

借用的许可证

一种许可证，允许用户在有限时间内使用 Autodesk 产品，而无需购买单独的许可证或具备对许可服务器的网络访问权。早期版本的 Autodesk 产品可能使用了许可证配置切换器。

空闲

产品中的非活动状态，用于提示网络许可服务器收回许可证。导致系统认为产品处于空闲状态的原因有多种，例如，产品内没有敲击键盘或鼠标的操作，或者在选项文件中定义的时间段内进程中没有运行命令、LISP 表达式、菜单宏或脚本。请参见许可证超时。

冗余服务器

一个许可服务器配置选项，其中使用三台服务器管理许可证。冗余服务器共享一个许可证文件和一个许可证池。只要三台服务器中有两台在运行，冗余服务器池即可正常运行。

守护程序

一个在计算机后台连续运行的程序。守护程序处理来自计算机的请求，然后将这些请求转发给其他程序或进程。Network License Manager 使用两种守护程序：供应商守护程序 (adskflex.exe) 和许可证管理器守护程序 (lmgrd.exe)。

网络许可证安装

一种安装，要求用户从网络服务器安装并运行 Network License Manager。必须先安装并配置 Network License Manager，客户端才能运行 Autodesk 产品。

网络许可证激活实用程序

允许网络管理员通过 Internet 向网络版的 Autodesk 产品颁发许可证和进行授权的实用程序。

物理地址

参见主机 ID。

心跳信号

Network License Manager 和工作站之间的通信信号，用于确认工作站是否可以访问以及是否正在运行活动的 Autodesk 产品任务。

许可服务器

包含 Network License Manager 的服务器。

许可证超时

一个允许用户在许可服务器上设置超时时间的特征，当到达所设置的时间后，则自动将空闲的许可证返回服务器以便再次使用。

许可证配置切换器

参见借用的许可证。

许可证文件

一个与 FLEXlm 一起使用的文件，用来控制允许的客户数。此文件必须是 ASCII 纯文本格式。

选项文件

由 FLEXlm 使用的文件，用来控制许可证管理器参数（例如，保留许可证以及创建与 SAMreport-Lite 一起使用的报告日志）。

以太网地址

参见主机 ID。

运行树

Autodesk 产品程序文件（例如，acad.exe）的位置。

展开

在服务器上创建的文件和文件夹，由工作站用来安装 Autodesk 程序。

主机 ID

网络适配器的唯一硬件地址。也称为以太网地址或物理地址。

主机名

与计算机相关联的 TCP/IP 名称。FLEXlm 技术将主机名用作参数，主机名必须不同于 NetBIOS（服务器）名。

主守护程序

参见 lmgrd.exe。


评论？

请使用该表格将注释发送至负责该文档的 Autodesk 技术出版组。

主题标题和位置（请勿编辑）：
姓名（可选）：
         电子邮件（可选）：
评论：

注意：该表并不作为用户接收反馈或技术支持的途径。用户提供的信息可使我们将来更好地更新该文档。谢谢！