OLE Automation 错误信息 1

尚未实现

此方法或特性尚未实现。


OLE Automation 错误信息 130

字符串太长

字符串太长。


OLE Automation 错误信息 52

面顶点索引无效

数据序列无效。


OLE Automation 错误信息 210

内存不足

系统内存不足。


OLE Automation 错误信息 196

线型名称无效

线型名称无效。


OLE Automation 错误信息 210

传送到函数中的参数无效

传送到函数中的参数无效。请重新检查参数及参数值，然后重试。


OLE Automation 错误信息 60

DXB 部分读取

读取了部分 DXB 信息。


OLE Automation 错误信息 64

无输入文件

不存在输入文件。


OLE Automation 错误信息 37

对象结束

已到对象信息的末尾。


OLE Automation 错误信息 92

关闭正在通知

正在执行通知操作。


OLE Automation 错误信息 70

打开文件太多

打开的文件数已超过允许的最大数量。


OLE Automation 错误信息 13

句柄正被使用

此句柄已存在且正被使用。


OLE Automation 错误信息 42

对象不能写入

对象不能写入，无法修改。


OLE Automation 错误信息 114

对象不在数据库中

对象不在数据库中。


OLE Automation 错误信息 108

不在块中

对象不在块中。


OLE Automation 错误信息 156

分页程序错误

分页程序无法写入页面文件。


OLE Automation 错误信息 203

无法打开文件

无法打开指定的文件。


OLE Automation 错误信息 89

无符号表

缺少符号表。


OLE Automation 错误信息 165

非顶层事务


OLE Automation 错误信息 85

存在多个阅读器

对象同时存在多个阅读器。


OLE Automation 错误信息 80

子图元仍处于打开状态

此对象的子图元已打开。请关闭子图元，然后重新执行该操作。


OLE Automation 错误信息 128

非平面型图元

图元不在平面中。


OLE Automation 错误信息 70

文件内部错误

文件内部存在错误。


OLE Automation 错误信息 211

AutoCAD 主窗口不可见

AutoCAD 主窗口不可见。要打开该窗口，请将应用程序对象的可见特性设置为 acTrue。


OLE Automation 错误信息 211

编组中已存在此工具栏

菜单组中已存在具有相同名称的工具栏。


OLE Automation 错误信息 115

不是当前数据库

参照的数据库不是当前数据库。


OLE Automation 错误信息 83

对象为外部参照对象

对象为外部参照对象。


OLE Automation 错误信息 32

数据库无效

数据库在当前上下文中无效。


OLE Automation 错误信息 16a

贮存器非空

贮存器对象非空。贮存器必须为空才能完成此操作。


OLE Automation 错误信息 41

对象不能读取

对象不能读取。


OLE Automation 错误信息 88

自参照

存在循环参照。


OLE Automation 错误信息 211

无法添加工具栏按钮

添加工具栏按钮时出错。通常是因为输入了不正确的参数。


OLE Automation 错误信息 175

起点必须不同于顶点

起点与顶点相同。起点必须不同于顶点。


OLE Automation 错误信息 208

无法添加编组

无法将图元添加到编组中。


OLE Automation 错误信息 28

ADSRX 名称无效

ADSRX 名称无效。


OLE Automation 错误信息 197

颜色名无效

颜色名无效。


OLE Automation 错误信息 110

物主不能读取

物主不能读取。


OLE Automation 错误信息 180

未找到块 {name}

图形中不存在此块名。


OLE Automation 错误信息 59

DXF 部分读取

读取了部分 DXF 信息。


OLE Automation 错误信息 53

网格顶点索引无效

数据序列无效。


OLE Automation 错误信息 125

点不在图元上

点不在图元上。


OLE Automation 错误信息 19

未找到主键

搜索主键不存在。


OLE Automation 错误信息 170

组中不存在

此对象不在编组中。


OLE Automation 错误信息 105

记录不在表中

此记录不在符号表中。


OLE Automation 错误信息 77

对象可以发布通知

对象已打开以执行通知操作。


OLE Automation 错误信息 178

无权访问文件：{name:被 {name} 于 {date} {time} 锁定

指定的文件当前被锁定，正由另一个用户使用。请稍后再试。


OLE Automation 错误信息 117

不能更改活动视口

不能更改活动视口。


OLE Automation 错误信息 211

用户输入为空

用户按下了回车键而没有输入任何数据，或者按下了取消键。


OLE Automation 错误信息 210

无法创建指定输入类型的安全数组

无法创建指定输入类型的安全数组。


OLE Automation 错误信息 210

安全数组中的元素数目不正确

安全数组中的元素数目不正确。


OLE Automation 错误信息 211

菜单中已存在具有相同标签的项目

弹出菜单中已存在具有相同标签的项目。


OLE Automation 错误信息 84

不是图元

对象不是一个图元。


OLE Automation 错误信息 51

顶点定义在面定义之后

数据序列无效。


OLE Automation 错误信息 207

需要基点

必须为此特性或方法指定一个基点。


OLE Automation 错误信息 210

CoCreateInstance 失败


OLE Automation 错误信息 145

图形需要修复

图形被损坏，需要修复。


OLE Automation 错误信息 40

正在修改对象

对象处于写入模式。


OLE Automation 错误信息 210

在接口上调用方法失败


OLE Automation 错误信息 29

符号表名称无效

符号表名称无效。请检查有效的符号表名称列表。


OLE Automation 错误信息 202

缺少必要字段

缺少必要字段。


OLE Automation 错误信息 81

阅读器数目已达到最大

已超过最大用户数目。


OLE Automation 错误信息 44

块名无效

块名无效。


OLE Automation 错误信息 24

磁盘空间不足

系统磁盘空间不足。请压缩或删除不需要的文件以释放磁盘空间，然后重新执行该操作。


OLE Automation 错误信息 144

用户打断

操作被用户中断。


OLE Automation 错误信息 211

对象被其他对象参照

此对象正被其他数据库对象参照。


OLE Automation 错误信息 21

索引无效

索引无效。


OLE Automation 错误信息 155

需要正确的类分隔符

没有使用正确的子类分隔数据。


OLE Automation 错误信息 134

线型元素不足

线型元素不足，无法完整地定义线型。


OLE Automation 错误信息 162

未设置物主

未设置此对象的物主。


OLE Automation 错误信息 56

不能嵌套块定义

不能嵌套块定义。


OLE Automation 错误信息 211

编组中不存在指定名称的工具栏

菜单组中不存在指定名称的工具栏。


OLE Automation 错误信息 111

物主不能写入

物主不能写入。


OLE Automation 错误信息 157

分页程序存储空间不足

分页程序存储空间不足。


OLE Automation 错误信息 106

枚举器完成

枚举器已完成。


OLE Automation 错误信息 127

偏移无效

偏移无效。


OLE Automation 错误信息 100

错误不可修复

错误不可修复。


OLE Automation 错误信息 189

找不到最后一个图元

找不到数据库中的最后一个图元。


OLE Automation 错误信息 132

未定义线型

线型未定义。


OLE Automation 错误信息 95

关闭失败且对象被损坏

关闭操作失败且对象被损坏。


OLE Automation 错误信息 90

无符号表记录

缺少符号表记录。


OLE Automation 错误信息 5

输出不确定

输出不确定。


OLE Automation 错误信息 210

安全数组维数不正确

安全数组的维数不正确。


OLE Automation 错误信息 22

索引重复

存在一个重复的索引。


OLE Automation 错误信息 211

不能插入菜单

不能将弹出菜单插入到 AutoCAD 菜单栏中。请确保 AutoCAD 菜单栏中不存在您正要添加的菜单。


OLE Automation 错误信息 200

块名无效

块名无效。


OLE Automation 错误信息 139

图纸空间视图无效

图纸空间视图无效。


OLE Automation 错误信息 11

句柄中断

数据库中已存在此句柄但当前未使用。


OLE Automation 错误信息 109

物主不在数据库中

物主不在数据库中。


OLE Automation 错误信息 12

未知句柄

此句柄无效。


OLE Automation 错误信息 102

超过扩展数据大小

已超过此对象的扩展数据大小。


OLE Automation 错误信息 46

DXF 字段重复

存在重复的 DXF 字段。


OLE Automation 错误信息 25

图元已被删除

此图元已被删除。


OLE Automation 错误信息 3

无效输入

提供的输入无效。请重新检查输入并重试。


OLE Automation 错误信息 137

重复的线型定义被忽略

重复的线型定义被忽略。


OLE Automation 错误信息 198

文字样式名无效

文字样式名无效。


OLE Automation 错误信息 182

写入或关闭文件时出错

写入或关闭文件时出错。


OLE Automation 错误信息 96

不能由调用程序删除

对象不能由调用程序删除。


OLE Automation 错误信息 154

可见性值无效

可见性值不正确。正确的值为 acTrue 或 acFalse。


OLE Automation 错误信息 190

不能删除视口图元

无法删除视口图元。


OLE Automation 错误信息 163

子图元类型无效

子图元类型不正确。


OLE Automation 错误信息 8

打开状态无效

对象所处的模式不正确，无法完成此操作。


OLE Automation 错误信息 211

菜单文件类型无效

输入文件不是一个正确的 AutoCAD 菜单文件。正确的 AutoCAD 菜单文件的扩展名应该为 mnc、mns 或 mnu（即 *.mnc、*.mns 或 *.mnu）。


OLE Automation 错误信息 177

图形文件被写保护

图形文件被写保护，无法写入。如果可以，请更改文件的特性，以允许写入文件。


OLE Automation 错误信息 91

不能写入

对象不能写入。


OLE Automation 错误信息 149

图层名无效

图层名无效。


OLE Automation 错误信息 69

文件系统错误

文件系统中存在错误。


OLE Automation 错误信息 171

REFIID 无效

参照 ID 无效。


OLE Automation 错误信息 211

不是一个弹出按钮

工具栏按钮不是一个弹出按钮。调用的特性只适用于弹出按钮。


OLE Automation 错误信息 205

没有足够的内存加载应用程序

没有足够的内存加载应用程序。请释放更多内存并重试。


OLE Automation 错误信息 142

标注样式无效

标注样式无效。


OLE Automation 错误信息 23

数据库中已存在

数据库中已存在此项目。


OLE Automation 错误信息 211

编组中已存在此菜单

菜单组中已存在具有相同标签的弹出菜单。


OLE Automation 错误信息 50

文件处理器错误

AutoCAD 文件处理器操作中存在错误。


OLE Automation 错误信息 195

图层名无效

图层名无效。


OLE Automation 错误信息 179

图形已存在，请重命名文件

已存在同名的图形。请使用不同的名称或者重命名现有的图形文件。


OLE Automation 错误信息 153

线型比例无效

线型的比例因子无效。


OLE Automation 错误信息 210

QueryInterface 失败


OLE Automation 错误信息 206

函数中存在无效的对象

此函数中使用了无效的对象。


OLE Automation 错误信息 211

AutoCAD 无法处理自动执行请求

AutoCAD 正忙，无法处理自动执行请求。请等待 AutoCAD 完成当前的操作，然后重试。


OLE Automation 错误信息 66

DXB 读取中断

DXB 读取操作已中断。


OLE Automation 错误信息 113

不能进行非统一比例缩放

不能对块进行非统一比例缩放。


OLE Automation 错误信息 186

自动保存文件名无效，使用默认名“auto.sv$”

指定的自动保存文件名无效。将使用 AutoCAD 为自动保存文件设置的默认名。


OLE Automation 错误信息 65

图形需要完全保存

需要对图形执行完全保存操作。


OLE Automation 错误信息 210

安全数组中的元素太少或总元素数目不是 3 的倍数

点、矢量等安全数组要求元素数目必须为 3 的倍数。


OLE Automation 错误信息 168

不是新创建的

不是一个新创建的对象。


OLE Automation 错误信息 57

图形修复完成

图形已成功修复。


OLE Automation 错误信息 183

不能将文件重命名为 {name}

系统未能将文件重命名为指定的名称。


OLE Automation 错误信息 120

基本建模失败

AutoCAD 中发生基本建模失败。


OLE Automation 错误信息 147

修复无效


OLE Automation 错误信息 6

内存不足

系统内存不足。请关闭某些应用程序以释放内存，然后重试。


OLE Automation 错误信息 158

分页程序写入错误

写入分页程序文件时出错。


OLE Automation 错误信息 161

物主对象无效

此对象的物主对象无效。


OLE Automation 错误信息 67

文件被 AutoCAD 锁定

文件当前已被 AutoCAD 锁定。


OLE Automation 错误信息 210

调用 SafeArrayPutElement 时出错


OLE Automation 错误信息 47

DXF 代码无效

DXF 代码无效。


OLE Automation 错误信息 71

对象已被删除

对象已被删除。


OLE Automation 错误信息 82

当前被写保护

对象被写保护。


OLE Automation 错误信息 112

变换之前进行分解


OLE Automation 错误信息 55

请先将块添加到数据库中

尚未将块添加到数据库中。请先将块添加到数据库中，然后重新执行该操作。


OLE Automation 错误信息 211

无法添加按钮分隔符

添加工具栏按钮分隔符时出错。这通常是因为输入了不正确的参数，或者试图连续添加两个按钮分隔符。


OLE Automation 错误信息 146

删除图元


OLE Automation 错误信息 43

类无效

无效的类类型。


OLE Automation 错误信息 176

构造线不能平行于 UCS 的 Z 轴


OLE Automation 错误信息 48

结果缓冲区无效

结果缓冲区无效。


OLE Automation 错误信息 211

未在编组中找到菜单

没有在指定的菜单组中找到弹出菜单。


OLE Automation 错误信息 93

关闭修改已中断

修改已中断。


OLE Automation 错误信息 73

对象可以读取

对象处于读取模式。


OLE Automation 错误信息 210

将安全数组点转换为双精度数组点时出错

将安全数组点转换为双精度数组点时出错。


OLE Automation 错误信息 34

图形版本无效

图形版本与此操作不兼容。


OLE Automation 错误信息 35

匿名图元

当前图元为匿名图元。


OLE Automation 错误信息 107

空枚举器

枚举器为空。


OLE Automation 错误信息 151

颜色索引无效

颜色索引无效。


OLE Automation 错误信息 211

无法设置浮动行

无法设置浮动行。常见的原因是工具栏已固定。请浮动工具栏，然后重新执行此操作。


OLE Automation 错误信息 210

调用 SafeArrayGetElement 时出错


OLE Automation 错误信息 97

插入到当前对象之后

插入对象时出错。


OLE Automation 错误信息 31

对象类型无效

对象的类型无效。


OLE Automation 错误信息 211

菜单中已存在具有相同标记的项目

菜单组中已存在具有相同标记的弹出菜单。


OLE Automation 错误信息 49

DXF 序列无效

数据序列无效。


OLE Automation 错误信息 209

未找到选择集

未找到指定的选择集。


OLE Automation 错误信息 2

不适用

此方法或特性不适用于该对象。要查看适用于特定对象的特性或方法，请使用 Object Browser。


OLE Automation 错误信息 159

无法传递对象

无法传递对象 ID。


OLE Automation 错误信息 118

不在图纸空间中

对象不在图纸空间中。


OLE Automation 错误信息 148

FSM 错误


OLE Automation 错误信息 211

编组中已存在具有相同别名的工具栏

菜单组中已存在具有相同别名的工具栏。


OLE Automation 错误信息 124

轴无效

轴无效。


OLE Automation 错误信息 60

DXF 读取中断

DXF 读取操作已中断。


OLE Automation 错误信息 211

未找到文件

没有在 AutoCAD 搜索路径中找到输入文件。请检查文件名或验证 AutoCAD 搜索路径是否正确。


OLE Automation 错误信息 210

将双精度数组点转换为安全数组点时出错

将双精度数组点转换为安全数组点时出错。


OLE Automation 错误信息 208

点表无效

指定的点表无效。


OLE Automation 错误信息 27

范围无效

图元的范围无效。


OLE Automation 错误信息 16

空块名

块名为空。


OLE Automation 错误信息 39

正在读取对象信息

对象处于读取模式。


OLE Automation 错误信息 17

空图元指针

此图元指针为空。


OLE Automation 错误信息 101

无数据库

不存在匹配的数据库。


OLE Automation 错误信息 211

视口未激活

视口未激活。请首先使视口成为图形的活动视口，然后重新执行此操作。


OLE Automation 错误信息 152

线型名称无效

线型名称无效。


OLE Automation 错误信息 133

文字样式无效

文字样式无效。


OLE Automation 错误信息 63

图形对象没有读取

图形对象没有正确读取。


OLE Automation 错误信息 166

命令结束时事务处于打开状态


OLE Automation 错误信息 191

坐标转换请求中的参数无效

坐标转换请求中的参数无效。请重新检查参数并重试。


OLE Automation 错误信息 143

图层无效

图层无效。


OLE Automation 错误信息 9

句柄已存在

数据库中已存在此句柄。


OLE Automation 错误信息 4

输入不确定

输入不确定。


OLE Automation 错误信息 78

位于锁定图层上

对象位于锁定图层上。


OLE Automation 错误信息 201

法线矢量无效

法线矢量无效。


OLE Automation 错误信息 103

未找到注册的应用程序 ID

未在 AutoCAD 中注册此类应用程序。


OLE Automation 错误信息 188

图元名无效

图元名无效。


OLE Automation 错误信息 167

正在提交

正在保存对对象的更改。


OLE Automation 错误信息 122

几何图形不共面

几何图形不共面。


OLE Automation 错误信息 141

无内部空间

磁盘空间不足。


OLE Automation 错误信息 172

法线无效

此法线无效。


OLE Automation 错误信息 94

关闭部分失败

关闭时发生部分失败。


OLE Automation 错误信息 211

编组中已存在具有相同别名的菜单

菜单组中已存在具有相同别名的弹出菜单。


OLE Automation 错误信息 211

不能删除菜单

不能从 AutoCAD 菜单栏中删除弹出菜单。请确保菜单栏中确实存在您正要删除的菜单。


OLE Automation 错误信息 62

图形标记不匹配

标记验证失败。


OLE Automation 错误信息 38

文件结束

已到文件的末尾。


OLE Automation 错误信息 211

UCS 的 X 轴与 Y 轴不垂直

UCS 的 X 轴与 Y 轴必须垂直。


OLE Automation 错误信息 164

没有活动的事务

不存在活动的事务。


OLE Automation 错误信息 15

空对象 ID

对象 ID 为空。


OLE Automation 错误信息 74

对象可以写入

对象处于写入模式。


OLE Automation 错误信息 210

应用程序不可见

应用程序不可见。要使之可见，请将可见特性设置为 acTrue。


OLE Automation 错误信息 138

UCS 无效

UCS 无效。


OLE Automation 错误信息 119

命令正在运行

正在运行一个 AutoCAD 命令。


OLE Automation 错误信息 173

样式无效

此样式无效。


OLE Automation 错误信息 18

图元类型非法

此图元类型不是一个有效的图元类型。


OLE Automation 错误信息 211

无法设置帮助字符串

无法为对象设置帮助字符串。这是一个 AutoCAD 内部错误。请将您的代码提交给 AutoCAD 错误跟踪小组，以尽快解决此问题。


OLE Automation 错误信息 210

系统注册表中不存在 AcRxClassName 项

系统注册表中不存在 AcRxClassName。


OLE Automation 错误信息 20

主键重复

此主键已存在。


OLE Automation 错误信息 211

不能为 AcDbAttribute 对象创建默认的包装

系统无法创建 Attribute 对象。


OLE Automation 错误信息 194

不允许零值

此参数的值不能为零。


OLE Automation 错误信息 169

组中已存在

编组中已存在此对象。


OLE Automation 错误信息 33

即将删除对象

此对象已标记为要删除。


OLE Automation 错误信息 75

对象可以放弃

对象已打开以执行放弃操作。


OLE Automation 错误信息 104

图元重复


OLE Automation 错误信息 76

对象正在发布通知

对象正在发布通知。


OLE Automation 错误信息 79

必须由物主打开

打开序列无效。


OLE Automation 错误信息 185

指定用于自动保存的目录无效或为只读

用于自动保存的目录为只读目录。请将此目录的特性更改为读写。


OLE Automation 错误信息 211

无法设置分隔符名

无法设置工具栏按钮分隔符名。分隔符不能带有名称。


OLE Automation 错误信息 211

面域不在当前 UCS 平面上

面域不在当前 UCS 平面上。某些操作可能会失败。


OLE Automation 错误信息 121

超界

值超界。


OLE Automation 错误信息 30

主键无效

搜索主键名称无效。


OLE Automation 错误信息 211

用户输入的是关键字

用户输入的是关键字。


OLE Automation 错误信息 36

非法替换

此替换非法，因此不允许。


OLE Automation 错误信息 211

不是一个按钮

工具栏项目不是一个按钮。调用的特性只适用于按钮。


OLE Automation 错误信息 10

空句柄

此句柄为空。


OLE Automation 错误信息 123

退化几何图形

几何图形正在退化。


OLE Automation 错误信息 87

依赖外部参照

依赖外部参照。


OLE Automation 错误信息 61

图形循环冗余码校验不匹配

图形循环冗余码校验失败。


OLE Automation 错误信息 181

不能保存外部 {name} 块


OLE Automation 错误信息 192

已删除图元的使用无效

已删除的图元不能以这种方式使用。


OLE Automation 错误信息 129

不能分解图元

不能分解图元。


OLE Automation 错误信息 135

线型元素太多

线型元素太多，超过定义线型所需的数量。


OLE Automation 错误信息 193

不能设置只读变量

变量为只读，无法进行设置。


OLE Automation 错误信息 45

无 DXF 字段

缺少 DXF 字段。


OLE Automation 错误信息 131

符号表标志无效

符号表标志无效。


OLE Automation 错误信息 174

不能从 ACIS 文件恢复

不能从 ACIS 数据恢复对象。


OLE Automation 错误信息 14

空对象指针

对象指针为空。


OLE Automation 错误信息 199

形名称无效

形名称无效。


OLE Automation 错误信息 187

选择集名称无效

选择集名称无效。


OLE Automation 错误信息 72

对象已被永久删除

对象已被永久删除。


OLE Automation 错误信息 26

不允许负值

不允许输入负值。请输入正值，重新执行该操作。


OLE Automation 错误信息 211

不存在指定名称的菜单组

指定名称的菜单组不存在。


OLE Automation 错误信息 98

已修复所有错误

已修复所有错误。


OLE Automation 错误信息 126

单一点

存在一个单一点。


OLE Automation 错误信息 58

图形不可恢复

图形不可恢复。


OLE Automation 错误信息 86

记录名重复

存在重复的符号表记录名。


OLE Automation 错误信息 150

无图层组码

缺少图层组码。


OLE Automation 错误信息 184

磁盘空间不足

磁盘空间不足。


OLE Automation 错误信息 116

图元不被允许

对象不能是一个图元。


OLE Automation 错误信息 140

未读取输入数据

输入数据没有完全读取。


OLE Automation 错误信息 210

无法将一个 AcDbObject 衍生指针转换为另一个 AcDbObject 衍生指针


OLE Automation 错误信息 68

文件访问错误

无法访问文件。


OLE Automation 错误信息 136

项目太多

集合中的项目太多。


OLE Automation 错误信息 99

错误未修复

错误未修复。


OLE Automation 错误信息 54

其他对象忙

其他对象当前正忙。


OLE Automation 错误信息 210

未加载自动执行协议扩展 dll oleaprot.arx

ActiveX Automation 功能需要 oleaprot.arx 文件。


OLE Automation 错误信息 204

应用程序已存在

应用程序已经加载。请使用 GetObject 进行连接。


OLE Automation 错误信息 7

缓冲区太小

内存缓冲区空间不足，无法完成此操作。


OLE Automation 错误信息 160

ID 映射图无效

ID 映射图无效。