AutoCAD 2008 自述：简介

AutoCAD 2008 自述

本自述文件包含有关 AutoCAD® 2008 的重要信息，这些信息可能未包含在印刷文档或帮助中。

  • 安装、配置和硬件
  • 图形卡驱动程序更新
  • 绘图和编辑
  • 打印和发布
  • 文字和语言
  • 开发人员信息
  • 命令和系统变量历史记录
  • 其他自述项
  • 商标


安装、配置和硬件

安装和配置

从双 CD/DVD ROM 驱动器系统安装

  • 如果尝试在双 CD/DVD ROM 驱动器系统中的每个驱动器中分别放入安装 CD 来安装 AutoCAD，安装将失败。如果要求放入第二张安装光盘，则第二个 CD 驱动器中的光盘未被识别。必须在同一个驱动器中用第二张光盘替换第一张光盘，才能完成安装。

从网络驱动器启动 HTML 帮助时失败

  • 在某些情况下，帮助文件无法从网络位置打开。这是由于某个已知的 Microsoft 问题所致。有关详细信息，请访问 http://support.microsoft.com/kb/892675。

磁盘映像

  • 如果计算机处在 SATA RAID 环境中，而且许可不稳定，则使用磁盘映像软件分发 Autodesk 产品可能导致产品激活问题。如果尝试在 SATA RAID 环境中激活产品，可能会收到“超出激活码限制”消息。

错误报告

  • 当 AutoCAD 任务意外终止时，将显示“错误报告”消息，提醒您将错误报告发送到 Autodesk。错误报告有助于 Autodesk 识别及解决产品的许多问题。“错误报告”消息与运行 Microsoft® Windows® XP 的计算机上的某个应用程序意外终止时显示的消息类似。错误报告记录工作任务结束时正在使用的产品部分。在“错误报告”消息中，单击“可选数据”，输入以下信息，然后单击“发送报告”：
    • 任务意外终止之前用户在 AutoCAD 中所执行操作的信息
    • 用户的联系信息

    提供此信息有助于 Autodesk 再现错误并尽快修复错误。如果 AutoCAD 任务意外终止而未显示“错误报告”消息，请确保 REPORTERROR 系统变量设置为 1。

自定义安装文件夹名称中的非 ASCII 字符

  • 在命名自定义安装文件夹时，使用非 ASCII 字符可能会导致 AutoCAD 帮助文档出现搜索功能方面的问题。

如果已安装 2008 产品，则某些非英文的 2006 产品线安装程序将失败

  • Autodesk 2008 产品线的安装程序将安装 .NET Framework 2.0。这将阻止在安装 2008 产品后安装某些非英文的 Autodesk 2006 产品。重新安装 .NET 1.1 及其相关 Service Pack 以安装基于 2006 的产品。
    1. 将基于 2006 的产品 CD 放入驱动器中。
    2. 浏览到“\Bin\acadFeui\support\dotnetfx\”，然后双击“dotnetfx.exe”安装 .NET 1.1。
    3. 从同一文件夹中，双击“NDP1.1sp1-KB867460-X86.exe”安装 .NET 1.1 Service Pack1。
    4. 要安装非英文版，请执行以下操作：
      • 浏览到“\Bin\acadFeui\support\dotnetfx\language\”，然后安装“langpack.exe”。
      • 安装基于 2006 的产品。

许可

将忽略更新的 PLIST 信息

  • 在分布式许可服务器环境中，将忽略更新的产品列表 (PLIST) 信息。Autodesk 可能将定期更新网络许可文件中的 PLIST 信息。

    例如，用户现有的许可文件包含 PLIST 信息，此许可文件位于分布式许可服务器环境的第一个服务器上。如果购买了另一个 Autodesk 产品，此产品附带包含更新的 PLIST 信息的许可文件，而该文件位于分布式服务器环境中的另一个服务器上，将识别第一个服务器上的较旧的 PLIST 数据，而非较新的 PLIST 数据。

    为确保读取更新的 PLIST 文件，请从 Autodesk 获取包含最新 PLIST 信息的新许可文件。或者，可以将更新的 PLIST 添加到分布式许可服务器环境中的第一个服务器，以确保始终读取此文件。

网络许可手册更新

  • 由于 AutoCAD 2008 安装向导中的最新更改，网络许可手册中提供的安装 Network License Manager 和网络许可证激活实用程序的步骤容易混淆。为了清楚起见，以下步骤已更新。

    安装 Autodesk Network License Manager

    • 安装 Autodesk Network License Manager 的步骤
    1. 在 AutoCAD 2008 安装向导中，单击“安装工具和实用程序”。
    2. 在“欢迎使用 AutoCAD 2008 安装向导”页面上，单击“下一步”。
    3. 在“选择要安装的产品”页面上，请确保选定了“Network License Manager”并单击“下一步”。
    4. 查看适用于用户所在国家或地区的 Autodesk 软件许可协议。用户必须接受协议才能继续安装。选择您所在国家或地区，单击“我接受”，然后单击“下一步”。

      注意：如果不同意许可的条款并希望终止安装，请单击“取消”。

    5. 在“查看 - 配置 - 安装”页面上，请单击“配置”。
    6. 如果在步骤 3 中选定了多个产品，则请单击“Network License Manager”选项卡。
    7. 在“选择安装位置”页面上，接受默认安装路径 (C:\Program Files\Autodesk Network License Manager\) 或单击“...”指定不同的路径。如果输入的路径不存在，则将使用用户提供的名称和位置创建一个新的文件夹。单击“配置完成”。

      警告：请勿在远程驱动器上安装 Network License Manager。安装 Network License Manager 文件时，用户必须提供一个本地驱动器的路径。用户必须指定驱动器号；不支持通用命名约定 (UNC)。

    8. 返回“查看 - 配置 - 安装”页面后，请单击“安装”以开始安装 Network License Manager 及其他任何选定的工具和实用程序。
    9. 显示“安装完成”页面时，单击“完成”。

    安装网络许可证激活实用程序

    安装网络许可证激活实用程序的步骤
    1. 在 AutoCAD 2008 安装向导中，单击“安装工具和实用程序”。
    2. 在“欢迎使用 AutoCAD 2008 安装向导”页面上，单击“下一步”。
    3. 在“选择要安装的产品”页面上，请确保选定了“网络许可证激活实用程序”并单击“下一步”。
    4. 查看适用于用户所在国家或地区的 Autodesk 软件许可协议。用户必须接受协议才能继续安装。选择您所在国家或地区，单击“我接受”，然后单击“下一步”。

      注意：如果不同意许可的条款并希望终止安装，请单击“取消”。

    5. 在“查看 - 配置 - 安装”页面上，请单击“配置”。
    6. 如果在步骤 3 中选定了多个产品，则请单击“网络许可证激活实用程序”选项卡。
    7. 在“选择安装位置”页面上，接受默认安装路径 (C:\Program Files\Autodesk Network License Manager\Network License Activation Utility\enu\) 或单击“...”指定不同的路径。如果输入的路径不存在，则将使用用户提供的名称和位置创建一个新的文件夹。单击“配置完成”。
    8. 返回“查看 - 配置 - 安装”页面后，请单击“安装”以开始安装网络许可证激活实用程序及其他任何选定的工具和实用程序。
    9. 显示“安装完成”页面时，单击“完成”。

硬件

SATA RAID 环境失败

  • 激活并重新启动产品后，将收到错误 0.1.0011 或 11.1.6011，并且需要重新激活。在使用 SATA RAID 控制器的计算机上，基于 Autodesk 2006、2007 和 2008 的产品可能发生此问题。

    有关该问题的产品支持解决方案，请参见 Autodesk 激活更新。

图形卡驱动程序更新

  • 为了获得程序的最佳性能，请验证并更新图形卡驱动程序。详细信息，请参见 图形卡驱动程序更新。

远程访问应用程序

  • 当配置 AutoCAD 以使用硬件加速时，建议不要将任何类型的远程访问应用程序与 AutoCAD 配合使用。大部分远程访问应用程序不支持硬件加速，因此可能导致无法正常显示和不稳定。如果需要使用远程访问应用程序，请禁用硬件加速或使用 /NOHARDWARE 命令行开关在“软件”模式下启动 AutoCAD。

HP DesignJet 打印机驱动程序

  • Autodesk 不再在产品 CD 上为 HP Designjet 系列附带 Windows 系统打印机驱动程序。如果需要此驱动程序，可以从 http://welcome.hp.com/country/cn/zh/ 下载。

硬件认证数据库

  • 请访问我们位于 http://www.autodesk.com/autocad-graphicscardupdate 的硬件认证网站，下载并安装最新的硬件认证 XML 文件。


图形卡驱动程序更新

建议用户验证并更新图形卡驱动程序以优化 AutoCAD。使用以下操作步骤识别当前的图形卡驱动程序。

识别图形卡驱动程序的步骤

  1. 启动 AutoCAD。
  2. 在命令行上，输入 3dconfig。
  3. 在“自适应降级和性能调节”对话框中，单击“查看调节日志”。
  4. 有关系统的图形卡驱动程序和驱动程序版本的信息，请查看“三维设备”一节。

如果用户发现需要更新驱动程序，请访问 http://www.autodesk.com/autocad-graphicscard 查找适用于用户图形卡的认证驱动程序。如果没有找到，则请访问该图形卡制造商的网站。

注意： 如果图形卡制造商未提供更新的驱动程序，请检查系统制造商的网站。IBM、Hewlett Packard 和 Dell 这些公司通常提供它们自己的系统驱动程序。


绘图和编辑

图形环境

DWF 参考底图

  • 建议在锁定的图层上插入 DWF 参考底图文件，以避免不慎编辑了这些文件。如果在 DWF 参考底图文件上进行放大操作并随后使用窗口选择方法，则即使参考底图中的几何图形看起来未被选定，也可能选定了 DWF 参考底图。
  • 建议在使用 REFEDIT 时不要对 DWF 参考底图使用 DWFATTACH 和 PASTECLIP。
  • 在图形中使用 REFEDIT 时，如果使用 PASTECLIP 粘贴 DWF 参考底图，则可能无法将更改存回。可能会显示以下消息：
    由于工作集中的对象参照了工作集以外的对象，因此无法存回更改。参照编辑任务仍然处于激活状态。在关闭对话框后按 F2 键以查看缺失参照的列表。
    在执行 REFEDIT 期间，如果在宿主图形中附着 DWF 参考底图，然后又尝试对外部参照中的同一 DWF 参考底图文件执行 DWFATTACH，也可能会显示此错误消息。存回用户的其他 REFEDIT 更改的方法为：删除执行 REFEDIT 任务期间附着或粘贴的 DWF 参考底图。

工具选项板

  • 不应在早期版本中使用在当前版本中创建的工具选项板。

在 Windows Vista 中打开样例图形文件

  • 由于 Windows Vista 的限制，所有在 AutoCAD 样例文件夹及子文件夹中找到的样例文件均是只读的。图纸集管理器样例文件可以在图纸集管理器中打开，但是不能更改。

在 Windows Vista 中搜索文件

  • 要在 Windows Vista 的 Windows 资源管理器中搜索图形文件中的内容，请使用“高级搜索”并选择“包括非索引、隐藏及系统文件”选项。

Autodesk i-drop

  • 要在运行 Windows Vista 的系统中正常运行 i-drop，应将用户设置为“以管理员身份运行”。

三维环境

AutoCAD 2007 提供了一个新的三维建模环境，用户可以通过 VISUALSTYLES 命令并选择任一非二维样式来访问该环境。三维环境与传统的二维绘图环境相比存在某些行为上的区别，例如：

  • 三维中不支持绘图次序
  • 三维中的内存占用量较大
  • REGEN 和 REGENALL 未必会清除显示假象。要重置显示，请在二维和非二维样式之间循环 VISUALSTYLES。

Windows Vista 中的 Direct 3D

  • 在 Windows Vista 环境中启用 Direct 3D 时，非二维视觉样式中的光标将以黑白两色（而不是彩色）显示。从“选项”对话框中对光标所做的任何更改，在此环境中均不会启用。

材质

过程化材质不通过 CONVERTOLDMATERIALS 进行转换

  • 应用到 AutoCAD 2007 模型中的对象的过程化材质不通过 AutoCAD 2008 中的 CONVERTOLDMATERIALS 命令进行转换。

动画和渲染

动画输出

  • Quicktime Player 无法播放使用非当前操作系统自带的字符保存的 MOV 文件。
  • Windows Vista 版本 K 和 N（适用于韩国和欧洲）未附带安装 Windows Media Player。要使用 AutoCAD 的动画功能，请从 Microsoft 网站下载最新版本的 Media Player。

特色内容和技术

  • 要安装特色的可视化内容和技术，请启用通讯中心并将其配置为接受更新。配置后，将看到一个称为“特色内容和技术”的新频道，并且其内容可以下载。

其他绘图问题

多重引线内容块中的注释性属性

  • 不建议在多重引线内容块中使用注释性属性。如此操作可能会导致这些块的可见性问题。在注释性多重引线对象中仅使用非注释性属性和非注释性块作为内容。

实体图案填充

  • 包含实体图案填充的图形生成的打印文件可能比包含其他类型的图案填充的图形生成的打印文件大。

图案填充的可见性

  • 引入 HPMAXLINES 系统变量以防止系统内存不足。基于当前 HPMAXLINES 的设置，一些图案填充可能不会显示。要修复该问题，请更改 HPMAXLINES 值。

视口中的注释性图案填充

  • 在模型空间视口 (TILEMODE = 0) 中，通过“特性”选项板添加到图案填充的注释比例可能不按照在其他视口中指定的方式显示。要防止这个问题，请执行以下操作之一：
    • 使用快捷菜单而非“特性”选项板添加注释比例。
    • 切换至模型空间 (TILEMODE = 1) 以添加注释比例。

    • 如果已经遇到该问题，请关闭并重新打开图形以在视口中正确地显示填充比例。

非矩形视口

  • 为非矩形视口指定非连续线型，可能导致该视口中的模型空间几何图形被不规则剪裁，也可能导致 AutoCAD 变得不稳定。
  • 选定所有对象和视口后，如果在包含非矩形视口、具有三维视觉样式的布局中使用 JPGOUT、PNGOUT、BMPOUT 和 TIFOUT 命令，则其他视口的某些部分可能会暗显，并且对象可能不可见。可以使用 PUBLISH 命令创建更加精确的光栅输出。
  • 不要冻结包含非矩形视口的图层；而应将包含非矩形视口的图层关闭或将该图层的“打印”特性设置为“不打印”。如果冻结包含非矩形视口的图层，则视口边界将变为矩形。视口中应由非矩形视口边界剪裁的对象显示为已剪裁，但重生成或打印图形时，对象未剪裁成预期样式。要在此问题出现时予以更正，必须解冻该图层，然后重生成图形。

外部参照

  • 由于外部参照的轮询周期，在尝试使用“管理外部参照”图标来重载 DWG 外部参照时可能会遇到延迟情况。只有在“管理外部参照”图标上看到气泡式通知之后，才能通过这种方法重载参照 DWG 文件。要加速重载过程，请使用以下方法之一：
    • 在“外部参照”选项板的“文件引用”列表中的参照图形上单击鼠标右键，然后单击“重载”。
    • 在位于“外部参照”选项板顶部的按钮控件上单击“重载所有参照”。
    • 在命令提示下输入 -XREF，然后使用“重载”选项。

将图形保存为早期文件格式

  • 将曲面对象从当前版本中移动或复制到 R14 时，可能会出现致命错误。

项目组织

图纸集

  • 图纸集管理器在以下情况下不能正常运行：
    • 命令处于活动状态。
    • 未打开任何图形。
    • 其他用户已锁定图纸集。
    • 图纸集管理器中图纸集名称前面显示的锁定图标指明该图纸集已锁定。将光标置于锁定图标上可以查看显示锁定该图纸集的用户的工具栏提示。
  • 在图纸集管理器中选择图纸后，图纸的状态可能会在“详细信息”区域中错误地显示为“已由未知人员锁定进行编辑”。要更新图纸的状态，请打开该图纸。
  • 如果从图纸集中删除图纸，然后将图纸输入回图纸集，则块属性中显示图纸集信息的字段将显示为磅符号。要更正这些字段，可以重新创建字段，也可以重新插入块。由于图纸集中已经存在该图纸，重新创建字段时，应使用图纸集特性字段，而不要使用占位符字段。
  • 图纸集字段（从图纸集类别中选定的字段）的表现与其他类型的字段不同。默认情况下，保存图形或使用 REGEN 时，其他类型的字段会自动更新。而图纸集字段将存储最后使用的值，如果无法访问图纸集字段引用的信息，则它们将显示这些存储的值。要更新图纸集字段中的值，请使用 UPDATEFIELD 命令。如果仍然无法访问图纸集字段引用的信息，字段的值将显示为 ####。

在网络上将同一个 DWT 用于页面设置和块

  • 当两个网络用户访问对标签和标注块、图纸样板以及页面设置替代均使用同一图形样板文件 (DWT) 的图纸集时，某些图纸集功能不可用。为了避免此问题，请不要使用同一 DWT 文件存储页面设置和块库。


打印和发布

打印和发布图形

打印大型光栅图像

  • 以下添加到 AutoCAD 2007 的两个新的系统变量使用户在打印包含大型光栅图像附件的图形时，或在大尺寸介质上打印高分辨率的大型渲染/着色视口时，可以更有效地进行控制。
    • RASTERTHRESHOLD
      • 类型：整数
      • 保存位置：注册表
      • 初始值：20
      • 以兆字节指定一个光栅阈值。如果打印的光栅图像超出了该阈值，将检查系统内存的可用性。如果图像对于可用内存来说太大，将中断打印。
    • RASTERPERCENT
      • 类型：整数
      • 保存位置：注册表
      • 初始值：20
      • 设置可用于打印光栅图像的可用虚拟内存的最大百分比。

发布图形

DWF 文件

  • 当打印到 DWF 时，将不打印 DWF 参考底图中的光栅图像。
  • 打印包含光栅图像的 DWF 参考底图文件可能产生意外的结果。


文字和语言

文字

多行文字高度

  • 如果在创建过程中未修改多行文字的默认高度，则多行文字高度值将被重置为 0。

语言

多种语言支持

  • 在 AutoCAD 2008 中，将使用 Unicode 字符来保存图形特性。例如，如果将包含多种语言图形特性的最新格式图形保存为 2004 格式图形，则图形特性将转换为当前 Windows 语言的本地字符。如果文字不能转换为本地字符，则文字将保存为 CIF 代码 (\U+nnnn) 或 MIF 代码 (\M+nxxxx)。
  • 将最新格式的图形保存为 2004 格式的图形时，在 AutoCAD 2008 中创建的所有新符号或词典名称（例如布局名称、文字样式名称、标注样式名称）将以创建符号名称时使用的语言保存。
  • 复制和粘贴使用系统语言之外的语言创建的字符时，字符可能无法正确显示。可以使用在位文字编辑器更正此显示。

    更正显示以显示原始语言的步骤
    1. 双击文字，在“在位文字编辑器”中将其打开。
    2. 在编辑器中单击鼠标右键。单击“字符集”，然后选择原始语言。
  • 当图形中包含的某些字符不包括在操作系统上指定的语言中时，如果要查看和编辑这些图形，请确保计算机的操作系统上安装了补充语言支持。可以在 Windows“控制面板”中的“区域和语言选项”对话框中指定语言。（可以查看使用 SHX 字体的文字，而无需指定额外的语言支持。）
  • 使用 SHX 和大字体的亚洲语言的文字样式只能支持相同代码页的字符。例如，使用日语大字体的文字样式不支持德语或朝鲜语字符。（支持英语字符，因为它是每个代码页的一部分。）如果文字样式中使用 SHX 字体而禁用大字体，则该文字样式支持非亚洲语言的多种语言支持。（SHX 字体必须定义所需的字符。）
  • 要更轻松地在支持不同语言的操作系统中使用多语言多行文字，请使用“在位文字编辑器”中的 TrueType 字体设置。
  • 某些早期版本的 AutoCAD 不提供多种语言支持。例如，将文件保存为 AutoCAD 2000 格式时，多语言多行文字的内容可能会损坏。如果打开并保存图形时所使用的操作系统上的系统语言设置与最后一次保存图形时所使用的操作系统不同，就很可能会发生此问题。

文件夹名称或文件名

  • AutoCAD 2006、AutoCAD LT 2006 及早期版本不是 Unicode 应用程序。在与早期非 Unicode 版本共享图形时，请使用 ASCII 字符以确保在保存文件、插入外部参照和指定文件夹路径时的兼容性。

双字节字符问题

数据源名称

  • 用于数据源名称的字符代码（例如 0x??41 和 0x??61）可能无法正确处理。使用数据库配置中指定的可选名称（日语）创建多个数据源时，会出现此问题。因此，某些数据源名称可能不会列出。出现此问题时，可以将未列出的数据源名称改为其他名称。

子对象和对象循环选择

  • 无法在 Microsoft Windows 的中文（中华人民共和国和台湾地区）版本中使用 CTRL + 空格键组合键和 SHIFT + 空格键组合键来循环选择子对象和对象。使用中文 IME 时，这些组合键具有以下功能：
    • CTRL + 空格键组合键切换中文 IME。
    • SHIFT + 空格键组合键切换双字节和单字节英文字符。

    在 IME 中，可以更改组合加速键。用户可以将 CTRL + 空格键组合键和 SHIFT + 空格键组合键的默认动作更改为与 AutoCAD CTRL + 空格键组合键和 SHIFT + 空格键组合键的行为不冲突的动作。

文字显示

亚洲语言的垂直文字

  • SHX 字体 - 可以使用 SHX 字体和大字体创建垂直显示的文字，创建方式与早期版本中的方式相同。要获得最佳结果，请使用单行 TEXT 命令，而不是 MTEXT。可以在“文字样式”对话框中选择垂直样式。

    TrueType 字体 - 仍选择以 @ 符号开始的字体，但现在文字将自动旋转 270 度。（在 AutoCAD 2005 及早期版本中，必须手动旋转此文字。）现在，垂直文字支持光标垂直移动。

字体显示

  • 如果默认字体不支持您用在位文字编辑器（MTEXT 命令）输入的字符，通常会使用替换字体。
  • 使用在位文字编辑器（MTEXT 命令）或 DTEXT 命令输入的 CIF 或 MIF 代码现在会自动转换以显示实际的字符。

更新的“bigfont.ini”

  • AutoCAD 2007 和 AutoCAD 2008 处理自定义 SHX 大字体的方式与 AutoCAD 2006 及早期版本不同。如果图形文件中使用了自定义 SHX 大字体，则需要将 SHX 大字体名称及其代码页 ID 添加到“Support”文件夹中的“bigfont.ini”文件中。要了解如何进行添加，请参阅“bigfont.ini”文件的标题部分。

命令输入

AltGR 和键的组合

  • ALTGR + 任意键的组合键将导致命令输入的终止。这是由用于隐含面拉伸的 CTRL+ALT 组合键引起的。如果使用 ALTGR 键盘布局，则解决方法为：将 IMPLIEDFACE 设置为 0（零）。


开发人员信息

可能影响脚本的更改

对以下命令或系统变量的修改可能会影响已存在的脚本：

  • EXTEND - 对于 EXTEND 命令，如果在“选择要延伸的对象”提示下不选择对象，则现在将提示您指定窗交窗口的对角点。此更改可能会影响已存在的脚本，该脚本可调用 EXTEND 并提供未选择对象的拾取点。通过忽略未选择对象的点可以修复传统脚本。
  • -INSERT - 如果使用“块定义”对话框中的“按统一比例缩放”选项，则在使用 -INSERT 命令插入块时，将不再提示您为 X,Y,Z 坐标分别输入比例因子。
  • MENULOAD - 默认情况下，MENULOAD 命令仅加载 AutoCAD 2006 或更高版本中的 CUI 文件。要加载 AutoCAD 2006 或更高版本中的 MNU 或 MNS 文件，必须将扩展名明确地包含在文件名中，如下例所示：

    (command "menuload" "myMenu.mnu")

    但是，强烈建议您不要更改代码，而在运行使用传统菜单文件的应用程序之前，先在 AutoCAD 2008 中打开这些文件。AutoCAD 会自动将它们转换为 CUI 文件，并且 CUI 文件将通过使用不带扩展名的文件名的现有代码进行加载。

    应更改指定 MNU、MNS 或 MNC 扩展名的传统代码，以使其参照 CUI 文件，而且基于 AutoCAD 2007 的应用程序应附带 CUI 文件，而不是 MNU、MNS 或 MNC 文件。

  • TRIM - 对于 TRIM 命令，如果在“选择要修剪的对象”提示下不选择对象，则现在将提示您指定窗交窗口的对角点。此更改可能会影响已存在的脚本，该脚本可调用 TRIM 并提供未选择对象的拾取点。通过忽略未选择对象的点可以修复传统脚本。

Visual LISP

通知

  • 在某些情况下，一个系统变量的更改会触发多次 vlr-sysVarWillChange 和 vlr-sysVarChanged 通知。

夹点

  • AutoCAD 不再支持未选定对象上的夹点。因此，AutoLISP sssetfirst 函数的 gripset 参数将被忽略，ssgetfirst 将为第一个返回的选择集返回 nil。

真彩色

  • 如果完全安装了 AutoCAD，则使用“真彩色”的实用程序位于“\Sample\VisualLISP”文件夹中的“color-util.lsp”文件中。这些实用程序用于与真彩色相关的操作，例如获取真彩色编号的部件，将颜色索引或颜色名转换为真彩色值，返回 DXF 组码列表，以及使用图元列表。

    使用以下 AutoLISP 函数可以访问“真彩色”用户界面：

    (acad_truecolordlg color [allowbylayer] [currentlayercolor])。
    通过对话框提示输入颜色。颜色参数是一个说明默认颜色的点对；点对的第一个元素必须是颜色相关 DXF 组码（62、420 或 430）之一。如果 allowbylayer 参数存在且不为 nil，则显示“随层”和“随块”按钮。如果操作成功，则该函数将返回说明选定颜色的一个或多个点对的列表。列表中发最后一个点对指示选定的颜色。如果用户取消对话框，则该函数返回 nil。

    (acad_truecolorcli color [allowbylayer] [alternatePrompt])。
    在命令行提示输入颜色。前两个参数与 acad_truecolordlg 相同，第三个参数是一个可选的提示字符串。如果省略此字符串，则默认值为“新颜色”。

entmod 和 entmake 函数

  • 在 AutoCAD 2004 及更高版本中，entmod 和 entmake 函数在颜色操作方面中具有新的表现。DXF 组码 62 保留了 AutoCAD 颜色索引 (ACI) 值，而组码 420 保留了真彩色值。如果真彩色值与 ACI 值冲突，则 AutoCAD 将使用 420 值，因此在试图使用组码 62 值之前应删除组码 420 值。有关详细信息，请完整安装 AutoCAD 并参见 \Sample\VisualLISP 文件夹中的 color-util.lsp 文件。

加载错误

  • 如果加载独立名称空间 VLX 时 LOAD 遇到错误，则某些函数可能在检测到错误之前已输出到当前文档名称空间中。必须确保修复此错误、重新编译并重载 VLX，才能确保所有函数的正确版本输出到当前文档。
  • 使用 CUILOAD 命令在 MDI 中加载部分菜单时，该菜单的 MNL 文件将为每个打开的文档加载一次，同时所有用户交互操作都发生在当前文档中。为避免在使用 AutoCAD 打开多个图形时出现多余的打印信息或用户提示，建议不要在 MNL LISP 代码中包含任何用户交互操作。而使用 MNL 代码为后续菜单项选择加载任何所需的 AutoLISP 文件。使用“acad.lsp”或“acaddoc.lsp”文件执行打开图形时要处理的 AutoLISP 代码。

“多文档设计环境”对话框的显示

  • “多文档设计环境”对话框使用户可以更改 AutoLISP 环境初始化的默认功能。此对话框在以下情况下显示：
    • AcadLspAsDocDlg 注册键的“Do Not Show”值设置为 0。
    • 未运行任何脚本，并且未运行 AutoLISP 或 ActiveX 应用程序。
    • ACADLSPASDOC 系统变量设置为 0。
    • AutoCAD 搜索路径中存在 acad.lsp 文件。
    • AutoCAD 搜索路径中不存在 acaddoc.lsp 文件。
    • SDI 系统变量设置为 0。
    如果所有这些条件都为真，则在每个任务中首次打开第二个文档时，将显示“多文档设计环境”对话框。

ActiveX 和 VBA

AutoCAD 进程的可见性

  • 启动时运行的 VBA 脚本应检查 AutoCAD 进程是否可见。如果该进程不可见，则不应该执行脚本，因为该进程可能正在执行后台打印或发布操作。要检查 AutoCAD 进程是否可见，可以使用 AutoCAD 对象模型中 Application 对象的 Visible 特性。


命令和系统变量历史记录

了解 AutoCAD 的途径

以下资源有助于用户了解有关本产品及其新功能的详细信息：

  • 新功能专题研习（“帮助”菜单）
  • 帮助系统（“帮助”菜单）
  • 开发人员帮助（“帮助”菜单 >“其他资源”）
  • Autodesk 国际用户组 (AUGI)（“帮助”菜单 >“其他资源”）
  • Autodesk 网站 http://www.autodesk.com.cn

命令

新命令

命令 | 说明
ANNORESET | 将注释性对象的所有比例图示的位置重置为当前比例图示的位置
ANNOUPDATE | 更新现有的注释性对象，使之与其样式的当前特性相匹配
ATTIPEDIT | 更改块中属性的文本内容
AUTOPUBLISH | 将图形自动发布为 DWF 文件
DGNADJUST | 更改选定的 DGN 参考底图的显示选项
DGNATTACH | 将 DGN 参考底图附着到当前图形
DGNCLIP | 定义选定的 DGN 参考底图的剪裁边界
DGNEXPORT | 从当前图形创建一个或多个 V8 DGN 文件
DGNIMPORT | 将数据从 V8 DGN 文件输入到新 DWG 文件中
DIMBREAK | 添加或删除标注打断
DIMINSPECT | 创建或删除检验标注
-DIMINSPECT | 创建或删除检验标注（命令提示版本）
DIMJOGLINE | 在线性标注或对齐标注中添加或删除锯齿线
DIMSPACE | 对平行线性标注和角度标注之间的间距做同样的调整
DWFLAYERS | 控制 DWF 参考底图中图层的显示
FREEPOINT | 在没有目标点提示的情况下，创建目标点光源
FREESPOT | 创建与未指定目标的聚光灯相似的自由聚光灯
FREEWEB | 创建与未指定目标的光域灯光相似的自由光域灯光
LAYERSTATE | 保存、恢复和管理已命名的图层状态
MLEADER | 创建连接注释与几何特征的引线
MLEADERALIGN | 沿指定的线组织选定的多重引线
MLEADERCOLLECT | 将选定的包含块的多重引线作为内容组织为一组并附着到单引线
MLEADEREDIT | 将引线添加至多重引线对象或从多重引线对象中删除引线
MLEADERSTYLE | 定义新多重引线样式
NEWVIEW | 加速新视图的创建
OBJECTSCALE | 为注释性对象添加或删除支持的比例
QUICKCUI | 以收拢状态显示“自定义用户界面”对话框
RECOVERALL | 修复损坏的图形和外部参照
-RENDER | RENDER 命令的命令提示版本
RENDEREXPOSURE | 提供设置以交互调整最近渲染的输出的全局光源
TARGETPOINT | 创建目标点光源
TPNAVIGATE | 显示指定的工具选项板或选项板组
WEBLIGHT | 创建光域灯光

修改的命令

命令 | 说明
3DCONFIG | 添加了“模拟打印”和“纹理压缩”选项
-3DCONFIG | 添加了“模拟打印”和“纹理压缩”选项（命令提示版本）
ATTDEF | 添加了对注释性比例缩放的支持
-ATTDEF | 添加了对注释性比例缩放的支持（命令提示版本）
ATTEDIT | 多行属性支持
BATTMAN | 添加了对注释性比例缩放的支持
BLOCK | 添加了对注释性比例缩放的支持
-BLOCK | 添加了对注释性比例缩放的支持（命令提示版本）
CHPROP | 添加了对注释性比例缩放的支持
CUI | 为自定义工具栏添加了面板自定义和一些增强功能
DASHBOARD | 添加了从快捷菜单访问“自定义用户界面”的功能
DIMANGULAR | 添加了“象限点”选项
DIMDIAMETER | 添加了“尺寸界限”选项
DIMJOGGED | 添加了“尺寸界限”选项
DIMRADIUS | 添加了“尺寸界限”选项
DIMSTYLE | 添加了新的公差对齐选项、线性折弯的尺寸选项和打断间距
-DIMSTYLE | DIMSTYLE 的命令提示版本（命令提示版本）
DISTANTLIGHT | 已修改为支持输入光度特性
EATTEXT | 现在激活的是 DATAEXTRACTION 命令而不是属性提取向导
-EATTEXT | EATTEXT 命令的命令提示版本（命令提示版本）
ETRANSMIT | 添加了对视觉逼真度的支持
HATCH | 添加了对注释性比例缩放的支持
-HATCH | 添加了对注释性比例缩放的支持（命令提示版本）
HATCHEDIT | 添加了对注释性比例缩放的支持
-HATCHEDIT | 添加了对注释性比例缩放的支持（命令提示版本）
INSERT | 添加了对注释性比例缩放的支持
-INSERT | 添加了对注释性比例缩放的支持（命令提示版本）
-LAYER | 添加了用于从图形输入图层状态的选项，“编辑”选项现在包括“材质”和“说明”子选项，“输入”选项现在包括 DWG/DWS/DWT 格式，“输出”选项包括 LAY 文件格式（命令提示版本）
MATCHCELL | 添加了对双线边框、边框线型和新单元格式的支持
MTEXT | 添加了对注释性比例缩放的支持
-MTEXT | 添加了对注释性比例缩放的支持（命令提示版本）
MVIEW | 在布局上使用时，新选项“图层(L)”将删除所有图层特性替代值，并将它们重置回其对应的全局特性
OPTIONS | 向“打开和保存”选项卡添加了“保持视觉逼真度”复选框，并向“显示”选项卡添加了“显示图形状态栏”复选框
PASTESPEC | 从剪贴板中粘贴 Microsoft Excel 数据以便立即创建指向此信息的数据链接的功能已增强
PLOT | 受硬件配置设置“模拟打印”和“纹理压缩”影响
POINTLIGHT | Direct 3D 驱动程序支持衰减的起始界限和结束界限；还添加了区域采样阴影选项提示和光域提示
QSELECT | 添加了对注释性比例缩放的支持
SPELL | 现在将检查标注中的词语、放大要更正的词语，并添加了用以忽略带有数字或特殊字符的词语的选项
SPOTLIGHT | Direct 3D 驱动程序支持衰减的起始界限和结束界限；还添加了区域采样阴影选项提示和光域提示
STYLE | 添加了对注释性比例缩放的支持
-STYLE | 添加了对注释性比例缩放的支持（命令提示版本）
TABLE | 从“样式”分支和“数据链接”分支中添加
-TABLE | 从“样式”分支和“数据链接”分支中添加（命令提示版本）
TABLESTYLE | 定义新的表格样式
TEXT | 添加了对注释性比例缩放的支持
VIEW | 已修改为支持新的“天光背景”选项（如果可用）
-VPORTS | 添加的选项“图层(L)”将删除所有图层特性替代值，并将它们重置回其对应的全局特性（命令提示版本）
XCLIP | 添加了“反向”选项

已删除或已废弃的命令

命令 | 说明
ASSIST | 打开信息选项板中的“快速帮助”，从而提供上下文相关信息
ASSISTCLOSE | 关闭“快速帮助”和信息选项板

系统变量

新的系统变量

系统变量 | 说明
3DCONVERSIONMODE | 用于转换材质和光源定义
3DSELECTIONMODE | 控制使用三维视觉样式时视觉上重叠的对象的选择优先级
ANNOALLVISIBLE | 隐藏或显示不支持当前注释比例的注释性对象
ANNOAUTOSCALE | 更改注释比例时，将更新注释性对象以支持注释比例
ANNOTATIVEDWG | 指定是否将图形作为注释性块插入其他图形
ATTIPE | 控制用于创建多线属性的在位编辑器的显示
ATTMULTI | 控制是否可创建多线属性
AUTODWFPUBLISH | 控制自动发布功能的开关状态
CANNOSCALE | 设置当前空间的当前注释比例的名称
CANNOSCALEVALUE | 返回当前注释比例的值
CMLEADERSTYLE | 确定当前多重引线样式
COPYMODE | 控制是否自动重复 COPY 命令
DATALINKNOTIFY | 控制更新或缺少数据链接的通知
DGNFRAME | 确定 DGN 参考底图边框在当前图形中是否可见或是否打印
DGNOSNAP | 控制 DGN 参考底图中几何体的对象捕捉
DIMANNO | 指示当前标注样式是否为注释性样式
DXEVAL | 控制数据提取处理表何时与数据源比较，如果数据不是当前数据，则显示更新通知
HPMAXLINES | 控制将生成的图案填充线的最大数目
LAYEREVAL | 控制何时针对新图层评估图层特性管理器中的“未协调新图层”过滤器列表
LAYERNOTIFY | 指定何时针对尚未协调的新图层显示警告
LAYLOCKFADECTL | 控制锁定图层上的对象的褪色
LIGHTINGUNITS | 控制是使用常规光源还是使用光度控制光源，并指示当前的光学单位
LIGHTSINBLOCKS | 控制渲染时是否使用块中包含的光源
LINEARBRIGHTNESS | 控制使用默认光源或常规光源时图形的全局亮度级别
LINEARCONTRAST | 控制使用默认光源或常规光源时图形的全局对比度级别
LOGEXPBRIGHTNESS | 控制使用光度控制光源时图形的全局亮度级别
LOGEXPCONTRAST | 控制使用光度控制光源时图形的全局对比度级别
LOGEXPDAYLIGHT | 控制使用光度控制光源时是否使用室外日光
LOGEXPMIDTONES | 控制在使用光度控制光源时图形的全局中色调级别
MSLTSCALE | 按注释比例缩放“模型”选项卡上显示的线型
PERSPECTIVECLIP | 确定视点剪裁的位置
PUBLISHCOLLATE | 控制打印图纸集、多页打印文件或后台打印文件是否能被其他打印作业打断
RENDERUSERLIGHTS | 控制渲染过程中是否转换用户光源
SAVEFIDELITY | 控制保存图形时是否保存其视觉逼真度
SELECTIONANNODISPLAY | 控制在选定注释性对象时，替换比例图示是否暂时以暗显状态显示
SETBYLAYERMODE | 控制为 SETBYLAYER 选择哪些特性
TABLETOOLBAR | 控制表格工具栏的显示
TEXTOUTPUTFILEFORMAT | 提供 Unicode 文本文件输出选项
VPLAYEROVERRIDES | 指示对于当前图层视口是否存在任何具有视口 (VP) 特性替代的图层
VPLAYEROVERRIDESMODE | 控制是否显示和打印与布局视口关联的图层特性替代
VSFACEHIGHLIGHT | 控制是否显示和打印与布局视口关联的图层特性替代

修改的系统变量

系统变量 | 说明
AFLAGS | 为新的“多行”模式添加了值
DCTMAIN | 显示当前主拼写词典的三字母关键字
DIMSCALE | 注释性标注样式作为当前标注样式时将自动设置为 0

已删除或已废弃的系统变量

系统变量 | 说明
ASSISTSTATE | 指示是否已激活显示“快速帮助”的“信息”选项板


其他信息

字体

要在绘图区域中正确查看双字节字符，必须在“样式”对话框中选择本地字体来进行设置。要访问“样式”对话框，请在命令行上输入 style。

安装

如果为安装目录选择双字节名称而不是默认名称，可能会改变产品的功能。强烈建议使用单字节字符作为安装目录名称。

向图形文件添加密码的限制

如果将同一密码用于多个图形，则密码对话框仅在打开第一个图形时显示。建议为每个图形添加不同的密码。

Windows 资源管理器搜索工具

Windows 资源管理器搜索工具可能无法查找 dwg、dwf 和 dxf 文件中包含的双字节字符串。此问题与操作系统有关。解决办法是在 XP 或其他高级操作系统上查找这些字符串。

移植自定义设置和命令别名

移植成功完成后，如果在 AutoCAD 2008 中遇到使用命令别名的问题，请执行以下简单操作：将新版与旧版 AutoCAD 软件中的所有 PGP 文件中的制表分隔符替换成空格，然后再次运行“移植自定义设置”工具。

需要安装 Acrobat Reader 才能通过 CD 或 DVD 浏览器查看文档

要查看 CD 或 DVD 浏览器中包含的文档，应在软件提示安装 Acrobat Reader 时执行安装。


商标

以下是 Autodesk, Inc. 在美国和其他国家/地区的注册商标或商标：3DEC（设计/徽标）、3December、3December.com、3ds Max、ActiveShapes、Actrix、ADI、Alias、Alias（swirl 设计/徽标）、AliasStudio、Alias|Wavefront （设计/徽标）、ATC、AUGI、AutoCAD、AutoCAD Learning Assistance、AutoCAD LT、AutoCAD Simulator、AutoCAD SQL Extension、AutoCAD SQL Interface、Autodesk、Autodesk Envision、Autodesk Insight、Autodesk Intent、Autodesk Inventor、Autodesk Map、Autodesk MapGuide、Autodesk Streamline、AutoLISP、AutoSnap、AutoSketch、AutoTrack、Backdraft、Built with ObjectARX（徽标）、Burn、Buzzsaw、CAiCE、Can You Imagine、Character Studio、Cinestream、Civil 3D、Cleaner、Cleaner Central、ClearScale、Colour Warper、Combustion、Communication Specification、Constructware、Content Explorer、Create>what's>Next>（设计/徽标）、Dancing Baby（图像）、DesignCenter、Design Doctor、Designer's Toolkit、DesignKids、DesignProf、DesignServer、DesignStudio、Design|Studio（设计/徽标）、Design Your World、Design Your World（设计/徽标）、DWF、DWG、DWG（徽标）、DWG TrueConvert、DWG TrueView、DXF、EditDV、Education by Design、Extending the Design Team、FBX、Filmbox、FMDesktop、GDX Driver、Gmax、Heads-up Design、Heidi、HOOPS、HumanIK、i-drop、iMOUT、Incinerator、IntroDV、Kaydara、Kaydara（设计/徽标）、LocationLogic、Lustre、Maya、Mechanical Desktop、MotionBuilder、ObjectARX、ObjectDBX、Open Reality、PolarSnap、PortfolioWall、Powered with Autodesk Technology、Productstream、ProjectPoint、Reactor、RealDWG、Real-time Roto、Render Queue、Revit、Showcase、SketchBook、StudioTools、Topobase、Toxik、Visual、Visual Bridge、Visual Construction、Visual Drainage、Visual Hydro、Visual Landscape、Visual Roads、Visual Survey、Visual Syllabus、Visual Toolbox、Visual Tugboat、Visual LISP、Voice Reality、Volo 和 Wiretap。

以下是 Autodesk Canada Co. 在美国和/或加拿大和其他国家/地区的注册商标或商标：Backburner、Discreet、Fire、Flame、Flint、Frost、Inferno、Multi-Master Editing、River、Smoke、Sparks、Stone 和 Wire。